[PATCH 5/7] gnu: Add vtk version 6.3.0

  • Done
  • quality assurance status badge
Details
3 participants
  • John Darrington
  • Kei Kebreau
  • Ricardo Wurmus
Owner
unassigned
Submitted by
John Darrington
Severity
normal

Debbugs page

John Darrington wrote 8 years ago
(address . guix-patches@gnu.org)(name . John Darrington)(address . jmd@gnu.org)
1489608324-23632-5-git-send-email-jmd@gnu.org
* gnu/packages/vtk.scm (vtk@6.3): New variable.
---
gnu/packages/vtk.scm | 16 ++++++++++++++++
1 file changed, 16 insertions(+)

Toggle diff (26 lines)
diff --git a/gnu/packages/vtk.scm b/gnu/packages/vtk.scm
index 5a5c941..ad12187 100644
--- a/gnu/packages/vtk.scm
+++ b/gnu/packages/vtk.scm
@@ -91,3 +91,19 @@ triangulation. VTK has an extensive information visualization framework, has
a suite of 3D interaction widgets, supports parallel processing, and
integrates with various databases on GUI toolkits such as Qt and Tk.")
(license bsd-3)))
+
+
+;; Mia 2.4.3 doesn't work against vtk7 so we package vtk 6.3 for it:
+(define-public vtk@6.3
+ (package
+ (inherit vtk)
+ (version "6.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.vtk.org/files/release/"
+ (version-major+minor version)
+ "/VTK-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0pla1r5mvkgl4sl213gfdhzrypdgai0h3z5mfgm6p9jz9hsr794j"))))))
+
--
2.1.4
Kei Kebreau wrote 8 years ago
(name . John Darrington)(address . jmd@gnu.org)(address . 26111@debbugs.gnu.org)
87var75r0i.fsf@openmailbox.org
John Darrington <jmd@gnu.org> writes:

Toggle quote (30 lines)
> * gnu/packages/vtk.scm (vtk@6.3): New variable.
> ---
> gnu/packages/vtk.scm | 16 ++++++++++++++++
> 1 file changed, 16 insertions(+)
>
> diff --git a/gnu/packages/vtk.scm b/gnu/packages/vtk.scm
> index 5a5c941..ad12187 100644
> --- a/gnu/packages/vtk.scm
> +++ b/gnu/packages/vtk.scm
> @@ -91,3 +91,19 @@ triangulation. VTK has an extensive information visualization framework, has
> a suite of 3D interaction widgets, supports parallel processing, and
> integrates with various databases on GUI toolkits such as Qt and Tk.")
> (license bsd-3)))
> +
> +
> +;; Mia 2.4.3 doesn't work against vtk7 so we package vtk 6.3 for it:
> +(define-public vtk@6.3
> + (package
> + (inherit vtk)
> + (version "6.3.0")
> + (source (origin
> + (method url-fetch)
> + (uri (string-append "http://www.vtk.org/files/release/"
> + (version-major+minor version)
> + "/VTK-" version ".tar.gz"))
> + (sha256
> + (base32
> + "0pla1r5mvkgl4sl213gfdhzrypdgai0h3z5mfgm6p9jz9hsr794j"))))))
> +

This doesn't build reproducibly for me, but it lints fine.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAljMiP0ACgkQ5qXuPBlG
eg1wHhAAufrALI6QQGgmKHmZXoGvTCNYPf0ToS6MRxZM/19JQhFGk3UZsO65xGVK
lgI37j7lJTDdCgQeV1AwZZSjHKTO735wNmUZAh9IbGnaJV+xsHMYcjq2P4jlQu9C
ZKryDBgv70c0U54y6rcxn3rtQQi5FhMus+OC4fQXueLC1Ajmw7yaujNVsrenZAJ6
cs7w1FUjfDHRbMxjqPOqRTUp/oJZaXOoeHHORdma6nfj2CNfVQRvY+9LnaYkJBkZ
KX3o3tZ4uXRD8JlWc/8iaBY+RqsgEIAVhpQOWQ5vqYxJZQi5M26kHtOK+5a8UOQS
wJCU8kdTGeYsS36sQRC24zfPW9UepQLlEPfeWSdvXP6alw199Xt3+T7/OmlWv7x8
pxw3VnyGYkG4SnrK6/vxQjQa4QkMuwPXYdXgMUtWsOVkYd94PimncW2f2J43li7b
zEf2SPDlb7KcjtFdccZBVoR6MaREBh6xoQjtktHu+34So1w8w7FZw/WJ6MDD6vrY
CILPKSsFTu8OwkA4SymwCJ+UmdYhfwN0/li50FfCjAZAabQVzA1YDG1J/wWQ82AD
rnL5S67Ujx4gLSC2WqVAyUYaYiV5w4yWK7ts52aK5Iyc8cuC5G5rc2/uh7NM+Qpv
hssZYK5ugyGvGCkjr43nCcGt+WOKBUjucnYUeAcyy5geAhTIUzA=
=4hB1
-----END PGP SIGNATURE-----

Ricardo Wurmus wrote 8 years ago
(name . John Darrington)(address . jmd@gnu.org)(address . 26111-done@debbugs.gnu.org)
874lwrhoz3.fsf@elephly.net
John Darrington <jmd@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/packages/vtk.scm (vtk@6.3): New variable.
> ---
[…]
Toggle quote (2 lines)
> +;; Mia 2.4.3 doesn't work against vtk7 so we package vtk 6.3 for it:

Meanwhile Mia 2.4.4 has been released which is compatible with vtk7, so
I’m closing this bug.

I’m currently working on this patch set and have updated dcmtk and mia.
I’ll push them once I’ve confirmed they are working correctly.

Thanks!

--
Ricardo

GPG: BCA6 89B6 3655 3801 C3C6 2150 197A 5888 235F ACAC
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26111@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26111
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help