[PATCH 0/2] Add shellcheck and its dependencies.

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Marius Bakke
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 8 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170312090231.23966-1-dannym@scratchpost.org
Danny Milosavljevic (2):
gnu: Add ghc-json.
gnu: Add shellcheck.

gnu/packages/haskell.scm | 62 ++++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 62 insertions(+)
Danny Milosavljevic wrote 8 years ago
[PATCH 1/2] gnu: Add ghc-json.
(address . 26069@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170312090429.24022-1-dannym@scratchpost.org
* gnu/packages/haskell.scm (ghc-json): New variable.
---
gnu/packages/haskell.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 2415881e8..ce37f63f9 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -8212,4 +8212,31 @@ handler built in.")
handled safely, this is what you're left with.")
(license license:isc)))
+(define-public ghc-json
+ (package
+ (name "ghc-json")
+ (version "0.9.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/json/"
+ "json-" version ".tar.gz"))
+ (sha256
+ (base32
+ "18l5027vc68hnnxrxlnyl59vkkg95a92m1zzms0dqiby2r6pxdcn"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-syb" ,ghc-syb)
+ ("ghc-mtl" ,ghc-mtl)
+ ("ghc-text" ,ghc-text)
+ ("ghc-parsec" ,ghc-parsec)))
+ (home-page "http://hackage.haskell.org/package/json")
+ (synopsis "Serializes Haskell data to and from JSON")
+ (description "This package provides a parser and pretty printer for
+converting between Haskell values and JSON.
+JSON (JavaScript Object Notation) is a lightweight data-interchange format.
+It is based on a subset of the JavaScript Programming Language, Standard
+ECMA-262 3rd Edition - December 1999.")
+ (license license:bsd-3)))
+
;;; haskell.scm ends here
Danny Milosavljevic wrote 8 years ago
[PATCH 2/2] gnu: Add shellcheck.
(address . 26069@debbugs.gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170312090429.24022-2-dannym@scratchpost.org
* gnu/packages/haskell.scm (shellcheck): New variable.
---
gnu/packages/haskell.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index ce37f63f9..62bae9d81 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -8239,4 +8239,39 @@ It is based on a subset of the JavaScript Programming Language, Standard
ECMA-262 3rd Edition - December 1999.")
(license license:bsd-3)))
+(define-public shellcheck
+ (package
+ (name "shellcheck")
+ (version "0.4.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/koalaman/shellcheck/archive/"
+ "v" version ".tar.gz"))
+ (sha256
+ (base32
+ "14r84fcn28rin339avlvca5g0kz832f01x8dpmwb5ql8mbc4rlxr"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-json" ,ghc-json)
+ ("ghc-mtl" ,ghc-mtl)
+ ("ghc-parsec" ,ghc-parsec)
+ ("ghc-regex-tdfa" ,ghc-regex-tdfa)))
+ (home-page "https://github.com/koalaman/shellcheck")
+ (synopsis "Static analysis for shell scripts")
+ (description "@code{shellcheck} provides static analysis for bash and sh shell
+scripts. It gives warnings and suggestions in order to:
+
+@enumerate
+@item Point out and clarify typical beginner's syntax issues that cause
+a shell to give cryptic error messages.
+@item Point out and clarify typical intermediate level semantic problems
+that cause a shell to behave strangely and counter-intuitively.
+@item Point out subtle caveats, corner cases and pitfalls that may cause an
+advanced user's otherwise working script to fail under future circumstances.
+@end enumerate")
+ (license license:gpl3+)))
+
;;; haskell.scm ends here
Marius Bakke wrote 8 years ago
Re: bug#26069: [PATCH 1/2] gnu: Add ghc-json.
87bmt6jskc.fsf@kirby.i-did-not-set--mail-host-address--so-tickle-me
Danny Milosavljevic <dannym@scratchpost.org> writes:

Toggle quote (39 lines)
> * gnu/packages/haskell.scm (ghc-json): New variable.
> ---
> gnu/packages/haskell.scm | 27 +++++++++++++++++++++++++++
> 1 file changed, 27 insertions(+)
>
> diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
> index 2415881e8..ce37f63f9 100644
> --- a/gnu/packages/haskell.scm
> +++ b/gnu/packages/haskell.scm
> @@ -8212,4 +8212,31 @@ handler built in.")
> handled safely, this is what you're left with.")
> (license license:isc)))
>
> +(define-public ghc-json
> + (package
> + (name "ghc-json")
> + (version "0.9.1")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "https://hackage.haskell.org/package/json/"
> + "json-" version ".tar.gz"))
> + (sha256
> + (base32
> + "18l5027vc68hnnxrxlnyl59vkkg95a92m1zzms0dqiby2r6pxdcn"))))
> + (build-system haskell-build-system)
> + (inputs
> + `(("ghc-syb" ,ghc-syb)
> + ("ghc-mtl" ,ghc-mtl)
> + ("ghc-text" ,ghc-text)
> + ("ghc-parsec" ,ghc-parsec)))
> + (home-page "http://hackage.haskell.org/package/json")
> + (synopsis "Serializes Haskell data to and from JSON")
> + (description "This package provides a parser and pretty printer for
> +converting between Haskell values and JSON.
> +JSON (JavaScript Object Notation) is a lightweight data-interchange format.
> +It is based on a subset of the JavaScript Programming Language, Standard
> +ECMA-262 3rd Edition - December 1999.")

The second sentence can be left off IMO. Otherwise LGTM.

Toggle quote (3 lines)
> + (license license:bsd-3)))
> +
> ;;; haskell.scm ends here
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAljFiaQACgkQoqBt8qM6
VPoPLQf/eSsFp53LVYXqZG3p+4yIf8lL9nZ9XS9Uh0csdWlkJvu58Z5K+FGkArQR
aD8VXETB+/XnTFCyP9H4PH8cELpvDT8LESao6ozfXm9KOTVDWRFKWSCaYIknIxnV
AlubZj4rrpP5TuHNOh82EAUWlb4GLxVh2K9t6ahpdNW3HD179aeq8oa5d3dAvMmM
a6ZR3epYzSiAsA+6mT3Pi1sPeCvJZdHxdijgrgp6RxZx0LozXeMge+JRzXEoWp2A
GIL04h1Z5vu8zIYrLW9yKa83viV7SoCP+MqhZ30LvfD7NTMiqmE7CdkS5JdrFfi2
DLK34bnqoAZX7aFKfe42IqHLnLe5Kg==
=j+Hk
-----END PGP SIGNATURE-----

Marius Bakke wrote 8 years ago
Re: bug#26069: [PATCH 2/2] gnu: Add shellcheck.
878toajsh4.fsf@kirby.i-did-not-set--mail-host-address--so-tickle-me
Danny Milosavljevic <dannym@scratchpost.org> writes:

Toggle quote (37 lines)
> * gnu/packages/haskell.scm (shellcheck): New variable.
> ---
> gnu/packages/haskell.scm | 35 +++++++++++++++++++++++++++++++++++
> 1 file changed, 35 insertions(+)
>
> diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
> index ce37f63f9..62bae9d81 100644
> --- a/gnu/packages/haskell.scm
> +++ b/gnu/packages/haskell.scm
> @@ -8239,4 +8239,39 @@ It is based on a subset of the JavaScript Programming Language, Standard
> ECMA-262 3rd Edition - December 1999.")
> (license license:bsd-3)))
>
> +(define-public shellcheck
> + (package
> + (name "shellcheck")
> + (version "0.4.5")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "https://github.com/koalaman/shellcheck/archive/"
> + "v" version ".tar.gz"))
> + (sha256
> + (base32
> + "14r84fcn28rin339avlvca5g0kz832f01x8dpmwb5ql8mbc4rlxr"))
> + (file-name (string-append name "-" version ".tar.gz"))))
> + (build-system haskell-build-system)
> + (inputs
> + `(("ghc-quickcheck" ,ghc-quickcheck)
> + ("ghc-json" ,ghc-json)
> + ("ghc-mtl" ,ghc-mtl)
> + ("ghc-parsec" ,ghc-parsec)
> + ("ghc-regex-tdfa" ,ghc-regex-tdfa)))
> + (home-page "https://github.com/koalaman/shellcheck")
> + (synopsis "Static analysis for shell scripts")
> + (description "@code{shellcheck} provides static analysis for bash and sh shell

@command{bash} (and sh)

Looks good elsewise, seems like a nice tool! :)

Toggle quote (13 lines)
> +scripts. It gives warnings and suggestions in order to:
> +
> +@enumerate
> +@item Point out and clarify typical beginner's syntax issues that cause
> +a shell to give cryptic error messages.
> +@item Point out and clarify typical intermediate level semantic problems
> +that cause a shell to behave strangely and counter-intuitively.
> +@item Point out subtle caveats, corner cases and pitfalls that may cause an
> +advanced user's otherwise working script to fail under future circumstances.
> +@end enumerate")
> + (license license:gpl3+)))
> +
> ;;; haskell.scm ends here
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAljFihcACgkQoqBt8qM6
VPpr+QgArJ+lfdyTXFvej5WP97HMh574fm8F0nFdLLuBO0cF2l8amZi5KaKl/TA2
NWWXcdlBT07YpRF+2V9zc2VOtHpRPOIeJLhAMOm2aH2TmqZuN6JLo5mC2qk8AUaz
BZf/g2uDbvsSsmfEvHcC5GAzyDKnzwEIEj6x+9bCDbUvFtWULRBCEt9ap52W5Tvx
UvaIfWCmZybuSR+5LV3b3HXPRDdVnwm7v2T4kr4JgGjXX+qsjJHKiTnou8caCz+k
hmwoQXUR3pBavTLp2VPqV2jMjUEIoSevtTr/iBSzvsZbeAU31LLscO+HMHCqdieL
wMOZsXjrr8XgQGlgeZm9cxxL4Wh0Hg==
=8NYZ
-----END PGP SIGNATURE-----

Danny Milosavljevic wrote 8 years ago
Shellcheck pushed to master
(address . 26069-done@debbugs.gnu.org)
20170325150328.6b0c7d20@scratchpost.org
Shellcheck pushed to master, commits 6f8016f4d8a84739ffdc7338bb1bbac5179e3ae3 (ghc-json) and 7e58cbbb39ea5efc890c84b9e42144117af0748d (shellcheck).
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26069@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26069
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help