[PATCH] python-rpy2: Propagate python2-singledispatch

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Pjotr Prins
  • Pjotr Prins
Owner
unassigned
Submitted by
Pjotr Prins
Severity
normal

Debbugs page

Pjotr Prins wrote 8 years ago
(address . guix-patches@gnu.org)(name . Pjotr Prins)(address . pjotr.public01@thebird.nl)
20170307102857.26170-1-pjotr.guix@thebird.nl
From: Pjotr Prins <pjotr.public01@thebird.nl>

* gnu/packages/python.scm (python-rp2): Fixes availability of singledispatch
when actually using the RPy2 package.
---
gnu/packages/python.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (18 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 5b86980..3b01a9a 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3836,9 +3836,9 @@ functions.")
(define-public python2-rpy2
(let ((rpy2 (package-with-python2 python-rpy2)))
(package (inherit rpy2)
- (native-inputs
+ (propagated-inputs
`(("python2-singledispatch" ,python2-singledispatch)
- ,@(package-native-inputs rpy2))))))
+ ,@(package-propagated-inputs rpy2))))))
(define-public python-scipy
(package
--
2.8.4
Ludovic Courtès wrote 8 years ago
(name . Pjotr Prins)(address . pjotr.guix@thebird.nl)(name . Pjotr Prins)(address . pjotr.public01@thebird.nl)(address . 26015-done@debbugs.gnu.org)
87zigx811a.fsf@gnu.org
Pjotr Prins <pjotr.guix@thebird.nl> skribis:

Toggle quote (5 lines)
> From: Pjotr Prins <pjotr.public01@thebird.nl>
>
> * gnu/packages/python.scm (python-rp2): Fixes availability of singledispatch
> when actually using the RPy2 package.

Applied, thanks!

Ludo'.
Closed
Pjotr Prins wrote 8 years ago
Re: [PATCH] python-rpy2: Propagate python2-singledispatch
(address . 26015@debbugs.gnu.org)(address . guix-patches@gnu.org)
20170308062733.GA32430@mail.thebird.nl
Example of what this patch fixes (sorry for the delay):

Traceback (most recent call last):
File "runserver.py", line 8, in <module>
from wqflask import app
File "/gnu/export/local/wrk/izip/git/opensource/genenetwork/sumo_gn2/wqflask/wqflask/__init__.py", line 24, in <module>
import wqflask.views
File "/gnu/export/local/wrk/izip/git/opensource/genenetwork/sumo_gn2/wqflask/wqflask/views.py", line 46, in <module>
from wqflask.marker_regression import marker_regression
File "/gnu/export/local/wrk/izip/git/opensource/genenetwork/sumo_gn2/wqflask/wqflask/marker_regression/marker_regression.py", line 16, in <module>
import rpy2.robjects as ro
File "/home/wrk/opt/genenetwork2-test/lib/python2.7/site-packages/rpy2/robjects/__init__.py", line 18, in <module>
from rpy2.robjects.robject import RObjectMixin, RObject
File "/home/wrk/opt/genenetwork2-test/lib/python2.7/site-packages/rpy2/robjects/robject.py", line 8, in <module>
from . import conversion
File "/home/wrk/opt/genenetwork2-test/lib/python2.7/site-packages/rpy2/robjects/conversion.py", line 13, in <module>
from singledispatch import singledispatch
ImportError: No module named singledispatch
?
Your comment

This issue is archived.

To comment on this conversation send an email to 26015@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 26015
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help