[PATCH] guix: Only attempt to build json builder if json is available.

  • Done
  • quality assurance status badge
Details
2 participants
  • John Darrington
  • Ludovic Courtès
Owner
unassigned
Submitted by
John Darrington
Severity
normal

Debbugs page

John Darrington wrote 8 years ago
(address . guix-patches@gnu.org)(name . John Darrington)(address . john@darrington.wattle.id.au)
1488563007-1161-1-git-send-email-john@darrington.wattle.id.au
* guix/import/stackage.scm: avoid loading the json module.
---
guix/import/stackage.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (23 lines)
diff --git a/guix/import/stackage.scm b/guix/import/stackage.scm
index 5b25adc..c8f195a 100644
--- a/guix/import/stackage.scm
+++ b/guix/import/stackage.scm
@@ -23,7 +23,6 @@
#:use-module (srfi srfi-26)
#:use-module (srfi srfi-34)
#:use-module (srfi srfi-35)
- #:use-module (guix import json)
#:use-module (guix import hackage)
#:use-module (guix memoization)
#:use-module (guix packages)
@@ -31,6 +30,8 @@
#:export (stackage->guix-package
%stackage-updater))
+(module-autoload! (current-module) '(guix import json) '(json))
+
;;;
;;; Stackage info fetcher and access functions
--
2.1.4
Ludovic Courtès wrote 8 years ago
(name . John Darrington)(address . john@darrington.wattle.id.au)(address . 25955@debbugs.gnu.org)
87mvcpe2qc.fsf@gnu.org
John Darrington <john@darrington.wattle.id.au> skribis:

Toggle quote (23 lines)
> * guix/import/stackage.scm: avoid loading the json module.
> ---
> guix/import/stackage.scm | 3 ++-
> 1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/guix/import/stackage.scm b/guix/import/stackage.scm
> index 5b25adc..c8f195a 100644
> --- a/guix/import/stackage.scm
> +++ b/guix/import/stackage.scm
> @@ -23,7 +23,6 @@
> #:use-module (srfi srfi-26)
> #:use-module (srfi srfi-34)
> #:use-module (srfi srfi-35)
> - #:use-module (guix import json)
> #:use-module (guix import hackage)
> #:use-module (guix memoization)
> #:use-module (guix packages)
> @@ -31,6 +30,8 @@
> #:export (stackage->guix-package
> %stackage-updater))
>
> +(module-autoload! (current-module) '(guix import json) '(json))

We don’t do that for any of the other (guix import …) modules that uses
(guix import json). What problem does it cause?

Thanks,
Ludo’.
John Darrington wrote 8 years ago
(no subject)
(address . 25955@debbugs.gnu.org)
20170315153616.GA19795@jocasta.intra
But the other modules are protected in Makefile.am.

The problem it causes, is that it's not possible to build Guix unless
guile-json is present.

--
Avoid eavesdropping. Send strong encrypted email.
PGP Public key ID: 1024D/2DE827B3
fingerprint = 8797 A26D 0854 2EAB 0285 A290 8A67 719C 2DE8 27B3
See http://sks-keyservers.netor any PGP keyserver for public key.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iEYEARECAAYFAljJX3AACgkQimdxnC3oJ7O8lgCfZ3mngf3PzM1rQiCxwXFQeD2b
G9gAniMHb1eKLVLpeDAA9ZEYt34mz2Ll
=d259
-----END PGP SIGNATURE-----


John Darrington wrote 8 years ago
Re: bug#25955: [PATCH] guix: Only attempt to build json builder if json is available.
(name . Ludovic Court??s)(address . ludo@gnu.org)(name . John Darrington)(address . john@darrington.wattle.id.au)(address . 25955@debbugs.gnu.org)
20170316141958.GA11088@jocasta.intra
On Mon, Mar 13, 2017 at 02:16:27PM +0100, Ludovic Court??s wrote:
John Darrington <john@darrington.wattle.id.au> skribis:
> * guix/import/stackage.scm: avoid loading the json module.
> ---
> guix/import/stackage.scm | 3 ++-
> 1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/guix/import/stackage.scm b/guix/import/stackage.scm
> index 5b25adc..c8f195a 100644
> --- a/guix/import/stackage.scm
> +++ b/guix/import/stackage.scm
> @@ -23,7 +23,6 @@
> #:use-module (srfi srfi-26)
> #:use-module (srfi srfi-34)
> #:use-module (srfi srfi-35)
> - #:use-module (guix import json)
> #:use-module (guix import hackage)
> #:use-module (guix memoization)
> #:use-module (guix packages)
> @@ -31,6 +30,8 @@
> #:export (stackage->guix-package
> %stackage-updater))
>
> +(module-autoload! (current-module) '(guix import json) '(json))
We don???t do that for any of the other (guix import ???) modules that uses

No. But all the others are projected in Makefile.am by "if HAVE_GUILE_JSON" .

(guix import json). What problem does it cause?

It means that one cannot build guix on a foreign system if guile-json is absent.


J'

--
Avoid eavesdropping. Send strong encrypted email.
PGP Public key ID: 1024D/2DE827B3
fingerprint = 8797 A26D 0854 2EAB 0285 A290 8A67 719C 2DE8 27B3
See http://sks-keyservers.netor any PGP keyserver for public key.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iEYEARECAAYFAljKnw4ACgkQimdxnC3oJ7OXAQCdF+z7glxAlv/zlU4XdZbTw4RL
+rkAn3bRBN7WaReWXIEJXyppfHteQCPD
=+OW0
-----END PGP SIGNATURE-----


Ludovic Courtès wrote 8 years ago
(name . John Darrington)(address . john@darrington.wattle.id.au)(address . 25955@debbugs.gnu.org)
877f3pz0u4.fsf@gnu.org
John Darrington <john@darrington.wattle.id.au> skribis:

Toggle quote (30 lines)
> On Mon, Mar 13, 2017 at 02:16:27PM +0100, Ludovic Court??s wrote:
> John Darrington <john@darrington.wattle.id.au> skribis:
>
> > * guix/import/stackage.scm: avoid loading the json module.
> > ---
> > guix/import/stackage.scm | 3 ++-
> > 1 file changed, 2 insertions(+), 1 deletion(-)
> >
> > diff --git a/guix/import/stackage.scm b/guix/import/stackage.scm
> > index 5b25adc..c8f195a 100644
> > --- a/guix/import/stackage.scm
> > +++ b/guix/import/stackage.scm
> > @@ -23,7 +23,6 @@
> > #:use-module (srfi srfi-26)
> > #:use-module (srfi srfi-34)
> > #:use-module (srfi srfi-35)
> > - #:use-module (guix import json)
> > #:use-module (guix import hackage)
> > #:use-module (guix memoization)
> > #:use-module (guix packages)
> > @@ -31,6 +30,8 @@
> > #:export (stackage->guix-package
> > %stackage-updater))
> >
> > +(module-autoload! (current-module) '(guix import json) '(json))
>
> We don???t do that for any of the other (guix import ???) modules that uses
>
> No. But all the others are projected in Makefile.am by "if HAVE_GUILE_JSON" .

Oh right. Then let’s move this one under “if HAVE_GUILE_JSON” as well.

Thanks,
Ludo’.
John Darrington wrote 8 years ago
(name . Ludovic Court??s)(address . ludo@gnu.org)(name . John Darrington)(address . john@darrington.wattle.id.au)(address . 25955@debbugs.gnu.org)
20170316171037.GA12329@jocasta.intra
On Thu, Mar 16, 2017 at 04:40:51PM +0100, Ludovic Court??s wrote:
John Darrington <john@darrington.wattle.id.au> skribis:
> On Mon, Mar 13, 2017 at 02:16:27PM +0100, Ludovic Court??s wrote:
> John Darrington <john@darrington.wattle.id.au> skribis:
>
> > * guix/import/stackage.scm: avoid loading the json module.
> > ---
> > guix/import/stackage.scm | 3 ++-
> > 1 file changed, 2 insertions(+), 1 deletion(-)
> >
> > diff --git a/guix/import/stackage.scm b/guix/import/stackage.scm
> > index 5b25adc..c8f195a 100644
> > --- a/guix/import/stackage.scm
> > +++ b/guix/import/stackage.scm
> > @@ -23,7 +23,6 @@
> > #:use-module (srfi srfi-26)
> > #:use-module (srfi srfi-34)
> > #:use-module (srfi srfi-35)
> > - #:use-module (guix import json)
> > #:use-module (guix import hackage)
> > #:use-module (guix memoization)
> > #:use-module (guix packages)
> > @@ -31,6 +30,8 @@
> > #:export (stackage->guix-package
> > %stackage-updater))
> >
> > +(module-autoload! (current-module) '(guix import json) '(json))
>
> We don???t do that for any of the other (guix import ???) modules that uses
>
> No. But all the others are projected in Makefile.am by "if HAVE_GUILE_JSON" .
Oh right. Then let???s move this one under ???if HAVE_GUILE_JSON??? as well.

No. I tried that. Unfortunately there are other modules which need this one.

J'
--
Avoid eavesdropping. Send strong encrypted email.
PGP Public key ID: 1024D/2DE827B3
fingerprint = 8797 A26D 0854 2EAB 0285 A290 8A67 719C 2DE8 27B3
See http://sks-keyservers.netor any PGP keyserver for public key.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iEYEARECAAYFAljKxw0ACgkQimdxnC3oJ7Pj7QCfYKKK/4vUs4iw9jzfftmkaKP8
iXsAnjmGzChMoSR4KWdoG9p2PRB+Ey9s
=CgeV
-----END PGP SIGNATURE-----


Ludovic Courtès wrote 8 years ago
(name . John Darrington)(address . john@darrington.wattle.id.au)(address . 25955-done@debbugs.gnu.org)
871sr25pe5.fsf@gnu.org
John Darrington <john@darrington.wattle.id.au> skribis:

Toggle quote (2 lines)
> * guix/import/stackage.scm: avoid loading the json module.

This was fixed later in commit 37fd9567710b0fc0d7b083f8a1eba3528597c2f6.

Thanks,
Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 25955@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 25955
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help