[PATCH] gnu: stellarium: Use modular Qt.

  • Done
  • quality assurance status badge
Details
3 participants
  • Danny Milosavljevic
  • Leo Famulari
  • Marius Bakke
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 8 years ago
(address . guix-patches@gnu.org)(name . Danny Milosavljevic)(address . dannym@scratchpost.org)
20170303113517.25630-1-dannym@scratchpost.org
* gnu/packages/astronomy.scm (stellarium)[inputs]: Remove qt.
Add qtbase, qtmultimedia, qtscript, qtserialport.
[native-inputs]: Add qtbase, qttools.
---
gnu/packages/astronomy.scm | 9 +++++++--
1 file changed, 7 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 43506a7bc..2695530fe 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -128,11 +128,16 @@ programs for the manipulation and analysis of astronomical data.")
"04avigz8i8mi2x6x71bqr9np85n1p9qnvbj2hxr947f1jv22zr8g"))))
(build-system cmake-build-system)
(inputs
- `(("qt" ,qt)
+ `(("qtbase" ,qtbase)
+ ("qtmultimedia" ,qtmultimedia)
+ ("qtscript" ,qtscript)
+ ("qtserialport" ,qtserialport)
("zlib" ,zlib)))
(native-inputs
`(("gettext" ,gettext-minimal) ; xgettext is used at compile time
- ("perl" ,perl))) ; For pod2man
+ ("perl" ,perl) ; For pod2man
+ ("qtbase" ,qtbase) ; Qt MOC is needed at compile time
+ ("qttools" ,qttools)))
(arguments
`(#:test-target "tests"
#:phases (modify-phases %standard-phases
Marius Bakke wrote 8 years ago
87h93a74nn.fsf@kirby.i-did-not-set--mail-host-address--so-tickle-me
Danny Milosavljevic <dannym@scratchpost.org> writes:

Toggle quote (4 lines)
> * gnu/packages/astronomy.scm (stellarium)[inputs]: Remove qt.
> Add qtbase, qtmultimedia, qtscript, qtserialport.
> [native-inputs]: Add qtbase, qttools.

LGTM, assuming the package still works :)

Also double check that `qtbase` and `qttools` are not listed in
`guix gc -R $(./pre-inst-env guix build stellarium)`.

Toggle quote (27 lines)
> ---
> gnu/packages/astronomy.scm | 9 +++++++--
> 1 file changed, 7 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
> index 43506a7bc..2695530fe 100644
> --- a/gnu/packages/astronomy.scm
> +++ b/gnu/packages/astronomy.scm
> @@ -128,11 +128,16 @@ programs for the manipulation and analysis of astronomical data.")
> "04avigz8i8mi2x6x71bqr9np85n1p9qnvbj2hxr947f1jv22zr8g"))))
> (build-system cmake-build-system)
> (inputs
> - `(("qt" ,qt)
> + `(("qtbase" ,qtbase)
> + ("qtmultimedia" ,qtmultimedia)
> + ("qtscript" ,qtscript)
> + ("qtserialport" ,qtserialport)
> ("zlib" ,zlib)))
> (native-inputs
> `(("gettext" ,gettext-minimal) ; xgettext is used at compile time
> - ("perl" ,perl))) ; For pod2man
> + ("perl" ,perl) ; For pod2man
> + ("qtbase" ,qtbase) ; Qt MOC is needed at compile time
> + ("qttools" ,qttools)))
> (arguments
> `(#:test-target "tests"
> #:phases (modify-phases %standard-phases
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAli5jawACgkQoqBt8qM6
VPqSugf/TdpOm/MgRgYzu/1ZSGJunX/0JVzMSxS0D+cC+0yQmCyzxSmcVZqVuOqe
Pe0BzhNqfxuh1K6BR+hvazGVGNDtuc+BlUmZqQRrTjflCtweMv996bAbEurshyJo
v4zfKz9vjr8laMqhgR22n6r467KB5SLS7O74whyOQVmbq4JldeOJfMlr+9AQT/6V
SXr/R2HcO5dbs3iudhnsyHLXunxLKziys8InxKPQ5+6wwLnLUacib+ytsDDYhpCP
n+XAIC0E+CIhMr6ayqokRDHBlQqdcscfJCsJHL1nFJIMFeZKSzCNzCoTg+NENP/t
LBv782yzg7bipXkAgtUHxWizmfjPPQ==
=7vhd
-----END PGP SIGNATURE-----

Leo Famulari wrote 8 years ago
(name . Marius Bakke)(address . mbakke@fastmail.com)
20170303173754.GA17559@jasmine
On Fri, Mar 03, 2017 at 04:37:16PM +0100, Marius Bakke wrote:
Toggle quote (11 lines)
> Danny Milosavljevic <dannym@scratchpost.org> writes:
>
> > * gnu/packages/astronomy.scm (stellarium)[inputs]: Remove qt.
> > Add qtbase, qtmultimedia, qtscript, qtserialport.
> > [native-inputs]: Add qtbase, qttools.
>
> LGTM, assuming the package still works :)
>
> Also double check that `qtbase` and `qttools` are not listed in
> `guix gc -R $(./pre-inst-env guix build stellarium)`.

I think only qttools should not be referenced, right? qtbase is not just
a native-input for stellarium:

Toggle quote (13 lines)
> > (inputs
> > - `(("qt" ,qt)
> > + `(("qtbase" ,qtbase)
> > + ("qtmultimedia" ,qtmultimedia)
> > + ("qtscript" ,qtscript)
> > + ("qtserialport" ,qtserialport)
> > ("zlib" ,zlib)))
> > (native-inputs
> > `(("gettext" ,gettext-minimal) ; xgettext is used at compile time
> > - ("perl" ,perl))) ; For pod2man
> > + ("perl" ,perl) ; For pod2man
> > + ("qtbase" ,qtbase) ; Qt MOC is needed at compile time
> > + ("qttools" ,qttools)))
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAli5qe8ACgkQJkb6MLrK
fwjruQ/+NH/fBJ8o3Pfe87WVnazIhH7Uv85plCc8yhZnoVgk6uEcbjwgZM79g2s1
Oq/tR/D4x1QkozBkZubuou4JKBgeeE2pnEDcDTzozBF+D3enO2SawzxkVMbbB0Hf
60zcpbJhfb9kWe6wxtAKdf89HIDkYGBrDRTwdJlK6QFpmOhli87qXRqjCeH8WSmf
sYG1NLTB1Bqloyo+9t9qZeJOeuXVw5gb57Zxkdqvy+/5qXhdrOPJM3oNk+362EF+
EgVbF5s2Yg3AXSDTq6K2arHgq5WbFqFGnB65k0fQcsLpABIe5cNiYMdONLjvygEY
U4rSnjsjyliVpkq39hVt9V1XEKbYmB8EB5c7xGIhk9RLMctmMLVwg7Tk0kkBQyKt
7CS1OGAAdd0K0LQIRt8KAabuK/LWLwgXAjhXiwGmtvN7G/CcBC58tyYCK7Hoq+nE
QZLj/q5cKjt6V43nbtzPwVRbkxIpVfs2gJy2pxX0CdrkOhi7eXrc75hBUqrw1bcB
L6aF1hFQP6nfsz8CZvTQNehSX/5qf0D6p38EUNYaG3bPAAh3aXinTWiqdnCqDoei
fdxvWqIS55cgvg81rUuGmAe/QI15BYowOG14frqyyrXRChUhiyUkqPsk6qbYi6JF
Q4JmW4GwzuWf9XKRQknNf881LiZ52eq2OXzSQg+T+xGxh1zzktc=
=1x4G
-----END PGP SIGNATURE-----


Marius Bakke wrote 8 years ago
(name . Leo Famulari)(address . leo@famulari.name)
87bmti6yve.fsf@kirby.i-did-not-set--mail-host-address--so-tickle-me
Leo Famulari <leo@famulari.name> writes:

Toggle quote (15 lines)
> On Fri, Mar 03, 2017 at 04:37:16PM +0100, Marius Bakke wrote:
>> Danny Milosavljevic <dannym@scratchpost.org> writes:
>>
>> > * gnu/packages/astronomy.scm (stellarium)[inputs]: Remove qt.
>> > Add qtbase, qtmultimedia, qtscript, qtserialport.
>> > [native-inputs]: Add qtbase, qttools.
>>
>> LGTM, assuming the package still works :)
>>
>> Also double check that `qtbase` and `qttools` are not listed in
>> `guix gc -R $(./pre-inst-env guix build stellarium)`.
>
> I think only qttools should not be referenced, right? qtbase is not just
> a native-input for stellarium:

Oops, you're right. Did not notice it was in both.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAli5qvYACgkQoqBt8qM6
VPpBYQf+PNAxc/YGt6tJ37XetTFKaBEACtjIMgaJmqtrk/9rv3y82LpkbTbUTkTc
5k+VdTJlVsjDTDzJNeocyuWSGXiKZEvcHlv0E6KM2Ty8tLiFjs3N7pswf40tdBfH
O8E/QZiepSmG9ziLeuloGcFjHS+YmA/4Ou3RVN76LmYaSjDZ3+DkP74JkNKqoORA
TMB1jPT5JEkR5AVnsJVPvaMl4V4uVVg1Gagc9aSAoCLGG2HLA5XE0gBkz0jNitMC
beuUL2chup7NU5GwrljgwzeXlhvpIPySiAqOF0EHBL1iPeZit0VPZVMN7KuI1hAS
aDsHAYE2ogB5RDQPd4J4r1Dly7Q9zw==
=tk5g
-----END PGP SIGNATURE-----

Danny Milosavljevic wrote 8 years ago
Pushed as 5bbf31ccba8c86730fac1dbe081032b1995ce31b to master
(address . 25948-done@debbugs.gnu.org)
20170304113401.6bbd57ad@scratchpost.org

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 25948@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 25948
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help