(address . guix-patches@gnu.org)
From f250e84b9d698e271240ca674a6dba8f94f27de6 Mon Sep 17 00:00:00 2001
From: Mekeor Melire <mekeor.melire@gmail.com>
Date: Wed, 1 Mar 2017 20:11:49 +0100
Subject: [PATCH 3/3] gnu: Add profanity.
* gnu/packages/messaging.scm (profanity): New variable.
---
gnu/packages/messaging.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)
Toggle diff (53 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 50ec49d77..e3f9b5b39 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -44,6 +44,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages check)
#:use-module (gnu packages crypto)
+ #:use-module (gnu packages curl)
#:use-module (gnu packages cyrus-sasl)
#:use-module (gnu packages databases)
#:use-module (gnu packages documentation)
@@ -1290,4 +1291,38 @@ are both supported).")
(home-page "http://strophe.im/libstrophe")
(license (list license:gpl3+ license:x11))))
+(define-public profanity
+ (package
+ (name "profanity")
+ (version "0.5.1")
+ (source (origin
+ (method url-fetch)
+ (uri "http://www.profanity.im/profanity-0.5.1.tar.gz")
+ (sha256
+ (base32
+ "1f7ylw3mhhnii52mmk40hyc4kqhpvjdr3hmsplzkdhsfww9kflg3"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("curl" ,curl)
+ ("expat" ,expat)
+ ("glib" ,glib)
+ ("gpgme" ,gpgme)
+ ("libmesode" ,libmesode)
+ ("libotr" ,libotr)
+ ("ncurses" ,ncurses)
+ ("openssl" ,openssl)
+ ("readline" ,readline)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("autoconf-archive" ,autoconf-archive)
+ ("automake" ,automake)
+ ("cmocka" ,cmocka)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
+ (synopsis "A console based XMPP client")
+ (description "Profanity is a console based XMPP client written in C
+using ncurses and libmesode, inspired by Irssi.")
+ (home-page "http://www.profanity.im")
+ (license license:gpl3+)))
+
;;; messaging.scm ends here
--
2.11.0