Kei Kebreau wrote 8 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kei@openmailbox.org)
* gnu/packages/telephony.scm (mumble)[source]: Add 'substitute*' calls
to 'snippet' for src/Version.h and src/mumble/VersionCheck.cpp.
---
gnu/packages/telephony.scm | 6 ++++++
1 file changed, 6 insertions(+)
Toggle diff (19 lines)
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index 87261825c..4ff2acd25 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -330,6 +330,12 @@ address of one of the participants.")
(modules '((guix build utils)))
(snippet
`(begin
+ ;; Remove timestamps for reproducibility.
+ (substitute* "src/Version.h"
+ (("\"Compiled \" __DATE__ \" \" __TIME__") "\"\""))
+ (substitute* "src/mumble/VersionCheck.cpp"
+ (("^.*__DATE__.*$") "")
+ (("^.*__TIME__.*$") ""))
;; Remove bundled software.
(for-each delete-file-recursively '("3rdparty"
"speex"
--
2.12.0