[PATCH] gnu: mumble: Make builds bit-reproducible.

  • Done
  • quality assurance status badge
Details
4 participants
  • Kei Kebreau
  • Leo Famulari
  • Ludovic Courtès
  • Marius Bakke
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 8 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kei@openmailbox.org)
20170301163530.17613-1-kei@openmailbox.org
* gnu/packages/telephony.scm (mumble)[source]: Add 'substitute*' calls
to 'snippet' for src/Version.h and src/mumble/VersionCheck.cpp.
---
gnu/packages/telephony.scm | 6 ++++++
1 file changed, 6 insertions(+)

Toggle diff (19 lines)
diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
index 87261825c..4ff2acd25 100644
--- a/gnu/packages/telephony.scm
+++ b/gnu/packages/telephony.scm
@@ -330,6 +330,12 @@ address of one of the participants.")
(modules '((guix build utils)))
(snippet
`(begin
+ ;; Remove timestamps for reproducibility.
+ (substitute* "src/Version.h"
+ (("\"Compiled \" __DATE__ \" \" __TIME__") "\"\""))
+ (substitute* "src/mumble/VersionCheck.cpp"
+ (("^.*__DATE__.*$") "")
+ (("^.*__TIME__.*$") ""))
;; Remove bundled software.
(for-each delete-file-recursively '("3rdparty"
"speex"
--
2.12.0
Marius Bakke wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)
87wpc9ymkd.fsf@kirby.i-did-not-set--mail-host-address--so-tickle-me
Kei Kebreau <kei@openmailbox.org> writes:

Toggle quote (3 lines)
> * gnu/packages/telephony.scm (mumble)[source]: Add 'substitute*' calls
> to 'snippet' for src/Version.h and src/mumble/VersionCheck.cpp.

Thanks a lot for this! The patch LGTM, but FYI won't be necessary once
'core-updates' is merged. See this commit, which backports a gcc7 patch.

d71d6fe85c4db778be6a2081cbbec6a3a494e4f9

Toggle quote (23 lines)
> ---
> gnu/packages/telephony.scm | 6 ++++++
> 1 file changed, 6 insertions(+)
>
> diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
> index 87261825c..4ff2acd25 100644
> --- a/gnu/packages/telephony.scm
> +++ b/gnu/packages/telephony.scm
> @@ -330,6 +330,12 @@ address of one of the participants.")
> (modules '((guix build utils)))
> (snippet
> `(begin
> + ;; Remove timestamps for reproducibility.
> + (substitute* "src/Version.h"
> + (("\"Compiled \" __DATE__ \" \" __TIME__") "\"\""))
> + (substitute* "src/mumble/VersionCheck.cpp"
> + (("^.*__DATE__.*$") "")
> + (("^.*__TIME__.*$") ""))
> ;; Remove bundled software.
> (for-each delete-file-recursively '("3rdparty"
> "speex"
> --
> 2.12.0
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAli2+kIACgkQoqBt8qM6
VPorVgf+OntKJGwxnO8CP6JD4JAg5ZyskT6MwBQNuiI+1hJz59eLLZuN038siPz7
Mm+MdN6RVlyxvOsQ2PQ18jXx4l+yBEFLvWpkuQ7XVGdm4rMfBoZl09LICrZP7R6I
e7mHWY3FRv7Wjq7qZE/IxE0mlfA/Vyj8vVox3tIrqHrKdgyREHhdoahNKCvTdTE8
nGnHbRw/91iLiGyqEq+AMufnBL5Qn//hHKg7B9Fs7GEKSRod0aHGXKPYvgPwVJ0v
h6sHv37TBeG2olL4Sw3WbL7TLXnSm3AoTaaTvJxCVcndP+4ohtd/usYV4iSFJ4hI
eP3KbxYr+8jIrVH1/Jst3/Tr5ndQMQ==
=41m/
-----END PGP SIGNATURE-----

Kei Kebreau wrote 8 years ago
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 25916@debbugs.gnu.org)
87fuiwkj6e.fsf@openmailbox.org
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (11 lines)
> Kei Kebreau <kei@openmailbox.org> writes:
>
>> * gnu/packages/telephony.scm (mumble)[source]: Add 'substitute*' calls
>> to 'snippet' for src/Version.h and src/mumble/VersionCheck.cpp.
>
> Thanks a lot for this! The patch LGTM, but FYI won't be necessary once
> 'core-updates' is merged. See this commit, which backports a gcc7 patch.
>
> d71d6fe85c4db778be6a2081cbbec6a3a494e4f9
>

Yay, what a useful patch!

Aren't we pretty close to merging core-updates? If that's the case, I
won't worry about pushing this to master.

Toggle quote (23 lines)
>> ---
>> gnu/packages/telephony.scm | 6 ++++++
>> 1 file changed, 6 insertions(+)
>>
>> diff --git a/gnu/packages/telephony.scm b/gnu/packages/telephony.scm
>> index 87261825c..4ff2acd25 100644
>> --- a/gnu/packages/telephony.scm
>> +++ b/gnu/packages/telephony.scm
>> @@ -330,6 +330,12 @@ address of one of the participants.")
>> (modules '((guix build utils)))
>> (snippet
>> `(begin
>> + ;; Remove timestamps for reproducibility.
>> + (substitute* "src/Version.h"
>> + (("\"Compiled \" __DATE__ \" \" __TIME__") "\"\""))
>> + (substitute* "src/mumble/VersionCheck.cpp"
>> + (("^.*__DATE__.*$") "")
>> + (("^.*__TIME__.*$") ""))
>> ;; Remove bundled software.
>> (for-each delete-file-recursively '("3rdparty"
>> "speex"
>> --
>> 2.12.0
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAli3AuoACgkQ5qXuPBlG
eg3X/g/9HnOvFRkTf9J6ogV71xoeFFvhahvTIvD5I5ix4iKyp2/SuJnTyv3cyzlt
3Vrk648YjWMDsYwDUpAN4em+edzdRNyzegD0bxbf+TmMUMAFTe3k+oUmke7EAK2G
S8f7sJJhmGHK59DPUsUZLLroIdnE9mwIrDnNV+Vva/Fq4lKiZQtJ4lBO6+D5tZ6t
COu1YSkwROVMQKqyyEPI7cwgCgOosUMVAszcI3RNrtSm09YWwnDegPHi6Yvnhwjv
aV476qlMwQK3sztBhabbfp3VEVnu0Nv1gb5ffkcusj1RLyRTo/cNZm9DRO70hHO7
ZBCeUKM4oTbKcoJwM5el2hJ5LBh9rekvRa4N4C8r//2QkxrrUCtqd9P63bZNfSJA
MLI3yP5toZZfO6vy1Nwq9NWHzqQCgPFmp3mTbTrk/vWNGu9yDyZjoP6A0+ClF+aH
jiwf2xx5Vti/vGohjQXy5R/Kv8OGypjo2CIxJvI//K0KqC6ITzqaf2nlipSnlPVQ
A4V1DkB+fMRpQkAufmMIJwlYobAM+6nW1xADlK5pXttYli1tkKoO0mT03B8Zyt8S
RNZUwQZ58P+/LLFe2G2LuLphr54ajPMNg18x9EQrazzXCJv1ESTUWkbhoKczeI6Z
nD4oNl9ZzF58JAUKE+/s3Bg3fdgS4knptneYeSaQhwH51apKlo4=
=pIj7
-----END PGP SIGNATURE-----

Marius Bakke wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 25916@debbugs.gnu.org)
87innszrrp.fsf@kirby.i-did-not-set--mail-host-address--so-tickle-me
Kei Kebreau <kei@openmailbox.org> writes:

Toggle quote (18 lines)
> Marius Bakke <mbakke@fastmail.com> writes:
>
>> Kei Kebreau <kei@openmailbox.org> writes:
>>
>>> * gnu/packages/telephony.scm (mumble)[source]: Add 'substitute*' calls
>>> to 'snippet' for src/Version.h and src/mumble/VersionCheck.cpp.
>>
>> Thanks a lot for this! The patch LGTM, but FYI won't be necessary once
>> 'core-updates' is merged. See this commit, which backports a gcc7 patch.
>>
>> d71d6fe85c4db778be6a2081cbbec6a3a494e4f9
>>
>
> Yay, what a useful patch!
>
> Aren't we pretty close to merging core-updates? If that's the case, I
> won't worry about pushing this to master.

I would guess at least 1-2 weeks more, but it's getting there.

Thanks anyway!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAli3KaoACgkQoqBt8qM6
VPpZEAf/XniOFgxYftzmzu8R6+SUWAw8dfZgt+ASo1nv+Pq0fEnB4cMQuPcSltBV
DiaFPH5E6ybZ7IVimmbolC+JVaArBTDZ+0t9CgwNE0Lk5MgbJPU/rnm2uS3Lbg77
LQ4BGlc2Urg2h1t1PS+B/L3tbB/8Q6UbOBZLXpKv1WDaFTG0Y3En1PFjcRiHFLPn
FAF5U8GVwtet0F5QkbDnJjzZk2ic7XaDRuY5HlkL9R8ydi8YLosAOkuTvMxFACn/
4Cv0YbKsytduFE+2abcHWJNZoZROafNuaMoP2dk1pj/SLJchQnY/wB2eCfLFpVrc
ZYnI61AqLP8AxjxBqmlAuiU6Wnh6WQ==
=4Xjf
-----END PGP SIGNATURE-----

Leo Famulari wrote 8 years ago
(name . Kei Kebreau)(address . kei@openmailbox.org)
20170301214401.GA22137@jasmine
On Wed, Mar 01, 2017 at 12:20:41PM -0500, Kei Kebreau wrote:
Toggle quote (18 lines)
> Marius Bakke <mbakke@fastmail.com> writes:
>
> > Kei Kebreau <kei@openmailbox.org> writes:
> >
> >> * gnu/packages/telephony.scm (mumble)[source]: Add 'substitute*' calls
> >> to 'snippet' for src/Version.h and src/mumble/VersionCheck.cpp.
> >
> > Thanks a lot for this! The patch LGTM, but FYI won't be necessary once
> > 'core-updates' is merged. See this commit, which backports a gcc7 patch.
> >
> > d71d6fe85c4db778be6a2081cbbec6a3a494e4f9
> >
>
> Yay, what a useful patch!
>
> Aren't we pretty close to merging core-updates? If that's the case, I
> won't worry about pushing this to master.

Someone should try checking if they can reproduce mumble on
core-updates, to make sure the backported GCC 7 patch is working
correctly :)
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAli3QKAACgkQJkb6MLrK
fwhDzA/+M6zuzhcR+tENWbaO2yvnXKgoKR/L+ZzIxDPpH45uPF6qTNKuxo2AD5Jl
hadij8ZUj3LqCdmW9aCcV7YtBlvZg6lec1WzvONCEmbsXsoH9kOkbDjsR0bkxfwE
Bwwq7Dst2bJ+iSzYEZGHmTtxqQn4t23Z/jykPl5KX8igdlwqfZczY2RDH7EcqKbS
LkCh0WYxp0STNaUgctWaByMua2dQEqrkBHU2w7bXpL0th3qYurdJDSJj+2ahyKP1
Qrec56gQqMYUS4gCS50G2uFe0x9ZK+e/we+h4MertOOelmQAP9LOT43E/0fVb8LH
FQlSNDyxbK6XNSY4TjVpaf1sJ+I0yn3DaVvDc5Oc6Bok1lq+uEStYwMH1D2EibHe
g7Bhuq53nwQJ5FA9wOH0Gvd4mHUFRVsVOuSJH08PvJYhEDICtk7oU6i6v8GMocDF
ju+10HUFDz/bw9RUX9ukKPhRXuekkAc1d0SghU+IN/wY1/VhBPm87qi3csAlK3AP
PB0BeCM6IkJzjEwJfwoLEzx6N7ODsWA7qhjKKGj2/6xiD/xBGuw5OXSOjloZda7Y
fg8YxNe7XuR69072dCyhYYaUzgH/zay6edfQERljSo2+HUdZYK1jfd7/ugtC5DZS
Z6dyg+1hzHdaIYY8+6PdA3qotoUChC3dtE1a+eEamwGii9wM5dY=
=5mFK
-----END PGP SIGNATURE-----


Marius Bakke wrote 8 years ago
(address . 25916@debbugs.gnu.org)
87h93csca5.fsf@kirby.i-did-not-set--mail-host-address--so-tickle-me
Leo Famulari <leo@famulari.name> writes:

Toggle quote (23 lines)
> On Wed, Mar 01, 2017 at 12:20:41PM -0500, Kei Kebreau wrote:
>> Marius Bakke <mbakke@fastmail.com> writes:
>>
>> > Kei Kebreau <kei@openmailbox.org> writes:
>> >
>> >> * gnu/packages/telephony.scm (mumble)[source]: Add 'substitute*' calls
>> >> to 'snippet' for src/Version.h and src/mumble/VersionCheck.cpp.
>> >
>> > Thanks a lot for this! The patch LGTM, but FYI won't be necessary once
>> > 'core-updates' is merged. See this commit, which backports a gcc7 patch.
>> >
>> > d71d6fe85c4db778be6a2081cbbec6a3a494e4f9
>> >
>>
>> Yay, what a useful patch!
>>
>> Aren't we pretty close to merging core-updates? If that's the case, I
>> won't worry about pushing this to master.
>
> Someone should try checking if they can reproduce mumble on
> core-updates, to make sure the backported GCC 7 patch is working
> correctly :)

That's a good test. Unfortunately, mumble fails to build on
'core-updates'.

starting phase `configure'
Reading /tmp/guix-build-mumble-1.2.19.drv-0/mumble-1.2.19/celt-0.7.0-build/celt-0.7.0-build.pro
Reading /tmp/guix-build-mumble-1.2.19.drv-0/mumble-1.2.19/celt-0.11.0-build/celt-0.11.0-build.pro
Reading /tmp/guix-build-mumble-1.2.19.drv-0/mumble-1.2.19/src/mumble/mumble.pro
Project ERROR: Package speexdsp not found
phase `configure' failed after 0.2 seconds

It seems to be related to the speex update; apparently the DSP component
have been split out of speex into a separate package:

-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAli3c9IACgkQoqBt8qM6
VPrUjggAhpbgiJHG+h/LVeOik4z42tyTNlX8oc8+wU+nmVU3Nxg/3MknvmHe7AXf
rjQrTZcpUUMZcyJl4kSyogXgyOi1aEpvKaUbYg9TvB+05onk32Hi3MoYltko03vK
rjPVLtx/MgnlYMvQYAEmm7am132UHpHb3hQIhSjaGjr0dyK7l+zkFtbeyPgIGp/G
kpUexcajaIlZmruoIac59Yj5A3kDvomzOH10YVRiFC2KfN41E8NTk1vrIMz1UWrF
J0mFv2oTJd2lbGGhARChb3CcCfYmY6SMj4+Zq//kVI3buAMMQfTiV7q9nr1Pzm/v
H63unT7YEyNNmhkdWvvn6TCcYE4Wlg==
=0BKO
-----END PGP SIGNATURE-----

Ludovic Courtès wrote 8 years ago
(name . Marius Bakke)(address . mbakke@fastmail.com)
87vaqjn93q.fsf@gnu.org
Hello!

Marius Bakke <mbakke@fastmail.com> skribis:

Toggle quote (28 lines)
> Leo Famulari <leo@famulari.name> writes:
>
>> On Wed, Mar 01, 2017 at 12:20:41PM -0500, Kei Kebreau wrote:
>>> Marius Bakke <mbakke@fastmail.com> writes:
>>>
>>> > Kei Kebreau <kei@openmailbox.org> writes:
>>> >
>>> >> * gnu/packages/telephony.scm (mumble)[source]: Add 'substitute*' calls
>>> >> to 'snippet' for src/Version.h and src/mumble/VersionCheck.cpp.
>>> >
>>> > Thanks a lot for this! The patch LGTM, but FYI won't be necessary once
>>> > 'core-updates' is merged. See this commit, which backports a gcc7 patch.
>>> >
>>> > d71d6fe85c4db778be6a2081cbbec6a3a494e4f9
>>> >
>>>
>>> Yay, what a useful patch!
>>>
>>> Aren't we pretty close to merging core-updates? If that's the case, I
>>> won't worry about pushing this to master.
>>
>> Someone should try checking if they can reproduce mumble on
>> core-updates, to make sure the backported GCC 7 patch is working
>> correctly :)
>
> That's a good test. Unfortunately, mumble fails to build on
> 'core-updates'.

It builds with current master (post ‘core-updates’ merge).

I’ve done a --check build and can confirm that our GCC now honors
‘SOURCE_DATE_EPOCH’, so the patch isn’t needed. \o/

Closing this bug!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 25916@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 25916
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help