[PATCH] gnu: Add unrar.

  • Done
  • quality assurance status badge
Details
4 participants
  • Catonano
  • John Darrington
  • Leo Famulari
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
John Darrington
Severity
normal

Debbugs page

John Darrington wrote 8 years ago
(address . guix-patches@gnu.org)(name . John Darrington)(address . jmd@gnu.org)
1488348097-13815-1-git-send-email-jmd@gnu.org
* gnu/packages/compression.scm (unrar): New variable.
---
gnu/packages/compression.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (28 lines)
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 9897883..73b2b84 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1128,3 +1128,21 @@ or junctions, and always follows hard links.")
;; libzpaq.cpp contains a mix of public-domain and
;; expat-licenced (or ‘MIT’) code.
license:expat))))
+
+(define-public unrar
+ (package
+ (name "unrar")
+ (version "0.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://download.gna.org/unrar/unrar-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1fgmjaxffj3shyxgy765jhxwz1cq88hk0fih1bsdzyvymyyz6mz7"))))
+ (build-system gnu-build-system)
+ (home-page "http://download.gna.org/unrar")
+ (synopsis "RAR archive extraction tool")
+ (description "Unrar is a simple command-line program to list and extract
+RAR archives.")
+ (license license:gpl2+)))
--
2.1.4
Leo Famulari wrote 8 years ago
(name . John Darrington)(address . jmd@gnu.org)(address . 25909@debbugs.gnu.org)
20170301152508.GA18139@jasmine
On Wed, Mar 01, 2017 at 07:01:37AM +0100, John Darrington wrote:
Toggle quote (2 lines)
> * gnu/packages/compression.scm (unrar): New variable.

LGTM
Catonano wrote 8 years ago
(address . 25909-done@debbugs.gnu.org)
CAJ98PDzb7uk2mpeapNUrRwv8swubgwv=C-KTTEoeqTM97BMecA@mail.gmail.com
I saw the patch in the log.
This ticket is closed

2017-03-01 16:25 GMT+01:00 Leo Famulari <leo@famulari.name>:

Toggle quote (8 lines)
> On Wed, Mar 01, 2017 at 07:01:37AM +0100, John Darrington wrote:
> > * gnu/packages/compression.scm (unrar): New variable.
>
> LGTM
>
>
>
>
Attachment: file
Closed
Tobias Geerinckx-Rice wrote 8 years ago
(address . 25909@debbugs.gnu.org)
c5fd2813-0361-54a6-838d-9e562c1bbec5@tobias.gr
On Wed, Mar 01, 2017 at 07:01:37AM +0100, John Darrington wrote:
Toggle quote (2 lines)
https://gna.org/projects/unrar lists http://home.gna.org/unrar/ as
project home page. I agree. It's far more homey and has more page, too.

Kind regards,

T G-R
Attachment: signature.asc
?
Your comment

This issue is archived.

To comment on this conversation send an email to 25909@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 25909
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help