Christopher Baines wrote 8 years ago
(address . guix-patches@gnu.org)
When launching a container created with guix system container, the
attempt to create /var/log/wtmp would fail, as /var/log did not exist.
* gnu/services.scm (activation-script): Create /var/log
---
gnu/services.scm | 1 +
1 file changed, 1 insertion(+)
Toggle diff (14 lines)
diff --git a/gnu/services.scm b/gnu/services.scm
index 6ac4f1322..15a0f2f89 100644
--- a/gnu/services.scm
+++ b/gnu/services.scm
@@ -345,6 +345,7 @@ ACTIVATION-SCRIPT-TYPE."
;; Same for 'wtmp', which is populated by mingetty et
;; al.
+ (if (not (file-exists? "/var/log")) (mkdir "/var/log"))
(close-port (open-file "/var/log/wtmp" "a0"))
;; Set up /run/current-system. Among other things this
--
2.11.1