[PATCH] gnu: %bootstrap-coreutils&co: Patch egrep/fgrep to point to the correct grep.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • manolis837
Owner
unassigned
Submitted by
manolis837
Severity
normal
Merged with
M
M
manolis837 wrote on 23 Feb 2017 12:41
(address . guix-patches@gnu.org)
20170223114119.18004-2-manolis837@gmail.com
From: Manolis Ragkousis <manolis837@gmail.com>

* gnu/packages/bootstrap.scm (%bootstrap-coreutils&co)[source]: Substitute the
absolute location of 'grep' with the one in /gnu/store.
---
gnu/packages/bootstrap.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index 61f1f1ab3..db7560b48 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -341,7 +341,8 @@ $out/bin/guile --version~%"
;; absolute file name instead of searching for it in $PATH.
(if (not (elf-file? "bin/egrep"))
(substitute* '("bin/egrep" "bin/fgrep")
- (("^exec grep") (string-append (getcwd) "/bin/grep"))))
+ (("/[^ ]+/bin/grep")
+ (string-append out "/bin/grep"))))
(chmod "bin" #o555)
#t)))
--
2.11.1
L
L
Ludovic Courtès wrote on 26 Mar 2017 15:53
control message for bug #25849
(address . control@debbugs.gnu.org)
87tw6gp2kf.fsf@gnu.org
merge 25849 25848
?
Your comment

This issue is archived.

To comment on this conversation send an email to 25849@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 25849
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch