[PATCH] gnu: Add font-tamzen.

  • Done
  • quality assurance status badge
Details
3 participants
  • contact.ng0
  • Kei Kebreau
  • Ludovic Courtès
Owner
unassigned
Submitted by
contact.ng0
Severity
normal
C
C
contact.ng0 wrote on 21 Feb 2017 12:39
(address . guix-patches@gnu.org)(name . ng0)(address . contact.ng0@cryptolab.net)
20170221113945.3791-1-contact.ng0@cryptolab.net
From: ng0 <contact.ng0@cryptolab.net>

* gnu/packages/fonts.scm (font-tamzen): New variable.
---
gnu/packages/fonts.scm | 64 ++++++++++++++++++++++++++++++++++++++++++++++++++
1 file changed, 64 insertions(+)

Toggle diff (77 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index ce07accbf..0a8d1efce 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -1035,6 +1035,70 @@ designed to work well in user interface environments.")
vector graphics.")
(license license:silofl1.1)))
+(define-public font-tamzen
+ (package
+ (name "font-tamzen")
+ (version "1.11.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/sunaku/tamzen-font/archive/"
+ "Tamzen-" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1ryd7gp6qiwaqw73jqbmh4kwlriyd8xykh4j7z90z8xp9fm7lrys"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+
+ (let ((tar (string-append (assoc-ref %build-inputs "tar")
+ "/bin/tar"))
+ (PATH (string-append (assoc-ref %build-inputs "gzip")
+ "/bin"))
+ (font-dir (string-append %output "/share/fonts/misc"))
+ (psf-dir (string-append %output "/share/kbd/consolefonts"))
+ (src-pcf-dir (string-append "tamzen-font-Tamzen-"
+ ,version "/pcf")))
+ (setenv "PATH" PATH)
+ (system* tar "xvf" (assoc-ref %build-inputs "source"))
+ (mkdir-p font-dir)
+ (mkdir-p psf-dir)
+ (chdir src-pcf-dir)
+ (for-each (lambda (pcf)
+ (install-file pcf font-dir))
+ (find-files "." "\\.pcf$"))
+ (chdir "../psf")
+ (for-each (lambda (psf)
+ (install-file psf psf-dir))
+ (find-files "." "\\.psf$"))
+ #t))))
+ (native-inputs
+ `(("tar" ,tar)
+ ("gzip" ,gzip)))
+ (home-page "https://github.com/sunaku/tamzen-font")
+ (synopsis "Monospaced bitmap font for console and X11")
+ (description
+ "Tamzen is a fork of the @code{Tamsyn} font. It is programatically forked
+from @code{Tamsyn} version 1.11, backporting glyphs from older versions while
+deleting deliberately empty glyphs (which are marked as unimplemented) to
+allow secondary/fallback fonts to provide real glyphs at those codepoints.
+
+The 'TamzenForPowerline' fonts provide additional @code{Powerline} symbols,
+which are programatically injected with @code{bitmap-font-patcher} and
+later hand-tweaked with the gbdfed(1) editor:
+
+@enumerate
+@item all icons are expanded to occupy the maximum available space
+@item the branch of the fork icon (? U+E0A0) was made larger than the trunk
+@item for the newline icon (? U+E0A1), the 'N' was made larger at the bottom
+@item the keyhole in the padlock icon (? U+E0A2) was replaced with '//' lines.
+@end enumerate\n")
+ (license (license:non-copyleft "file://LICENSE"))))
+
(define-public font-comic-neue
(package
(name "font-comic-neue")
--
2.11.1
N
Re: bug#25829: Acknowledgement ([PATCH] gnu: Add font-tamzen.)
(address . 25829@debbugs.gnu.org)
20170221114829.hjwawisf42odmt3w@wasp
On 17-02-21 11:39:02, GNU bug Tracking System wrote:
Toggle quote (23 lines)
> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> Your message has been sent to the package maintainer(s):
> guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 25829@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
>
> --
> 25829: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=25829
> GNU Bug Tracking System
> Contact help-debbugs@gnu.org with problems


What works: pcf fonts (the ones in kbd/consolefonts) - Powerline in vim
without X... useful feature.

What I can't get to work though, are the fonts for X. Do I have to
convert them like archlinux does for one of their bdf (bitmap) fonts? I
tried plain bdf before and decided to pick the other format, and it
doesn't work again so maybe it's the directory? But when I run fc-cache
-fv it is being picked up... What do you think is the best way to go
here?
N
(address . 25829@debbugs.gnu.org)
20170222153625.6jdwnwro7orzlhjw@wasp
On 17-02-21 11:48:29, ng0 wrote:
Toggle quote (37 lines)
> On 17-02-21 11:39:02, GNU bug Tracking System wrote:
> > Thank you for filing a new bug report with debbugs.gnu.org.
> >
> > This is an automatically generated reply to let you know your message
> > has been received.
> >
> > Your message is being forwarded to the package maintainers and other
> > interested parties for their attention; they will reply in due course.
> >
> > Your message has been sent to the package maintainer(s):
> > guix-patches@gnu.org
> >
> > If you wish to submit further information on this problem, please
> > send it to 25829@debbugs.gnu.org.
> >
> > Please do not send mail to help-debbugs@gnu.org unless you wish
> > to report a problem with the Bug-tracking system.
> >
> > --
> > 25829: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=25829
> > GNU Bug Tracking System
> > Contact help-debbugs@gnu.org with problems
>
>
> What works: pcf fonts (the ones in kbd/consolefonts) - Powerline in vim
> without X... useful feature.
>
> What I can't get to work though, are the fonts for X. Do I have to
> convert them like archlinux does for one of their bdf (bitmap) fonts? I
> tried plain bdf before and decided to pick the other format, and it
> doesn't work again so maybe it's the directory? But when I run fc-cache
> -fv it is being picked up... What do you think is the best way to go
> here?
>
>
>

I can now confirm: All 4 kinds of fonts work. For pcf it's clear
(loadfonts blafooopathtofont) for both powerline and without
powerline, and for X11 I had to use facename, not font as an option. I
thought bitmap == bitmap option for Xterm, but it's a regular X font.
K
K
Kei Kebreau wrote on 10 Mar 2017 01:40
Re: bug#25829: [PATCH] gnu: Add font-tamzen.
(address . contact.ng0@cryptolab.net)(address . 25829@debbugs.gnu.org)
87zigu9d6i.fsf@openmailbox.org
contact.ng0@cryptolab.net writes:

Toggle quote (72 lines)
> From: ng0 <contact.ng0@cryptolab.net>
>
> * gnu/packages/fonts.scm (font-tamzen): New variable.
> ---
> gnu/packages/fonts.scm | 64 ++++++++++++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 64 insertions(+)
>
> diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
> index ce07accbf..0a8d1efce 100644
> --- a/gnu/packages/fonts.scm
> +++ b/gnu/packages/fonts.scm
> @@ -1035,6 +1035,70 @@ designed to work well in user interface environments.")
> vector graphics.")
> (license license:silofl1.1)))
>
> +(define-public font-tamzen
> + (package
> + (name "font-tamzen")
> + (version "1.11.4")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "https://github.com/sunaku/tamzen-font/archive/"
> + "Tamzen-" version ".tar.gz"))
> + (file-name (string-append name "-" version ".tar.gz"))
> + (sha256
> + (base32
> + "1ryd7gp6qiwaqw73jqbmh4kwlriyd8xykh4j7z90z8xp9fm7lrys"))))
> + (build-system trivial-build-system)
> + (arguments
> + `(#:modules ((guix build utils))
> + #:builder
> + (begin
> + (use-modules (guix build utils))
> +
> + (let ((tar (string-append (assoc-ref %build-inputs "tar")
> + "/bin/tar"))
> + (PATH (string-append (assoc-ref %build-inputs "gzip")
> + "/bin"))
> + (font-dir (string-append %output "/share/fonts/misc"))
> + (psf-dir (string-append %output "/share/kbd/consolefonts"))
> + (src-pcf-dir (string-append "tamzen-font-Tamzen-"
> + ,version "/pcf")))
> + (setenv "PATH" PATH)
> + (system* tar "xvf" (assoc-ref %build-inputs "source"))
> + (mkdir-p font-dir)
> + (mkdir-p psf-dir)
> + (chdir src-pcf-dir)
> + (for-each (lambda (pcf)
> + (install-file pcf font-dir))
> + (find-files "." "\\.pcf$"))
> + (chdir "../psf")
> + (for-each (lambda (psf)
> + (install-file psf psf-dir))
> + (find-files "." "\\.psf$"))
> + #t))))
> + (native-inputs
> + `(("tar" ,tar)
> + ("gzip" ,gzip)))
> + (home-page "https://github.com/sunaku/tamzen-font")
> + (synopsis "Monospaced bitmap font for console and X11")
> + (description
> + "Tamzen is a fork of the @code{Tamsyn} font. It is programatically forked
> +from @code{Tamsyn} version 1.11, backporting glyphs from older versions while
> +deleting deliberately empty glyphs (which are marked as unimplemented) to
> +allow secondary/fallback fonts to provide real glyphs at those codepoints.
> +
> +The 'TamzenForPowerline' fonts provide additional @code{Powerline} symbols,
> +which are programatically injected with @code{bitmap-font-patcher} and
> +later hand-tweaked with the gbdfed(1) editor:
> +

I changed 'TamzenForPowerline' to @code{TamzenForPowerline} for guix
lint's sake.

Toggle quote (7 lines)
> +@enumerate
> +@item all icons are expanded to occupy the maximum available space
> +@item the branch of the fork icon (? U+E0A0) was made larger than the trunk
> +@item for the newline icon (? U+E0A1), the 'N' was made larger at the bottom
> +@item the keyhole in the padlock icon (? U+E0A2) was replaced with '//' lines.
> +@end enumerate\n")

I changed the 'N' and '//' to @emph{N} and @emph{//} also for guix lint's sake.

Toggle quote (6 lines)
> + (license (license:non-copyleft "file://LICENSE"))))
> +
> (define-public font-comic-neue
> (package
> (name "font-comic-neue")

Pushed to master as f2a7ce5033390e5a7b5faa8218010c4fd05ace1f.
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAljB9gUACgkQ5qXuPBlG
eg11Qg//c2Df3C7NtAWQbplWA3vFQfi3AMcqB8IwBbjEYaQi3ZAf5zagLXJAmaju
frFIl4uwxUYUesHVaTjVCaVBUOuyQQo8ebi9z+0xMB7GNtaYxGlMEGCBSitHWFey
2oR32HcmP36vywiZpKiPhaMNqtijxNZUJd4fqcislJnMgdq32VqDNMzOBZSiMGkf
chrBvWIHFxwaZckD0IsOmw6tol9WXbPeL8HiSZ9JEud17cFf6Ea01VAsTngxLu2l
Po0LmIadvVUkzGITvRTqtl2/YJ04ZVhFDwazPeO5zb0iVcPI/uusnF8sFsTPPFhd
m+orwbgg/L7rY3jrHdk8/A6m87QlNq9LV3ipZDASvCuc3ErF7hrun49qf0pUX276
6NRfBn+L7lAPKpDMI0JYz20dMFXyAbMnl4YKFq9crlntpsQKYdbuK4tB0xU8HTMJ
NU0qklivPmpTj+sHza/oF44E2mbOnOsi/UG4SnOiPE5VJPPwR0khw7sp+hVmJECy
xUyzb2mEtVjMQa7YSuQHiBpFetIAjmlBKFZbI5dD/TUo3F10j3MVq1gqCCUyTxYH
2XqxeYQKzRIKJ4ytC9OXR1Zb5PeJd0c2AJHPZyqIrkPtkbhBy9quup+ixdQ+Butc
ZCWCBBi6XfZoeQabivS3EShwvX0adKFFMgfTQugS9JO4uWmlXN0=
=nHD8
-----END PGP SIGNATURE-----

N
(name . Kei Kebreau)(address . kei@openmailbox.org)(address . 25829-done@debbugs.gnu.org)
20170310092911.jsdwmtikm4yn7qcb@abyayala
Kei Kebreau transcribed 4.7K bytes:
Toggle quote (94 lines)
> contact.ng0@cryptolab.net writes:
>
> > From: ng0 <contact.ng0@cryptolab.net>
> >
> > * gnu/packages/fonts.scm (font-tamzen): New variable.
> > ---
> > gnu/packages/fonts.scm | 64 ++++++++++++++++++++++++++++++++++++++++++++++++++
> > 1 file changed, 64 insertions(+)
> >
> > diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
> > index ce07accbf..0a8d1efce 100644
> > --- a/gnu/packages/fonts.scm
> > +++ b/gnu/packages/fonts.scm
> > @@ -1035,6 +1035,70 @@ designed to work well in user interface environments.")
> > vector graphics.")
> > (license license:silofl1.1)))
> >
> > +(define-public font-tamzen
> > + (package
> > + (name "font-tamzen")
> > + (version "1.11.4")
> > + (source
> > + (origin
> > + (method url-fetch)
> > + (uri (string-append "https://github.com/sunaku/tamzen-font/archive/"
> > + "Tamzen-" version ".tar.gz"))
> > + (file-name (string-append name "-" version ".tar.gz"))
> > + (sha256
> > + (base32
> > + "1ryd7gp6qiwaqw73jqbmh4kwlriyd8xykh4j7z90z8xp9fm7lrys"))))
> > + (build-system trivial-build-system)
> > + (arguments
> > + `(#:modules ((guix build utils))
> > + #:builder
> > + (begin
> > + (use-modules (guix build utils))
> > +
> > + (let ((tar (string-append (assoc-ref %build-inputs "tar")
> > + "/bin/tar"))
> > + (PATH (string-append (assoc-ref %build-inputs "gzip")
> > + "/bin"))
> > + (font-dir (string-append %output "/share/fonts/misc"))
> > + (psf-dir (string-append %output "/share/kbd/consolefonts"))
> > + (src-pcf-dir (string-append "tamzen-font-Tamzen-"
> > + ,version "/pcf")))
> > + (setenv "PATH" PATH)
> > + (system* tar "xvf" (assoc-ref %build-inputs "source"))
> > + (mkdir-p font-dir)
> > + (mkdir-p psf-dir)
> > + (chdir src-pcf-dir)
> > + (for-each (lambda (pcf)
> > + (install-file pcf font-dir))
> > + (find-files "." "\\.pcf$"))
> > + (chdir "../psf")
> > + (for-each (lambda (psf)
> > + (install-file psf psf-dir))
> > + (find-files "." "\\.psf$"))
> > + #t))))
> > + (native-inputs
> > + `(("tar" ,tar)
> > + ("gzip" ,gzip)))
> > + (home-page "https://github.com/sunaku/tamzen-font")
> > + (synopsis "Monospaced bitmap font for console and X11")
> > + (description
> > + "Tamzen is a fork of the @code{Tamsyn} font. It is programatically forked
> > +from @code{Tamsyn} version 1.11, backporting glyphs from older versions while
> > +deleting deliberately empty glyphs (which are marked as unimplemented) to
> > +allow secondary/fallback fonts to provide real glyphs at those codepoints.
> > +
> > +The 'TamzenForPowerline' fonts provide additional @code{Powerline} symbols,
> > +which are programatically injected with @code{bitmap-font-patcher} and
> > +later hand-tweaked with the gbdfed(1) editor:
> > +
>
> I changed 'TamzenForPowerline' to @code{TamzenForPowerline} for guix
> lint's sake.
>
> > +@enumerate
> > +@item all icons are expanded to occupy the maximum available space
> > +@item the branch of the fork icon (? U+E0A0) was made larger than the trunk
> > +@item for the newline icon (? U+E0A1), the 'N' was made larger at the bottom
> > +@item the keyhole in the padlock icon (? U+E0A2) was replaced with '//' lines.
> > +@end enumerate\n")
>
> I changed the 'N' and '//' to @emph{N} and @emph{//} also for guix lint's sake.
>
> > + (license (license:non-copyleft "file://LICENSE"))))
> > +
> > (define-public font-comic-neue
> > (package
> > (name "font-comic-neue")
>
> Pushed to master as f2a7ce5033390e5a7b5faa8218010c4fd05ace1f.

Thanks, closed.
Closed
L
L
Ludovic Courtès wrote on 10 Mar 2017 09:31
control message for bug #25829
(address . control@debbugs.gnu.org)
87o9x9bkje.fsf@gnu.org
tags 25829 fixed
close 25829
?