guix on other distribution fails to pull

  • Done
  • quality assurance status badge
Details
3 participants
  • Leo Famulari
  • Tomas Cech
  • Tomas Cech
Owner
unassigned
Submitted by
Tomas Cech
Severity
normal
T
T
Tomas Cech wrote on 13 Feb 2017 14:11
(address . bug-guix@gnu.org)
877f4u5j7d.wl-tcech@suse.com
I'm having problems with running Guix on top of openSUSE. I installed
clean 0.12 release on clean system.

$ guix pull

Starting download of /tmp/guix-file.Z09Ce2
….tar.gz 3.0MiB/s 00:04 | 11.0MiB transferred
unpacking '/gnu/store/z13bqhi66zzxhzdql046khzm09r21xxq-guix-latest.tar.gz'...
substitute: updating list of substitutes from 'https://mirror.hydra.gnu.org'... 100.0%
substitute: updating list of substitutes from 'https://mirror.hydra.gnu.org'... 100.0%
fetching path `/gnu/store/k4jwdl2ca04552z9hd9c0721wxlahjyy-curl-7.47.0'...
curl-7.47.0 444KiB/s 00:01 | 632KiB transferred

fetching path `/gnu/store/2mz84alls2i314x4506wdw15zwmz82n8-python-2.7.10'...
python-2.7.10 4.0MiB/s 00:04 | 15.3MiB transferred

hash mismatch in downloaded path `/gnu/store/2mz84alls2i314x4506wdw15zwmz82n8-python-2.7.10': expected 4f6ac594d87839f78be751763fda022f57910f77011616c95f22a53655b0942d, got 222a0f7d89133c011acd36536141c87239a71b43c36a5dd1d939460058a15f98
building path(s) `/gnu/store/cwc9qg98wavxy69jvj42srdl14594b11-apr-util-1.5.4'
guix pull: error: build failed: some substitutes for the outputs of derivation `/gnu/store/acgss8990yn864yxf857ba9fyjsyfsa7-python-2.7.10.drv' failed (usually happens due to networking issues); try `--fallback' to build derivation from source


This shows 2 problems:

- pull doesn't support `--fallback'
- hydra build of apr-util is probably corrupted


When I try to help manually, it sometimes helps...

$ guix build apr-util --fallback
The following derivation will be built:
/gnu/store/3fz5akwl2s3f7n1lp04avdcwcnnwfnyc-apr-util-1.5.4.drv
@ build-started /gnu/store/3fz5akwl2s3f7n1lp04avdcwcnnwfnyc-apr-util-1.5.4.drv - x86_64-linux /var/log/guix/drvs/3f//z5akwl2s3f7n1lp04avdcwcnnwfnyc-apr-util-1.5.4.drv.bz2
grafting '/gnu/store/symq7x013biwxc697271vvm0nxpb4d13-apr-util-1.5.4' -> '/gnu/store/cwc9qg98wavxy69jvj42srdl14594b11-apr-util-1.5.4'...
@ build-succeeded /gnu/store/3fz5akwl2s3f7n1lp04avdcwcnnwfnyc-apr-util-1.5.4.drv -
/gnu/store/cwc9qg98wavxy69jvj42srdl14594b11-apr-util-1.5.4

$ guix pull

Starting download of /tmp/guix-file.VxLjfT
….tar.gz 3.1MiB/s 00:04 | 11.0MiB transferred
unpacking '/gnu/store/z13bqhi66zzxhzdql046khzm09r21xxq-guix-latest.tar.gz'...
fetching path `/gnu/store/2mz84alls2i314x4506wdw15zwmz82n8-python-2.7.10'...
python-2.7.10 4.2MiB/s 00:04 | 15.3MiB transferred

hash mismatch in downloaded path `/gnu/store/2mz84alls2i314x4506wdw15zwmz82n8-python-2.7.10': expected 4f6ac594d87839f78be751763fda022f57910f77011616c95f22a53655b0942d, got 222a0f7d89133c011acd36536141c87239a71b43c36a5dd1d939460058a15f98
building path(s) `/gnu/store/nw1lim6cr83rfbyih6pz41rnc0f1l2cs-file-5.25'
guix pull: error: build failed: some substitutes for the outputs of derivation `/gnu/store/acgss8990yn864yxf857ba9fyjsyfsa7-python-2.7.10.drv' failed (usually happens due to networking issues); try `--fallback' to build derivation from source

...and sometimes it gives me different hash...

$ guix build python@2.7.10 --fallback
/gnu/store/7fm1qk703x47qzb9p6xg08cxgb009akz-python-2.7.10
/gnu/store/813i9qr3l6w5ada97l1m1cna08fzrra9-python-2.7.10-tk

...and pull will never work.


Is there anything I could do to workaround the problem?
T
T
Tomas Cech wrote on 20 Feb 2017 12:07
(address . 25704@debbugs.gnu.org)
87lgt1p1cn.wl-sleep_walker@gnu.org
Toggle quote (5 lines)
>
> This shows 2 problems:
>
> - pull doesn't support `--fallback'

and `--substitute-urls` is missing there as well...

Toggle quote (2 lines)
> - hydra build of apr-util is probably corrupted

sorry, it should be probably python-2.7.10
L
L
Leo Famulari wrote on 21 Feb 2017 04:58
(name . Tomas Cech)(address . tcech@suse.com)(address . 25704@debbugs.gnu.org)
20170221035833.GA19762@jasmine
On Mon, Feb 13, 2017 at 02:11:34PM +0100, Tomas Cech wrote:
Try starting the guix-daemon with
'--substitute-urls=https://hydra.gnu.org'. This will bypass the mirror
completely.

Let us know if it works and be sure to remove that URL afterwards; that
server cannot handle much traffic.
T
T
Tomas Cech wrote on 21 Feb 2017 08:41
(name . Leo Famulari)(address . leo@famulari.name)(address . 25704@debbugs.gnu.org)
87k28kdm7t.wl-sleep_walker@gnu.org
On Tue, 21 Feb 2017 04:58:33 +0100,
Leo Famulari wrote:
Toggle quote (10 lines)
>
> On Mon, Feb 13, 2017 at 02:11:34PM +0100, Tomas Cech wrote:
> Try starting the guix-daemon with
> '--substitute-urls=https://hydra.gnu.org'. This will bypass the mirror
> completely.
>
> Let us know if it works and be sure to remove that URL afterwards; that
> server cannot handle much traffic.
>

Thanks, I solved it some other way in the meantime. But thanks, this
could work as well...

From single user perspective it is valid workaround but I'm aftraid
that from guix package maintainer on foreign distribution it is not
usable workaround...

Best regards,

S_W
L
L
Leo Famulari wrote on 21 Feb 2017 18:11
(name . Tomas Cech)(address . sleep_walker@gnu.org)(address . 25704@debbugs.gnu.org)
20170221171151.GA1656@jasmine
On Tue, Feb 21, 2017 at 08:41:58AM +0100, Tomas Cech wrote:
Toggle quote (19 lines)
> On Tue, 21 Feb 2017 04:58:33 +0100,
> Leo Famulari wrote:
> >
> > On Mon, Feb 13, 2017 at 02:11:34PM +0100, Tomas Cech wrote:
> > Try starting the guix-daemon with
> > '--substitute-urls=https://hydra.gnu.org'. This will bypass the mirror
> > completely.
> >
> > Let us know if it works and be sure to remove that URL afterwards; that
> > server cannot handle much traffic.
> >
>
> Thanks, I solved it some other way in the meantime. But thanks, this
> could work as well...
>
> From single user perspective it is valid workaround but I'm aftraid
> that from guix package maintainer on foreign distribution it is not
> usable workaround...

Sure, and we know that `guix pull` needs to be overhauled. We've been
discussing its shortcomings and designing the replacement:

L
L
Leo Famulari wrote on 22 Mar 2020 21:29
(name . Tomas Cech)(address . sleep_walker@gnu.org)(address . 25704-done@debbugs.gnu.org)
20200322202935.GA19078@jasmine.lan
On Tue, Feb 21, 2017 at 12:11:51PM -0500, Leo Famulari wrote:
Toggle quote (3 lines)
> Sure, and we know that `guix pull` needs to be overhauled. We've been
> discussing its shortcomings and designing the replacement:

This work has been completed. Closing the bug.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 25704@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 25704
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch