angband [new package]

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Allan Webber
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Christopher Allan Webber
Severity
normal

Debbugs page

Christopher Allan Webber wrote 8 years ago
(address . guix-patches@gnu.org)
87k28v5x0x.fsf@dustycloud.org
This patch adds Angband, one of those delightfully life-destroying
roguelikes. Now you too can ruin your life chasing an @ around a screen
for hours at a time. Horray!
From c167b96d38acf580e42a618b6211c007760949f0 Mon Sep 17 00:00:00 2001
From: Christopher Allan Webber <cwebber@dustycloud.org>
Date: Fri, 10 Feb 2017 16:45:11 -0600
Subject: [PATCH] gnu: Add angband.

* gnu/packages/games.scm (angband): New variable.
---
gnu/packages/games.scm | 37 ++++++++++++++++++++++++++++++++++++-
1 file changed, 36 insertions(+), 1 deletion(-)

Toggle diff (57 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 0867089d5..0df1f69e5 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
-;;; Copyright © 2015 Christopher Allan Webber <cwebber@dustycloud.org>
+;;; Copyright © 2015, 2017 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016, 2017 Alex Kost <alezost@gmail.com>
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
@@ -227,6 +227,41 @@ them, called Jean Raymond, found an old church in which to hide, not knowing
that beneath its ruins lay buried an ancient evil.")
(license license:gpl3)))
+(define-public angband
+ (package
+ (name "angband")
+ (version "4.0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://rephial.org/downloads/4.0/"
+ "angband-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0lpq2kms7hp421vrasx2bkkn9w08kr581ldwik3v0hlq6h7rlxhd"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;no check target
+ ;; #:configure-flags '("--enable-sdl")
+ #:configure-flags (list (string-append "--bindir=" %output "/bin"))
+ #:phases (modify-phases %standard-phases
+ (add-after
+ 'unpack 'autogen.sh
+ (lambda _
+ (substitute* "acinclude.m4"
+ (("ncursesw5-config") "ncursesw6-config"))
+ (zero? (system* "sh" "autogen.sh")))))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)))
+ (inputs `(("ncurses" ,ncurses)))
+ (home-page "http://rephial.org/")
+ (synopsis "Dungeon exploration roguelike")
+ (description "Classic dungeon exploration roguelike. Explore the depths
+below Angband, seeking riches, fighting monsters, and preparing to fight
+Morgoth, the Lord of Darkness.")
+ (license license:gpl2)))
+
(define-public pingus
(package
(name "pingus")
--
2.11.0
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEUQqGKOKndniPjHCcS8Alkl/49NMFAligao8ACgkQS8Alkl/4
9NPQhBAAhORWL2Mev8sasFx0hbAVqIku7/n+CsPUBoPmbUbsINXp6PPlx0g+Pi3p
h3VMY49ZbqwGh9ERkbC3oT2CZr4BYX/edt+NtbFqm1Um9Z+FhPZsqbhz7CGYtCz5
nxVb7x2PJbKsb/fo4h5VnwbIBbo4KAC+9U6r+zl376tI5rJ5/jFdlNZbP1tAlb+P
iCdKlXcBlP+7Vya6+a8kZ1tOvy/ZULdba+NsONXNmu0gS4eU+8Ap/JuAFCfosZZx
WNJNgKgsi2dU10pJha7zNrcYjYj0knc9xeSZm15asAUyDNd8WraoFdeusN+fJvx4
DStq74Ohh9xVW7EftaSWeDshMWlAao6P+maIwUiFkOVkWxOm9SHlhTP0tR7A7peS
0I/sbioHr9TXKPlofsZGUkTp7LaA39PFNvRELvgbXmN3XWrCg8SuX2nIPma1SxUi
GxIY4zWo+ZmVoiO/bWxlBTYtih5qaNfmwB53JHOavFwnrfTMEZ2BZ3lcdX2aS8B6
d+EXeL909RzscEzPaJPElpBJd0gnI+ZGhVe7qoQ3CdksP1VWpKWwTwMLKjdU6AgX
t0wk8bKk4lcIj3Hfx+moznK5+U8hR5NqJTRXR0jotozxttF2aXAJThOIiX5ykCfo
V50htH2JAJMuane6rTj24v95JPbBJMhjPdK8OoWYiJJ/EZZJfRg=
=Ngv9
-----END PGP SIGNATURE-----

Christopher Allan Webber wrote 8 years ago
control message for bug #25695
(address . control@debbugs.gnu.org)
87h93z5roz.fsf@dustycloud.org
tags 25695 patch
Ricardo Wurmus wrote 8 years ago
Re: bug#25695: angband [new package]
(name . Christopher Allan Webber)(address . cwebber@dustycloud.org)(address . 25695@debbugs.gnu.org)
87vasfcnq8.fsf@elephly.net
Christopher Allan Webber <cwebber@dustycloud.org> writes:

Toggle quote (4 lines)
> This patch adds Angband, one of those delightfully life-destroying
> roguelikes. Now you too can ruin your life chasing an @ around a screen
> for hours at a time. Horray!

Neat!

Toggle quote (45 lines)
> From c167b96d38acf580e42a618b6211c007760949f0 Mon Sep 17 00:00:00 2001
> From: Christopher Allan Webber <cwebber@dustycloud.org>
> Date: Fri, 10 Feb 2017 16:45:11 -0600
> Subject: [PATCH] gnu: Add angband.
>
> * gnu/packages/games.scm (angband): New variable.
> ---
> gnu/packages/games.scm | 37 ++++++++++++++++++++++++++++++++++++-
> 1 file changed, 36 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index 0867089d5..0df1f69e5 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -10,7 +10,7 @@
> ;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
> ;;; Copyright © 2015, 2016 Andreas Enge <andreas@enge.fr>
> ;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
> -;;; Copyright © 2015 Christopher Allan Webber <cwebber@dustycloud.org>
> +;;; Copyright © 2015, 2017 Christopher Allan Webber <cwebber@dustycloud.org>
> ;;; Copyright © 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
> ;;; Copyright © 2015, 2016, 2017 Alex Kost <alezost@gmail.com>
> ;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
> @@ -227,6 +227,41 @@ them, called Jean Raymond, found an old church in which to hide, not knowing
> that beneath its ruins lay buried an ancient evil.")
> (license license:gpl3)))
>
> +(define-public angband
> + (package
> + (name "angband")
> + (version "4.0.5")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append "http://rephial.org/downloads/4.0/"
> + "angband-" version ".tar.gz"))
> + (sha256
> + (base32
> + "0lpq2kms7hp421vrasx2bkkn9w08kr581ldwik3v0hlq6h7rlxhd"))))
> + (build-system gnu-build-system)
> + (arguments
> + `(#:tests? #f ;no check target
> + ;; #:configure-flags '("--enable-sdl")
> + #:configure-flags (list (string-append "--bindir=" %output "/bin"))

Did you leave the commented entry for #:configure-flags on purpose? If
that’s a TODO or FIXME I’d prefer if it was made explicit.

Toggle quote (4 lines)
> + #:phases (modify-phases %standard-phases
> + (add-after
> + 'unpack 'autogen.sh

Nitpick: move the phase names onto the same line as “add-after”.

Toggle quote (14 lines)
> + (lambda _
> + (substitute* "acinclude.m4"
> + (("ncursesw5-config") "ncursesw6-config"))
> + (zero? (system* "sh" "autogen.sh")))))))
> + (native-inputs
> + `(("autoconf" ,autoconf)
> + ("automake" ,automake)))
> + (inputs `(("ncurses" ,ncurses)))
> + (home-page "http://rephial.org/")
> + (synopsis "Dungeon exploration roguelike")
> + (description "Classic dungeon exploration roguelike. Explore the depths
> +below Angband, seeking riches, fighting monsters, and preparing to fight
> +Morgoth, the Lord of Darkness.")

Please turn the first sentence fragment into a full sentence?

Toggle quote (2 lines)
> + (license license:gpl2)))

Would it be better to add that the sounds and graphics are under
different licenses?

“copying.txt” says:

Toggle snippet (16 lines)
* Adam Bolt's (16x16) graphics may be redistributed and used for any purpose,
with or without modification.

* David Gervais' (32x32) graphics may be redistributed, modified, and used
only under the terms of the Creative Commons Attribution 3.0 licence:
http://creativecommons.org/licenses/by/3.0/

* Shockbolt's (64x64) graphics are distributed under the licence at the end
of this file. Currently some of the tiles in the 64x64.png tilesheet were
resized from tiles made by David Gervais for the 32x32 set.

* The sounds are licenced under the Creative Commons Attribution-NonCommercial-
Sharealike licence. They were created by Dubtrain <angband@dubtrain.com>.
You can find them in Wave format at http://www.dubtrain.com/angband/.

--
Ricardo

GPG: BCA6 89B6 3655 3801 C3C6 2150 197A 5888 235F ACAC
Ricardo Wurmus wrote 8 years ago
Re: bug#25695: angband [new package]
(name . Christopher Allan Webber)(address . cwebber@dustycloud.org)(address . 25695@debbugs.gnu.org)
87shnjcksz.fsf@elephly.net
Christopher Allan Webber <cwebber@dustycloud.org> writes:

Toggle quote (8 lines)
>>> + #:phases (modify-phases %standard-phases
>>> + (add-after
>>> + 'unpack 'autogen.sh
>>
>> Nitpick: move the phase names onto the same line as “add-after”.
>
> Hm, okay, I can do that, but I didn't do it for a reason... emacs
> an indentation style reason!
[…]
Toggle quote (4 lines)
>
> Maybe we should put something in Guix's .dir-locals?
>

Do you have “guix-devel-mode” enabled? It indents the expression just
fine in my Emacs (though I’d add a line break after “#:phases”).

Toggle quote (24 lines)
>> “copying.txt” says:
>>
>> * Adam Bolt's (16x16) graphics may be redistributed and used for any purpose,
>> with or without modification.
>>
>> * David Gervais' (32x32) graphics may be redistributed, modified, and used
>> only under the terms of the Creative Commons Attribution 3.0 licence:
>> http://creativecommons.org/licenses/by/3.0/
>>
>> * Shockbolt's (64x64) graphics are distributed under the licence at the end
>> of this file. Currently some of the tiles in the 64x64.png tilesheet were
>> resized from tiles made by David Gervais for the 32x32 set.
>>
>> * The sounds are licenced under the Creative Commons Attribution-NonCommercial-
>> Sharealike licence. They were created by Dubtrain <angband@dubtrain.com>.
>> You can find them in Wave format at http://www.dubtrain.com/angband/.
>
> Hmm, that last one is a problem because I think it doesn't meet our
> licensing requirements. It's a bit funny because we aren't using the
> graphics or sounds anyway since this is a console-only version of this
> package. So! Easy solution: I added a phase that just deleted them all
> from the output. Problem solved! (Until someone adds a graphical
> variant. Then they can deal with it ;))

Could you remove the sounds in a snippet instead? This ensures that we
don’t redistribute them as part of the source tarball either.

I think it’s okay to push with that change. Thanks!

--
Ricardo

GPG: BCA6 89B6 3655 3801 C3C6 2150 197A 5888 235F ACAC
Christopher Allan Webber wrote 8 years ago
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 25695@debbugs.gnu.org)
878tpb5gp2.fsf@dustycloud.org
Ricardo Wurmus writes:

Toggle quote (18 lines)
> Christopher Allan Webber <cwebber@dustycloud.org> writes:
>
>>>> + #:phases (modify-phases %standard-phases
>>>> + (add-after
>>>> + 'unpack 'autogen.sh
>>>
>>> Nitpick: move the phase names onto the same line as “add-after”.
>>
>> Hm, okay, I can do that, but I didn't do it for a reason... emacs
>> an indentation style reason!
> […]
>>
>> Maybe we should put something in Guix's .dir-locals?
>>
>
> Do you have “guix-devel-mode” enabled? It indents the expression just
> fine in my Emacs (though I’d add a line break after “#:phases”).

I didn't even know such a thing existed. Cool!

Toggle quote (29 lines)
>>> “copying.txt” says:
>>>
>>> * Adam Bolt's (16x16) graphics may be redistributed and used for any purpose,
>>> with or without modification.
>>>
>>> * David Gervais' (32x32) graphics may be redistributed, modified, and used
>>> only under the terms of the Creative Commons Attribution 3.0 licence:
>>> http://creativecommons.org/licenses/by/3.0/
>>>
>>> * Shockbolt's (64x64) graphics are distributed under the licence at the end
>>> of this file. Currently some of the tiles in the 64x64.png tilesheet were
>>> resized from tiles made by David Gervais for the 32x32 set.
>>>
>>> * The sounds are licenced under the Creative Commons Attribution-NonCommercial-
>>> Sharealike licence. They were created by Dubtrain <angband@dubtrain.com>.
>>> You can find them in Wave format at http://www.dubtrain.com/angband/.
>>
>> Hmm, that last one is a problem because I think it doesn't meet our
>> licensing requirements. It's a bit funny because we aren't using the
>> graphics or sounds anyway since this is a console-only version of this
>> package. So! Easy solution: I added a phase that just deleted them all
>> from the output. Problem solved! (Until someone adds a graphical
>> variant. Then they can deal with it ;))
>
> Could you remove the sounds in a snippet instead? This ensures that we
> don’t redistribute them as part of the source tarball either.
>
> I think it’s okay to push with that change. Thanks!

I didn't know about snippets either. :)

Okay, done! Pushed up! For all the productivity risks that might
entail...! :)
Christopher Allan Webber wrote 8 years ago
control message for bug #25695
(address . control@debbugs.gnu.org)
877f4v5gm6.fsf@dustycloud.org
close 25695
?
Your comment

This issue is archived.

To comment on this conversation send an email to 25695@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 25695
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help