Christopher Allan Webber wrote 8 years ago
(address . guix-patches@gnu.org)
This patch adds Angband, one of those delightfully life-destroying
roguelikes. Now you too can ruin your life chasing an @ around a screen
for hours at a time. Horray!
From c167b96d38acf580e42a618b6211c007760949f0 Mon Sep 17 00:00:00 2001
From: Christopher Allan Webber <cwebber@dustycloud.org>
Date: Fri, 10 Feb 2017 16:45:11 -0600
Subject: [PATCH] gnu: Add angband.
* gnu/packages/games.scm (angband): New variable.
---
gnu/packages/games.scm | 37 ++++++++++++++++++++++++++++++++++++-
1 file changed, 36 insertions(+), 1 deletion(-)
Toggle diff (57 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 0867089d5..0df1f69e5 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
-;;; Copyright © 2015 Christopher Allan Webber <cwebber@dustycloud.org>
+;;; Copyright © 2015, 2017 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016, 2017 Alex Kost <alezost@gmail.com>
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
@@ -227,6 +227,41 @@ them, called Jean Raymond, found an old church in which to hide, not knowing
that beneath its ruins lay buried an ancient evil.")
(license license:gpl3)))
+(define-public angband
+ (package
+ (name "angband")
+ (version "4.0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://rephial.org/downloads/4.0/"
+ "angband-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0lpq2kms7hp421vrasx2bkkn9w08kr581ldwik3v0hlq6h7rlxhd"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;no check target
+ ;; #:configure-flags '("--enable-sdl")
+ #:configure-flags (list (string-append "--bindir=" %output "/bin"))
+ #:phases (modify-phases %standard-phases
+ (add-after
+ 'unpack 'autogen.sh
+ (lambda _
+ (substitute* "acinclude.m4"
+ (("ncursesw5-config") "ncursesw6-config"))
+ (zero? (system* "sh" "autogen.sh")))))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)))
+ (inputs `(("ncurses" ,ncurses)))
+ (home-page "http://rephial.org/")
+ (synopsis "Dungeon exploration roguelike")
+ (description "Classic dungeon exploration roguelike. Explore the depths
+below Angband, seeking riches, fighting monsters, and preparing to fight
+Morgoth, the Lord of Darkness.")
+ (license license:gpl2)))
+
(define-public pingus
(package
(name "pingus")
--
2.11.0
-----BEGIN PGP SIGNATURE-----
iQIzBAEBCAAdFiEEUQqGKOKndniPjHCcS8Alkl/49NMFAligao8ACgkQS8Alkl/4
9NPQhBAAhORWL2Mev8sasFx0hbAVqIku7/n+CsPUBoPmbUbsINXp6PPlx0g+Pi3p
h3VMY49ZbqwGh9ERkbC3oT2CZr4BYX/edt+NtbFqm1Um9Z+FhPZsqbhz7CGYtCz5
nxVb7x2PJbKsb/fo4h5VnwbIBbo4KAC+9U6r+zl376tI5rJ5/jFdlNZbP1tAlb+P
iCdKlXcBlP+7Vya6+a8kZ1tOvy/ZULdba+NsONXNmu0gS4eU+8Ap/JuAFCfosZZx
WNJNgKgsi2dU10pJha7zNrcYjYj0knc9xeSZm15asAUyDNd8WraoFdeusN+fJvx4
DStq74Ohh9xVW7EftaSWeDshMWlAao6P+maIwUiFkOVkWxOm9SHlhTP0tR7A7peS
0I/sbioHr9TXKPlofsZGUkTp7LaA39PFNvRELvgbXmN3XWrCg8SuX2nIPma1SxUi
GxIY4zWo+ZmVoiO/bWxlBTYtih5qaNfmwB53JHOavFwnrfTMEZ2BZ3lcdX2aS8B6
d+EXeL909RzscEzPaJPElpBJd0gnI+ZGhVe7qoQ3CdksP1VWpKWwTwMLKjdU6AgX
t0wk8bKk4lcIj3Hfx+moznK5+U8hR5NqJTRXR0jotozxttF2aXAJThOIiX5ykCfo
V50htH2JAJMuane6rTj24v95JPbBJMhjPdK8OoWYiJJ/EZZJfRg=
=Ngv9
-----END PGP SIGNATURE-----