It turns out that I couldn't figure out how to do so.
So far I have tried:
- Attempt 1
- Add the output path as "prefix" variable to #:make-flags.
But I don't think this will work because $(prefix) seems hard-coded
in "src/system-install.mk".
- Attempt 2
- Change "copy-paths" phase to:
- Make "$out/share/redeclipse" directory.
- Copy "data" to "$out/share/redeclipse/data".
- Make "$out/lib/redeclipse" directory.
- Make symbolic link from "$out/share/redeclipse/data" to
"$out/lib/redeclipse/data".
- Add "set-prefix-path" phase after "unpack" phase. With outputs as
key:
- Inside "src/system-install.mk", substitute:
- Line begining with "prefix=", with "prefix=$out". The regular
expression used for this was "(^prefix=)[^\r\n]*", this makes
sure that the "prefix=" assignment is in it's own line.
In any attempt, Red Eclipse still complains that no "data" was found,
although it always builds successfully.
Any ideas? :)
--
- Palestrante e consultor sobre /software/ livre (não confundir com
gratis).
- "WhatsApp"? Ele não é livre. Por favor, use o GNU Ring ou o Tox.
- Arquivos comuns aceitos (apenas sem DRM): Corel Draw, Microsoft
Office, MP3, MP4, WMA, WMV.
- Arquivos comuns aceitos e enviados: CSV, GNU Dia, GNU Emacs Org, GNU
GIMP, Inkscape SVG, JPG, LibreOffice (padrão ODF), OGG, OPUS, PDF
(apenas sem DRM), PNG, TXT, WEBM.