java does not support swing

  • Done
  • quality assurance status badge
Details
2 participants
  • Alex Vong
  • ???
Owner
unassigned
Submitted by
Alex Vong
Severity
normal
A
A
Alex Vong wrote on 29 Aug 2016 07:21
(address . bug-guix@gnu.org)
87a8fwkv5d.fsf@gmail.com
Hi,

Our current java does not support swing. To reproduce, first install
java and clojure. Then start the clojure repl by running:
$ ~/.guix-profile/bin/java -cp ~/.guix-profile/share/java/clojure-1.8.0.jar clojure.main

Then try the repl by typing:
=> (+ 1 2 3)
6

Now run:
=> (javax.swing.JOptionPane/showMessageDialog nil "Hello World")
NullPointerException sun.awt.FontConfiguration.getVersion (FontConfiguration.java:1264)

Note that the above test case is taken from

In contrast, if we replace ~/.guix-profile/bin/java by /usr/bin/java in
the command, we do not get a nullpointerexception (my base distro is
debian testing). So there should be a problem in our java build. Any
ideas?

Thanks,
Alex
?
control message for bug #24327
(address . control@debbugs.gnu.org)
20160911021317.A782D200FAE@mail.openmailbox.org
tags 24327 fixed
close 24327 cab1760de
?
Re: bug#24327: java does not support swing
(name . Alex Vong)(address . alexvong1995@gmail.com)(address . 24327-done@debbugs.gnu.org)
87fup7chd6.fsf@member.fsf.org
Alex Vong <alexvong1995@gmail.com> writes:

Toggle quote (22 lines)
> Hi,
>
> Our current java does not support swing. To reproduce, first install
> java and clojure. Then start the clojure repl by running:
> $ ~/.guix-profile/bin/java -cp ~/.guix-profile/share/java/clojure-1.8.0.jar clojure.main
>
> Then try the repl by typing:
> => (+ 1 2 3)
> 6
>
> Now run:
> => (javax.swing.JOptionPane/showMessageDialog nil "Hello World")
> NullPointerException sun.awt.FontConfiguration.getVersion (FontConfiguration.java:1264)
>
> Note that the above test case is taken from
> <https://clojure.org/guides/getting_started>.
>
> In contrast, if we replace ~/.guix-profile/bin/java by /usr/bin/java in
> the command, we do not get a nullpointerexception (my base distro is
> debian testing). So there should be a problem in our java build. Any
> ideas?

Yeah, openjdk-8 loads fontconfig via dlopen.

Fixed in commit cab1760de.
Closed
?