colordiff glitch

  • Done
  • quality assurance status badge
Details
3 participants
  • Andreas Enge
  • Ludovic Courtès
  • Vincent Legoll
Owner
unassigned
Submitted by
Vincent Legoll
Severity
normal
V
V
Vincent Legoll wrote on 13 Jul 2016 11:10
(address . bug-guix@gnu.org)
CAEwRq=oB6izVDHPcbTHsOq4maKVmPwgppMrZKGMJ=B2xXs+ZMw@mail.gmail.com
during "guix package -i colordiff" I saw this error being reported:

cp colordiffrc /gnu/store/gc9vqsz0jzylcdsik0hmnghiff1kf3am-colordiff-1.0.16/etc/colordiffrc
chown root.root
/gnu/store/gc9vqsz0jzylcdsik0hmnghiff1kf3am-colordiff-1.0.16/etc/colordiffrc
chown: invalid user: ‘root.root’
Makefile:24: recipe for target 'install' failed
make: [install] Error 1 (ignored)
chmod 644 /gnu/store/gc9vqsz0jzylcdsik0hmnghiff1kf3am-colordiff-1.0.16/etc/colordiffrc
phase `install' succeeded after 0.1 seconds

But it looks like it is harmless (at least from the guix install PoV)

vince@guixsd ~/guix-packages$ l
/gnu/store/gc9vqsz0jzylcdsik0hmnghiff1kf3am-colordiff-1.0.16/etc/
total 4.0K
-r--r--r-- 2 root guixbuild 963 Jan 1 1970 colordiffrc

This leaks the guixbuild group into /gnu/store, but it is not alone in
doing so...

If I try to do it manually afterwards, it obviously tell me the FS is R/O

root@guixsd /tmp# chown root.root /gnu/store/*colordiff*/etc/*
chown: changing ownership of
‘/gnu/store/gc9vqsz0jzylcdsik0hmnghiff1kf3am-colordiff-1.0.16/etc/colordiffrc’:
Read-only file system

--
Vincent Legoll
L
L
Ludovic Courtès wrote on 13 Jul 2016 23:39
(name . Vincent Legoll)(address . vincent.legoll@gmail.com)(address . 23970@debbugs.gnu.org)
878tx5jjzg.fsf@gnu.org
Hello,

Vincent Legoll <vincent.legoll@gmail.com> skribis:

Toggle quote (13 lines)
> during "guix package -i colordiff" I saw this error being reported:
>
> cp colordiffrc /gnu/store/gc9vqsz0jzylcdsik0hmnghiff1kf3am-colordiff-1.0.16/etc/colordiffrc
> chown root.root
> /gnu/store/gc9vqsz0jzylcdsik0hmnghiff1kf3am-colordiff-1.0.16/etc/colordiffrc
> chown: invalid user: ‘root.root’
> Makefile:24: recipe for target 'install' failed
> make: [install] Error 1 (ignored)
> chmod 644 /gnu/store/gc9vqsz0jzylcdsik0hmnghiff1kf3am-colordiff-1.0.16/etc/colordiffrc
> phase `install' succeeded after 0.1 seconds
>
> But it looks like it is harmless (at least from the guix install PoV)

It’s indeed harmless and fine.

Toggle quote (15 lines)
> vince@guixsd ~/guix-packages$ l
> /gnu/store/gc9vqsz0jzylcdsik0hmnghiff1kf3am-colordiff-1.0.16/etc/
> total 4.0K
> -r--r--r-- 2 root guixbuild 963 Jan 1 1970 colordiffrc
>
> This leaks the guixbuild group into /gnu/store, but it is not alone in
> doing so...
>
> If I try to do it manually afterwards, it obviously tell me the FS is R/O
>
> root@guixsd /tmp# chown root.root /gnu/store/*colordiff*/etc/*
> chown: changing ownership of
> ‘/gnu/store/gc9vqsz0jzylcdsik0hmnghiff1kf3am-colordiff-1.0.16/etc/colordiffrc’:
> Read-only file system

Right, /gnu/store is meant to be read-only and manually modifying it
voids your warranty. :-)


For this reason, /gnu/store is a read-only bind-mount on GuixSD.

That files in /gnu/store have group ‘guixbuild’ is innocuous.

I hope this clarifies things!

Ludo’.
V
V
Vincent Legoll wrote on 14 Jul 2016 11:17
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 23970@debbugs.gnu.org)
CAEwRq=qkbapQs94CkscQjQtqPgYbucKbiAQCwH5RGPro51Sbww@mail.gmail.com
Toggle quote (11 lines)
>> during "guix package -i colordiff" I saw this error being reported:
>>
>> chown: invalid user: ‘root.root’
>> Makefile:24: recipe for target 'install' failed
>> make: [install] Error 1 (ignored)
>> phase `install' succeeded after 0.1 seconds
>>
>> But it looks like it is harmless (at least from the guix install PoV)
>
> It’s indeed harmless and fine.

The problem I saw here, was that a build *error* is ignored, even if
in this particular case it
is harmless. Or maybe chown is kind of special-cased when it is done
inside /gnu/store ?

--
Vincent Legoll
L
L
Ludovic Courtès wrote on 14 Jul 2016 14:55
(name . Vincent Legoll)(address . vincent.legoll@gmail.com)(address . 23970@debbugs.gnu.org)
87a8hkidkk.fsf@gnu.org
Vincent Legoll <vincent.legoll@gmail.com> skribis:

Toggle quote (16 lines)
>>> during "guix package -i colordiff" I saw this error being reported:
>>>
>>> chown: invalid user: ‘root.root’
>>> Makefile:24: recipe for target 'install' failed
>>> make: [install] Error 1 (ignored)
>>> phase `install' succeeded after 0.1 seconds
>>>
>>> But it looks like it is harmless (at least from the guix install PoV)
>>
>> It’s indeed harmless and fine.
>
> The problem I saw here, was that a build *error* is ignored, even if
> in this particular case it
> is harmless. Or maybe chown is kind of special-cased when it is done
> inside /gnu/store ?

The error is purposefully ignored here: upstream’s Makefile explicitly
marks it as can be ignored, using a hyphen (info "(make) Errors").

And indeed, it makes a lot of sense to ignore this error with Guix since
this operation is not permitted.

Hope this clarifies things,
Ludo’.
V
V
Vincent Legoll wrote on 15 Jul 2016 09:38
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 23970@debbugs.gnu.org)
CAEwRq=o-bmgVMz_KN9CYPFTss9SZ2kBYzxiZ5xW8djh6VObLAw@mail.gmail.com
OK, thanks, that explains it, case closed...

On Thu, Jul 14, 2016 at 2:55 PM, Ludovic Courtès <ludo@gnu.org> wrote:
Toggle quote (29 lines)
> Vincent Legoll <vincent.legoll@gmail.com> skribis:
>
>>>> during "guix package -i colordiff" I saw this error being reported:
>>>>
>>>> chown: invalid user: ‘root.root’
>>>> Makefile:24: recipe for target 'install' failed
>>>> make: [install] Error 1 (ignored)
>>>> phase `install' succeeded after 0.1 seconds
>>>>
>>>> But it looks like it is harmless (at least from the guix install PoV)
>>>
>>> It’s indeed harmless and fine.
>>
>> The problem I saw here, was that a build *error* is ignored, even if
>> in this particular case it
>> is harmless. Or maybe chown is kind of special-cased when it is done
>> inside /gnu/store ?
>
> The error is purposefully ignored here: upstream’s Makefile explicitly
> marks it as can be ignored, using a hyphen (info "(make) Errors").
>
> And indeed, it makes a lot of sense to ignore this error with Guix since
> this operation is not permitted.
>
> Hope this clarifies things,
> Ludo’.



--
Vincent Legoll
A
A
Andreas Enge wrote on 15 Jul 2016 10:30
(name . Vincent Legoll)(address . vincent.legoll@gmail.com)
20160715083028.GA14216@solar
Closing then with a cc to 23970-done@debbugs.gnu.org.

Andreas
Closed
?