Vincent Legoll wrote 9 years ago
(address . bug-guix@gnu.org)
Hello,
I'm discovering guix, and started to try to package something.
I made an error (add a string URL parameter to license x11-style):
(license x11-style "file://LICENSE")
But this is not working, because I've forgotten the scheme call syntax
(missing parens)
I'll fix my package definition with:
(license (x11-style "file://LICENSE"))
which seems to be working OK...
But the error message I got was very unhelpful:
something.scm:10:2: warning: source expression failed to match any pattern
the line 10 is:
(package
whereas the real error happened on line 32 (the license one)
So what's wrong:
- wrong line number
- 'source expression' meaning is shady, as there is a "(source (origin
...))" element defined in the package, which is also not on line 10,
but misleading anyways
I would have expected that error to be reported as:
error: license x11-style: cannot match the pattern : file://LICENSE in
directory /tmp/guix-build-something/something/path/to/where/it/searched
--
Vincent Legoll