Danny Milosavljevic wrote 9 years ago
(address . bug-guix@gnu.org)
$ guix import pypi jedi
Starting download of /tmp/guix-file.n01KoB
….0.tar.gz 326KiB 402KiB/s 00:01 [####################] 100.0%
Starting download of /tmp/guix-file.CbhRLk
…py3-none-any.whl 154KiB 291KiB/s 00:01 [####################] 100.0%
Backtrace:
In ice-9/boot-9.scm:
157: 19 [catch srfi-34 #<procedure 57736c0 at ice-9/eval.scm:416:20 ()> ...]
In ice-9/r4rs.scm:
90: 18 [dynamic-wind #<procedure 5773570 at ice-9/eval.scm:416:20 ()> ...]
In ice-9/eval.scm:
387: 17 [eval # #]
387: 16 [eval # #]
387: 15 [eval # #]
387: 14 [eval # #]
387: 13 [eval # #]
387: 12 [eval # #]
387: 11 [eval # #]
387: 10 [eval # #]
387: 9 [eval # #]
387: 8 [eval # #]
387: 7 [eval # #]
411: 6 [eval # #]
In ice-9/r4rs.scm:
90: 5 [dynamic-wind #<procedure 57d3900 at ice-9/eval.scm:416:20 ()> ...]
90: 4 [dynamic-wind #<procedure 5c332a0 at ice-9/boot-9.scm:1133:2 _> ...]
In ice-9/boot-9.scm:
867: 3 [call-with-input-file "jedi-0.9.0.dist-info/metadata.json" ...]
In ice-9/eval.scm:
411: 2 [eval # #]
387: 1 [eval # #]
In unknown file:
?: 0 [list-ref #f 0]
This stacktrace is ... unhelpful. I think there was a post somewhere where it detailed how to debug that but I can't find it again :(
$ cat metadata.json
{"classifiers": ["Development Status :: 4 - Beta", "Environment :: Plugins", "Intended Audience :: Developers", "License :: OSI Approved :: MIT License", "Operating System :: OS Independent", "Programming Language :: Python :: 2", "Programming Language :: Python :: 2.6", "Programming Language :: Python :: 2.7", "Programming Language :: Python :: 3", "Programming Language :: Python :: 3.2", "Programming Language :: Python :: 3.3", "Programming Language :: Python :: 3.4", "Topic :: Software Development :: Libraries :: Python Modules", "Topic :: Text Editors :: Integrated Development Environments (IDE)", "Topic :: Utilities"], "summary": "An autocompletion tool for Python that can be used for text editors.", "platform": "any", "generator": "bdist_wheel (0.24.0)", "metadata_version": "2.0", "version": "0.9.0", "extensions": {"python.details": {"contacts": [{"role": "author", "email": "davidhalter88@gmail.com", "name": "David Halter"}], "project_urls": {"Home": "https://github.com/davidhalter/jedi"},"document_names": {"description": "DESCRIPTION.rst"}}}, "license": "MIT", "keywords": ["python", "completion", "refactoring", "vim"], "name": "jedi"}