(address . bug-guix@gnu.org)
$ ssh -X daya20
Warning: untrusted X11 forwarding setup failed: xauth key data not generated
Because:
$ strings $(which ssh) |grep /xauth
/usr/X11R6/bin/xauth
%s/xauthfile
However,
$ which xauth
/home/dannym/.guix-profile/bin/xauth
Adding the following and rebuilding doesn't help either (for some reason):
Toggle diff (26 lines)
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index b8f107b..d85124b 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -35,6 +35,7 @@
#:autoload (gnu packages boost) (boost)
#:use-module (gnu packages base)
#:use-module (gnu packages tls)
+ #:use-module (gnu packages xorg)
#:use-module (gnu packages)
#:use-module (guix packages)
#:use-module (guix download)
@@ -131,7 +132,8 @@ a server that supports the SSH-2 protocol.")
(build-system gnu-build-system)
(inputs `(("groff" ,groff)
("openssl" ,openssl)
- ("zlib" ,zlib)))
+ ("zlib" ,zlib)
+ ("xauth" ,xauth)))
(arguments
`(#:test-target "tests"
#:phases
But
$ ssh -o XAuthLocation=$(which xauth) daya20
works.