rxvt-unicode is missing .desktop file(s)

  • Done
  • quality assurance status badge
Details
3 participants
  • Leo Famulari
  • Ludovic Courtès
  • Nils Gillmann
Owner
unassigned
Submitted by
Nils Gillmann
Severity
minor

Debbugs page

Nils Gillmann wrote 9 years ago
(address . bug-guix@gnu.org)
878u183vry.fsf@grrlz.net
urxvt / rxvt-unicode has no .desktop files in Guix and therefore
does not show up in application menus like GNOME provides.


Whoever wants to fix it faster than I do (currently occupied with
psyced related packages), here is my work in progress part of the
rxvt-unicode package.

.desktop files can be found in the source dir of gentoo and
archlinux

Code below has not been tested, it may need some fixes, and we
need at least 3 like in archlinux.

(arguments
;; This sets the destination when installing the necessary terminal
;; capability data, which are not provided by 'ncurses'. See
'(#:make-flags
(list (string-append "TERMINFO="
(assoc-ref %outputs "out")
"/share/terminfo"))
#:phases
(modify-phases %standard-phases
(add-after
'install 'install-desktop
(lambda _
(let ((desktop (string-append %output "/share/applications")))
(mkdir-p desktop)
(call-with-output-file
(string-append desktop "/urxvt.desktop")
(lambda (port)
(format port "~
[Desktop Entry]~@
Name=~a~@
Comment=~a~@
TryExec=~a/bin/urxvt~@
Exec=~a/bin/urxvt~@
Icon=terminal~@
Type=Application~@
Categories=GNOME;GTK;Utility;TerminalEmulator;System;~@
StartupNotify=true~%" ,name ,synopsis %output)))))))))
--
ng
personal contact: http://krosos.sdf.org
Ludovic Courtès wrote 8 years ago
control message for bug #23106
(address . control@debbugs.gnu.org)
87bmvdut3y.fsf@gnu.org
severity 23106 minor
Leo Famulari wrote 8 years ago
Re: [PATCH] gnu: rxvt-unicode: Add '.desktop' files.
(address . contact.ng0@cryptolab.net)(address . guix-devel@gnu.org)(address . 23106-done@debbugs.gnu.org)
20170305212629.GA6844@jasmine
On Sat, Feb 11, 2017 at 07:26:45PM +0000, contact.ng0@cryptolab.net wrote:
Toggle quote (8 lines)
> From: ng0 <contact.ng0@cryptolab.net>
>
> This fixes <https://bugs.gnu.org/23106>.
>
> * gnu/packages/xdisorg.scm (rxvt-unicode)[arguments]: Use
> 'modify-phases'.
> Add 'install-desktop-urxvt' and 'install-desktop-urxvtc' phase.

Pushed, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 23106@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 23106
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help