Nils Gillmann wrote 9 years ago
(address . bug-guix@gnu.org)
urxvt / rxvt-unicode has no .desktop files in Guix and therefore
does not show up in application menus like GNOME provides.
Whoever wants to fix it faster than I do (currently occupied with
psyced related packages), here is my work in progress part of the
rxvt-unicode package.
.desktop files can be found in the source dir of gentoo and
archlinux
Code below has not been tested, it may need some fixes, and we
need at least 3 like in archlinux.
(arguments
;; This sets the destination when installing the necessary terminal
;; capability data, which are not provided by 'ncurses'. See
'(#:make-flags
(list (string-append "TERMINFO="
(assoc-ref %outputs "out")
"/share/terminfo"))
#:phases
(modify-phases %standard-phases
(add-after
'install 'install-desktop
(lambda _
(let ((desktop (string-append %output "/share/applications")))
(mkdir-p desktop)
(call-with-output-file
(string-append desktop "/urxvt.desktop")
(lambda (port)
(format port "~
[Desktop Entry]~@
Name=~a~@
Comment=~a~@
TryExec=~a/bin/urxvt~@
Exec=~a/bin/urxvt~@
Icon=terminal~@
Type=Application~@
Categories=GNOME;GTK;Utility;TerminalEmulator;System;~@
StartupNotify=true~%" ,name ,synopsis %output)))))))))
--
ng
personal contact: http://krosos.sdf.org