"guix package -i" sometimes can't use what "guix import pypi" generated

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Ludovic Courtès
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 9 years ago
(address . bug-guix@gnu.org)
20160319153243.550e9127@scratchpost.org
I tried to create a package for uwsgi (in git guix) by

$ guix import pypi uwsgi

...
(package
(name "python-uwsgi")
(version "2.0.12")
(source
(origin
(method url-fetch)
(uri (pypi-uri "uWSGI" version))
(sha256
(base32
"02g46dnw5j1iw8fsq392bxbk8d21b9pdgb3ypcinv3b4jzdm2srh"))))
(build-system python-build-system)
(inputs
`(("python-setuptools" ,python-setuptools)))
(home-page "UNKNOWN")
(synopsis "The uWSGI server")
(description "The uWSGI server")
(license #f))

Then I put that (and define-public python-uwsgi ...) into python.scm and did

$ guix package -i python-uwsgi

I get the following error message:

Starting download of /gnu/store/d16s3cw2arg89pm7djh6xrdkf0dnckyy-uWSGI-2.0.12.tar.gz
failed to download "/gnu/store/d16s3cw2arg89pm7djh6xrdkf0dnckyy-uWSGI-2.0.12.tar.gz" from "https://pypi.python.org/packages/source/u/uWSGI/uWSGI-2.0.12.tar.gz"
builder for `/gnu/store/d5jfk4l2yvxfd3pw0fndwx2bxjwg1gpl-uWSGI-2.0.12.tar.gz.drv' failed to produce output path `/gnu/store/d16s3cw2arg89pm7djh6xrdkf0dnckyy-uWSGI-2.0.12.tar.gz'
cannot build derivation `/gnu/store/xqwnqx8yw63i864z0c3vd3vr9c8xcflr-python-uwsgi-2.0.12.drv': 1 dependencies couldn't be built
guix package: error: build failed: build of `/gnu/store/xqwnqx8yw63i864z0c3vd3vr9c8xcflr-python-uwsgi-2.0.12.drv' failed

(Note the wrong basename)

guix/build-system/python.scm says:

(define* (pypi-uri name version #:optional (extension ".tar.gz"))
"Return a URI string for the Python package hosted on the Python Package
Index (PyPI) corresponding to NAME and VERSION. EXTENSION is the file name
extension, such as '.tar.gz'."
(string-take name 1) "/" name "/"
name "-" version extension))

So it's currently impossible for pypi-uri to work correctly in the uwsgi case.
Ludovic Courtès wrote 9 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 23062-done@debbugs.gnu.org)
87zituc8m4.fsf@gnu.org
Fixed in 522773b70024272555aab0448fae8606add4c582.

Thanks,
Ludo'.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 23062@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 23062
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help