mysql_config missing references to sed and gawk

  • Done
  • quality assurance status badge
Details
3 participants
  • Thompson, David
  • Sarah Morgensen
  • zimoun
Owner
unassigned
Submitted by
Thompson, David
Severity
normal

Debbugs page

Thompson, David wrote 9 years ago
(address . bug-guix@gnu.org)
CAJ=RwfbaL5zWqX3wsjQsBg4-iiG6QFTmic_hXYtbMjQF7xQ27w@mail.gmail.com
The mysql_config binary in the mysql package needs sed and gawk to be
on $PATH in order to run. Instead, it should be patched to hardcode
the store paths to sed and gawk.
zimoun wrote 3 years ago
(name . Thompson, David)(address . dthompson2@worcester.edu)(address . 23045@debbugs.gnu.org)
86bl4vtfit.fsf@gmail.com
Hi,

On Thu, 17 Mar 2016 at 15:52, "Thompson, David" <dthompson2@worcester.edu> wrote:
Toggle quote (4 lines)
> The mysql_config binary in the mysql package needs sed and gawk to be
> on $PATH in order to run. Instead, it should be patched to hardcode
> the store paths to sed and gawk.

Indeed, it is still the case with Guix 53f54d4:

Toggle snippet (8 lines)
$ guix environment --ad-hoc mysql -C
[env]$ mysql_config
/gnu/store/babgwy3cvv851ddx7npvh9ick3fs0fgc-profile/bin/mysql_config: line 87: sed: command not found
/gnu/store/babgwy3cvv851ddx7npvh9ick3fs0fgc-profile/bin/mysql_config: line 95: sed: command not found
/gnu/store/babgwy3cvv851ddx7npvh9ick3fs0fgc-profile/bin/mysql_config: line 99: sed: command not found
/gnu/store/babgwy3cvv851ddx7npvh9ick3fs0fgc-profile/bin/mysql_config: line 131: cat: command not found

or another example:

Toggle snippet (4 lines)
$ cat $GUIX_ENVIRONMENT/bin/mysql_config | grep awk
file=`ls -l $file | awk '{ print $NF }'`

and the package definition of ’mysql’ reads:

Toggle snippet (14 lines)
(native-inputs
`(("bison" ,bison)
("perl" ,perl)
("pkg-config" ,pkg-config)))
(inputs
`(("boost" ,boost-for-mysql)
("libaio" ,libaio)
("libtirpc" ,libtirpc)
("ncurses" ,ncurses)
("openssl" ,openssl)
("rpcsvc-proto" ,rpcsvc-proto) ; rpcgen
("zlib" ,zlib)))

To make it works, the packages ’coreutils’, ’sed’ and ’gawk’ should be
propagated. Right?

Could you comment on patch#50586 [1]? It should fix the issue.


All the best,
simon
Closed
zimoun wrote 3 years ago
(address . 23045-done@debbugs.gnu.org)
CAJ3okZ2Cu+JskYkavWTh8PMtnrLKpUWqC_S7=iakKoT9AhCLkA@mail.gmail.com
Hi Sarah,

On Sat, 25 Sept 2021 at 23:51, Sarah Morgensen <iskarian@mgsn.dev> wrote:

Toggle quote (2 lines)
Thanks for closing! :-)

Cheers,
simon
?
Your comment

This issue is archived.

To comment on this conversation send an email to 23045@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 23045
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help