"VM stack overflow" with graft dependencies from substitutes

  • Done
  • quality assurance status badge
Details
3 participants
  • Eric Bavier
  • Ludovic Courtès
  • Pjotr Prins
Owner
unassigned
Submitted by
Eric Bavier
Severity
normal

Debbugs page

Eric Bavier wrote 9 years ago
(address . bug-guix@gnu.org)
20160305000939.3ea8c23d@openmailbox.org
Starting with commit c90cb5c9d84ded26ef44d1e6593508d5b9e4655e (via 'git
bisect') I get the following error messages after `make clean && make
&& ./pre-inst-env guix environment texlive`:

--- BEGIN SNIP ---
Backtrace:
In srfi/srfi-1.scm:
646: 19 [append-map #<procedure dependency-grafts (item)> #]
578: 18 [map #<procedure dependency-grafts (item)> #]
In guix/grafts.scm:
235: 17 [cumulative-grafts # # # ...]
In srfi/srfi-1.scm:
646: 16 [append-map #<procedure dependency-grafts (item)> #]
578: 15 [map #<procedure dependency-grafts (item)> #]
In guix/grafts.scm:
235: 14 [cumulative-grafts # # # ...]
In srfi/srfi-1.scm:
646: 13 [append-map #<procedure dependency-grafts (item)> #]
578: 12 [map #<procedure dependency-grafts (item)> #]
In guix/grafts.scm:
235: 11 [cumulative-grafts # # # ...]
In srfi/srfi-1.scm:
646: 10 [append-map #<procedure dependency-grafts (item)> #]
578: 9 [map #<procedure dependency-grafts (item)> #]
In guix/grafts.scm:
222: 8 [dependency-grafts "/gnu/store/09gwygs9vdja1bkpyfqsb51rjzs7d5zs-libunistring-0.9.6"]
156: 7 [item->deriver # ...]
In guix/store.scm:
832: 6 [valid-derivers # ...]
In srfi/srfi-1.scm:
534: 5 [unfold #<procedure 6ecb980 at guix/serialization.scm:162:12 (t-722807)> ...]
In guix/serialization.scm:
122: 4 [read-string #<input-output: socket 10>]
114: 3 [read-byte-string #<input-output: socket 10>]
85: 2 [read-int #<input-output: socket 10>]
71: 1 [get-bytevector-n* #<input-output: socket 10> 8]
In unknown file:
?: 0 [get-bytevector-n #<input-output: socket 10> 8]

ERROR: In procedure get-bytevector-n:
ERROR: Throw to key `vm-error' with args `(vm-run "VM: Stack overflow" ())'.
--- END SNIP ---

This backtrace is printed 3 times.

If it means anything, it's been at least a week since I've fetched any
substitutes from hydra on this machine.

`~Eric
Pjotr Prins wrote 9 years ago
(name . Eric Bavier)(address . ericbavier@openmailbox.org)(address . 22914@debbugs.gnu.org)
20160305093822.GA28350@thebird.nl
Same here. It is the new graft thing. Just a guix pull will do it.

288: 10 [#<procedure 32ccf00 at guix/monads.scm:287:30 (item result)> "/gnu/store/8cv92vy3m47v2b2pf73jdz9k26lzl1xw-libgc-7.4.2" ...]
In guix/grafts.scm:
225: 9 [dependency-grafts "/gnu/store/8cv92vy3m47v2b2pf73jdz9k26lzl1xw-libgc-7.4.2"]
156: 8 [item->deriver # "/gnu/store/8cv92vy3m47v2b2pf73jdz9k26lzl1xw-libgc-7.4.2"]
In guix/store.scm:
832: 7 [valid-derivers # "/gnu/store/8cv92vy3m47v2b2pf73jdz9k26lzl1xw-libgc-7.4.2"]
In srfi/srfi-1.scm:
534: 6 [unfold #<procedure 37c7360 at guix/serialization.scm:162:12 (t-821323)> ...]
In guix/serialization.scm:
122: 5 [read-string #<input-output: socket 10>]
114: 4 [read-byte-string #<input-output: socket 10>]
85: 3 [read-int #<input-output: socket 10>]
71: 2 [get-bytevector-n* #<input-output: socket 10> 8]
In ice-9/boot-9.scm:
105: 1 [#<procedure c95180 at ice-9/boot-9.scm:97:6 (thrown-k . args)> vm-error ...]
65: 0 [abort-to-prompt catch7 vm-error vm-run "VM: Stack overflow" ()]

ice-9/boot-9.scm:65:2: In procedure abort-to-prompt:
ice-9/boot-9.scm:65:2: Throw to key `vm-error' with args `(vm-run "VM: Stack overflow" ())'.

Pj.

On Sat, Mar 05, 2016 at 12:09:39AM -0600, Eric Bavier wrote:
Toggle quote (53 lines)
> Starting with commit c90cb5c9d84ded26ef44d1e6593508d5b9e4655e (via 'git
> bisect') I get the following error messages after `make clean && make
> && ./pre-inst-env guix environment texlive`:
>
> --- BEGIN SNIP ---
> Backtrace:
> In srfi/srfi-1.scm:
> 646: 19 [append-map #<procedure dependency-grafts (item)> #]
> 578: 18 [map #<procedure dependency-grafts (item)> #]
> In guix/grafts.scm:
> 235: 17 [cumulative-grafts # # # ...]
> In srfi/srfi-1.scm:
> 646: 16 [append-map #<procedure dependency-grafts (item)> #]
> 578: 15 [map #<procedure dependency-grafts (item)> #]
> In guix/grafts.scm:
> 235: 14 [cumulative-grafts # # # ...]
> In srfi/srfi-1.scm:
> 646: 13 [append-map #<procedure dependency-grafts (item)> #]
> 578: 12 [map #<procedure dependency-grafts (item)> #]
> In guix/grafts.scm:
> 235: 11 [cumulative-grafts # # # ...]
> In srfi/srfi-1.scm:
> 646: 10 [append-map #<procedure dependency-grafts (item)> #]
> 578: 9 [map #<procedure dependency-grafts (item)> #]
> In guix/grafts.scm:
> 222: 8 [dependency-grafts "/gnu/store/09gwygs9vdja1bkpyfqsb51rjzs7d5zs-libunistring-0.9.6"]
> 156: 7 [item->deriver # ...]
> In guix/store.scm:
> 832: 6 [valid-derivers # ...]
> In srfi/srfi-1.scm:
> 534: 5 [unfold #<procedure 6ecb980 at guix/serialization.scm:162:12 (t-722807)> ...]
> In guix/serialization.scm:
> 122: 4 [read-string #<input-output: socket 10>]
> 114: 3 [read-byte-string #<input-output: socket 10>]
> 85: 2 [read-int #<input-output: socket 10>]
> 71: 1 [get-bytevector-n* #<input-output: socket 10> 8]
> In unknown file:
> ?: 0 [get-bytevector-n #<input-output: socket 10> 8]
>
> ERROR: In procedure get-bytevector-n:
> ERROR: Throw to key `vm-error' with args `(vm-run "VM: Stack overflow" ())'.
> --- END SNIP ---
>
> This backtrace is printed 3 times.
>
> If it means anything, it's been at least a week since I've fetched any
> substitutes from hydra on this machine.
>
> `~Eric
>
>
>

--
Ludovic Courtès wrote 9 years ago
(name . Eric Bavier)(address . ericbavier@openmailbox.org)(address . 22914@debbugs.gnu.org)
87wppg1teu.fsf@gnu.org
Eric Bavier <ericbavier@openmailbox.org> skribis:

Toggle quote (4 lines)
> Starting with commit c90cb5c9d84ded26ef44d1e6593508d5b9e4655e (via 'git
> bisect') I get the following error messages after `make clean && make
> && ./pre-inst-env guix environment texlive`:

I experienced something similar while doing “guix build icecat”. I
believe this is fixed by dd78e90a4dcd1e637b56ae278c4e631ccb384ee0.

Could you confirm?

Thanks!

Ludo’.
Eric Bavier wrote 9 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 22914@debbugs.gnu.org)
20160307095004.2c0f56c3@openmailbox.org
On Sat, 05 Mar 2016 22:55:37 +0100
ludo@gnu.org (Ludovic Courtès) wrote:

Toggle quote (11 lines)
> Eric Bavier <ericbavier@openmailbox.org> skribis:
>
> > Starting with commit c90cb5c9d84ded26ef44d1e6593508d5b9e4655e (via 'git
> > bisect') I get the following error messages after `make clean && make
> > && ./pre-inst-env guix environment texlive`:
>
> I experienced something similar while doing “guix build icecat”. I
> believe this is fixed by dd78e90a4dcd1e637b56ae278c4e631ccb384ee0.
>
> Could you confirm?

This appears to have fixed the issue on my end too. Thanks!

`~Eric
Ludovic Courtès wrote 9 years ago
(name . Eric Bavier)(address . ericbavier@openmailbox.org)(address . 22914-done@debbugs.gnu.org)
87d1r66lzh.fsf@gnu.org
Eric Bavier <ericbavier@openmailbox.org> skribis:

Toggle quote (16 lines)
> On Sat, 05 Mar 2016 22:55:37 +0100
> ludo@gnu.org (Ludovic Courtès) wrote:
>
>> Eric Bavier <ericbavier@openmailbox.org> skribis:
>>
>> > Starting with commit c90cb5c9d84ded26ef44d1e6593508d5b9e4655e (via 'git
>> > bisect') I get the following error messages after `make clean && make
>> > && ./pre-inst-env guix environment texlive`:
>>
>> I experienced something similar while doing “guix build icecat”. I
>> believe this is fixed by dd78e90a4dcd1e637b56ae278c4e631ccb384ee0.
>>
>> Could you confirm?
>
> This appears to have fixed the issue on my end too. Thanks!

Great.
Next bug… :-)

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 22914@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 22914
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help