syntax error in postgresql default config

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Leo Famulari
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 9 years ago
(address . submit@debbugs.gnu.org)
20160210195343.197649ef@scratchpost.org
Package: guix
Version: git from an hour ago

The default postgresql config file contains:
hba_file = '/gnu/store/2pnrdnasjxjr8zmnvhk9ypw2vdl00cks-pg_hba.conf'
ident_file = '/gnu/store/b4cm2bk8kz8brjcgpwrafxfvxcy35vz9-pg_ident.conf

Note missing end-quote.

The reason is: gnu/services/databases.scm contains:

(define %default-postgres-config
(mixed-text-file "postgresql.conf"
"hba_file = '" %default-postgres-hba "'\n"
"ident_file = '" %default-postgres-ident "\n"))

Note missing end-quote.
Leo Famulari wrote 9 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 22618-done@debbugs.gnu.org)
20160210205020.GA28413@jasmine
On Wed, Feb 10, 2016 at 07:53:43PM +0100, Danny Milosavljevic wrote:
Toggle quote (18 lines)
> Package: guix
> Version: git from an hour ago
>
> The default postgresql config file contains:
> hba_file = '/gnu/store/2pnrdnasjxjr8zmnvhk9ypw2vdl00cks-pg_hba.conf'
> ident_file = '/gnu/store/b4cm2bk8kz8brjcgpwrafxfvxcy35vz9-pg_ident.conf
>
> Note missing end-quote.
>
> The reason is: gnu/services/databases.scm contains:
>
> (define %default-postgres-config
> (mixed-text-file "postgresql.conf"
> "hba_file = '" %default-postgres-hba "'\n"
> "ident_file = '" %default-postgres-ident "\n"))
>
> Note missing end-quote.

Fixed in 8823ed4e12960a6f6c0e9fa2775feecaa6f10a9b.

Thanks for the report!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 22618@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 22618
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help