Jeff Mickey <j@codemac.net> skribis:
Toggle quote (8 lines)
> On NixOS when I follow the binary installation instructions as of 0.9.0,
> it places the acl in the wrong place.
>
> guix archive --authorize < hydra.gnu.org.pub
>
> This puts the file in /etc/nix/acl, not /etc/guix acl. This means the
> guix daemon can't find the acl, and you build everything from scratch.
Toggle snippet (4 lines)
(define %acl-file
(string-append %config-directory "/acl"))
where (guix config) does:
Toggle snippet (5 lines)
(define %config-directory
;; This must match `NIX_CONF_DIR' as defined in `daemon.am'.
(or (getenv "NIX_CONF_DIR") "@guix_sysconfdir@/guix"))
So most likely the ‘NIX_CONF_DIR’ environment variable is defined on
your system, and ‘guix archive’ simply honors that.
Can you confirm?
Now, we’ve honored those ‘NIX_’ variables mostly because the daemon
code, which comes from Nix, uses them, and I initially didn’t want to
diverge. Nowadays it would probably make sense to rename them.
Toggle quote (2 lines)
> Also, /gnu/store is set to only have 1770 permissions instead of 1774,
Toggle snippet (4 lines)
$ tar tvf guix-binary-0.9.0.x86_64-linux.tar.xz |grep /gnu/store/$
drwxrwxr-t root/root 0 1970-01-01 01:00 ./gnu/store/
Which installation method did you use?
Toggle quote (2 lines)
> which means you can't use any of your guix symlinks with 0.9.0 :/
What do you mean by “your guix symlinks”?
Thanks,
Ludo’.