Christopher Allan Webber wrote 9 years ago
(address . bug-guix@gnu.org)
Hello,
I recently installed GuixSD on the laptop I got fresh from Minifree. I
was happy to see how much worked, but I've noticed a bug that occurs in
GuixSD but not in Debian.
In Debian I can set the hardware clock (with `hwclock -w`) and if I
reboot back into Debian again, I still have the same hardware clock.
If I reboot into GuixSD, at some point in the boot process it resets my
hardware clock to 1970! If I reboot into Debian again after that, it's
1970 there also.
This is fairly serious, because this could greatly mess up committing to
git, running makefiles, or simply knowing when I wrote that file to
disk. Also, ssl certs no longer validate, etc.
Any idea what could be causing this? I noticed that if I rebooted it
at the time that it asked me for a passphrase to decrypt /home/ that it
didn't reset the clock, though maybe I should test that again.
My system config file is attached.
;; This is an operating system configuration template
;; for a "desktop" setup with X11.
(use-modules (gnu) (gnu system nss))
(use-service-modules desktop)
(use-package-modules xfce ratpoison certs)
(operating-system
(host-name "oolong")
(timezone "America/Chicago")
(locale "en_US.UTF-8")
;; Assuming /dev/sdX is the target hard disk, and "root" is
;; the label of the target root file system.
(bootloader (grub-configuration
(device "/dev/sda")))
(mapped-devices (list (mapped-device
(source "/dev/sda8")
(target "home-luks")
(type luks-device-mapping))))
(file-systems `(,(file-system
(device "guix")
(title 'label)
(mount-point "/")
(type "ext4"))
,(file-system
(device "/dev/mapper/home-luks")
(mount-point "/home")
(type "ext4"))
,@%base-file-systems))
(users (cons (user-account
(name "cwebber")
(uid 1000)
(comment "Christopher Allan Webber")
(group "cwebber")
(supplementary-groups '("users"
"wheel" "netdev"
"audio" "video"))
(home-directory "/home/cwebber"))
%base-user-accounts))
(groups (cons (user-group
(name "cwebber")
(id 1000))
%base-groups))
;; Add Xfce and Ratpoison; that allows us to choose
;; sessions using either of these at the log-in screen.
(packages (cons* xfce ratpoison ;desktop environments
nss-certs ;for HTTPS access
%base-packages))
;; Use the "desktop" services, which include the X11
;; log-in service, networking with Wicd, and more.
(services %desktop-services)
;; Allow resolution of '.local' host names with mDNS.
(name-service-switch %mdns-host-lookup-nss))