failed test
(address . bug-guix@gnu.org)
Failed test for guix-environment-container.sh
I don't know where the version is for guix but I just pulled it
yesterday from savannah.
I'm on Ubuntu 14.04
Guile 2.0.9
libgcrypt11 and 20 are installed
make 3.81-8.2ubuntu3
Thank you,
Sam
======================================
GNU Guix 0.9.0: ./test-suite.log
======================================
# TOTAL: 51
# PASS: 50
# SKIP: 0
# XFAIL: 0
# FAIL: 1
# XPASS: 0
# ERROR: 0
.. contents:: :depth: 2
FAIL: tests/guix-environment-container
======================================
+ set -e
+ guix environment --version
guix environment (GNU Guix) 0.9.0
Copyright (C) 2015 the Guix authors
License GPLv3+: GNU GPL version 3 or later http://gnu.org/licenses/gpl.html
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
+ tmpdir=t-guix-environment-13420
+ trap 'rm -r "$tmpdir"' EXIT
+ mkdir t-guix-environment-13420
+ guix environment --container --ad-hoc --bootstrap guile-bootstrap -- guile -c '(exit 42)'
accepted connection from pid 13428, user salotz
+ test 42 = 42
+ mount_test_code='
(use-modules (ice-9 rdelim)
(ice-9 match)
(srfi srfi-1))
(define mappings
(filter-map (lambda (line)
(match (string-split line #\space)
;; Empty line.
(("") #f)
;; Ignore these types of file systems.
((_ _ (or "tmpfs" "proc" "sysfs" "devtmpfs"
"devpts" "cgroup" "mqueue") _ _ _)
#f)
((_ mount _ _ _ _)
mount)))
(string-split (call-with-input-file "/proc/mounts" read-string)
#\newline)))
(for-each (lambda (mount)
(display mount)
(newline))
mappings)'
+ guix environment --container --ad-hoc --bootstrap guile-bootstrap -- guile -c '
(use-modules (ice-9 rdelim)
(ice-9 match)
(srfi srfi-1))
(define mappings
(filter-map (lambda (line)
(match (string-split line #\space)
;; Empty line.
(("") #f)
;; Ignore these types of file systems.
((_ _ (or "tmpfs" "proc" "sysfs" "devtmpfs"
"devpts" "cgroup" "mqueue") _ _ _)
#f)
((_ mount _ _ _ _)
mount)))
(string-split (call-with-input-file "/proc/mounts" read-string)
#\newline)))
(for-each (lambda (mount)
(display mount)
(newline))
mappings)'
accepted connection from pid 13436, user salotz
+ cat t-guix-environment-13420/mounts
/
/home/salotz/guix
/home/salotz/guix/test-tmp/store/mymx77h45s4jbym3g0y02dywkbkkf2fd-bash
/home/salotz/guix/test-tmp/store/1njh72acy1s1glwp9kx5zh13j6jabjr9-guile-bootstrap-2.0
++ wc -l
+ test 4 -eq 3
+ rm -r t-guix-environment-13420