Guix environment is incredibly slow when using Python2 packages

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Cyril Roelandt
Owner
unassigned
Submitted by
Cyril Roelandt
Severity
normal
C
C
Cyril Roelandt wrote on 12 Oct 2015 23:31
(address . bug-guix@gnu.org)
561C2696.6080800@gmail.com
Let's look at the following command, which behaves as expected:

$ time guix environment --ad-hoc --pure python-pbr python-babel
python-iso8601 python-debtcollector python-netaddr python-oslo.config
python-oslo.i18n python-oslo.serialization python-oslo.utils
python-prettytable python-requests python-six python-stevedore
python-coverage python-discover python-fixtures python-keyring
python-lxml python-mock python-oauthlib python-oslotest python-pycrypto
python-requests-mock python-sphinx python-testrepository
python-testresources python-testtools python-webob python-bandit
python-setuptools python-pbr openssl python --exec="echo done"
done

real 0m5.043s
user 0m4.672s
sys 0m0.148s

Its Python2 counterpart is incredibly slow:

$ time guix environment --ad-hoc --pure python2-pbr python2-babel
python2-iso8601 python2-debtcollector python2-netaddr python2-oslo.config
python2-oslo.i18n python2-oslo.serialization python2-oslo.utils
python2-prettytable python2-requests python2-six python2-stevedore
python2-coverage python2-discover python2-fixtures
python2-keyring python2-lxml python2-mock python2-oauthlib
python2-oslotest python2-pycrypto python2-requests-mock
python2-sphinx python2-testrepository
python2-testresources python2-testtools python2-webob python2-bandit
python2-setuptools python2-pbr openssl python-2 --exec="echo done"
warning: failed to install locale: Invalid argument
done

real 9m16.557s
user 9m7.868s
sys 0m8.128s


This makes "guix environment" unusable with Python 2.


Cyril.
L
L
Ludovic Courtès wrote on 13 Oct 2015 00:07
(name . Cyril Roelandt)(address . tipecaml@gmail.com)(address . 21675-done@debbugs.gnu.org)
87twpv7nb8.fsf@gnu.org
Fixed in commit b3e2a5a.

Let me know if you encounter similar problems again.

Thanks!

Ludo’.
Closed
?