python Tkinter

  • Done
  • quality assurance status badge
Details
5 participants
  • Andreas Enge
  • Federico Beffa
  • ???
  • Ludovic Courtès
  • Cyril Roelandt
Owner
unassigned
Submitted by
Federico Beffa
Severity
normal
F
C
C
Cyril Roelandt wrote on 4 Jul 2015 02:34
55972A09.9020508@gmail.com
On 06/24/2015 09:14 AM, Federico Beffa wrote:
Toggle quote (5 lines)
> The python package does not provide Tkinter which is part of the
> Python Standard Library
> https://docs.python.org/3/library/tkinter.html?highlight=tkinter#module-tkinter
>

I think we need to add tcl and tk to the inputs, and add the
corresponding "-I" and "-L" flags to the configure flags. The issue is
that tk depends on Python (through libx11, which depends on libxcb,
which depends on Python), so we end up with a circular dependency
leading to what I reported in

I think we should:
- rename the Python package to "python-without-tkinter" or
"python-minimal" and use that as a dependency in xorg.scm;
- define a "python" package that would inherit the "minimal Python"
package and add the dependency on tcl/tk to it.


WDYT ?
L
L
Ludovic Courtès wrote on 5 Jul 2015 12:16
(name . Cyril Roelandt)(address . tipecaml@gmail.com)
87fv52rjso.fsf@gnu.org
Cyril Roelandt <tipecaml@gmail.com> skribis:

Toggle quote (19 lines)
> On 06/24/2015 09:14 AM, Federico Beffa wrote:
>> The python package does not provide Tkinter which is part of the
>> Python Standard Library
>> https://docs.python.org/3/library/tkinter.html?highlight=tkinter#module-tkinter
>>
>
> I think we need to add tcl and tk to the inputs, and add the
> corresponding "-I" and "-L" flags to the configure flags. The issue is
> that tk depends on Python (through libx11, which depends on libxcb,
> which depends on Python), so we end up with a circular dependency
> leading to what I reported in
> http://debbugs.gnu.org/cgi/bugreport.cgi?bug=20967 .
>
> I think we should:
> - rename the Python package to "python-without-tkinter" or
> "python-minimal" and use that as a dependency in xorg.scm;
> - define a "python" package that would inherit the "minimal Python"
> package and add the dependency on tcl/tk to it.

How frequently do Python packages rely on the availability of Tkinter?

I’m asking because it might be that we could keep the default Python
without Tk, and only use the Tk-enabled Python for the few packages that
need it, if it’s rare enough.

WDYT?

Ludo’.
C
C
Cyril Roelandt wrote on 6 Jul 2015 00:39
(name . Ludovic Courtès)(address . ludo@gnu.org)
5599B21D.60008@gmail.com
On 07/05/2015 12:16 PM, Ludovic Courtès wrote:
Toggle quote (4 lines)
> I’m asking because it might be that we could keep the default Python
> without Tk, and only use the Tk-enabled Python for the few packages that
> need it, if it’s rare enough.

No, we do not want that. Users who install Python expect to be able to
import tkinter, since it is part of the standard library.

Cyril.
F
F
Federico Beffa wrote on 6 Jul 2015 09:27
(name . Cyril Roelandt)(address . tipecaml@gmail.com)
CAKrPhPMB7nyyu7_FZOEiaJ_oFoqq6-vDHJZMLeYMLW4gZy8utw@mail.gmail.com
On Mon, Jul 6, 2015 at 12:39 AM, Cyril Roelandt <tipecaml@gmail.com> wrote:
Toggle quote (8 lines)
> On 07/05/2015 12:16 PM, Ludovic Courtès wrote:
>> I’m asking because it might be that we could keep the default Python
>> without Tk, and only use the Tk-enabled Python for the few packages that
>> need it, if it’s rare enough.
>
> No, we do not want that. Users who install Python expect to be able to
> import tkinter, since it is part of the standard library.

I agree with Cyril.
L
L
Ludovic Courtès wrote on 6 Jul 2015 12:21
(name . Federico Beffa)(address . beffa@ieee.org)
87wpyd4meg.fsf@gnu.org
Federico Beffa <beffa@ieee.org> skribis:

Toggle quote (11 lines)
> On Mon, Jul 6, 2015 at 12:39 AM, Cyril Roelandt <tipecaml@gmail.com> wrote:
>> On 07/05/2015 12:16 PM, Ludovic Courtès wrote:
>>> I’m asking because it might be that we could keep the default Python
>>> without Tk, and only use the Tk-enabled Python for the few packages that
>>> need it, if it’s rare enough.
>>
>> No, we do not want that. Users who install Python expect to be able to
>> import tkinter, since it is part of the standard library.
>
> I agree with Cyril.

OK. Then we effectively need to proceed as you suggest: Build
python-minimal (which does not depend on Tk), build Tk, and then build
python.

But we should make sure that python-minimal is not retained, if
possible.

Ludo’.
A
A
Andreas Enge wrote on 6 Jul 2015 13:17
(name . Ludovic Courtès)(address . ludo@gnu.org)
20150706111739.GA2969@debian
On Mon, Jul 06, 2015 at 12:21:11PM +0200, Ludovic Courtï¿œs wrote:
Toggle quote (4 lines)
> OK. Then we effectively need to proceed as you suggest: Build
> python-minimal (which does not depend on Tk), build Tk, and then build
> python.

And maybe this python-minimal could be smaller than the current python,
in the sense of "minimal"?

Andreas
L
L
Ludovic Courtès wrote on 8 Oct 2015 00:19
(name . Federico Beffa)(address . beffa@ieee.org)
87egh61fue.fsf@gnu.org
ludo@gnu.org (Ludovic Courtès) skribis:

Toggle quote (4 lines)
> OK. Then we effectively need to proceed as you suggest: Build
> python-minimal (which does not depend on Tk), build Tk, and then build
> python.

Done in commits 95288fc and afa181f.

Thanks,
Ludo’.
Closed
L
L
Ludovic Courtès wrote on 8 Oct 2015 00:18
(name . Federico Beffa)(address . beffa@ieee.org)
87fv1m1fwh.fsf@gnu.org
ludo@gnu.org (Ludovic Courtès) skribis:

Toggle quote (4 lines)
> OK. Then we effectively need to proceed as you suggest: Build
> python-minimal (which does not depend on Tk), build Tk, and then build
> python.

Done in commits 95288fc and afa181f.

Thanks,
Ludo’.
Closed
F
F
Federico Beffa wrote on 9 Nov 2015 10:38
unarchive 20889
(address . control@debbugs.gnu.org)
CAKrPhPPmo+qn9ohj2A1NHh8MN0oozjBuCb4emFyhRusJwsEb3A@mail.gmail.com
unarchive 20889
F
F
Federico Beffa wrote on 9 Nov 2015 10:42
Re: bug#20889: python Tkinter
(address . 20889@debbugs.gnu.org)
CAKrPhPOi6xUKvr0DKA1QE_tPbOzYrL2suY5YouHmeijCMHH=Qg@mail.gmail.com
If I start python3 and do:

-------------------------------------------------------
$ python3
Python 3.4.3 (default, Oct 9 2015, 22:53:58)
[GCC 4.9.3] on linux
Type "help", "copyright", "credits" or "license" for more information.
Toggle quote (2 lines)
>>> import tkinter
>>> root = tkinter.Tk()
Traceback (most recent call last):
File "<stdin>", line 1, in <module>
File "/gnu/store/y5x6c38fzrbfl80jxrgjd6py2k88x12a-python-3.4.3/lib/python3.4/tkinter/__init__.py",
line 1851, in __init__
self.tk = _tkinter.create(screenName, baseName, className,
interactive, wantobjects, useTk, sync, use)
_tkinter.TclError: Can't find a usable tk.tcl in the following directories:
/gnu/store/sd4fcdk9yzh1s0230fjx1yfwk9pl71bf-tcl-8.6.4/lib/tcl8.6/tk8.6
/gnu/store/sd4fcdk9yzh1s0230fjx1yfwk9pl71bf-tcl-8.6.4/lib/tk8.6
/gnu/store/y5x6c38fzrbfl80jxrgjd6py2k88x12a-python-3.4.3/lib/tk8.6
/gnu/store/lib/tk8.6
/gnu/store/y5x6c38fzrbfl80jxrgjd6py2k88x12a-python-3.4.3/library



This probably means that tk wasn't installed properly.
-------------------------------------------------------

Did you successfully test it?

Regards,
Fede
F
F
Federico Beffa wrote on 9 Nov 2015 11:36
(address . 20889@debbugs.gnu.org)
CAKrPhPMrO3m+ZXu36kVfip_7w0b=m+Zjt6fqwEwFpTZf9gdmZg@mail.gmail.com
with:

$TCLLIBPATH=/gnu/store/c4rpx4050d0qkccwbzggabag403b31l3-tk-8.6.4/lib python3

it works. So I guess that 'tcl' needs a search-path-specification.

Regards,
Fede
F
F
Federico Beffa wrote on 9 Nov 2015 11:59
(address . 20889@debbugs.gnu.org)
CAKrPhPOZf8x_3708bbfuQRM4znwd9snp9MJ3kVd6eUrzkhgooA@mail.gmail.com
... and the configure script for Python defines the flag
'--with-tcltk-libs'. Maybe that would help...

Regards,
Fede
L
L
Ludovic Courtès wrote on 11 Nov 2015 22:44
(name . Federico Beffa)(address . beffa@ieee.org)(address . 20889@debbugs.gnu.org)
87io589po5.fsf@gnu.org
Federico Beffa <beffa@ieee.org> skribis:

Toggle quote (14 lines)
> >>> root = tkinter.Tk()
> Traceback (most recent call last):
> File "<stdin>", line 1, in <module>
> File "/gnu/store/y5x6c38fzrbfl80jxrgjd6py2k88x12a-python-3.4.3/lib/python3.4/tkinter/__init__.py",
> line 1851, in __init__
> self.tk = _tkinter.create(screenName, baseName, className,
> interactive, wantobjects, useTk, sync, use)
> _tkinter.TclError: Can't find a usable tk.tcl in the following directories:
> /gnu/store/sd4fcdk9yzh1s0230fjx1yfwk9pl71bf-tcl-8.6.4/lib/tcl8.6/tk8.6
> /gnu/store/sd4fcdk9yzh1s0230fjx1yfwk9pl71bf-tcl-8.6.4/lib/tk8.6
> /gnu/store/y5x6c38fzrbfl80jxrgjd6py2k88x12a-python-3.4.3/lib/tk8.6
> /gnu/store/lib/tk8.6
> /gnu/store/y5x6c38fzrbfl80jxrgjd6py2k88x12a-python-3.4.3/library

This error message comes from Tcl, in file ‘auto.tcl’, procedure
‘tcl_findLibrary’.

We’d need to find where the call comes from and hard-code a search path
in there maybe?

Toggle quote (2 lines)
> Did you successfully test it?

I just did “import tkinter.”

Toggle quote (6 lines)
> with:
>
> $TCLLIBPATH=/gnu/store/c4rpx4050d0qkccwbzggabag403b31l3-tk-8.6.4/lib python3
>
> it works. So I guess that 'tcl' needs a search-path-specification.

Yes. That wouldn’t help for Python though, where we need to hard-code
the search path somehow.

Toggle quote (3 lines)
> ... and the configure script for Python defines the flag
> '--with-tcltk-libs'. Maybe that would help...

I don’t think it would help because Python finds Tcl and Tk anyway.

Thanks,
Ludo’.
L
L
Ludovic Courtès wrote on 12 Nov 2015 13:58
Re: [PATCH] tk: Hardcode path to TK_LIBRARY.
(name . ???)(address . iyzsong@openmailbox.org)
87ziyjxtkp.fsf@gnu.org
??? <iyzsong@openmailbox.org> skribis:

Toggle quote (11 lines)
> From 6c9ea521e88d36bd1ce990a561477ec0e2950017 Mon Sep 17 00:00:00 2001
> From: =?UTF-8?q?=E5=AE=8B=E6=96=87=E6=AD=A6?= <iyzsong@gmail.com>
> Date: Thu, 12 Nov 2015 13:31:19 +0800
> Subject: [PATCH] tk: Hardcode path to TK_LIBRARY.
>
> Fixes <http://bugs.gnu.org/20889>.
>
> * gnu/packages/patches/tk-find-library.patch: New patch.
> * gnu-system.am (dist_patch_DATA): Add it.
> * gnu/packages/tcl.scm (tk)[source]: Add patch.

[...]

Toggle quote (3 lines)
> +++ b/gnu/packages/patches/tk-find-library.patch
> @@ -0,0 +1,30 @@
> +This patch hardcode where Tk found its script library during package
^^ ^^^^
“This patch hard-codes the Tk library directory during package
initialization.”

OK with this change. Thanks for providing a quick fix! :-)

Could you commit it in a new ‘tk-update’ branch?

At the same time, I think we should move tkinter*.so to a separate
output of the Python packages; I think it’s a matter of moving the .so
to a separate output, literally. Would you like to give it a try?

Thanks!

Ludo’.
?
(name . Ludovic Courtès)(address . ludo@gnu.org)
877flmnmfv.fsf@member.fsf.org
ludo@gnu.org (Ludovic Courtès) writes:

Toggle quote (25 lines)
> ??? <iyzsong@openmailbox.org> skribis:
>
>> From 6c9ea521e88d36bd1ce990a561477ec0e2950017 Mon Sep 17 00:00:00 2001
>> From: =?UTF-8?q?=E5=AE=8B=E6=96=87=E6=AD=A6?= <iyzsong@gmail.com>
>> Date: Thu, 12 Nov 2015 13:31:19 +0800
>> Subject: [PATCH] tk: Hardcode path to TK_LIBRARY.
>>
>> Fixes <http://bugs.gnu.org/20889>.
>>
>> * gnu/packages/patches/tk-find-library.patch: New patch.
>> * gnu-system.am (dist_patch_DATA): Add it.
>> * gnu/packages/tcl.scm (tk)[source]: Add patch.
>
> [...]
>
>> +++ b/gnu/packages/patches/tk-find-library.patch
>> @@ -0,0 +1,30 @@
>> +This patch hardcode where Tk found its script library during package
> ^^ ^^^^
> “This patch hard-codes the Tk library directory during package
> initialization.”
>
> OK with this change. Thanks for providing a quick fix! :-)
>
> Could you commit it in a new ‘tk-update’ branch?
Done.
Toggle quote (4 lines)
>
> At the same time, I think we should move tkinter*.so to a separate
> output of the Python packages; I think it’s a matter of moving the .so
> to a separate output, literally. Would you like to give it a try?
I don't know much about python, so I'd like to leave it for others :-)
L
L
Ludovic Courtès wrote on 16 Nov 2015 09:42
Tkinter moved to separate output
(name . ???)(address . iyzsong@openmailbox.org)
87k2picp2z.fsf_-_@gnu.org
In ‘tk-update’ the ‘python’ packages now have a separate ‘tk’ output for
Tkinter (adding ~50 MiB to the closure of Python.) I’ve tested it along
these lines, for 2.x and 3.x:

guix environment --ad-hoc python python:tk --pure -- python
> import Tkinter
> root = Tkinter.Tk()
One thing I haven’t checked is whether some packages need to have an
additional python:tk input. Matplotlib maybe? Federico?

I plan to have Hydra build that branch once we’ve checked that.

Thanks,
Ludo’.
F
F
Federico Beffa wrote on 16 Nov 2015 12:44
(name . Ludovic Courtès)(address . ludo@gnu.org)
CAKrPhPNQ9n3KznhkbbY2f8R1jx4JBU95Z0bzdrAHBHYYvE=RTA@mail.gmail.com
On Mon, Nov 16, 2015 at 9:42 AM, Ludovic Courtès <ludo@gnu.org> wrote:
Toggle quote (11 lines)
> In ‘tk-update’ the ‘python’ packages now have a separate ‘tk’ output for
> Tkinter (adding ~50 MiB to the closure of Python.) I’ve tested it along
> these lines, for 2.x and 3.x:
>
> guix environment --ad-hoc python python:tk --pure -- python
> > import Tkinter
> > root = Tkinter.Tk()
>
> One thing I haven’t checked is whether some packages need to have an
> additional python:tk input. Matplotlib maybe? Federico?

Yes, given that the back-end currently used by matploblib doesn't
work, I would change that by using 'Tkinter'.

Since you are at it, I would also change the default back-end by
changing 'GTK3Agg' to 'TkAgg' in the following snippet:

(lambda (port)
(format port "[rc_options]~%
backend = GTK3Agg~%")))))

I'm not convinced that having 2 versions of packages (a "normal" and a
"minimal" one) is a good idea. The reason is that you often end up
downloading both instead of just one. As one example, I just
downloaded 'vlc' and I noticed that it downloaded both 'cups' and
'cups-minimal'. Similarly, for python, anyone needing 'Tkinter' will
end up with 2 versions in the store.

Regards,
Fede
L
L
Ludovic Courtès wrote on 16 Nov 2015 13:57
(name . Federico Beffa)(address . beffa@ieee.org)
87a8qe85ku.fsf@gnu.org
Federico Beffa <beffa@ieee.org> skribis:

Toggle quote (22 lines)
> On Mon, Nov 16, 2015 at 9:42 AM, Ludovic Courtès <ludo@gnu.org> wrote:
>> In ‘tk-update’ the ‘python’ packages now have a separate ‘tk’ output for
>> Tkinter (adding ~50 MiB to the closure of Python.) I’ve tested it along
>> these lines, for 2.x and 3.x:
>>
>> guix environment --ad-hoc python python:tk --pure -- python
>> > import Tkinter
>> > root = Tkinter.Tk()
>>
>> One thing I haven’t checked is whether some packages need to have an
>> additional python:tk input. Matplotlib maybe? Federico?
>
> Yes, given that the back-end currently used by matploblib doesn't
> work, I would change that by using 'Tkinter'.
>
> Since you are at it, I would also change the default back-end by
> changing 'GTK3Agg' to 'TkAgg' in the following snippet:
>
> (lambda (port)
> (format port "[rc_options]~%
> backend = GTK3Agg~%")))))

OTOH I see that Matploblib already depends on GTK+ 3.x and
python-pygobject, so maybe it’s best to stick to GTK+ by default?

Toggle quote (7 lines)
> I'm not convinced that having 2 versions of packages (a "normal" and a
> "minimal" one) is a good idea. The reason is that you often end up
> downloading both instead of just one. As one example, I just
> downloaded 'vlc' and I noticed that it downloaded both 'cups' and
> 'cups-minimal'. Similarly, for python, anyone needing 'Tkinter' will
> end up with 2 versions in the store.

The ‘minimal’ variants are there to break cyclic dependencies most of
the time. This is the case for cups/cups-filters and Python/Tk.

At run time, cups indeed depends on cups-filters, which depends on
cups-minimal. In that case, as you say, we end up downloading those two
variants. But there’s not much of a choice, as was discussed during the
initial review:


Conversely, python does not depend on python-minimal. So python-minimal
is here just to break the cycle with Tk/libxcb, as noted in python.scm
and discussed in:


As for Tkinter, it is in a separate “tk” output, which users can choose
to install or not. The “tk” output contains a single file, but it pulls
in Tcl/Tk.

I hope this clarifies things.

Thanks for your feedback,
Ludo’.
F
F
Federico Beffa wrote on 16 Nov 2015 14:16
(name . Ludovic Courtès)(address . ludo@gnu.org)
CAKrPhPOXRTG10qVkEqAPmcLyPGteT_JwkbH+QFprGOcBT=6uQw@mail.gmail.com
On Mon, Nov 16, 2015 at 1:57 PM, Ludovic Courtès <ludo@gnu.org> wrote:
Toggle quote (14 lines)
> Federico Beffa <beffa@ieee.org> skribis:
>> Yes, given that the back-end currently used by matploblib doesn't
>> work, I would change that by using 'Tkinter'.
>>
>> Since you are at it, I would also change the default back-end by
>> changing 'GTK3Agg' to 'TkAgg' in the following snippet:
>>
>> (lambda (port)
>> (format port "[rc_options]~%
>> backend = GTK3Agg~%")))))
>
> OTOH I see that Matploblib already depends on GTK+ 3.x and
> python-pygobject, so maybe it’s best to stick to GTK+ by default?

Unfortunately, the back-ends based on GTK+ are broken and I didn't
manage to find how to fix the problem.

That's why I'm looking forward to get Tkinter :-)

Toggle quote (27 lines)
>> I'm not convinced that having 2 versions of packages (a "normal" and a
>> "minimal" one) is a good idea. The reason is that you often end up
>> downloading both instead of just one. As one example, I just
>> downloaded 'vlc' and I noticed that it downloaded both 'cups' and
>> 'cups-minimal'. Similarly, for python, anyone needing 'Tkinter' will
>> end up with 2 versions in the store.
>
> The ‘minimal’ variants are there to break cyclic dependencies most of
> the time. This is the case for cups/cups-filters and Python/Tk.
>
> At run time, cups indeed depends on cups-filters, which depends on
> cups-minimal. In that case, as you say, we end up downloading those two
> variants. But there’s not much of a choice, as was discussed during the
> initial review:
>
> https://lists.gnu.org/archive/html/guix-devel/2015-01/msg00057.html
>
> Conversely, python does not depend on python-minimal. So python-minimal
> is here just to break the cycle with Tk/libxcb, as noted in python.scm
> and discussed in:
>
> http://debbugs.gnu.org/cgi/bugreport.cgi?bug=20889
>
> As for Tkinter, it is in a separate “tk” output, which users can choose
> to install or not. The “tk” output contains a single file, but it pulls
> in Tcl/Tk.

OK. Thanks for the explanation!

Regards,
Fede
L
L
Ludovic Courtès wrote on 29 Nov 2015 23:09
(name . Federico Beffa)(address . beffa@ieee.org)
87two4e9v8.fsf@gnu.org
Federico Beffa <beffa@ieee.org> skribis:

Toggle quote (21 lines)
> On Mon, Nov 16, 2015 at 1:57 PM, Ludovic Courtès <ludo@gnu.org> wrote:
>> Federico Beffa <beffa@ieee.org> skribis:
>>> Yes, given that the back-end currently used by matploblib doesn't
>>> work, I would change that by using 'Tkinter'.
>>>
>>> Since you are at it, I would also change the default back-end by
>>> changing 'GTK3Agg' to 'TkAgg' in the following snippet:
>>>
>>> (lambda (port)
>>> (format port "[rc_options]~%
>>> backend = GTK3Agg~%")))))
>>
>> OTOH I see that Matploblib already depends on GTK+ 3.x and
>> python-pygobject, so maybe it’s best to stick to GTK+ by default?
>
> Unfortunately, the back-ends based on GTK+ are broken and I didn't
> manage to find how to fix the problem.
> http://debbugs.gnu.org/cgi/bugreport.cgi?bug=20888
>
> That's why I'm looking forward to get Tkinter :-)

Could you or someone else test this patch on current master?

Thanks in advance!

Ludo’.
Toggle diff (21 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 39d0751..76bda96 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3190,6 +3190,7 @@ transcendental functions).")
`(("python-pyparsing" ,python-pyparsing)
("python-pygobject" ,python-pygobject)
("gobject-introspection" ,gobject-introspection)
+ ("python-tkinter" ,python "tk")
;; The 'gtk+' package (and 'gdk-pixbuf', 'atk' and 'pango' propagated
;; from 'gtk+') provides the required 'typelib' files used by
;; 'gobject-introspection'. The location of these files is set with the
@@ -3244,7 +3245,7 @@ transcendental functions).")
(call-with-output-file "setup.cfg"
(lambda (port)
(format port "[rc_options]~%
-backend = GTK3Agg~%")))))
+backend = TkAgg~%")))))
(alist-cons-after
'install 'install-doc
(lambda* (#:key outputs #:allow-other-keys)
F
F
Federico Beffa wrote on 30 Nov 2015 17:45
(name . Ludovic Courtès)(address . ludo@gnu.org)
CAKrPhPPp4hkbNezo5mJv8UX=7UH0ftNuDrj+aVzMNTDBZrpFNw@mail.gmail.com
On Sun, Nov 29, 2015 at 11:09 PM, Ludovic Courtès <ludo@gnu.org> wrote:
Toggle quote (25 lines)
> Federico Beffa <beffa@ieee.org> skribis:
>
>> On Mon, Nov 16, 2015 at 1:57 PM, Ludovic Courtès <ludo@gnu.org> wrote:
>>> Federico Beffa <beffa@ieee.org> skribis:
>>>> Yes, given that the back-end currently used by matploblib doesn't
>>>> work, I would change that by using 'Tkinter'.
>>>>
>>>> Since you are at it, I would also change the default back-end by
>>>> changing 'GTK3Agg' to 'TkAgg' in the following snippet:
>>>>
>>>> (lambda (port)
>>>> (format port "[rc_options]~%
>>>> backend = GTK3Agg~%")))))
>>>
>>> OTOH I see that Matploblib already depends on GTK+ 3.x and
>>> python-pygobject, so maybe it’s best to stick to GTK+ by default?
>>
>> Unfortunately, the back-ends based on GTK+ are broken and I didn't
>> manage to find how to fix the problem.
>> http://debbugs.gnu.org/cgi/bugreport.cgi?bug=20888
>>
>> That's why I'm looking forward to get Tkinter :-)
>
> Could you or someone else test this patch on current master?

It does not work. It can't find the tcl/tk header files:

...
tkagg: no [The C/C++ header for Tk (tk.h) could not be
found. You may need to install the development
package.]
...

With the attached patch it does find the headers, but then it fails at
link time.

...
g++ -pthread -shared
-Wl,-rpath=/gnu/store/cxrqlhbr6xqgi08x3amd0lvl6m7sxx57-python-3.4.3/lib
build/temp.linux-x86_64-3.4/src/agg_py_transforms.o
build/temp.linux-x86_64-3.4/src/_tkagg.o
build/temp.linux-x86_64-3.4/extern/agg24/src/agg_bezier_arc.o
build/temp.linux-x86_64-3.4/extern/agg24/src/agg_curves.o
build/temp.linux-x86_64-3.4/extern/agg24/src/agg_image_filters.o
build/temp.linux-x86_64-3.4/extern/agg24/src/agg_trans_affine.o
build/temp.linux-x86_64-3.4/extern/agg24/src/agg_vcgen_contour.o
build/temp.linux-x86_64-3.4/extern/agg24/src/agg_vcgen_dash.o
build/temp.linux-x86_64-3.4/extern/agg24/src/agg_vcgen_stroke.o
build/temp.linux-x86_64-3.4/extern/agg24/src/agg_vpgen_segmentator.o
build/temp.linux-x86_64-3.4/extern/CXX/IndirectPythonInterface.o
build/temp.linux-x86_64-3.4/extern/CXX/cxxsupport.o
build/temp.linux-x86_64-3.4/extern/CXX/cxx_extensions.o
build/temp.linux-x86_64-3.4/extern/CXX/cxxextensions.o
-L/gnu/store/ipsq9hlk6k0w1qfiw0y0a03bxkp2clhl-tcl-8.6.4/lib
-L/gnu/store/my9wgryzpfvksng6k7h87xz9rphdwddw-tk-8.6.4/lib
-L/usr/local/lib -L/usr/local/lib
-L/gnu/store/cxrqlhbr6xqgi08x3amd0lvl6m7sxx57-python-3.4.3/lib -ltcl
-ltk -lstdc++ -lm -lpython3.4m -o
build/lib.linux-x86_64-3.4/matplotlib/backends/_tkagg.cpython-34m.so
ld: cannot find -ltcl
ld: cannot find -ltk
collect2: error: ld returned 1 exit status
error: command 'g++' failed with exit status 1
phase `build' failed after 94.8 seconds
...

Looking into the failed build directory, it seems that PKG_CONFIG_PATH
is set correctly. Still, it doesn't get the correct flags.

Regards,
Fede
Toggle diff (38 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 39d0751..4dfe557 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3190,6 +3190,7 @@ transcendental functions).")
`(("python-pyparsing" ,python-pyparsing)
("python-pygobject" ,python-pygobject)
("gobject-introspection" ,gobject-introspection)
+ ("python-tkinter" ,python "tk")
;; The 'gtk+' package (and 'gdk-pixbuf', 'atk' and 'pango' propagated
;; from 'gtk+') provides the required 'typelib' files used by
;; 'gobject-introspection'. The location of these files is set with the
@@ -3224,7 +3225,8 @@ transcendental functions).")
;; FIXME: Add backends when available.
;("python-wxpython" ,python-wxpython)
;("python-pyqt" ,python-pyqt)
- ))
+ ("tcl" ,tcl)
+ ("tk" ,tk)))
(native-inputs
`(("pkg-config" ,pkg-config)
("texlive" ,texlive)
@@ -3243,8 +3245,13 @@ transcendental functions).")
(setenv "HOME" (getcwd))
(call-with-output-file "setup.cfg"
(lambda (port)
- (format port "[rc_options]~%
-backend = GTK3Agg~%")))))
+ (format port "[directories]~%
+basedirlist = ~a,~a~%
+~%
+[rc_options]~%
+backend = TkAgg~%"
+ (assoc-ref inputs "tcl")
+ (assoc-ref inputs "tk"))))))
(alist-cons-after
'install 'install-doc
(lambda* (#:key outputs #:allow-other-keys)
F
F
Federico Beffa wrote on 1 Dec 2015 21:19
(name . Ludovic Courtès)(address . ludo@gnu.org)
CAKrPhPM0UqgC0x+pOqR7Ta7afGchG6KGaBqfwp+OB2RoaAMQpg@mail.gmail.com
Federico Beffa <beffa@ieee.org> writes:

Toggle quote (6 lines)
> On Sun, Nov 29, 2015 at 11:09 PM, Ludovic Courtès <ludo@gnu.org> wrote:
>> Federico Beffa <beffa@ieee.org> skribis:

> Looking into the failed build directory, it seems that PKG_CONFIG_PATH
> is set correctly. Still, it doesn't get the correct flags.

The attached patch fixes the problem and I can now plot with TkAgg :-)

Thanks for making Tkinter available!
Fede
From b40cf5522bcc15166ca07dfbae50167203d29e2d Mon Sep 17 00:00:00 2001
From: Federico Beffa <beffa@fbengineering.ch>
Date: Tue, 1 Dec 2015 17:20:59 +0100
Subject: [PATCH 1/2] gnu: python-matplotlib: Add 'TkAgg' backend and update to
version '1.4.3'.

* gnu/packages/python.scm (python-matplotlib): Do it.
* gnu/packages/patches/matplotlib-setupext-tk.patch: New file.
---
gnu/packages/patches/matplotlib-setupext-tk.patch | 30 +++++++++++++++++++++++
gnu/packages/python.scm | 17 +++++++++----
2 files changed, 42 insertions(+), 5 deletions(-)
create mode 100644 gnu/packages/patches/matplotlib-setupext-tk.patch

Toggle diff (93 lines)
diff --git a/gnu/packages/patches/matplotlib-setupext-tk.patch b/gnu/packages/patches/matplotlib-setupext-tk.patch
new file mode 100644
index 0000000..cd0332e
--- /dev/null
+++ b/gnu/packages/patches/matplotlib-setupext-tk.patch
@@ -0,0 +1,30 @@
+Use 'pkg-config' instead of heuristics to find 'tk' flags.
+
+--- matplotlib-1.4.3/setupext.py.orig 2015-12-01 14:21:19.554417453 +0100
++++ matplotlib-1.4.3/setupext.py 2015-12-01 14:35:51.999928797 +0100
+@@ -1457,7 +1457,7 @@
+ p = subprocess.Popen(
+ '. %s ; eval echo ${%s}' % (file, varname),
+ shell=True,
+- executable="/bin/sh",
++ executable="sh",
+ stdout=subprocess.PIPE)
+ result = p.communicate()[0]
+ return result.decode('ascii')
+@@ -1601,8 +1601,15 @@
+ # of distros.
+
+ # Query Tcl/Tk system for library paths and version string
++ def getoutput(s):
++ ret = os.popen(s).read().strip()
++ return ret
+ try:
+- tcl_lib_dir, tk_lib_dir, tk_ver = self.query_tcltk()
++ #tcl_lib_dir, tk_lib_dir, tk_ver = self.query_tcltk()
++ pkg_config_res = getoutput('pkg-config --libs tk').split()
++ tk_ver = pkg_config_res[-1][-3:]
++ tcl_lib_dir = pkg_config_res[0][2:] + '/tcl' + tk_ver
++ tk_lib_dir = pkg_config_res[1][2:] + '/tk' + tk_ver
+ except:
+ tk_ver = ''
+ result = self.hardcoded_tcl_config()
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 39d0751..5e23bab 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3175,7 +3175,7 @@ transcendental functions).")
(define-public python-matplotlib
(package
(name "python-matplotlib")
- (version "1.4.2")
+ (version "1.4.3")
(source
(origin
(method url-fetch)
@@ -3183,13 +3183,15 @@ transcendental functions).")
"/matplotlib-" version ".tar.gz"))
(sha256
(base32
- "0m6v9nwdldlwk22gcd339zg6mny5m301fxgks7z8sb8m9wawg8qp"))))
+ "1dn05cvd0g984lzhh72wa0z93psgwshbbg93fkab6slx5m3l95av"))
+ (patches (list (search-patch "matplotlib-setupext-tk.patch")))))
(build-system python-build-system)
(outputs '("out" "doc"))
(propagated-inputs ; the following packages are all needed at run time
`(("python-pyparsing" ,python-pyparsing)
("python-pygobject" ,python-pygobject)
("gobject-introspection" ,gobject-introspection)
+ ("python" ,python "tk")
;; The 'gtk+' package (and 'gdk-pixbuf', 'atk' and 'pango' propagated
;; from 'gtk+') provides the required 'typelib' files used by
;; 'gobject-introspection'. The location of these files is set with the
@@ -3224,7 +3226,8 @@ transcendental functions).")
;; FIXME: Add backends when available.
;("python-wxpython" ,python-wxpython)
;("python-pyqt" ,python-pyqt)
- ))
+ ("tcl" ,tcl)
+ ("tk" ,tk)))
(native-inputs
`(("pkg-config" ,pkg-config)
("texlive" ,texlive)
@@ -3243,8 +3246,12 @@ transcendental functions).")
(setenv "HOME" (getcwd))
(call-with-output-file "setup.cfg"
(lambda (port)
- (format port "[rc_options]~%
-backend = GTK3Agg~%")))))
+ (format port "[directories]~%
+basedirlist = ~a,~a~%
+[rc_options]~%
+backend = TkAgg~%"
+ (assoc-ref inputs "tcl")
+ (assoc-ref inputs "tk"))))))
(alist-cons-after
'install 'install-doc
(lambda* (#:key outputs #:allow-other-keys)
--
2.4.3
L
L
Ludovic Courtès wrote on 1 Dec 2015 23:00
(name . Federico Beffa)(address . beffa@ieee.org)
87y4dd3k3c.fsf@gnu.org
Federico Beffa <beffa@ieee.org> skribis:

Toggle quote (14 lines)
> The attached patch fixes the problem and I can now plot with TkAgg :-)
>
> Thanks for making Tkinter available!
> Fede
>
> From b40cf5522bcc15166ca07dfbae50167203d29e2d Mon Sep 17 00:00:00 2001
> From: Federico Beffa <beffa@fbengineering.ch>
> Date: Tue, 1 Dec 2015 17:20:59 +0100
> Subject: [PATCH 1/2] gnu: python-matplotlib: Add 'TkAgg' backend and update to
> version '1.4.3'.
>
> * gnu/packages/python.scm (python-matplotlib): Do it.
> * gnu/packages/patches/matplotlib-setupext-tk.patch: New file.

Nice!

Please make sure to add the patch to gnu-system.am, but otherwise looks
great!

Thanks for fixing it!

I gather this addresses http://bugs.gnu.org/20888,right?

Ludo’.
F
F
Federico Beffa wrote on 2 Dec 2015 18:28
(name . Ludovic Courtès)(address . ludo@gnu.org)
CAKrPhPMo9f2zV0GS=8ORZOkhReY=NE7NDxpuiX3NxFQJt__2yA@mail.gmail.com
On Tue, Dec 1, 2015 at 11:00 PM, Ludovic Courtès <ludo@gnu.org> wrote:
Toggle quote (2 lines)
> I gather this addresses http://bugs.gnu.org/20888,right?

Well, it partially solves it:
Now there is a working backend suitable for interactive plotting which
is enabled by default. However, the 'GTK3Agg' backend is still there
and still not working. At some point it would be nice to have it
working as well.

Regards,
Fede
?