Hi,
The commit bea3b17739fc591b8cf6db1f8d28a6f6c9585577 changed a bit the
importers. However, even before this commit, the errors are incorrectly
reported for ’gnu’ and ’json’, without the --recursive option, e.g,
commit 23e2cd156f. And bea3b17739 does not change anything. This very
same backtrace:
Toggle snippet (28 lines)
# Importer: gnu
Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
Backtrace:
10 (primitive-load "/home/simon/.cache/guix/inferiors/uefwax7zflbosucfo3nxhvvwwyvldkx447xk…")
In guix/ui.scm:
2118:12 9 (run-guix-command _ . _)
In guix/scripts/import.scm:
120:11 8 (guix-import . _)
In ice-9/boot-9.scm:
1736:10 7 (with-exception-handler _ _ #:unwind? _ #:unwind-for-type _)
1731:15 6 (with-exception-handler #<procedure 7f44f4628900 at ice-9/boot-9.scm:1815:7 (exn)> _ # _ …)
In guix/import/gnu.scm:
111:2 5 (gnu->guix-package "kikoo-lol" #:key-download _)
In guix/gnu-maintenance.scm:
364:20 4 (latest-ftp-release "kikoo-lol" #:server _ #:directory _ #:keep-file? _ # _ #:ftp-open _ …)
In guix/ftp-client.scm:
233:6 3 (ftp-list #<<ftp-connection> socket: #<input-output: socket 15> addrinfo: #(32 10 1 6 …> …)
In srfi/srfi-1.scm:
460:18 2 (fold #<procedure 7f44f4628720 at guix/ftp-client.scm:187:10 (dir result)> _ _)
In guix/ftp-client.scm:
74:8 1 (_ _ _)
In ice-9/boot-9.scm:
1669:16 0 (raise-exception _ #:continuable? _)
ice-9/boot-9.scm:1669:16: In procedure raise-exception:
Throw to key `ftp-error' with args `(#<input-output: socket 15> "CWD kikoo-lol" 550 "Failed to change directory.\r")'.
Toggle snippet (24 lines)
# Importer: json
Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
Backtrace:
7 (primitive-load "/home/simon/.cache/guix/inferiors/uefwax7zflbosucfo3nxhvvwwyvldkx447xk…")
In guix/ui.scm:
2118:12 6 (run-guix-command _ . _)
In guix/scripts/import.scm:
120:11 5 (guix-import . _)
In guix/scripts/import/json.scm:
91:11 4 (guix-import-json . _)
In ice-9/boot-9.scm:
1731:15 3 (with-exception-handler #<procedure 7f25ebaf6210 at ice-9/boot-9.scm:1815:7 (exn)> _ # _ …)
In guix/import/json.scm:
61:19 2 (_)
In ice-9/ports.scm:
440:11 1 (call-with-input-file "kikoo-lol" #<procedure 7f25ebad92c0 at ice-9/ports.scm:492:3 (p)> …)
In unknown file:
0 (open-file "kikoo-lol" "r" #:encoding #f #:guess-encoding #f)
ERROR: In procedure open-file:
In procedure open-file: No such file or directory: "kikoo-lol"
Then, for the same commit 23e2cd156f and the importers supporting the
--recursive option, the only one reporting correctly the error is the
’stackage’ importer:
Toggle snippet (91 lines)
for from in pypi hackage stackage elpa gem cran opam ;\
do echo "# Importer: $from" ;\
guix time-machine --commit=23e2cd156f -- import $from kikoo-lol -r ;\
done
# Importer: pypi
Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
following redirection to `https://pypi.org/pypi/kikoo-lol/json/'...
Backtrace:
4 (primitive-load "/home/simon/.cache/guix/inferiors/uefwax7zflbosucfo3nxhvvwwyvldkx447xk…")
In guix/ui.scm:
2118:12 3 (run-guix-command _ . _)
In guix/scripts/import.scm:
120:11 2 (guix-import . _)
In guix/scripts/import/pypi.scm:
97:16 1 (guix-import-pypi . _)
In guix/import/utils.scm:
431:36 0 (recursive-import "kikoo-lol" #f #:repo->guix-package _ #:guix-name _)
guix/import/utils.scm:431:36: In procedure recursive-import:
Wrong number of values returned to continuation (expected 2)
# Importer: hackage
Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
Backtrace:
4 (primitive-load "/home/simon/.cache/guix/inferiors/uefwax7zflbosucfo3nxhvvwwyvldkx447xk…")
In guix/ui.scm:
2118:12 3 (run-guix-command _ . _)
In guix/scripts/import.scm:
120:11 2 (guix-import . _)
In guix/scripts/import/hackage.scm:
132:26 1 (guix-import-hackage . _)
In guix/import/utils.scm:
431:36 0 (recursive-import "kikoo-lol" #f #:repo->guix-package _ #:guix-name _)
guix/import/utils.scm:431:36: In procedure recursive-import:
Wrong number of values returned to continuation (expected 2)
# Importer: stackage
Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
guix import: error: kikoo-lol: Stackage package not found
# Importer: elpa
Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
Backtrace:
4 (primitive-load "/home/simon/.cache/guix/inferiors/uefwax7zflbosucfo3nxhvvwwyvldkx447xk…")
In guix/ui.scm:
2118:12 3 (run-guix-command _ . _)
In guix/scripts/import.scm:
120:11 2 (guix-import . _)
In guix/scripts/import/elpa.scm:
103:16 1 (guix-import-elpa . _)
In guix/import/utils.scm:
431:36 0 (recursive-import "kikoo-lol" gnu #:repo->guix-package _ #:guix-name _)
guix/import/utils.scm:431:36: In procedure recursive-import:
Wrong number of values returned to continuation (expected 2)
# Importer: gem
Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
#f
# Importer: cran
Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
error: failed to retrieve package information from "https://cran.r-project.org/web/packages/kikoo-lol/DESCRIPTION": 404 ("Not Found")
Backtrace:
4 (primitive-load "/home/simon/.cache/guix/inferiors/uefwax7zflbosucfo3nxhvvwwyvldkx447xk…")
In guix/ui.scm:
2118:12 3 (run-guix-command _ . _)
In guix/scripts/import.scm:
120:11 2 (guix-import . _)
In srfi/srfi-1.scm:
586:17 1 (map1 (#f))
In guix/import/utils.scm:
258:2 0 (package->definition _)
guix/import/utils.scm:258:2: In procedure package->definition:
Throw to key `match-error' with args `("match" "no matching pattern" #f)'.
# Importer: opam
Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
Package not found in opam repository: kikoo-lol
Backtrace:
4 (primitive-load "/home/simon/.cache/guix/inferiors/uefwax7zflbosucfo3nxhvvwwyvldkx447xk…")
In guix/ui.scm:
2118:12 3 (run-guix-command _ . _)
In guix/scripts/import.scm:
120:11 2 (guix-import . _)
In guix/scripts/import/opam.scm:
96:16 1 (guix-import-opam . _)
In guix/import/utils.scm:
431:36 0 (recursive-import "kikoo-lol" #f #:repo->guix-package _ #:guix-name _)
guix/import/utils.scm:431:36: In procedure recursive-import:
Wrong number of values returned to continuation (expected 2)
And now the commit bea3b17739 introduces instead this backtraces for
’opam’:
Toggle snippet (21 lines)
# Importer: opam
Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
Backtrace:
6 (primitive-load "/home/simon/.cache/guix/inferiors/fbnvi5znqq6m3atsgadr35wm3anm7hwiouof…")
In guix/ui.scm:
2118:12 5 (run-guix-command _ . _)
In guix/scripts/import.scm:
120:11 4 (guix-import . _)
In guix/scripts/import/opam.scm:
96:16 3 (guix-import-opam . _)
In guix/import/utils.scm:
445:31 2 (recursive-import "kikoo-lol" #:repo->guix-package _ #:guix-name _ #:version _ #:repo _)
436:33 1 (lookup-node "kikoo-lol" #f)
In guix/import/opam.scm:
264:0 0 (opam->guix-package _ #:repository _ #:version _)
guix/import/opam.scm:264:0: In procedure opam->guix-package:
Unrecognized keyword: #:repo
Last and annoying, the commit bea3b17739 introduces the regression:
Toggle snippet (45 lines)
for ci in 23e2cd156f bea3b17739 ; do guix time-machine --commit=$ci -- import hackage process -r ; done
Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
Starting download of /tmp/guix-file.WAQrHM
From https://hackage.haskell.org/package/process/process-1.6.10.0.tar.gz...
….10.0.tar.gz 72KiB 559KiB/s 00:00 [##################] 100.0%
(define-public ghc-process
(package
(name "ghc-process")
(version "1.6.10.0")
(source
(origin
(method url-fetch)
(uri (string-append
"https://hackage.haskell.org/package/process/process-"
version
".tar.gz"))
(sha256
(base32
"01c50qhrsvymbifa3lzyq6g4hmj6jl3awjp1jmbhdkmfdfaq3v16"))))
(build-system haskell-build-system)
(home-page
"http://hackage.haskell.org/package/process")
(synopsis "Process libraries")
(description
"This package contains libraries for dealing with system processes. . The typed-process package is a more recent take on a process API, which uses this package internally. It features better binary support, easier concurrency, and a more composable API. You can read more about it at <https://github.com/fpco/typed-process/#readme>.")
(license bsd-3)))
Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
Backtrace:
4 (primitive-load "/home/simon/.cache/guix/inferiors/fbnvi5znqq6m3atsgadr35wm3anm7hwiouof…")
In guix/ui.scm:
2118:12 3 (run-guix-command _ . _)
In guix/scripts/import.scm:
120:11 2 (guix-import . _)
In guix/scripts/import/hackage.scm:
132:26 1 (guix-import-hackage . _)
In guix/import/utils.scm:
416:0 0 (recursive-import _ #:repo->guix-package _ #:guix-name _ #:version _ #:repo _)
guix/import/utils.scm:416:0: In procedure recursive-import:
Invalid keyword: #f