(address . guix-patches@gnu.org)
From f5f390689908f065fd12abaeba8fa4e19e5e96c8 Mon Sep 17 00:00:00 2001
From: Greg Hogan <code@greghogan.com>
Date: Tue, 5 Jan 2021 16:23:24 +0000
Subject: [PATCH] gnu: python-numpy: Update to 1.19.4.
* gnu/packages/python-xyz.scm (python-numpy): Update to 1.19.4.
[native-inputs]: Add python-hypothesis.
---
gnu/packages/python-xyz.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)
Toggle diff (41 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ab10668a01..a049f257cb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -94,6 +94,7 @@
;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
;;; Copyright © 2019 Kristian Trandem <kristian@devup.no>
;;; Copyright © 2020 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4515,7 +4516,7 @@ between language specification and implementation
aspects.")
(define-public python-numpy
(package
(name "python-numpy")
- (version "1.17.3")
+ (version "1.19.4")
(source
(origin
(method url-fetch)
@@ -4524,13 +4525,14 @@ between language specification and implementation
aspects.")
version "/numpy-" version ".tar.gz"))
(sha256
(base32
- "1ak9dmjja0q90a7fsxli51ypcwssh8c4pb6f8wkrsnf2xgdk6dy9"))))
+ "04w46xsllj7al9bfjk5zzs48xa9y300yzjh3ysrxnf38bml6m0zy"))))
(build-system python-build-system)
(inputs
`(("openblas" ,openblas)
("lapack" ,lapack)))
(native-inputs
`(("python-cython" ,python-cython)
+ ("python-hypothesis" ,python-hypothesis)
("python-pytest" ,python-pytest)
("gfortran" ,gfortran)))
(arguments
--
2.30.0