Cannot build gcc-toolchain with "make-gcc-toolchain"

  • Done
  • quality assurance status badge
Details
2 participants
  • Roel Janssen
  • zimoun
Owner
unassigned
Submitted by
Roel Janssen
Severity
normal
R
R
Roel Janssen wrote on 26 Mar 2020 11:29
(address . bug-guix@gnu.org)
b815b0f6b24af54c1064cadf7ae96603264b96fa.camel@gnu.org
Dear Guix,

I am trying to build a package with glibc-2.28. So my native-inputs looks like
this:
--------------
(native-inputs
`(("gcc-toolchain" ,(make-gcc-toolchain gcc-5 glibc-2.28))))
--------------


When building this custom gcc-toolchain, it fails with:

--------------
libtool: compile: /tmp/guix-build-gcc-glibc-2.28-5.5.0.drv-0/build/./gcc/xgcc -B/tmp/guix-build-gcc-glibc-2.28-5.5.0.drv-0/build/./gcc/ -B/gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-glibc-2.28-5.5.0/x86_64-unknown-linux-gnu/bin/ -B/gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-glibc-2.28-5.5.0/x86_64-unknown-linux-gnu/lib/ -isystem /gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-glibc-2.28-5.5.0/x86_64-unknown-linux-gnu/include -isystem /gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-glibc-2.28-5.5.0/x86_64-unknown-linux-gnu/sys-include -DHAVE_CONFIG_H -I. -I../../../gcc-5.5.0/libquadmath -I ../../../gcc-5.5.0/libquadmath/../include -g -O2 -MT math/isinf_nsq.lo -MD -MP -MF math/.deps/isinf_nsq.Tpo -c ../../../gcc-5.5.0/libquadmath/math/isinf_nsq.c -fPIC -DPIC -o math/.libs/isinf_nsq.o
xgcc: error trying to exec 'cc1': execvp: No such file or directory

...

xgcc: error trying to exec 'cc1': execvp: No such file or directory
libtool: compile: /tmp/guix-build-gcc-glibc-2.28-5.5.0.drv-0/build/./gcc/xgcc
-B/tmp/guix-build-gcc-glibc-2.28-5.5.0.drv-0/build/./gcc/
-B/gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-glibc-2.28-5.5.0/x86_64-
unknown-linux-gnu/bin/ -B/gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-glibc-
2.28-5.5.0/x86_64-unknown-linux-gnu/lib/ -isystem
/gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-glibc-2.28-5.5.0/x86_64-unknown-
linux-gnu/include -isystem /gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-
glibc-2.28-5.5.0/x86_64-unknown-linux-gnu/sys-include -DHAVE_CONFIG_H -I.
-I../../../gcc-5.5.0/libquadmath -I ../../../gcc-5.5.0/libquadmath/../include -g
-O2 -MT math/frexpq.lo -MD -MP -MF math/.deps/frexpq.Tpo -c ../../../gcc-
5.5.0/libquadmath/math/frexpq.c -fPIC -DPIC -o math/.libs/frexpq.o
libtool: compile: /tmp/guix-build-gcc-glibc-2.28-5.5.0.drv-0/build/./gcc/xgcc
-B/tmp/guix-build-gcc-glibc-2.28-5.5.0.drv-0/build/./gcc/
-B/gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-glibc-2.28-5.5.0/x86_64-
unknown-linux-gnu/bin/ -B/gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-glibc-
2.28-5.5.0/x86_64-unknown-linux-gnu/lib/ -isystem
/gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-glibc-2.28-5.5.0/x86_64-unknown-
linux-gnu/include -isystem /gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-
glibc-2.28-5.5.0/x86_64-unknown-linux-gnu/sys-include -DHAVE_CONFIG_H -I.
-I../../../gcc-5.5.0/libquadmath -I ../../../gcc-5.5.0/libquadmath/../include -g
-O2 -MT math/hypotq.lo -MD -MP -MF math/.deps/hypotq.Tpo -c ../../../gcc-
5.5.0/libquadmath/math/hypotq.c -fPIC -DPIC -o math/.libs/hypotq.o
xgcc: error trying to exec 'cc1': execvp: No such file or directory
xgcc: error trying to exec 'cc1': execvp: xgccNo such file or directory: error
trying to exec '
cc1': execvp: No such file or directory
xgcc: error trying to exec 'cc1': execvp: No such file or directory
libtool: compile: /tmp/guix-build-gcc-glibc-2.28-5.5.0.drv-0/build/./gcc/xgcc
-B/tmp/guix-build-gcc-glibc-2.28-5.5.0.drv-0/build/./gcc/
-B/gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-glibc-2.28-5.5.0/x86_64-
unknown-linux-gnu/bin/ -B/gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-glibc-
2.28-5.5.0/x86_64-unknown-linux-gnu/lib/ -isystem
/gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-glibc-2.28-5.5.0/x86_64-unknown-
linux-gnu/include -isystem /gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-
glibc-2.28-5.5.0/x86_64-unknown-linux-gnu/sys-include -DHAVE_CONFIG_H -I.
-I../../../gcc-5.5.0/libquadmath -I ../../../gcc-5.5.0/libquadmath/../include -g
-O2 -MT math/signbitq.lo -MD -MP -MF math/.deps/signbitq.Tpo -c ../../../gcc-
5.5.0/libquadmath/math/signbitq.c -fPIC -DPIC -o math/.libs/signbitq.o
xgcc: error trying to exec 'cc1': execvp: No such file or directory
xgcc: error trying to exec 'cc1': execvp: No such file or directory
libtool: compile: /tmp/guix-build-gcc-glibc-2.28-5.5.0.drv-0/build/./gcc/xgcc
-B/tmp/guix-build-gcc-glibc-2.28-5.5.0.drv-0/build/./gcc/
-B/gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-glibc-2.28-5.5.0/x86_64-
unknown-linux-gnu/bin/ -B/gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-glibc-
2.28-5.5.0/x86_64-unknown-linux-gnu/lib/ -isystem
/gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-glibc-2.28-5.5.0/x86_64-unknown-
linux-gnu/include -isystem /gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-
glibc-2.28-5.5.0/x86_64-unknown-linux-gnu/sys-include -DHAVE_CONFIG_H -I.
-I../../../gcc-5.5.0/libquadmath -I ../../../gcc-5.5.0/libquadmath/../include -g
-O2 -MT math/scalblnq.lo -MD -MP -MF math/.deps/scalblnq.Tpo -c ../../../gcc-
5.5.0/libquadmath/math/scalblnq.c -fPIC -DPIC -o math/.libs/scalblnq.o
xgcc: error trying to exec 'cc1': execvp: No such file or directory
xgcc: error trying to exec 'cc1': execvp: No such file or directory
libtool: compile: /tmp/guix-build-gcc-glibc-2.28-5.5.0.drv-0/build/./gcc/xgcc
-B/tmp/guix-build-gcc-glibc-2.28-5.5.0.drv-0/build/./gcc/
-B/gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-glibc-2.28-5.5.0/x86_64-
unknown-linux-gnu/bin/ -B/gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-glibc-
2.28-5.5.0/x86_64-unknown-linux-gnu/lib/ -isystem
/gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-glibc-2.28-5.5.0/x86_64-unknown-
linux-gnu/include -isystem /gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-
glibc-2.28-5.5.0/x86_64-unknown-linux-gnu/sys-include -DHAVE_CONFIG_H -I.
-I../../../gcc-5.5.0/libquadmath -I ../../../gcc-5.5.0/libquadmath/../include -g
-O2 -MT math/ceilq.lo -MD -MP -MF math/.deps/ceilq.Tpo -c ../../../gcc-
5.5.0/libquadmath/math/ceilq.c -fPIC -DPIC -o math/.libs/ceilq.o
xgcc: error trying to exec 'cc1': execvp: No such file or directory
libtool: compile: /tmp/guix-build-gcc-glibc-2.28-5.5.0.drv-0/build/./gcc/xgcc
-B/tmp/guix-build-gcc-glibc-2.28-5.5.0.drv-0/build/./gcc/
-B/gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-glibc-2.28-5.5.0/x86_64-
unknown-linux-gnu/bin/ -B/gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-glibc-
2.28-5.5.0/x86_64-unknown-linux-gnu/lib/ -isystem
/gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-glibc-2.28-5.5.0/x86_64-unknown-
linux-gnu/include -isystem /gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-
glibc-2.28-5.5.0/x86_64-unknown-linux-gnu/sys-include -DHAVE_CONFIG_H -I.
-I../../../gcc-5.5.0/libquadmath -I ../../../gcc-5.5.0/libquadmath/../include -g
-O2 -MT math/asinq.lo -MD -MP -MF math/.deps/asinq.Tpo -c ../../../gcc-
5.5.0/libquadmath/math/asinq.c -fPIC -DPIC -o math/.libs/asinq.o
xgcc: error trying to exec 'xgcccc1: error trying to exec 'cc1': ':
execvpexecvp: : No such file or directory
No such file or directory
xgcc: error trying to exec 'cc1': execvp: No such file or directory
xgcclibtool: compile: /tmp/guix-build-gcc-glibc-2.28-5.5.0.drv-
0/build/./gcc/xgcc -B/tmp/guix-build-gcc-glibc-2.28-5.5.0.drv-0/build/./gcc/
-B/gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-glibc-2.28-5.5.0/x86_64-
unknown-linux-gnu/bin/ -B/gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-glibc-
2.28-5.5.0/x86_64-unknown-linux-gnu/lib/ -isystem
/gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-glibc-2.28-5.5.0/x86_64-unknown-
linux-gnu/include -isystem /gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-
glibc-2.28-5.5.0/x86_64-unknown-linux-gnu/sys-include -DHAVE_CONFIG_H -I.
-I../../../gcc-5.5.0/libquadmath -I ../../../gcc-5.5.0/libquadmath/../include -g
-O2 -MT math/roundq.lo -MD -MP -MF math/.deps/roundq.Tpo -c ../../../gcc-
5.5.0/libquadmath/math/roundq.c -fPIC -DPIC -o math/.libs/roundq.o
: error trying to exec 'cc1': execvp: No such file or directory
xgcc: error trying to exec 'cc1': execvp: No such file or directory
make[3]: *** [Makefile:1008: math/isnanq.lo] Error 1
make[3]: *** [Makefile:1008: math/x2y2m1q.lo] Error 1
xgcc: error trying to exec 'cc1': execvp: No such file or directory
make[3]: *** [Makefile:1008: math/atanq.lo] Error 1
make[3]: *** [Makefile:1008: math/rem_pio2q.lo] Error 1
make[3]: *** [Makefile:1008: math/cbrtq.lo] Error 1
xgcc: error trying to exec 'cc1': execvp: No such file or directory
make[3]: *** [Makefile:1008: math/isinfq.lo] Error 1
make[3]: *** [Makefile:1008: math/fmodq.lo] Error 1
make[3]: *** [Makefile:1008: math/atanhq.lo] Error 1
make[3]: *** [Makefile:1008: math/rintq.lo] Error 1
xgcc: error trying to exec 'cc1': execvp: No such file or directory
xgcc: error trying to exec 'cc1': execvp: No such file or directory
libtool: compile: /tmp/guix-build-gcc-glibc-2.28-5.5.0.drv-0/build/./gcc/xgcc
-B/tmp/guix-build-gcc-glibc-2.28-5.5.0.drv-0/build/./gcc/
-B/gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-glibc-2.28-5.5.0/x86_64-
unknown-linux-gnu/bin/ -B/gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-glibc-
2.28-5.5.0/x86_64-unknown-linux-gnu/lib/ -isystem
/gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-glibc-2.28-5.5.0/x86_64-unknown-
linux-gnu/include -isystem /gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-
glibc-2.28-5.5.0/x86_64-unknown-linux-gnu/sys-include -DHAVE_CONFIG_H -I.
-I../../../gcc-5.5.0/libquadmath -I ../../../gcc-5.5.0/libquadmath/../include -g
-O2 -MT math/j1q.lo -MD -MP -MF math/.deps/j1q.Tpo -c ../../../gcc-
5.5.0/libquadmath/math/j1q.c -fPIC -DPIC -o math/.libs/j1q.o
make[3]: *** [Makefile:1008: math/asinhq.lo] Error 1
make[3]: *** [Makefile:1008: math/atan2q.lo] Error 1
make[3]: *** [Makefile:1008: math/j0q.lo] Error 1
make[3]: *** [Makefile:1008: math/scalbnq.lo] Error 1
make[3]: *** [Makefile:1008: math/remainderq.lo] Error 1
make[3]: *** [Makefile:1008: math/acoshq.lo] Error 1
make[3]: *** [Makefile:1008: math/frexpq.lo] Error 1
make[3]: *** [Makefile:1008: math/signbitq.lo] Error 1
xgcc: error trying to exec 'cc1': execvp: No such file or directory
xgcc: error trying to exec 'cc1': execvp: No such file or directory
make[3]: *** [Makefile:1008: math/scalblnq.lo] Error 1
make[3]: *** [Makefile:1008: math/ceilq.lo] Error 1
xgcc: error trying to exec 'cc1': execvp: No such file or directory
make[3]: *** [Makefile:1008: math/asinq.lo] Error 1
xgcc: error trying to exec 'cc1': execvp: No such file or directory
make[3]: *** [Makefile:1008: math/hypotq.lo] Error 1
make[3]: *** [Makefile:1008: math/roundq.lo] Error 1
make[3]: *** [Makefile:1008: math/j1q.lo] Error 1
make[3]: Leaving directory '/tmp/guix-build-gcc-glibc-2.28-5.5.0.drv-
0/build/x86_64-unknown-linux-gnu/libquadmath'
make[2]: *** [Makefile:425: all] Error 2
make[2]: Leaving directory '/tmp/guix-build-gcc-glibc-2.28-5.5.0.drv-
0/build/x86_64-unknown-linux-gnu/libquadmath'
make[1]: *** [Makefile:16545: all-target-libquadmath] Error 2
libtool: compile: /tmp/guix-build-gcc-glibc-2.28-5.5.0.drv-0/build/./gcc/xgcc
-B/tmp/guix-build-gcc-glibc-2.28-5.5.0.drv-0/build/./gcc/
-B/gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-glibc-2.28-5.5.0/x86_64-
unknown-linux-gnu/bin/ -B/gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-glibc-
2.28-5.5.0/x86_64-unknown-linux-gnu/lib/ -isystem
/gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-glibc-2.28-5.5.0/x86_64-unknown-
linux-gnu/include -isystem /gnu/store/kfmbkjadms4x1qaxfrdf4lxqkql2hmfr-gcc-
glibc-2.28-5.5.0/x86_64-unknown-linux-gnu/sys-include "-DPACKAGE_NAME=\"Cilk
Runtime Library\"" -DPACKAGE_TARNAME=\"cilk-runtime-library\"
-DPACKAGE_VERSION=\"2.0\" "-DPACKAGE_STRING=\"Cilk Runtime Library 2.0\""
-DPACKAGE_BUGREPORT=\"cilk@intel.com\" -DPACKAGE_URL=\"\" -DPACKAGE=\"cilk-
runtime-library\" -DVERSION=\"2.0\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1
-DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1
-DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1
-DHAVE_ALLOCA_H=1 -DHAVE_ALLOCA=1 -DHAVE_ATTRIBUTE_VISIBILITY=1 -DHAVE_DLFCN_H=1
-DLT_OBJDIR=\".libs/\" -DHAVE_PTHREAD_AFFINITY_NP=1 -I. -I../../../gcc-
5.5.0/libcilkrts -I../../../gcc-5.5.0/libcilkrts/include -I../../../gcc-
5.5.0/libcilkrts/runtime -I../../../gcc-5.5.0/libcilkrts/runtime/config/x86
-DIN_CILK_RUNTIME=1 -fcilkplus -pthread -funwind-tables -I../../../gcc-
5.5.0/libcilkrts/include -I../../../gcc-5.5.0/libcilkrts/runtime -I../../../gcc-
5.5.0/libcilkrts/runtime/config/x86 -DIN_CILK_RUNTIME=1 -fcilkplus -funwind-
tables -std=c99 -g -O2 -MT symbol_test.lo -MD -MP -MF .deps/symbol_test.Tpo -c
../../../gcc-5.5.0/libcilkrts/runtime/symbol_test.c -fPIC -DPIC -o
.libs/symbol_test.o
xgcc: error trying to exec 'cc1': execvp: No such file or directory
make[2]: *** [Makefile:736: symbol_test.lo] Error 1
make[2]: Leaving directory '/tmp/guix-build-gcc-glibc-2.28-5.5.0.drv-
0/build/x86_64-unknown-linux-gnu/libcilkrts'
make[1]: *** [Makefile:14592: all-target-libcilkrts] Error 2
config.status: creating sanitizer_common/Makefile
config.status: creating libbacktrace/Makefile
config.status: creating lsan/Makefile
config.status: creating asan/Makefile
config.status: creating Makefile
config.status: creating ubsan/Makefile
config.status: creating testsuite/Makefile
config.status: creating auto-config.h
config.status: executing default-1 commands
echo | /tmp/guix-build-gcc-glibc-2.28-5.5.0.drv-0/build/./gcc/xgcc -B/tmp/guix-
build-gcc-glibc-2.28-5.5.0.drv-0/build/./gcc/ -E -dM - | \
sed -n -e 's/^#define \([^_][a-zA-Z0-9_]*\).*/\1/p' \
-e 's/^#define \(_[^_A-Z][a-zA-Z0-9_]*\).*/\1/p' | \
sort -u > tmp-macro_list
/gnu/store/29jhbbg1hf557x8j53f9sxd9imlmf02a-bash-minimal-5.0.7/bin/bash
../../gcc-5.5.0/gcc/../move-if-change tmp-macro_list macro_list
config.status: creating tsan/Makefile
echo timestamp > s-macro_list
config.status: executing depfiles commands
make[2]: warning: Clock skew detected. Your build may be incomplete.
make[2]: Leaving directory '/tmp/guix-build-gcc-glibc-2.28-5.5.0.drv-
0/build/gcc'
config.status: executing libtool commands
config.status: creating config.h
config.status: executing gstdint.h commands
config.status: executing default-1 commands
config.status: executing depfiles commands
config.status: executing libtool commands
config.status: executing gstdint.h commands
make[1]: Leaving directory '/tmp/guix-build-gcc-glibc-2.28-5.5.0.drv-0/build'
make: *** [Makefile:905: all] Error 2
command "make" "-j" "32" "LDFLAGS_FOR_TARGET=-
B/gnu/store/wzfdcfmp6ax2agl43bw2pnpjsnxn1v2p-glibc-2.28/lib -Wl,-dynamic-linker
-Wl,/gnu/store/wzfdcfmp6ax2agl43bw2pnpjsnxn1v2p-glibc-2.28/lib/ld-linux-x86-
64.so.2" "LDFLAGS=-Wl,-rpath=/gnu/store/wzfdcfmp6ax2agl43bw2pnpjsnxn1v2p-glibc-
2.28/lib -Wl,-dynamic-linker -Wl,/gnu/store/wzfdcfmp6ax2agl43bw2pnpjsnxn1v2p-
glibc-2.28/lib/ld-linux-x86-64.so.2" "BOOT_CFLAGS=-O2 -g0" failed with status 2
--------------

Kind regards,
Roel Janssen
Z
Z
zimoun wrote on 18 Oct 2022 17:41
(name . Roel Janssen)(address . roel@gnu.org)(address . 40237@debbugs.gnu.org)
86bkq9ywa0.fsf@gmail.com
Hi Roel,

It is about this old bug#40237 [1]


On Thu, 26 Mar 2020 at 11:29, Roel Janssen <roel@gnu.org> wrote:

Toggle quote (10 lines)
> I am trying to build a package with glibc-2.28. So my native-inputs looks like
> this:
> --------------
> (native-inputs
> `(("gcc-toolchain" ,(make-gcc-toolchain gcc-5 glibc-2.28))))
> --------------
>
>
> When building this custom gcc-toolchain, it fails with:

Is it still the case? Well, could you provide more information about
your use case?


Cheers,
simon
R
R
Roel Janssen wrote on 18 Oct 2022 21:21
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 40237@debbugs.gnu.org)
2dd624795ede85ee06a31c3a999020880ce85329.camel@gnu.org
Hi Simon,

On Tue, 2022-10-18 at 17:41 +0200, zimoun wrote:
Toggle quote (22 lines)
> Hi Roel,
>
> It is about this old bug#40237 [1]
>
> 1: <http://issues.guix.gnu.org/issue/40237>
>
> On Thu, 26 Mar 2020 at 11:29, Roel Janssen <roel@gnu.org> wrote:
>
> > I am trying to build a package with glibc-2.28.  So my native-inputs looks like
> > this:
> > --------------
> > (native-inputs
> >      `(("gcc-toolchain" ,(make-gcc-toolchain gcc-5 glibc-2.28))))
> > --------------
> >
> >
> > When building this custom gcc-toolchain, it fails with:
>
> Is it still the case?  Well, could you provide more information about
> your use case?
>

Actually, I don't have any more information, and most probably I messed up myself.
I suppose we can just close this. If there's anything actually wrong it'll pop up
another bug report. Shall I close this bug report, or would you like to keep it open?

Thanks for looking into this old bug report!


Kind regards,
Roel Janssen
Z
Z
zimoun wrote on 19 Oct 2022 10:35
(name . Roel Janssen)(address . roel@gnu.org)(address . 40237-done@debbugs.gnu.org)
867d0wxlb7.fsf@gmail.com
Hi Roel,

On Tue, 18 Oct 2022 at 21:21, Roel Janssen <roel@gnu.org> wrote:

Toggle quote (10 lines)
>> > When building this custom gcc-toolchain, it fails with:
>>
>> Is it still the case?  Well, could you provide more information about
>> your use case?
>>
>
> Actually, I don't have any more information, and most probably I messed up myself.
> I suppose we can just close this. If there's anything actually wrong it'll pop up
> another bug report. Shall I close this bug report, or would you like to keep it open?

I am in favor to close it. As you said, if there is anything wrong, the
bug will pop again elsewhere. So closing. :-)

Thank you for your answer.


Cheers,
simon
Closed
?