(address . guix-patches@gnu.org)(name . h.nasajpour)(address . h.nasajpour@pantherx.org)
* gnu/packages/python-xyz.scm (python-persist-queue): New variable
---
gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)
Toggle diff (28 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 298a59f59f..e47e5bbcd2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15537,3 +15537,21 @@ by Igor Pavlov.")
gradual typing, generics and union types.")
(license license:expat)))
+
+(define-public python-persist-queue
+ (package
+ (name "python-persist-queue")
+ (version "0.4.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "persist-queue" version))
+ (sha256 (base32 "0xhvj26jkc4fk0yjzn47is6wh8figyp5cralj8d56r4bidn78wp2"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f))
+ (home-page "https://github.com/peter-wangxu/persist-queue")
+ (synopsis "A thread-safe disk based persistent queue in Python.")
+ (description
+ "persist-queue implements a file-based queue and a serial of sqlite3-based queues")
+ (license license:bsd-2)))
+
--
2.17.1