[PATCH 44/47] gnu: Add python-persist-queue.

  • Done
  • quality assurance status badge
Details
4 participants
  • Brett Gilio
  • h.nasajpour
  • Maxim Cournoyer
  • zimoun
Owner
unassigned
Submitted by
h.nasajpour
Severity
normal
H
H
h.nasajpour wrote on 29 May 2019 02:36
(address . guix-patches@gnu.org)(name . h.nasajpour)(address . h.nasajpour@pantherx.org)
20190529003607.3264-1-h.nasajpour@pantherx.org
* gnu/packages/python-xyz.scm (python-persist-queue): New variable
---
gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (28 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 298a59f59f..e47e5bbcd2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15537,3 +15537,21 @@ by Igor Pavlov.")
gradual typing, generics and union types.")
(license license:expat)))
+
+(define-public python-persist-queue
+ (package
+ (name "python-persist-queue")
+ (version "0.4.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "persist-queue" version))
+ (sha256 (base32 "0xhvj26jkc4fk0yjzn47is6wh8figyp5cralj8d56r4bidn78wp2"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f))
+ (home-page "https://github.com/peter-wangxu/persist-queue")
+ (synopsis "A thread-safe disk based persistent queue in Python.")
+ (description
+ "persist-queue implements a file-based queue and a serial of sqlite3-based queues")
+ (license license:bsd-2)))
+
--
2.17.1
B
B
Brett Gilio wrote on 10 Dec 2019 07:43
(name . h.nasajpour)(address . h.nasajpour@pantherx.org)(address . 35976@debbugs.gnu.org)
87o8wgk7dn.fsf@posteo.net
"h.nasajpour" <h.nasajpour@pantherx.org> writes:

Toggle quote (32 lines)
> * gnu/packages/python-xyz.scm (python-persist-queue): New variable
> ---
> gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
> 1 file changed, 18 insertions(+)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 298a59f59f..e47e5bbcd2 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -15537,3 +15537,21 @@ by Igor Pavlov.")
> gradual typing, generics and union types.")
> (license license:expat)))
>
> +
> +(define-public python-persist-queue
> + (package
> + (name "python-persist-queue")
> + (version "0.4.2")
> + (source (origin
> + (method url-fetch)
> + (uri (pypi-uri "persist-queue" version))
> + (sha256 (base32 "0xhvj26jkc4fk0yjzn47is6wh8figyp5cralj8d56r4bidn78wp2"))))
> + (build-system python-build-system)
> + (arguments
> + `(#:tests? #f))
> + (home-page "https://github.com/peter-wangxu/persist-queue")
> + (synopsis "A thread-safe disk based persistent queue in Python.")
> + (description
> + "persist-queue implements a file-based queue and a serial of sqlite3-based queues")
> + (license license:bsd-2)))
> +

Hi,

This package needs the same treatment as some of the other packages I
have mentioned from your series. If you could do those things we can get
it pushed to master! Thanks.

--
Brett M. Gilio
Homepage -- https://scm.pw/
M
M
Maxim Cournoyer wrote on 8 Oct 2022 06:40
control message for bug #35976
(address . control@debbugs.gnu.org)
87wn9b0vyh.fsf@gmail.com
tags 35976 + moreinfo
quit
M
M
Maxim Cournoyer wrote on 8 Oct 2022 06:41
Re: bug#35976: [PATCH 44/47] gnu: Add python-persist-queue.
(name . Brett Gilio)(address . brettg@posteo.net)
87sfjz0vx6.fsf_-_@gmail.com
Hi,

Brett Gilio <brettg@posteo.net> writes:

Toggle quote (40 lines)
> "h.nasajpour" <h.nasajpour@pantherx.org> writes:
>
>> * gnu/packages/python-xyz.scm (python-persist-queue): New variable
>> ---
>> gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
>> 1 file changed, 18 insertions(+)
>>
>> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
>> index 298a59f59f..e47e5bbcd2 100644
>> --- a/gnu/packages/python-xyz.scm
>> +++ b/gnu/packages/python-xyz.scm
>> @@ -15537,3 +15537,21 @@ by Igor Pavlov.")
>> gradual typing, generics and union types.")
>> (license license:expat)))
>>
>> +
>> +(define-public python-persist-queue
>> + (package
>> + (name "python-persist-queue")
>> + (version "0.4.2")
>> + (source (origin
>> + (method url-fetch)
>> + (uri (pypi-uri "persist-queue" version))
>> + (sha256 (base32 "0xhvj26jkc4fk0yjzn47is6wh8figyp5cralj8d56r4bidn78wp2"))))
>> + (build-system python-build-system)
>> + (arguments
>> + `(#:tests? #f))
>> + (home-page "https://github.com/peter-wangxu/persist-queue")
>> + (synopsis "A thread-safe disk based persistent queue in Python.")
>> + (description
>> + "persist-queue implements a file-based queue and a serial of sqlite3-based queues")
>> + (license license:bsd-2)))
>> +
>
> Hi,
>
> This package needs the same treatment as some of the other packages I
> have mentioned from your series. If you could do those things we can get
> it pushed to master! Thanks.

It's been nearly 3 years :-) Are these package Python still useful, or
should we close the tickets awaiting feedback?

--
Thanks,
Maxim
Z
Z
zimoun wrote on 3 Nov 2022 10:45
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
86wn8cbcbx.fsf_-_@gmail.com
Hi,

It is about this old bug#35976 [1].



On Sat, 08 Oct 2022 at 00:41, Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:

Toggle quote (3 lines)
> It's been nearly 3 years :-) Are these package Python still useful, or
> should we close the tickets awaiting feedback?

Without more feedback, I will close it soon.


Cheers,
simon
S
S
Simon Tournier wrote on 17 Oct 2023 00:49
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
86pm1ep4ha.fsf_-_@gmail.com
Hi,

On Thu, 03 Nov 2022 at 10:45, zimoun <zimon.toutoune@gmail.com> wrote:

Toggle quote (12 lines)
> It is about this old bug#35976 [1].
>
> 1: <http://issues.guix.gnu.org/issue/35976>
>
>
> On Sat, 08 Oct 2022 at 00:41, Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
>
>> It's been nearly 3 years :-) Are these package Python still useful, or
>> should we close the tickets awaiting feedback?
>
> Without more feedback, I will close it soon.

Well, soon is 49 weeks and 4 days later. :-)

Closing. Feel free to reopen if I am missing something.

Cheers,
simon
Closed
?