(address . bug-guix@gnu.org)
I'm searching for a good solution to analyze some logs. Geo::IP
is good enough. Now the problem is this:
user@abyayala /gnu/store/5mhrli41qbcpns3gg0yf1vv07lvpg8hm-perl-geo-ip-1.51$ egrep -nr "/usr/" lib/perl5/site_perl/5.26.0/
lib/perl5/site_perl/5.26.0/Geo/IP/Record.pod:9: my $gi = Geo::IP->open("/usr/local/share/GeoIP/GeoIPCity.dat", GEOIP_STANDARD);
lib/perl5/site_perl/5.26.0/Geo/IP.pm:5075:# default path /usr/local/share/GeoIP
lib/perl5/site_perl/5.26.0/Geo/IP.pm:5159: my $def_db_file = '/usr/local/share/GeoIP/GeoIP.dat';
lib/perl5/site_perl/5.26.0/Geo/IP.pm:5962: my $gi = Geo::IP->open("/usr/local/share/GeoIP/GeoIPCity.dat", GEOIP_STANDARD);
lib/perl5/site_perl/5.26.0/Geo/IP.pm:5984: my $g = Geo::IP->open('/usr/local/share/GeoIP/GeoIPv6.dat') or die;
lib/perl5/site_perl/5.26.0/Geo/IP.pm:6046:I<datadir>, typically I</usr/local/share/GeoIP/GeoIP.dat>.
lib/perl5/site_perl/5.26.0/Geo/IP.pm:6078:typically I</usr/local/share/GeoIP/GeoIPCity.dat>.
lib/perl5/site_perl/5.26.0/Geo/IP.pm:6226: my $g = Geo::IP->open('/usr/local/share/GeoIP/GeoIPv6.dat') or die;
However this is not really a problem unless you are on GuixSD.
As we do not package the DB of MaxDB (yet) you'll need for this, it's
not a problem. I'm filing this bug to remind myself to fix Geo::IP once
I have revisited the discussion we had about the DB a while back.
--
GnuPG: A88C8ADD129828D7EAC02E52E22F9BBFEE348588
WWW: https://n0.is
-----BEGIN PGP SIGNATURE-----
iQIzBAABCgAdFiEEqIyK3RKYKNfqwC5S4i+bv+40hYgFAlodg8YACgkQ4i+bv+40
hYheDhAAgQp9/HehCakE17tcaRvZ69HN4zMmhckJqaTCK9sgGUqBEYrIJwG7KpiF
SLoPvHJGPIq8cYyR8x96yKm9algA8nJwNZ6ySjjjHwolhcMHZA9F5L5sdynP61Dk
IaLq44UZuVz+vW19ErQ/zwCygnJo/WNxDw3KAIMg8UGkcPQiIAYdaJN5Z80qvmtN
/OvunmHFiDnT/G6wixJumlK7o2Ucgc0dhfEAcTKT/H8zGbGYNVpNjkvALNoiuswy
dphx3zajIgNFkgSxFta778Q5jKDPliJuKA+Muu418UxDDeSPdxgtZV1RotTnBca1
cZ53haY5h1yF9k+93wadk/i4pTzAESWP5efmQhy9lwBt6cEwlLJHP7diCTydzV36
ZN3IST0DebUWTOe2t39p6EOfvVMhxDmq/7SZQVDNXdPS6dFPEp4PWfNCpg8msiNV
M2Z+5Ony5UYz6e6Hhid21SOPFXAcD8JDor9iQg6TD/JmsQf634k7/6xVvfHTkWva
OZECpMGPxu61DwGpLoXfplF7Njuy8xKtfOcAG0XbM5bqBhjK6OXidnbn/iZBz/na
2vc+hOzqjotbAT+WPLNT6qXkuikRH7eSFWjUNmvmk957j9airnd+nsARa8WBEg7i
FGms5XL2H7Kro2SiPgHiWA7GjOSotrxNVD6BRJy0Ca6Ap0kvh4Q=
=kh57
-----END PGP SIGNATURE-----