(address . guix-patches@gnu.org)
* gnu/packages/guile.scm
used substitute* to correct some hardcoded paths in the artanis package
---
gnu/packages/guile.scm | 12 +++++++++++-
1 file changed, 11 insertions(+), 1 deletion(-)
Toggle diff (40 lines)
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index abcefd32e..b7c2dd4c7 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017 Theodoros Foradis <theodoros@foradis.org>
;;; Copyright © 2017 ng0 <ng0@infotropique.org>
+;;; Copyright © 2017 Kristofer Buffington <kristoferbuffington@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -431,7 +432,8 @@ program can be installed in one go.")
post)))
(substitute* "artanis/artanis.scm"
(("[[:punct:][:space:]]+->json-string[[:punct:][:space:]]+")
- ""))))))
+ ""))
+ ))))
(build-system gnu-build-system)
;; TODO: Add guile-dbi and guile-dbd optional dependencies.
(inputs `(("guile" ,guile-2.2)
@@ -458,6 +460,14 @@ program can be installed in one go.")
((" /etc/bash.bashrc") " /dev/null"))
(substitute* "Makefile" ;set the root of config files to OUT
((" /etc") (string-append " " out "/etc")))
+ (substitute* "artanis/config.scm"
+ (("/etc/artanis/artanis.conf")
+ (string-append out "/etc/artanis.conf"))
+ (("/etc/artanis/pages")
+ (string-append out "/etc/artanis")))
+ (substitute* "etc/artanis/artanis.conf"
+ (("/etc/artanis/pages")
+ (string-append out "/etc/artanis")))
(mkdir-p (string-append out "/bin")) ;for the `art' executable
#t)))
(add-after 'install 'wrap-art
--
2.15.0
Message-ID: <877euscq0y.fsf@gmail.com>