Unable to abort 'make' with Ctrl-C while building .go files

  • Done
  • quality assurance status badge
Details
2 participants
  • Mark H Weaver
  • zimoun
Owner
unassigned
Submitted by
Mark H Weaver
Severity
normal
M
M
Mark H Weaver wrote on 18 Sep 2017 07:38
(address . bug-guix@gnu.org)
87shfkk1lr.fsf@netris.org
It used to be that I could Ctrl-C to abort 'make'. Now I find that it
only aborts compiling one file and then moves on to the next. Here's a
partial transcript within shell mode in Emacs.

Mark

Toggle snippet (39 lines)
GUILEC gnu/services/lirc.go
GUILEC gnu/services/virtualization.go
GUILEC gnu/services/mail.go
C-c C-c GUILEC gnu/services/mcron.go
GUILEC gnu/services/messaging.go
C-c C-c GUILEC gnu/services/networking.go
C-c C-c GUILEC gnu/services/nfs.go
C-c C-c GUILEC gnu/services/shepherd.go
C-c C-c GUILEC gnu/services/herd.go
C-c C-c GUILEC gnu/services/pm.go
C-c C-c GUILEC gnu/services/sddm.go
C-c C-c GUILEC gnu/services/spice.go
C-c C-c GUILEC gnu/services/ssh.go
C-c C-c GUILEC gnu/services/sysctl.go
GUILEC gnu/services/version-control.go
C-c C-c GUILEC gnu/services/vpn.go
C-c C-c GUILEC gnu/services/web.go
C-c C-c GUILEC gnu/services/xorg.go
C-c C-c GUILEC gnu/system.go
C-c C-c GUILEC gnu/system/file-systems.go
C-c C-c GUILEC gnu/system/install.go
C-c C-c GUILEC gnu/system/linux-container.go
C-c C-c GUILEC gnu/system/linux-initrd.go
C-c C-c GUILEC gnu/system/locale.go
C-c C-c GUILEC gnu/system/mapped-devices.go
C-c C-c GUILEC gnu/system/nss.go
GUILEC gnu/system/pam.go
C-c C-z
[1]+ Stopped make
mhw@jojen ~/guix [env]$ kill %1

[1]+ Stopped make
mhw@jojen ~/guix [env]$ make[2]: *** [Makefile:5254: make-go] Terminated
make[1]: *** [Makefile:4385: all-recursive] Terminated
make: *** [Makefile:2975: all] Interrupt

[1]+ Interrupt make
mhw@jojen ~/guix [env]$
Z
Z
zimoun wrote on 23 Dec 2020 19:17
(name . Mark H Weaver)(address . mhw@netris.org)(address . 28490@debbugs.gnu.org)
86pn30qtdz.fsf@gmail.com
Hi Mark

Digging in old bugs, I find bug#28490 about C-c to abort ’make’ when
compiling:


On Mon, 18 Sep 2017 at 01:38, Mark H Weaver <mhw@netris.org> wrote:
Toggle quote (45 lines)
> It used to be that I could Ctrl-C to abort 'make'. Now I find that it
> only aborts compiling one file and then moves on to the next. Here's a
> partial transcript within shell mode in Emacs.
>
> Mark
>
> GUILEC gnu/services/lirc.go
> GUILEC gnu/services/virtualization.go
> GUILEC gnu/services/mail.go
> C-c C-c GUILEC gnu/services/mcron.go
> GUILEC gnu/services/messaging.go
> C-c C-c GUILEC gnu/services/networking.go
> C-c C-c GUILEC gnu/services/nfs.go
> C-c C-c GUILEC gnu/services/shepherd.go
> C-c C-c GUILEC gnu/services/herd.go
> C-c C-c GUILEC gnu/services/pm.go
> C-c C-c GUILEC gnu/services/sddm.go
> C-c C-c GUILEC gnu/services/spice.go
> C-c C-c GUILEC gnu/services/ssh.go
> C-c C-c GUILEC gnu/services/sysctl.go
> GUILEC gnu/services/version-control.go
> C-c C-c GUILEC gnu/services/vpn.go
> C-c C-c GUILEC gnu/services/web.go
> C-c C-c GUILEC gnu/services/xorg.go
> C-c C-c GUILEC gnu/system.go
> C-c C-c GUILEC gnu/system/file-systems.go
> C-c C-c GUILEC gnu/system/install.go
> C-c C-c GUILEC gnu/system/linux-container.go
> C-c C-c GUILEC gnu/system/linux-initrd.go
> C-c C-c GUILEC gnu/system/locale.go
> C-c C-c GUILEC gnu/system/mapped-devices.go
> C-c C-c GUILEC gnu/system/nss.go
> GUILEC gnu/system/pam.go
> C-c C-z
> [1]+ Stopped make
> mhw@jojen ~/guix [env]$ kill %1
>
> [1]+ Stopped make
> mhw@jojen ~/guix [env]$ make[2]: *** [Makefile:5254: make-go] Terminated
> make[1]: *** [Makefile:4385: all-recursive] Terminated
> make: *** [Makefile:2975: all] Interrupt
>
> [1]+ Interrupt make
> mhw@jojen ~/guix [env]$

I am not able to reproduce, here a transcript within Emacs shell mode:

[ 50%] GUILEC guix/deprecation.go
[ 50%] GUILEC guix/docker.go
[ 50%] GUILEC guix/records.go
[ 51%] GUILEC guix/openpgp.go
C-c C-cerror: failed to load 'build-aux/compile-all.scm':
ice-9/eval.scm:293:34: Throw to key `quit' with args `(1)'.
make[2]: *** [Makefile:6257 : make-go] Erreur 1
make[1]: *** [Makefile:5305: all-recursive] Interrompre
make: *** [Makefile:3636: all] Interrompre


All the best,
simon
M
M
Mark H Weaver wrote on 23 Dec 2020 22:57
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 28490-done@debbugs.gnu.org)
87lfdoi3sg.fsf@netris.org
Hi Simon,

zimoun <zimon.toutoune@gmail.com> writes:

Toggle quote (11 lines)
> Digging in old bugs, I find bug#28490 about C-c to abort ’make’ when
> compiling:
>
> <http://issues.guix.gnu.org/issue/28490>
>
> On Mon, 18 Sep 2017 at 01:38, Mark H Weaver <mhw@netris.org> wrote:
>> It used to be that I could Ctrl-C to abort 'make'. Now I find that it
>> only aborts compiling one file and then moves on to the next. [...]
>
> I am not able to reproduce [...]

Indeed, looks like it's now fixed. I'm closing this bug.

Thank you!
Mark
Closed
?