(address . bug-guix@gnu.org)
guix [env]$ ./pre-inst-env guix import pypi flex
;;; note: source file /x/home/dannym/src/guix/gnu/packages/databases.scm
;;; newer than compiled /x/home/dannym/src/guix/gnu/packages/databases.go
Backtrace:
9 (primitive-load "/x/home/dannym/src/guix/scripts/guix")
In guix/ui.scm:
1264:8 8 (run-guix-command _ . _)
In guix/scripts/import.scm:
114:11 7 (guix-import . _)
In guix/scripts/import/pypi.scm:
84:19 6 (guix-import-pypi . _)
In guix/import/pypi.scm:
279:17 5 (pypi->guix-package _)
In ice-9/boot-9.scm:
837:9 4 (catch srfi-34 #<procedure 34cec00 at guix/import/json?> ?)
In guix/import/json.scm:
32:17 3 (_)
In guix/http-client.scm:
239:25 2 (http-fetch _ #:port _ #:text? _ #:buffered? _ # _ # _ # ?)
In guix/build/download.scm:
520:4 1 (open-connection-for-uri _ #:timeout _ # _)
417:6 0 (tls-wrap #<closed: file 1e2a9a0> _ # _)
guix/build/download.scm:417:6: In procedure tls-wrap:
guix/build/download.scm:417:6: X.509 certificate of 'pypi.python.org' could not be verified:
signer-not-found
invalid
Also, the most interesting information, which is which certificates it DID know and where it got them, is not printed.