`make && make check` fails

  • Done
  • quality assurance status badge
Details
4 participants
  • Andrew Tropin
  • Maxim Cournoyer
  • Rostislav Svoboda
  • zimoun
Owner
unassigned
Submitted by
Rostislav Svoboda
Severity
normal
R
R
Rostislav Svoboda wrote on 14 Nov 2021 15:50
(address . bug-guix@gnu.org)
CAEtmmewPXhJS97MUXM6s_EPYvG5F1AfNUu4KRHKVZ_ppbBEx+w@mail.gmail.com
Trying to compile guix (for the first time, ever!) I get:

FAIL: tests/home-import.scm
FAIL: tests/guix-home.sh

the log is attached.

Bost
Attachment: test-suite.log
Z
Z
zimoun wrote on 15 Nov 2021 17:01
(name . Rostislav Svoboda)(address . rostislav.svoboda@gmail.com)
85o86l1k8g.fsf@gmail.com
Hi,

On dim., 14 nov. 2021 at 15:50, Rostislav Svoboda <rostislav.svoboda@gmail.com> wrote:

Toggle quote (3 lines)
> FAIL: tests/home-import.scm
> FAIL: tests/guix-home.sh

I confirm the failures using Guix ce9b9e7cba.


Toggle snippet (14 lines)
;;; (fail (begin (use-modules (gnu home) (gnu packages) (gnu services) (guix gexp) (gnu home services shells)) (home-environment (packages (map specification->package (list))) (services (list (service home-bash-service-type (home-bash-configuration (aliases (quote ())) (bashrc (list (local-file "/tmp/guix-config/.bashrc" "bashrc"))))))))) #f)
test-name: manifest->code: Bash service
location: /home/sitour/src/guix/wk/remove-python2/tests/home-import.scm:181
source:
+ (test-assert
+ "manifest->code: Bash service"
+ (eval-test-with-home-environment
+ '((".bashrc" . "echo 'hello guix'"))
+ (make-manifest '())
+ match-home-environment-bash-service))
actual-value: #f
result: FAIL

Toggle snippet (34 lines)
+ set -e
+ guix home --version
guix show (GNU Guix) 1.3.0.8404-ce9b9
Copyright (C) 2021 the Guix authors
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
++ guile -c '(use-modules (guix config))(display %storedir)'
+ NIX_STORE_DIR=/gnu/store
++ guile -c '(use-modules (guix config))(display %localstatedir)'
+ localstatedir=/var
+ GUIX_DAEMON_SOCKET=/var/guix/daemon-socket/socket
+ export NIX_STORE_DIR GUIX_DAEMON_SOCKET
+ guile -c '(use-modules (guix)) (exit (false-if-exception (open-connection)))'
++ dirname /gnu/store
+ STORE_PARENT=/gnu
+ export STORE_PARENT
+ test /gnu = /
++ mktemp -d
+ test_directory=/tmp/tmp.ScA50H2Z6n
+ trap 'chmod -Rf +w "$test_directory"; rm -rf "$test_directory"' EXIT
+ cd /tmp/tmp.ScA50H2Z6n
+ HOME=/tmp/tmp.ScA50H2Z6n
+ export HOME
+ printf '# dot-bashrc test file for guix home'
+ cat
+ guix home reconfigure /tmp/tmp.ScA50H2Z6n/home.scm
guix home: error: reference to invalid output 'out' of derivation '/gnu/store/a6cwlz5yibi7w3pfm60j26inf434ard2-on-first-login.drv'
+ chmod -Rf +w /tmp/tmp.ScA50H2Z6n
+ rm -rf /tmp/tmp.ScA50H2Z6n
FAIL tests/guix-home.sh (exit status: 1)


Cheers,
simon
A
A
Andrew Tropin wrote on 22 Nov 2021 11:13
87ee78sdki.fsf@trop.in
On 2021-11-15 17:01, zimoun wrote:

Toggle quote (24 lines)
> Hi,
>
> On dim., 14 nov. 2021 at 15:50, Rostislav Svoboda <rostislav.svoboda@gmail.com> wrote:
>
>> FAIL: tests/home-import.scm
>> FAIL: tests/guix-home.sh
>
> I confirm the failures using Guix ce9b9e7cba.
>
>
> --8<---------------cut here---------------start------------->8---
> ;;; (fail (begin (use-modules (gnu home) (gnu packages) (gnu services) (guix gexp) (gnu home services shells)) (home-environment (packages (map specification->package (list))) (services (list (service home-bash-service-type (home-bash-configuration (aliases (quote ())) (bashrc (list (local-file "/tmp/guix-config/.bashrc" "bashrc"))))))))) #f)
> test-name: manifest->code: Bash service
> location: /home/sitour/src/guix/wk/remove-python2/tests/home-import.scm:181
> source:
> + (test-assert
> + "manifest->code: Bash service"
> + (eval-test-with-home-environment
> + '((".bashrc" . "echo 'hello guix'"))
> + (make-manifest '())
> + match-home-environment-bash-service))
> actual-value: #f
> result: FAIL
> --8<---------------cut here---------------end--------------->8---
Toggle quote (30 lines)
>
> --8<---------------cut here---------------start------------->8---
> + set -e
> + guix home --version
> guix show (GNU Guix) 1.3.0.8404-ce9b9
> Copyright (C) 2021 the Guix authors
> License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
> This is free software: you are free to change and redistribute it.
> There is NO WARRANTY, to the extent permitted by law.
> ++ guile -c '(use-modules (guix config))(display %storedir)'
> + NIX_STORE_DIR=/gnu/store
> ++ guile -c '(use-modules (guix config))(display %localstatedir)'
> + localstatedir=/var
> + GUIX_DAEMON_SOCKET=/var/guix/daemon-socket/socket
> + export NIX_STORE_DIR GUIX_DAEMON_SOCKET
> + guile -c '(use-modules (guix)) (exit (false-if-exception (open-connection)))'
> ++ dirname /gnu/store
> + STORE_PARENT=/gnu
> + export STORE_PARENT
> + test /gnu = /
> ++ mktemp -d
> + test_directory=/tmp/tmp.ScA50H2Z6n
> + trap 'chmod -Rf +w "$test_directory"; rm -rf "$test_directory"' EXIT
> + cd /tmp/tmp.ScA50H2Z6n
> + HOME=/tmp/tmp.ScA50H2Z6n
> + export HOME
> + printf '# dot-bashrc test file for guix home'
> + cat
> + guix home reconfigure /tmp/tmp.ScA50H2Z6n/home.scm
> guix home: error: reference to invalid output 'out' of derivation '/gnu/store/a6cwlz5yibi7w3pfm60j26inf434ard2-on-first-login.drv'
This one was fixed in e5d8302b2ce596a0518ea5bd79b338f68a3246eb.
Toggle quote (9 lines)
> + chmod -Rf +w /tmp/tmp.ScA50H2Z6n
> + rm -rf /tmp/tmp.ScA50H2Z6n
> FAIL tests/guix-home.sh (exit status: 1)
> --8<---------------cut here---------------end--------------->8---
>
>
> Cheers,
> simon

--
Best regards,
Andrew Tropin
-----BEGIN PGP SIGNATURE-----

iQJDBAEBCgAtFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmGbbU0PHGFuZHJld0B0
cm9wLmluAAoJECII0glYwd6wfQ8P/1J1ciH+iQUYtHzEWy4eTek7u9k26xmN59Sm
U+1YhpkirHbXUPB64nN+JxiwsvhgSpwWMKdbgBGv7edI4DLy4/+VyOUpXB3s4vP5
sf2LScs6I+wEwDLMIGm71zkoHrS1BCLSMW9a8QJOjNyGdqHkC6VLQCgN4SKtDYYn
rSjIGMLJHjLTdKwLIzNbGKW/thfpcTuIGCZ+7qB1W6Jm+Bp11SY1n3jPxKAz3WC/
YBdNOq3idi3OzLD79FadZMLEU+/FCC3d9xRtfzQd4rCsHCfO49zr8BhaKV3wQgBb
3QifZPkl/vQ69oSbGIghGzHJMyz/gxrXktsMxkZs2jTsvdnbQTjxhnd2+ofG/22m
Q9xaPHMW3xAx/O51OB7p/yMoQV4gOFErIwyUNNVZaQglOo2aKMLD/C6fUkkHlFAu
JAPAiQm1Ola9/q2cyW2+/jOzzAdI2Q6UKvdtETGdU4szW2BTDI4hTGBqPHDKDgFp
4HYHRt+dgBsgWyinETV00jJxc4rtKC8P5BIvka06njqBz/ABZOFhYDXRJFuTokX5
YhdeXqCV4gc+10cwMFJfyrN1A9l8GmTvevIzkQMT955y8hkOGWNP5j7mbtpRBnV0
ywPZ58HWEdhtBvjKr+pZCA7K1JPRlotzoNjSPb9CcaONmdFxHmM6/SbhOXtJkSdW
/WRa1PPD
=wv9F
-----END PGP SIGNATURE-----

M
M
Maxim Cournoyer wrote on 26 Mar 2022 14:52
(name . Rostislav Svoboda)(address . rostislav.svoboda@gmail.com)(address . 51848-done@debbugs.gnu.org)
87mthcx1m1.fsf@gmail.com
Hello,

Rostislav Svoboda <rostislav.svoboda@gmail.com> writes:

Toggle quote (5 lines)
> Trying to compile guix (for the first time, ever!) I get:
>
> FAIL: tests/home-import.scm
> FAIL: tests/guix-home.sh

Both issues appear to have been fixed.

Closing.

Thanks for the report!

Maxim
Closed
?