[PATCH 0/2] go-github-com-aswinkarthik-csvdiff package updates

  • Done
  • quality assurance status badge
Details
2 participants
  • Arun Isaac
  • BonfaceKilz
Owner
unassigned
Submitted by
BonfaceKilz
Severity
normal
B
B
BonfaceKilz wrote on 19 Aug 2021 09:17
(address . guix-patches@gnu.org)
20210819071709.90126-1-me@bonfacemunyoki.com
Hi all. Find attached the updated package definition of csv diff which addresses the following issues that were kindly pointed out by Sarah:

Toggle snippet (9 lines)
Typically end-user Go packages will want inputs/native-inputs rather
than propagated inputs unless the input provides a binary used at
runtime, so user profiles are not cluttered (go-build-system needs
source from all transitive dependencies). Also, a more friendly name
("csvdiff" is available) might be better for end-user packages like
this.


BonfaceKilz (2):
gnu: go-github-com-aswinkarthik-csvdiff: Rename name to "csvdiff".
gnu: go-github-com-aswinkarthik-csvdiff: Make inputs native.

gnu/packages/golang.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

--
2.31.1
B
B
BonfaceKilz wrote on 19 Aug 2021 09:21
(address . 50117@debbugs.gnu.org)
20210819072156.90545-1-me@bonfacemunyoki.com
Hi all. Find attached the updated package definition of csv diff which addresses the following issues that were kindly pointed out by Sarah:

Toggle snippet (9 lines)
Typically end-user Go packages will want inputs/native-inputs rather
than propagated inputs unless the input provides a binary used at
runtime, so user profiles are not cluttered (go-build-system needs
source from all transitive dependencies). Also, a more friendly name
("csvdiff" is available) might be better for end-user packages like
this.


BonfaceKilz (2):
gnu: go-github-com-aswinkarthik-csvdiff: Rename name to "csvdiff".
gnu: go-github-com-aswinkarthik-csvdiff: Make inputs native.

gnu/packages/golang.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

--
2.31.1
B
B
BonfaceKilz wrote on 19 Aug 2021 09:21
[PATCH 1/2] gnu: go-github-com-aswinkarthik-csvdiff: Rename name to "csvdiff".
(address . 50117@debbugs.gnu.org)
20210819072156.90545-2-me@bonfacemunyoki.com
* gnu/packages/golang.scm (go-github-com-aswinkarthik-csvdiff)[name]: Rename
to "csvdiff" which is more user-friendly.
---
gnu/packages/golang.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 72579d6bd2..8a8830a6f6 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8424,7 +8424,7 @@ non-cryptographic hash algorithm, working at speeds close to RAM limits.")
(define-public go-github-com-aswinkarthik-csvdiff
(package
- (name "go-github-com-aswinkarthik-csvdiff")
+ (name "csvdiff")
(version "1.4.0")
(source
(origin
--
2.31.1
B
B
BonfaceKilz wrote on 19 Aug 2021 09:21
[PATCH 2/2] gnu: go-github-com-aswinkarthik-csvdiff: Make inputs native.
(address . 50117@debbugs.gnu.org)
20210819072156.90545-3-me@bonfacemunyoki.com
* gnu/packages/golang.scm (go-github-com-aswinkarthik-csvdiff)
[propagated-inputs]: Make these inputs native. Typically end-user Go packages
will want inputs/native-inputs rather than propagated inputs unless the input
provides a binary used at runtime, so user profiles are not
cluttered (go-build-system needs source from all transitive dependencies).
---
gnu/packages/golang.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 8a8830a6f6..7b151a03e3 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8439,7 +8439,7 @@ non-cryptographic hash algorithm, working at speeds close to RAM limits.")
(build-system go-build-system)
(arguments
'(#:import-path "github.com/aswinkarthik/csvdiff"))
- (propagated-inputs
+ (native-inputs
`(("go-golang-org-x-sys" ,go-golang-org-x-sys)
("go-github-com-stretchr-testify" ,go-github-com-stretchr-testify)
("go-github-com-spf13-cobra" ,go-github-com-spf13-cobra)
--
2.31.1
A
A
Arun Isaac wrote on 19 Aug 2021 21:47
Re: [PATCH 0/2] go-github-com-aswinkarthik-csvdiff package updates
87wnohrzc4.fsf@systemreboot.net
Hi Bonface,

Thanks for the patches! Some feedback follows.

1. I think we can combine the two commits into one since this is
logically just a single change.

2. We should retain the old package as a deprecated package. We should
add something like the snippet below.

Toggle snippet (4 lines)
(define-public go-github-com-aswinkarthik-csvdiff
(deprecated-package "go-github-com-aswinkarthik-csvdiff" csvdiff))

Toggle quote (2 lines)
> (define-public go-github-com-aswinkarthik-csvdiff

3. We should rename the variable name as well.

Toggle quote (4 lines)
> (package
> - (name "go-github-com-aswinkarthik-csvdiff")
> + (name "csvdiff")

3. We should also move the package to some file other than
golang.scm. How about textutils.scm?

Thank you for your patience! :-)
Arun
-----BEGIN PGP SIGNATURE-----

iQFPBAEBCAA5FiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAmEetVsbHGFydW5pc2Fh
Y0BzeXN0ZW1yZWJvb3QubmV0AAoJEC4l7othgCuzRoIH/RKkfAklXhz2l9QommDE
gWWBXmUTg1DqbvzbtqoekbhiXQv2lteC5V8SuTBsMPK6fCdP3YR+16kdDJHOwSR8
COrcekCM+W0V9WClUvyk9MPNmtbIF0pu4zeCXHmlPpspN8Qj6lLAlkeZ6V/Fsi8J
d2d6gpCJcQDpqHNK5IPLVRFP/jRVJ5g0A9NjnlsNJ5dzQ8U/H7jABy5f8iDWa0qp
FIhqPh648934xRTNLz2VCfKEeqnhRodUFs2BxmBC50evaOsBb8EszLqFPq8GpuVH
dHQf/FcCCo5yFrk9ZD6bZGH/zSctibdDH6HsC5sRXI7C1kBnAM7WBeVWP3y7UDlq
HMU=
=Q5Z+
-----END PGP SIGNATURE-----

A
A
Arun Isaac wrote on 9 Dec 2021 11:35
Re: [bug#50117] [PATCH 0/2] go-github-com-aswinkarthik-csvdiff package updates
(address . iskarian@mgsn.dev)
87o85qhxqf.fsf@systemreboot.net
Hi Bonface,

Any progress on this? Just a gentle ping.

Thanks,
Arun
-----BEGIN PGP SIGNATURE-----

iQFPBAEBCAA5FiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAmGx2/gbHGFydW5pc2Fh
Y0BzeXN0ZW1yZWJvb3QubmV0AAoJEC4l7othgCuzVPEIALlb1t4n1BfoLvN30rpd
GuTxoAIVjRSfK+C2J6Swli12rM2Vawrdy1zybqzhvsZimzhdHHQI9a39bPQmZMWV
EijQXmm31Xh7CVgzh8X/qNPFBO+HZtSBww37qkoECfijWDA7/TH2eybw/ZtKpEVI
mXju+0yK9aUCkKWrNUer4CoP/2syesYE7NzvWtBBkbyQkt7NJE8bEwQoMkEx6a+b
EvriRn1UwsPDCxi8piRwt7kVGxnDMJ85eqIMMVhnAaERLPOfwzkCRpFUK6+UQS7b
KhYyo37TgBnhFboe+6mzWwHwYX3L3NOVi5y5w/2ZtcbQC1sb9ZGYJT/F4zIHZHF1
mR8=
=vVaL
-----END PGP SIGNATURE-----

B
B
Bonface M. K wrote on 9 Dec 2021 15:02
(address . iskarian@mgsn.dev)
86o85pho6e.fsf@bonfacemunyoki.com
Arun Isaac <arunisaac@systemreboot.net> anaandika:

Toggle quote (7 lines)
> Hi Bonface,
>
> Any progress on this? Just a gentle ping.
>
> Thanks,
> Arun

Hi! Lemme have a look at this once my classes are
done. Somehow this got lost in my To-Do tasks!
Thanks for the reminder.

--
Bonface M. K.
D4F09EB110177E03C28E2FE1F5BBAE1E0392253F (hkp://keys.gnupg.net)
Free Software Activist
Humble GNU Emacs User | Bearer of scheme-y parens
Curator: https://upbookclub.com | Twitter: @BonfaceKilz
-----BEGIN PGP SIGNATURE-----

iQJKBAEBCAA0FiEE1PCesRAXfgPCji/h9buuHgOSJT8FAmGyDFkWHG1lQGJvbmZh
Y2VtdW55b2tpLmNvbQAKCRD1u64eA5IlP108D/4wIZY5277Rk4bKbZrVLMAk9dKX
z9WmxRsW3ObNzRIpFc22l4G79Y90xTkniXav4F4+e+EfVlt4eLjMnUm1SqCSQMfc
FMDe2Xe1BlFlIvj2CgfJJZsQubzhU5gIqHYN5DBP9doIBTNbIoSdgYzoRLeZauel
zsWUE8a/v66yz4nHmTj3lvHfzuzyVQuUwXVGn156SXlmysiRbCXSXWJXXENpOpCh
CMPalw8AuXRIFTUmnzg71lNSABb1nyzn9Ecm7uvvOu4JkZvZG6k/RFwNRVJey4Oa
2NPoGCNvoC86oNxyYq149E+G33js9zIkoePM4CSc31DibTQTvdHkrzsfjv8zEh91
qm2CwrnxDCCL1HVZM7kqNkOjAaO65y82JxMUIoSsQ5zS9MgdsffwkxzaCWEPHU2g
f9oXQ2Yilx5lmcgvJscatRArkUNenHDmoj6gl0fOvw9cc9ricmMrQ7aBffbTlrmK
nHVWcVAHzrSN769LN4RN15KKyz6pJHTKCT+SvwDgc1EpDxIYSORgDM7fXzpd9pMZ
iX8cz/ZH05v5sZEgmLnTxH327+zm0+AM2yqCJLoFhr6NAC2LSQEIYuZ8MTa4MPeL
1ABYMHvbyQH6ozZTDpfX3o+DergT+5H8l2tjCJG/I3GceiFDOvmTMFeUXoBU4UHb
ocZdPyFqOFhvfkEFTw==
=BhhG
-----END PGP SIGNATURE-----

A
A
Arun Isaac wrote on 10 Dec 2021 04:30
(address . iskarian@mgsn.dev)
87bl1pi1bo.fsf@systemreboot.net
Toggle quote (3 lines)
> Hi! Lemme have a look at this once my classes are done. Somehow this
> got lost in my To-Do tasks! Thanks for the reminder.

Sure, Bonface, thanks!
-----BEGIN PGP SIGNATURE-----

iQFPBAEBCAA5FiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAmGyycsbHGFydW5pc2Fh
Y0BzeXN0ZW1yZWJvb3QubmV0AAoJEC4l7othgCuzRcoIAL9vhmPM+RDNinFvv2XS
Af7k8R3umzuvHIY9Uq/B6JdtMGMrpCGBUdWAljp0a87wTqXXaqK4PY95nfs8P9IX
JlNqx/Q1sOjSjzpS7CcFv4cbWKldEG+jq1KTnthtMJv6sRWgvFHjCdEfPwPYHdXa
nofwnxDSGmZAOhKgzAqOtnwcERnataWMKmCUjosfxB/V2jnQbngJ6WioQS+5kup9
QvWyoilw6mrdTH1WzjRzamkiSZvnGRKRenapVYVW75WnLp1UB0f05kqobdyCE1AI
9jXSxTbIdoAVoiEnWT9RpAz6z1UzKUarGRUTR42wH4WToJ5VnN1ZwqVBZn5Wb7/6
37o=
=bd3M
-----END PGP SIGNATURE-----

B
B
BonfaceKilz wrote on 10 Dec 2021 12:17
[PATCH 0/1] go-github-com-aswinkarthik-csvdiff package updates
(address . 50117@debbugs.gnu.org)
20211210111752.20147-1-me@bonfacemunyoki.com
Hi all! Find below updated patches from a review from a while back. @Arun, I
have moved csvdiff to textutils(it makes more semantic sense). I see no need
of defining it as a deprecated-package since there's no package dependent on
it ATM. Let me know if I need to change anything. Thanks for being patient
with this!

BonfaceKilz (1):
gnu: Move csvdiff to (gnu packages textutils).

gnu/packages/golang.scm | 44 ------------------------------------
gnu/packages/textutils.scm | 46 ++++++++++++++++++++++++++++++++++++++
2 files changed, 46 insertions(+), 44 deletions(-)

--
2.31.1
B
B
BonfaceKilz wrote on 10 Dec 2021 12:17
[PATCH 1/1] gnu: Move csvdiff to (gnu packages textutils).
(address . 50117@debbugs.gnu.org)
20211210111752.20147-2-me@bonfacemunyoki.com

* gnu/packages/golang.scm (go-github-com-aswinkarthik-csvdiff): Move from here
* gnu/packages/textutils (go-github-com-aswinkarthik-csvdiff): to here.
---
gnu/packages/golang.scm | 44 ------------------------------------
gnu/packages/textutils.scm | 46 ++++++++++++++++++++++++++++++++++++++
2 files changed, 46 insertions(+), 44 deletions(-)

Toggle diff (125 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d555a92579..49c124a415 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8788,50 +8788,6 @@ zero round-trip encryption, and other advanced features.")
non-cryptographic hash algorithm, working at speeds close to RAM limits.")
(license license:asl2.0)))
-(define-public go-github-com-aswinkarthik-csvdiff
- (package
- (name "go-github-com-aswinkarthik-csvdiff")
- (version "1.4.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/aswinkarthik/csvdiff")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0cd1ikxsypjqisfnmr7zix3g7x8p892w77086465chyd39gpk97b"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/aswinkarthik/csvdiff"))
- (propagated-inputs
- `(("go-golang-org-x-sys" ,go-golang-org-x-sys)
- ("go-github-com-stretchr-testify" ,go-github-com-stretchr-testify)
- ("go-github-com-spf13-cobra" ,go-github-com-spf13-cobra)
- ("go-github-com-spf13-afero" ,go-github-com-spf13-afero)
- ("go-github-com-spaolacci-murmur3" ,go-github-com-spaolacci-murmur3)
- ("go-github-com-mattn-go-colorable" ,go-github-com-mattn-go-colorable)
- ("go-github-com-fatih-color" ,go-github-com-fatih-color)
- ("go-github-com-cespare-xxhash" ,go-github-com-cespare-xxhash)
- ("go-github-com-oneofone-xxhash" ,go-github-com-oneofone-xxhash)))
- (home-page "https://github.com/aswinkarthik/csvdiff")
- (synopsis "Fast diff tool for comparing CSV files")
- (description "@code{csvdiff} is a diff tool to compute changes between two
-CSV files. It can compare CSV files with a million records in under 2
-seconds. It is specifically suited for comparing CSV files dumped from
-database tables. GNU Diff is orders of magnitude faster for comparing line by
-line. @code{csvdiff} supports
-
-@itemize
-@item Selective comparison of fields in a row
-@item Specifying group of columns as primary-key to uniquely identify a row
-@item Ignoring columns
-@item Several output formats including colored git style output or
-JSON for post-processing
-@end itemize")
- (license license:expat)))
-
(define-public go-gopkg-in-djherbis-times-v1
(package
(name "go-gopkg-in-djherbis-times-v1")
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 7e7293ac16..9a8b9ae1e8 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -22,6 +22,7 @@
;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Jean-Baptiste Volatier <jbv@pm.me>
;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -64,6 +65,7 @@
#:use-module (gnu packages python)
#:use-module (gnu packages python-build)
#:use-module (gnu packages python-xyz)
+ #:use-module (gnu packages syncthing)
#:use-module (gnu packages readline)
#:use-module (gnu packages ruby)
#:use-module (gnu packages slang)
@@ -1347,3 +1349,47 @@ languages such as HTML, Markdown, Asciidoc, and reStructuredText. The community
around it also has a list of style guides implemented with Vale in
@url{https://github.com/errata-ai/styles, their styles repo}.")
(license license:expat)))
+
+(define-public go-github-com-aswinkarthik-csvdiff
+ (package
+ (name "csvdiff")
+ (version "1.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aswinkarthik/csvdiff")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0cd1ikxsypjqisfnmr7zix3g7x8p892w77086465chyd39gpk97b"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/aswinkarthik/csvdiff"))
+ (propagated-inputs
+ `(("go-golang-org-x-sys" ,go-golang-org-x-sys)
+ ("go-github-com-stretchr-testify" ,go-github-com-stretchr-testify)
+ ("go-github-com-spf13-cobra" ,go-github-com-spf13-cobra)
+ ("go-github-com-spf13-afero" ,go-github-com-spf13-afero)
+ ("go-github-com-spaolacci-murmur3" ,go-github-com-spaolacci-murmur3)
+ ("go-github-com-mattn-go-colorable" ,go-github-com-mattn-go-colorable)
+ ("go-github-com-fatih-color" ,go-github-com-fatih-color)
+ ("go-github-com-cespare-xxhash" ,go-github-com-cespare-xxhash)
+ ("go-github-com-oneofone-xxhash" ,go-github-com-oneofone-xxhash)))
+ (home-page "https://github.com/aswinkarthik/csvdiff")
+ (synopsis "Fast diff tool for comparing CSV files")
+ (description "@code{csvdiff} is a diff tool to compute changes between two
+CSV files. It can compare CSV files with a million records in under 2
+seconds. It is specifically suited for comparing CSV files dumped from
+database tables. GNU Diff is orders of magnitude faster for comparing line by
+line. @code{csvdiff} supports
+
+@itemize
+@item Selective comparison of fields in a row
+@item Specifying group of columns as primary-key to uniquely identify a row
+@item Ignoring columns
+@item Several output formats including colored git style output or
+JSON for post-processing
+@end itemize")
+ (license license:expat)))
--
2.31.1
A
A
Arun Isaac wrote on 13 Dec 2021 07:08
Re: [PATCH 0/1] go-github-com-aswinkarthik-csvdiff package updates
(name . BonfaceKilz)(address . me@bonfacemunyoki.com)(address . 50117@debbugs.gnu.org)
87r1ahf35q.fsf@systemreboot.net
Hi Bonface,

Toggle quote (3 lines)
> Hi all! Find below updated patches from a review from a while back. @Arun, I
> have moved csvdiff to textutils(it makes more semantic sense).

Sounds good.

Toggle quote (3 lines)
> I see no need of defining it as a deprecated-package since there's no
> package dependent on it ATM.

Users might have installed csvdiff into their profiles. So, I think we
still need to define a deprecated-package. Could you send an updated
patchset?

Thanks!
Arun
-----BEGIN PGP SIGNATURE-----

iQFOBAEBCAA5FiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAmG240EbHGFydW5pc2Fh
Y0BzeXN0ZW1yZWJvb3QubmV0AAoJEC4l7othgCuzTrQH9AyuW+e/w8OrDLysPWri
lWqRmArvRl8Yk9KgF25Q72lAUiJOWzJ9JmOD46aUCVBxPNJBHNT++mZ9FiOvOnhq
sxbG3vTPo3bJTukw/fQeUHfOKlIm2/mjZB7/9dKLX5pE2ltXmVi7/Jqdh9r+xCtS
7NZ4FC8XFBu6Z/WSf4VDGvWuUZQDtFdeN8QzBmfVe7y+p1T4eCrfKS2v8TrumBxH
xHnJz9Lx9l0Qmq1zlmAIvRF5BfIWE0CqUHQ2Mpr7UXO5M5p9RCiFyooulnLMU0iw
/gSYFeAUeUta9Tp03oG688Zp57JUyhhX7Z20PSBmEwfti1EHD/vPBLOV1Eyll5su
sQ==
=0cyb
-----END PGP SIGNATURE-----

B
B
Bonface M. K wrote on 13 Dec 2021 07:50
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 50117@debbugs.gnu.org)
86bl1lxali.fsf@bonfacemunyoki.com
Arun Isaac <arunisaac@systemreboot.net> anaandika:

Toggle quote (15 lines)
> Hi Bonface,
>
>> Hi all! Find below updated patches from a review from a while back. @Arun, I
>> have moved csvdiff to textutils(it makes more semantic sense).
>
> Sounds good.
>
>> I see no need of defining it as a deprecated-package since there's no
>> package dependent on it ATM.
>
> Users might have installed csvdiff into their profiles. So, I think we
> still need to define a deprecated-package. Could you send an updated
> patchset?
>

Sure. Let me do that later during the day...

Toggle quote (3 lines)
> Thanks!
> Arun

--
Bonface M. K.
D4F09EB110177E03C28E2FE1F5BBAE1E0392253F (hkp://keys.gnupg.net)
Free Software Activist
Humble GNU Emacs User | Bearer of scheme-y parens
Curator: https://upbookclub.com | Twitter: @BonfaceKilz
-----BEGIN PGP SIGNATURE-----

iQJKBAEBCAA0FiEE1PCesRAXfgPCji/h9buuHgOSJT8FAmG27RkWHG1lQGJvbmZh
Y2VtdW55b2tpLmNvbQAKCRD1u64eA5IlP89kD/90/aZAoH6+HvkPxUIOyNgKm0B7
o6tt5RxwEiaii32Xj705TYsViD/eCgZlpP6rHzAd3pNijqXjl9YnUctjOnCNdFab
yytScpW9qrnswBDtgiNUVF71OhwzvO3DyIatx214ntaSTk7a+vE0a/YEMzZovday
09fdSXs3lz47urtv9tPVSbJrIkh2GnogrGQ3t1xRpd16TIXusffn2mOGUjOg1zFo
JvygzYRgjhnfQfyOLyApBQZviZWlY97yg7RtqEcrMeQ+M09Hm9LYkAi7NzNzp3st
/cNloAw694ozY4cIaymFjOF0//rCD/CFTaKXXcv3Mjl7KiAW9NMHn2wvW9+BsdvU
fO5VoCHLAoxSKA2lMbFAGglR9uuQnsF0w8BtW7TZSKDe+JLFYeDij4Qk2188ClDI
wUuN4WB3b6dnb68eUDZ8QoGcjjiELUJFmCVp7rSZ+MULRz0YZ0Tu5kaFq+0tWx/r
uDXeHCWKd53py4oITC7RknXzGB/62usPof+i6NvPfsXfvwCOPqFvlVMUCwcd1l40
2d1YwVkayK0c1W/WjiNvLtxdhdDNX1IEUj0ayMEDvt2sthaGaDYtnOiKXKYt03lN
+W8Wuo+msE1ZzJh11AaLnuYgiUK+0QdYfuCFZe+0fjGToqtYBBeX6ZZ1EcOkBV72
eCYDGlpzczXQqRvMYg==
=WHtD
-----END PGP SIGNATURE-----

B
B
Bonface M. K wrote on 13 Dec 2021 21:51
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 50117@debbugs.gnu.org)
868rwo44a2.fsf@bonfacemunyoki.com
Arun Isaac <arunisaac@systemreboot.net> anaandika:

Toggle quote (14 lines)
> Hi Bonface,
>
>> Hi all! Find below updated patches from a review from a while back. @Arun, I
>> have moved csvdiff to textutils(it makes more semantic sense).
>
> Sounds good.
>
>> I see no need of defining it as a deprecated-package since there's no
>> package dependent on it ATM.
>
> Users might have installed csvdiff into their profiles. So, I think we
> still need to define a deprecated-package. Could you send an updated
> patchset?

Yup. This makes sense. Find attached a new patch
that adds an alias for the deprecated package.
Let me know if this is okay :)
--
Bonface M. K.
D4F09EB110177E03C28E2FE1F5BBAE1E0392253F (hkp://keys.gnupg.net)
Free Software Activist
Humble GNU Emacs User | Bearer of scheme-y parens
Curator: https://upbookclub.com | Twitter: @BonfaceKilz
-----BEGIN PGP SIGNATURE-----

iQJKBAEBCAA0FiEE1PCesRAXfgPCji/h9buuHgOSJT8FAmG3slUWHG1lQGJvbmZh
Y2VtdW55b2tpLmNvbQAKCRD1u64eA5IlP7aPD/9s2kkwfO50zMuGWkO3feuts/KA
s+x9GWSgM+zamM0Esx+p6pSTX/0hQBkOgCZaXhnVeq1+X4GMlFQtSPtb/88HSdT3
t0NN9DxCeobIZcSm/gXfAKV8NdgDGcMkbnLGeKo3WsBuQerszD5h6zoJdSXlNhPs
T4BjxD87bnLPYVbWGo3mDCbS88Qg8h6rHa5YYFJhPhUg1jDDpv1taexa5vTzo/Px
OHuzNFw42124d87HRoK/AEu/Gmq4SDqC9uN8F0u056/AkJSW/c/GathhQtHgpja2
UXCNsAQ+wuDzNKyZxdAc5ByKK8XuzVIWC2DkoGDy9Tnj/Gvp+Xmv3d3aoe9oZXaw
g3h3PU1kNWHjX8pTh1cCNI5M63q64lafLHkmk3Vmqw44NtaHsALOOa6RKBts/i6/
8UiEMALQxNmfiQMMOrd6BsMOZkj3Z+J+qnITENJlEoHgUB+u5JM8UOAyc0B+5PhN
0/+OSJ3fbSldRZltT/GtVz1ErdjN/G2//w4SelkUNmHsVOdUbaY68DD+3OO0DV5T
hiJ47UFzDFfccqF06O3DEnk6o2H/fZZHnuhZoY4QrGAJ1QX8iqj9Td+Age50kBzq
yGdd4erOYJj19Cvump7KpypF/ID+ehMZJwR14v+l34vHA/xK+OyELXJ4NYZZGCCc
7Lybbi/zj6dW8OQlVQ==
=CvxR
-----END PGP SIGNATURE-----

A
A
Arun Isaac wrote on 20 Dec 2021 06:35
(name . Bonface M. K)(address . me@bonfacemunyoki.com)(address . 50117-done@debbugs.gnu.org)
87ee6796ug.fsf@systemreboot.net
Hi Bonface,

I have applied the patch on master with a few changes. Most
significantly, I moved the deprecated alias from
gnu/packages/textutils.scm to gnu/packages/golang.scm since golang.scm
is where the original package was.

Thanks,
Arun
-----BEGIN PGP SIGNATURE-----

iQFPBAEBCAA5FiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAmHAFhcbHGFydW5pc2Fh
Y0BzeXN0ZW1yZWJvb3QubmV0AAoJEC4l7othgCuzXjMH/A60jxwxo1+5brtciMgD
robF9xK5Sy5shZVLNP7u4qG31lA/ToxqfzlqgQm+zdtPX6+mHLxymjBy/pL71POM
p6GdGKpG4fqqBCiOWdKPezaHckM5tZD8gEYDDfQwYrqpSnYuHDdCOxnAKuFCtYZk
/WbDFXiDACsbQykIw7Oqdg9gJpLXL0FWhUZAYCyFIN0sSsWeKw4eWI9ORyuLwK1a
sQC2pb9r2Vkk1Ec1vrtLR4YFW+twN72wmJWWBg6E/YLKve8IZLwrqMaNUMYTZxAN
wxxfbApBakisDDBHgTNSt/sG5OtPJ9RdotIQMpTBE/poHWi7WpbEL4l42UkjyQfn
8kc=
=jqBE
-----END PGP SIGNATURE-----

Closed
B
B
Bonface M. K wrote on 21 Dec 2021 13:29
(name . Arun Isaac)(address . arunisaac@systemreboot.net)(address . 50117-done@debbugs.gnu.org)
86wnjydtuv.fsf@bonfacemunyoki.com
Arun Isaac <arunisaac@systemreboot.net> anaandika:

Toggle quote (7 lines)
> Hi Bonface,
>
> I have applied the patch on master with a few changes. Most
> significantly, I moved the deprecated alias from
> gnu/packages/textutils.scm to gnu/packages/golang.scm since golang.scm
> is where the original package was.

Thanks!

--
Bonface M. K.
D4F09EB110177E03C28E2FE1F5BBAE1E0392253F (hkp://keys.gnupg.net)
Free Software Activist
Humble GNU Emacs User | Bearer of scheme-y parens
Curator: https://upbookclub.com | Twitter: @BonfaceKilz
-----BEGIN PGP SIGNATURE-----

iQJKBAEBCAA0FiEE1PCesRAXfgPCji/h9buuHgOSJT8FAmHByJgWHG1lQGJvbmZh
Y2VtdW55b2tpLmNvbQAKCRD1u64eA5IlP5qMD/4p8d4T1U9oS8aa8pnSEX6ecJEr
kNUPjYajbzmrQdX6SilLGzcusyBJhvNox52H+9kyqqPzLGzTTo0j/SqukOr5KFYS
tfxw9mKBIbjQvEkmng5Ki7K4RtQZi5c2nENQOkaUPERwDXaypZjWy9P3eALSG74Z
TTYB2gIuFIDwLEqILoP1yMQYrooKaZ73uWg+m3+iljxEbYw7qnufRYP7L0qEltO/
/qs3mdx22LDwCnSxo15mPN5awxrq9Q8m5w5AQWGDH9HhbOGS5+rZN50ydeaqL654
Zxm0rSPvFMDTRAJqIfAiO6GAZwn18t76b0B1J3x7wBqSpj6cy3+bka7olPb1T46Z
fHVWBzxK3emsy4D4tOvHhfiCjSBusKvLssK9Knkx0Vpm7WNd62a8b1u4XkG77L6T
egZS9OPwIxWTYbEMo3kK+Ydsn0zlE97gWV7nbAVEhQINEMAhvb/8BtHTKEg5dsgS
NihEn4GiqU8yLWNIflXnxmWs35zyKIXGwNoy/mrSt0KVw2PE/gFCUs5O1D38uzJT
nqnd8RnvbxB8X5M3L+8Y6m91Xz4HIY2eObLMZlJEpKNKhGKOHUMeHhf5hAEapjEb
bdvjxrtF6JgDdCEy8ApzTdbU0KYJVPltBhf3RdDbi081iLlJPyKmk9Z3SLcbgi0t
LRNK9QEvYrh4TYhuzg==
=xezy
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 50117@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 50117
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch