[PATCH 1/1] Added a package definition for the C++17 header only library 'magic-enum'.

  • Done
  • quality assurance status badge
Details
2 participants
  • Anadon
  • Leo Prikler
Owner
unassigned
Submitted by
Anadon
Severity
normal
Merged with
A
A
Anadon wrote on 14 Jan 2021 03:36
(address . guix-patches@gnu.org)
20210114023630.53568-2-joshua.r.marshall.1991@gmail.com
gnu/packages/cpp.scm: Added the package definition.
---
gnu/packages/cpp.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 00e006928e..673867dbd2 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -807,3 +807,27 @@ code will be mixed in with the actual programming logic. This implementation
provides a number of utilities to make coding with expected cleaner.")
(home-page "https://tl.tartanllama.xyz/")
(license license:cc0)))
+
+(define-public magic-enum
+ (package
+ (name "magic-enum")
+ (version "0.7.2")
+ (home-page "https://github.com/Neargye/magic_enum")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "0fmkyh1srkz2bx68agfa30sankg1ig1f95xqp8sp9wj3p9qilsv2"))
+ (modules '((guix build utils)))))
+ (build-system cmake-build-system)
+
+ (inputs
+ `(("gcc" ,gcc-9)))
+ (synopsis "C++17 header only library for compile time reflection of enums")
+ (description "C++17 header only library which offers static reflection
+of enums, with to string, from string, and iteration, and related
+functionality.")
+ (license license:expat)))
--
2.27.0
L
L
Leo Prikler wrote on 14 Jan 2021 11:03
Please don't tag guix-patches in follow-ups
(address . control@debbugs.gnu.org)
b3ee40116e925066349799811038b8813b0332dd.camel@student.tugraz.at
merge 45604 45730 45731 45850 45851 45852 45853
?