[PATCH 0/1] Add magic-enum package

  • Done
  • quality assurance status badge
Details
2 participants
  • Anadon
  • Leo Prikler
Owner
unassigned
Submitted by
Anadon
Severity
normal
Merged with
A
A
Anadon wrote on 2 Jan 2021 01:51
(address . guix-patches@gnu.org)(name . Anadon)(address . joshua.r.marshall.1991@gmail.com)
20210102005145.582428-1-joshua.r.marshall.1991@gmail.com
Magic-enum is a C++17 header-only library for support of static
reflection on enums.

Josh Marshall (1):
Added magic-enum header-only library as a package.

gnu/packages/cpp.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

--
2.29.2
A
A
Anadon wrote on 2 Jan 2021 01:51
[PATCH 1/1] Added magic-enum header-only library as a package.
(address . guix-patches@gnu.org)(name . Josh Marshall)(address . joshua.r.marshall.1991@gmail.com)
20210102005145.582428-2-joshua.r.marshall.1991@gmail.com
From: Josh Marshall <joshua.r.marshall.1991@gmail.com>

---
gnu/packages/cpp.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 00e006928e..ff10a4247b 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -807,3 +807,27 @@ code will be mixed in with the actual programming logic. This implementation
provides a number of utilities to make coding with expected cleaner.")
(home-page "https://tl.tartanllama.xyz/")
(license license:cc0)))
+
+(define-public magic-enum
+ (package
+ (name "magic-enum")
+ (version "0.7.2")
+ (home-page "https://github.com/Neargye/magic_enum")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "0fmkyh1srkz2bx68agfa30sankg1ig1f95xqp8sp9wj3p9qilsv2"))
+ (modules '((guix build utils)))))
+ (build-system cmake-build-system)
+
+ (inputs
+ `(("gcc" ,gcc-10)))
+ (synopsis "Header-only C++17 library for reflection for enums")
+ (description "Static reflection for enums (to string, from string,
+iteration) for modern C++, work with any enum type without any macro or
+boilerplate code")
+ (license license:expat)))
--
2.29.2
L
L
Leo Prikler wrote on 4 Jan 2021 14:06
(name . Anadon)(address . joshua.r.marshall.1991@gmail.com)(address . 45604@debbugs.gnu.org)
678c89426254d320a0962d8c47d88b29aa754b03.camel@student.tugraz.at
Hello Anadon,

I have not yet built your package (because I'm currently also handling
another patch), but since you've requested review over at guix-devel,
I'll have a go at it.
For the future please note, that a delay of 2 days does not mean we
haven't noticed you at all. The manual has the following to say for
committers:
Toggle quote (5 lines)
> For anything else, please post to <guix-patches@gnu.org> and leave
> time for a review, without committing anything (*note Submitting
> Patches::). If you didn’t receive any reply after two weeks, and if
> you’re confident, it’s OK to commit.

Am Freitag, den 01.01.2021, 19:51 -0500 schrieb Anadon:
Toggle quote (1 lines)
> From: Josh Marshall <joshua.r.marshall.1991@gmail.com>
Ehh, somehow the commit message and everything is missing here. Is
that intended or just misconfigured?

Toggle quote (34 lines)
> ---
> gnu/packages/cpp.scm | 24 ++++++++++++++++++++++++
> 1 file changed, 24 insertions(+)
>
> diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
> index 00e006928e..ff10a4247b 100644
> --- a/gnu/packages/cpp.scm
> +++ b/gnu/packages/cpp.scm
> @@ -807,3 +807,27 @@ code will be mixed in with the actual
> programming logic. This implementation
> provides a number of utilities to make coding with expected
> cleaner.")
> (home-page "https://tl.tartanllama.xyz/")
> (license license:cc0)))
> +
> +(define-public magic-enum
> + (package
> + (name "magic-enum")
> + (version "0.7.2")
> + (home-page "https://github.com/Neargye/magic_enum")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url home-page)
> + (commit (string-append "v" version))))
> + (sha256
> + (base32
> + "0fmkyh1srkz2bx68agfa30sankg1ig1f95xqp8sp9wj3p9qil
> sv2"))
> + (modules '((guix build utils)))))
> + (build-system cmake-build-system)
> +
> + (inputs
> + `(("gcc" ,gcc-10)))
The home-page claims, that it works with GCC>=9. Have you encountered
any issues with gcc-9 instead?
Toggle quote (2 lines)
> + (synopsis "Header-only C++17 library for reflection for
> enums")
I feel as though that could be worded better.
Toggle quote (5 lines)
> + (description "Static reflection for enums (to string, from
> string,
> +iteration) for modern C++, work with any enum type without any macro
> or
> +boilerplate code")
Descriptions should be complete sentences and end with a period.
Toggle quote (2 lines)
> + (license license:expat)))

Regards,
Leo
J
J
Josh Marshall wrote on 4 Jan 2021 22:59
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 45604@debbugs.gnu.org)
CAFkJGRex36HPoGXo_HMhtxenxTHnKMKwOkY8mgUvOzpmxFnp1w@mail.gmail.com
Sorry, one more thing I missed in the documentation was the waiting
period. The commit message missing is probably a misconfiguration. I can
change to gcc-9, I just defaulted to the newest since the default was too
old. That description is a verbatim copy of their description.

I'll fix these up, then issue another patch series.







On Mon, Jan 4, 2021 at 8:06 AM Leo Prikler <leo.prikler@student.tugraz.at>
wrote:

Toggle quote (69 lines)
> Hello Anadon,
>
> I have not yet built your package (because I'm currently also handling
> another patch), but since you've requested review over at guix-devel,
> I'll have a go at it.
> For the future please note, that a delay of 2 days does not mean we
> haven't noticed you at all. The manual has the following to say for
> committers:
> > For anything else, please post to <guix-patches@gnu.org> and leave
> > time for a review, without committing anything (*note Submitting
> > Patches::). If you didn’t receive any reply after two weeks, and if
> > you’re confident, it’s OK to commit.
>
> Am Freitag, den 01.01.2021, 19:51 -0500 schrieb Anadon:
> > From: Josh Marshall <joshua.r.marshall.1991@gmail.com>
> Ehh, somehow the commit message and everything is missing here. Is
> that intended or just misconfigured?
>
> > ---
> > gnu/packages/cpp.scm | 24 ++++++++++++++++++++++++
> > 1 file changed, 24 insertions(+)
> >
> > diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
> > index 00e006928e..ff10a4247b 100644
> > --- a/gnu/packages/cpp.scm
> > +++ b/gnu/packages/cpp.scm
> > @@ -807,3 +807,27 @@ code will be mixed in with the actual
> > programming logic. This implementation
> > provides a number of utilities to make coding with expected
> > cleaner.")
> > (home-page "https://tl.tartanllama.xyz/")
> > (license license:cc0)))
> > +
> > +(define-public magic-enum
> > + (package
> > + (name "magic-enum")
> > + (version "0.7.2")
> > + (home-page "https://github.com/Neargye/magic_enum")
> > + (source (origin
> > + (method git-fetch)
> > + (uri (git-reference
> > + (url home-page)
> > + (commit (string-append "v" version))))
> > + (sha256
> > + (base32
> > + "0fmkyh1srkz2bx68agfa30sankg1ig1f95xqp8sp9wj3p9qil
> > sv2"))
> > + (modules '((guix build utils)))))
> > + (build-system cmake-build-system)
> > +
> > + (inputs
> > + `(("gcc" ,gcc-10)))
> The home-page claims, that it works with GCC>=9. Have you encountered
> any issues with gcc-9 instead?
> > + (synopsis "Header-only C++17 library for reflection for
> > enums")
> I feel as though that could be worded better.
> > + (description "Static reflection for enums (to string, from
> > string,
> > +iteration) for modern C++, work with any enum type without any macro
> > or
> > +boilerplate code")
> Descriptions should be complete sentences and end with a period.
> > + (license license:expat)))
>
> Regards,
> Leo
>
>
Attachment: file
L
L
Leo Prikler wrote on 5 Jan 2021 21:39
(name . Josh Marshall)(address . joshua.r.marshall.1991@gmail.com)(address . 45604@debbugs.gnu.org)
7c5a8335d41424b10c950d6dd5f20adb16a4bbfb.camel@student.tugraz.at
Hello Josh,
Am Montag, den 04.01.2021, 16:59 -0500 schrieb Josh Marshall:
Toggle quote (5 lines)
> Sorry, one more thing I missed in the documentation was the waiting
> period. The commit message missing is probably a misconfiguration.
> I can change to gcc-9, I just defaulted to the newest since the
> default was too old. That description is a verbatim copy of their
> description.
W.r.t. the description you should probably come up with words of your
own. The upstream one doesn't appear all that usable.

For the record, gcc should likely also be a native-input, given that
it'll be used for compilation and testing.

Toggle quote (1 lines)
> I'll fix these up, then issue another patch series.
Don't forget to set --to, --cc and --reroll-count when you do ;)
Otherwise you might inadvertently open up new issues which will at
least confuse the bug tracker.

Regards,
Leo

Toggle quote (78 lines)
> On Mon, Jan 4, 2021 at 8:06 AM Leo Prikler <
> leo.prikler@student.tugraz.at> wrote:
> > Hello Anadon,
> >
> > I have not yet built your package (because I'm currently also
> > handling
> > another patch), but since you've requested review over at guix-
> > devel,
> > I'll have a go at it.
> > For the future please note, that a delay of 2 days does not mean we
> > haven't noticed you at all. The manual has the following to say
> > for
> > committers:
> > > For anything else, please post to <guix-patches@gnu.org> and
> > leave
> > > time for a review, without committing anything (*note Submitting
> > > Patches::). If you didn’t receive any reply after two weeks, and
> > if
> > > you’re confident, it’s OK to commit.
> >
> > Am Freitag, den 01.01.2021, 19:51 -0500 schrieb Anadon:
> > > From: Josh Marshall <joshua.r.marshall.1991@gmail.com>
> > Ehh, somehow the commit message and everything is missing here. Is
> > that intended or just misconfigured?
> >
> > > ---
> > > gnu/packages/cpp.scm | 24 ++++++++++++++++++++++++
> > > 1 file changed, 24 insertions(+)
> > >
> > > diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
> > > index 00e006928e..ff10a4247b 100644
> > > --- a/gnu/packages/cpp.scm
> > > +++ b/gnu/packages/cpp.scm
> > > @@ -807,3 +807,27 @@ code will be mixed in with the actual
> > > programming logic. This implementation
> > > provides a number of utilities to make coding with expected
> > > cleaner.")
> > > (home-page "https://tl.tartanllama.xyz/")
> > > (license license:cc0)))
> > > +
> > > +(define-public magic-enum
> > > + (package
> > > + (name "magic-enum")
> > > + (version "0.7.2")
> > > + (home-page "https://github.com/Neargye/magic_enum")
> > > + (source (origin
> > > + (method git-fetch)
> > > + (uri (git-reference
> > > + (url home-page)
> > > + (commit (string-append "v" version))))
> > > + (sha256
> > > + (base32
> > > +
> > "0fmkyh1srkz2bx68agfa30sankg1ig1f95xqp8sp9wj3p9qil
> > > sv2"))
> > > + (modules '((guix build utils)))))
> > > + (build-system cmake-build-system)
> > > +
> > > + (inputs
> > > + `(("gcc" ,gcc-10)))
> > The home-page claims, that it works with GCC>=9. Have you
> > encountered
> > any issues with gcc-9 instead?
> > > + (synopsis "Header-only C++17 library for reflection for
> > > enums")
> > I feel as though that could be worded better.
> > > + (description "Static reflection for enums (to string, from
> > > string,
> > > +iteration) for modern C++, work with any enum type without any
> > macro
> > > or
> > > +boilerplate code")
> > Descriptions should be complete sentences and end with a period.
> > > + (license license:expat)))
> >
> > Regards,
> > Leo
> >
A
A
Anadon wrote on 9 Jan 2021 03:40
[PATCH 0/2] Added magic-enum header-only library as a package.
(address . guix-patches@gnu.org)
20210109024058.68902-1-joshua.r.marshall.1991@gmail.com
Added magic-enum header-only library as a package.

Anadon (1):
Made changes Leo on the ML suggested.

Josh Marshall (1):
Added magic-enum header-only library as a package.

gnu/packages/cpp.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

--
2.30.0
A
A
Anadon wrote on 9 Jan 2021 03:40
[PATCH 2/2] Made changes Leo on the ML suggested.
(address . guix-patches@gnu.org)
20210109024058.68902-3-joshua.r.marshall.1991@gmail.com
---
gnu/packages/cpp.scm | 12 +++++-------
1 file changed, 5 insertions(+), 7 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index ff10a4247b..487639c879 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -823,11 +823,9 @@ provides a number of utilities to make coding with expected cleaner.")
"0fmkyh1srkz2bx68agfa30sankg1ig1f95xqp8sp9wj3p9qilsv2"))
(modules '((guix build utils)))))
(build-system cmake-build-system)
-
- (inputs
- `(("gcc" ,gcc-10)))
- (synopsis "Header-only C++17 library for reflection for enums")
- (description "Static reflection for enums (to string, from string,
-iteration) for modern C++, work with any enum type without any macro or
-boilerplate code")
+ (native-inputs
+ `(("gcc" ,gcc-9)))
+ (synopsis "Header-only C++17 library for reflection on enums")
+ (description "C++17 static reflection for enums, allowing functions like
+ to string, from string, and iteration.")
(license license:expat)))
--
2.30.0
A
A
Anadon wrote on 9 Jan 2021 03:40
[PATCH 1/2] Added magic-enum header-only library as a package.
(address . guix-patches@gnu.org)
20210109024058.68902-2-joshua.r.marshall.1991@gmail.com
From: Josh Marshall <joshua.r.marshall.1991@gmail.com>

---
gnu/packages/cpp.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 00e006928e..ff10a4247b 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -807,3 +807,27 @@ code will be mixed in with the actual programming logic. This implementation
provides a number of utilities to make coding with expected cleaner.")
(home-page "https://tl.tartanllama.xyz/")
(license license:cc0)))
+
+(define-public magic-enum
+ (package
+ (name "magic-enum")
+ (version "0.7.2")
+ (home-page "https://github.com/Neargye/magic_enum")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "0fmkyh1srkz2bx68agfa30sankg1ig1f95xqp8sp9wj3p9qilsv2"))
+ (modules '((guix build utils)))))
+ (build-system cmake-build-system)
+
+ (inputs
+ `(("gcc" ,gcc-10)))
+ (synopsis "Header-only C++17 library for reflection for enums")
+ (description "Static reflection for enums (to string, from string,
+iteration) for modern C++, work with any enum type without any macro or
+boilerplate code")
+ (license license:expat)))
--
2.30.0
L
L
Leo Prikler wrote on 9 Jan 2021 08:51
[bug#45604] [PATCH 0/2] Added magic-enum header-only library as a package.
(address . joshua.r.marshall.1991@gmail.com)(address . 45604@debbugs.gnu.org)
734fefc52faea2d05b562f823dcc844696d7aed1.camel@student.tugraz.at
Hello Anadon,

three nitpicks:
1. You should squash the changes into the original commit.
2. The commit message(s) is/are still missing.
3. Please pick one name for your contributions.

Otherwise LGTM,
Leo
A
A
Anadon wrote on 14 Jan 2021 03:17
[PATCH 0/1] New package 'magic-enum'
(address . guix-patches@gnu.org)
20210114021711.52857-1-joshua.r.marshall.1991@gmail.com
Added a simple package definition for the C++17 header only library
'magic-enum'.

Anadon (1):
Added a package definition for the C++17 header only library
'magic-enum'.

gnu/packages/cpp.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

--
2.27.0
A
A
Anadon wrote on 14 Jan 2021 03:17
[PATCH 1/1] Added a package definition for the C++17 header only library 'magic-enum'.
(address . guix-patches@gnu.org)
20210114021711.52857-2-joshua.r.marshall.1991@gmail.com
gnu/packages/cpp.scm: Added the package definition.
---
gnu/packages/cpp.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 00e006928e..ff10a4247b 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -807,3 +807,27 @@ code will be mixed in with the actual programming logic. This implementation
provides a number of utilities to make coding with expected cleaner.")
(home-page "https://tl.tartanllama.xyz/")
(license license:cc0)))
+
+(define-public magic-enum
+ (package
+ (name "magic-enum")
+ (version "0.7.2")
+ (home-page "https://github.com/Neargye/magic_enum")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "0fmkyh1srkz2bx68agfa30sankg1ig1f95xqp8sp9wj3p9qilsv2"))
+ (modules '((guix build utils)))))
+ (build-system cmake-build-system)
+
+ (inputs
+ `(("gcc" ,gcc-10)))
+ (synopsis "Header-only C++17 library for reflection for enums")
+ (description "Static reflection for enums (to string, from string,
+iteration) for modern C++, work with any enum type without any macro or
+boilerplate code")
+ (license license:expat)))
--
2.27.0
A
A
Anadon wrote on 14 Jan 2021 03:36
[PATCH 0/1] New package 'magic-enum'
(address . guix-patches@gnu.org)
20210114023630.53568-1-joshua.r.marshall.1991@gmail.com
Added a simple package definition for the C++17 header only library
'magic-enum'.

Anadon (1):
Added a package definition for the C++17 header only library
'magic-enum'.

gnu/packages/cpp.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

--
2.27.0
A
A
Anadon wrote on 14 Jan 2021 03:36
[PATCH 1/1] Added a package definition for the C++17 header only library 'magic-enum'.
(address . guix-patches@gnu.org)
20210114023630.53568-2-joshua.r.marshall.1991@gmail.com
gnu/packages/cpp.scm: Added the package definition.
---
gnu/packages/cpp.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 00e006928e..673867dbd2 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -807,3 +807,27 @@ code will be mixed in with the actual programming logic. This implementation
provides a number of utilities to make coding with expected cleaner.")
(home-page "https://tl.tartanllama.xyz/")
(license license:cc0)))
+
+(define-public magic-enum
+ (package
+ (name "magic-enum")
+ (version "0.7.2")
+ (home-page "https://github.com/Neargye/magic_enum")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "0fmkyh1srkz2bx68agfa30sankg1ig1f95xqp8sp9wj3p9qilsv2"))
+ (modules '((guix build utils)))))
+ (build-system cmake-build-system)
+
+ (inputs
+ `(("gcc" ,gcc-9)))
+ (synopsis "C++17 header only library for compile time reflection of enums")
+ (description "C++17 header only library which offers static reflection
+of enums, with to string, from string, and iteration, and related
+functionality.")
+ (license license:expat)))
--
2.27.0
L
L
Leo Prikler wrote on 14 Jan 2021 11:03
Please don't tag guix-patches in follow-ups
(address . control@debbugs.gnu.org)
b3ee40116e925066349799811038b8813b0332dd.camel@student.tugraz.at
merge 45604 45730 45731 45850 45851 45852 45853
L
L
Leo Prikler wrote on 14 Jan 2021 12:59
Re: [PATCH 1/1] Added a package definition for the C++17 header only library 'magic-enum'.
(name . Anadon)(address . joshua.r.marshall.1991@gmail.com)(address . 45604@debbugs.gnu.org)
6733a5f6ccb0bb3b189eaca8d61fd5bc58924d07.camel@student.tugraz.at
Hello Anadon,

I was prepared to overlook some formal errors and push this with some
slight adjustment, but my package build failed, so I'll have to make
you adjust it once again.

Am Mittwoch, den 13.01.2021, 21:36 -0500 schrieb Anadon:
Toggle quote (1 lines)
> gnu/packages/cpp.scm: Added the package definition.
The commit message for this package should be (minus indentation)

gnu: Add magic-enum.
* gnu/packages/cpp.scm (magic-enum): New variable.

to keep with the already established style.

You don't need to send a cover letter for a single patch. Also, don't
include guix-patches in your follow-up messages, but do CC me.
Additionally, it'd be nice if you used --reroll-count, but I'll sort
things out.

Toggle quote (25 lines)
> ---
> gnu/packages/cpp.scm | 24 ++++++++++++++++++++++++
> 1 file changed, 24 insertions(+)
>
> diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
> index 00e006928e..673867dbd2 100644
> --- a/gnu/packages/cpp.scm
> +++ b/gnu/packages/cpp.scm
> @@ -807,3 +807,27 @@ code will be mixed in with the actual
> programming logic. This implementation
> provides a number of utilities to make coding with expected
> cleaner.")
> (home-page "https://tl.tartanllama.xyz/")
> (license license:cc0)))
> +
> +(define-public magic-enum
> + (package
> + (name "magic-enum")
> + (version "0.7.2")
> + (home-page "https://github.com/Neargye/magic_enum")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url home-page)
> + (commit (string-append "v" version))))
Missing (file-name (git-file-name name version)).
This is needed with git-references as otherwise it'll just be named
"git-checkout", which isn't very helpful.
Toggle quote (4 lines)
> + (sha256
> + (base32
> + "0fmkyh1srkz2bx68agfa30sankg1ig1f95xqp8sp9wj3p9qil
> sv2"))
After I recently cleaned my checkout completely (unrelated bytecode
troubles), this hash does not match up the one I get with `guix build'.

r:sha256 hash mismatch for /gnu/store/ajxz311mls8ybih8cify2lcwnwkqd1wy-
git-checkout:
expected hash: 0fmkyh1srkz2bx68agfa30sankg1ig1f95xqp8sp9wj3p9qilsv2
actual hash: 07j5zdf3vkliwrcv6k663k35akn7qp23794sz2mnvkj9hbv9s8cx

Did something change upstream?
Toggle quote (1 lines)
> + (modules '((guix build utils)))))
modules should only be needed if you have a snippet.

Toggle quote (4 lines)
> + (build-system cmake-build-system)
> +
> + (inputs
> + `(("gcc" ,gcc-9)))
Should probably be native-inputs.
Toggle quote (8 lines)
> + (synopsis "C++17 header only library for compile time
> reflection of enums")
> + (description "C++17 header only library which offers static
> reflection
> +of enums, with to string, from string, and iteration, and related
> +functionality.")
> + (license license:expat)))

Regards,
Leo
A
A
Anadon wrote on 20 Jan 2021 05:09
[PATCH] gnu: Add magic-enum.
(address . 45604@debbugs.gnu.org)
20210120040924.43817-1-joshua.r.marshall.1991@gmail.com
* gnu/packages/cpp.scm (magic-enum): Added the package definition.
---
gnu/packages/cpp.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 00e006928e..012640171a 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -807,3 +807,27 @@ code will be mixed in with the actual programming logic. This implementation
provides a number of utilities to make coding with expected cleaner.")
(home-page "https://tl.tartanllama.xyz/")
(license license:cc0)))
+
+(define-public magic-enum
+ (package
+ (name "magic-enum")
+ (version "0.7.2")
+ (home-page "https://github.com/Neargye/magic_enum")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "07j5zdf3vkliwrcv6k663k35akn7qp23794sz2mnvkj9hbv9s8cx"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+
+ (native-inputs
+ `(("gcc" ,gcc-9)))
+ (synopsis "C++17 header only library for compile time reflection of enums")
+ (description "C++17 header only library which offers static reflection
+of enums, with to string, from string, and iteration, and relate324 d
+functionality.")
+ (license license:expat)))
--
2.30.0
L
L
Leo Prikler wrote on 20 Jan 2021 09:14
f8a34a253fbeaccf6e674c9095c537aed4827d37.camel@student.tugraz.at
Pushed with some slight changes in the description. Thanks!
Closed
?