[GAJIM]: Fix loading of installed plugins

  • Open
  • quality assurance status badge
Details
3 participants
  • Tobias Geerinckx-Rice
  • Raghav Gururajan
  • Raghav Gururajan
Owner
unassigned
Submitted by
Raghav Gururajan
Severity
normal
Merged with
R
R
Raghav Gururajan wrote on 18 Nov 2020 21:50
(address . guix-patches@gnu.org)(name . Julien Lepiller)(address . julien@lepiller.eu)
101c1bb4-2513-b1de-2962-436b4431f836@raghavgururajan.name
Hello Guix!

Please find the attached patch to fix plugins issue in Gajim.

@Julien
Will you be able to push this patch? This patch is a follow-up of #43575.

Thank you!

Regards,
RG.
From efa57cb42f620009b13f27774167e452d40a318b Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Wed, 18 Nov 2020 15:33:24 -0500
Subject: [PATCH] gnu: gajim: Fix loading of os-installed plugins.

* gnu/packages/messaging.scm (gajim) [patches]: Add gajim-plugins-os.patch.
[arguments]<#:phases>['add-plugins-dir]: Remove phase.
[native-search-paths]: Modify.
* gnu/packages/patches/gajim-plugins-os.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
---
gnu/local.mk | 1 +
gnu/packages/messaging.scm | 14 +++---------
gnu/packages/patches/gajim-plugins-os.patch | 25 +++++++++++++++++++++
3 files changed, 29 insertions(+), 11 deletions(-)
create mode 100644 gnu/packages/patches/gajim-plugins-os.patch

Toggle diff (84 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 217c05eab6..53bda11011 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -991,6 +991,7 @@ dist_patch_DATA = \
%D%/packages/patches/freedink-engine-fix-sdl-hints.patch \
%D%/packages/patches/freeimage-unbundle.patch \
%D%/packages/patches/fuse-overlapping-headers.patch \
+ %D%/packages/patches/gajim-plugins-os.patch \
%D%/packages/patches/ganeti-deterministic-manual.patch \
%D%/packages/patches/ganeti-disable-version-symlinks.patch \
%D%/packages/patches/ganeti-drbd-compat.patch \
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 624ad72c23..714cfa27d6 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -742,6 +742,8 @@ of xmpppy.")
(string-append "https://gajim.org/downloads/"
(version-major+minor version)
"/gajim-" version ".tar.gz"))
+ (patches
+ (search-patches "gajim-plugins-os.patch"))
(sha256
(base32 "1gfcp3b5nq43xxz5my8vfhfxnnli726j3hzcgwh9fzrzzd9ic3gx"))))
(build-system python-build-system)
@@ -756,16 +758,6 @@ of xmpppy.")
(guix build utils))
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'add-plugin-dirs
- (lambda _
- (substitute* "gajim/common/configpaths.py"
- (("_paths\\['PLUGINS_USER'\\]\\]")
- "_paths['PLUGINS_USER']] + \
-([os.getenv('GAJIM_PLUGIN_PATH')] \
-if os.getenv('GAJIM_PLUGIN_PATH') \
-and Path(os.getenv('GAJIM_PLUGIN_PATH')).is_dir() \
-else [])"))
- #t))
(replace 'check
(lambda _
;; Tests require a running X server.
@@ -795,7 +787,7 @@ else [])"))
(native-search-paths
(list
(search-path-specification
- (variable "GAJIM_PLUGIN_PATH")
+ (variable "PLUGINS_OS")
(separator #f) ;single entry
(files
(list
diff --git a/gnu/packages/patches/gajim-plugins-os.patch b/gnu/packages/patches/gajim-plugins-os.patch
new file mode 100644
index 0000000000..39c22803f7
--- /dev/null
+++ b/gnu/packages/patches/gajim-plugins-os.patch
@@ -0,0 +1,25 @@
+From c1974d64e5b8f03dc5fc9564f4dd8cff5f2cbc9b Mon Sep 17 00:00:00 2001
+From: Raghav Gururajan <raghavgururajan@disroot.org>
+Date: Wed, 18 Nov 2020 15:12:45 -0500
+Subject: [PATCH] [PATCH]: Fix loading of plugins installed via OS's package
+ manager.
+
+---
+ gajim/common/configpaths.py | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/gajim/common/configpaths.py b/gajim/common/configpaths.py
+index 0ac879314..57b99f955 100644
+--- a/gajim/common/configpaths.py
++++ b/gajim/common/configpaths.py
+@@ -47,6 +47,7 @@ def get_plugin_dirs() -> List[Path]:
+ return [Path(_paths['PLUGINS_BASE']),
+ Path('/app/plugins')]
+ return [Path(_paths['PLUGINS_BASE']),
++ Path(os.getenv['PLUGINS_OS']),
+ Path(_paths['PLUGINS_USER'])]
+
+
+--
+2.29.2
+
--
2.29.2
Attachment: OpenPGP_signature
R
R
Raghav Gururajan wrote on 19 Nov 2020 01:45
Merge Duplication
(address . control@debbugs.gnu.org)
52d136f0a3177cb14a2059b71a6fad5f@disroot.org
merge 44728 44730
T
T
Tobias Geerinckx-Rice wrote on 19 Nov 2020 15:44
Re: [bug#44730] [GAJIM]: Fix loading of installed plugins
(name . Raghav Gururajan)(address . rg@raghavgururajan.name)
87eekp76eo.fsf@nckx
Hullo Raghav!

Thanks for taking care of Gajim.

Raghav Gururajan ???
Toggle quote (2 lines)
> fix plugins issue in Gajim.

Please provide more information: what was wrong with the original
code, and why and how will your patch fix it? It's better to put
this in the commit message itself (above the change log), not just
the cover letter (your mail). No more than a few lines.

The more clear your explanation, the faster the fix can be
reviewed and merged.

I assume that the problem is the empty ‘Plugins’ list when I run:

$ guix environment guix \
-- ./pre-inst-env guix environment \
--pure --ad-hoc gajim{,-openpgp,-omemo} \
-- gajim

However, the fix doesn't look right to me.

After applying your patch, Gajim is broken. Menus don't work.

Toggle snippet (27 lines)
Traceback (most recent call last):
File
"/gnu/store/zd02xplbafrmzs2swrj3r3zx1hrsvg4y-gajim-1.2.2/lib/python3.8/site-packages/gajim/application.py",
line 222, in _activate
self.interface.run(self)
File
"/gnu/store/zd02xplbafrmzs2swrj3r3zx1hrsvg4y-gajim-1.2.2/lib/python3.8/site-packages/gajim/gui_interface.py",
line 1965, in run
app.plugin_manager = plugins.PluginManager()
File
"/gnu/store/zd02xplbafrmzs2swrj3r3zx1hrsvg4y-gajim-1.2.2/lib/python3.8/site-packages/gajim/common/helpers.py",
line 1002, in __call__
cls._instances[cls] = super(Singleton, cls).__call__(
File
"/gnu/store/zd02xplbafrmzs2swrj3r3zx1hrsvg4y-gajim-1.2.2/lib/python3.8/site-packages/gajim/plugins/pluginmanager.py",
line 224, in __init__
self._load_plugins()
File
"/gnu/store/zd02xplbafrmzs2swrj3r3zx1hrsvg4y-gajim-1.2.2/lib/python3.8/site-packages/gajim/plugins/pluginmanager.py",
line 668, in _load_plugins
for plugin_dir in configpaths.get_plugin_dirs():
File
"/gnu/store/zd02xplbafrmzs2swrj3r3zx1hrsvg4y-gajim-1.2.2/lib/python3.8/site-packages/gajim/common/configpaths.py",
line 50, in get_plugin_dirs
Path(os.getenv['PLUGINS_OS']),

I wrote my own patch (attached; no, I don't speak much Python). I
think it fixes the problem but I can't test it.
From 866593af88993ab5068f165b1284b8b4cb32e04e Mon Sep 17 00:00:00 2001
From: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Thu, 19 Nov 2020 15:20:14 +0100
Subject: [PATCH] gnu: gajim: Honour $GAJIM_PLUGIN_PATH.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

This perhaps fixes http://issues.guix.gnu.org/44730 maybe.

* gnu/packages/messaging.scm (gajim)[arguments]: Replace the
‘add-plugin-dirs’ substitution phase with a...
[source]: ...patch that won't silently break in the future.
* gnu/packages/patches/gajim-honour-GAJIM_PLUGIN_PATH.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
---
gnu/local.mk | 1 +
gnu/packages/messaging.scm | 13 ++-----------
.../patches/gajim-honour-GAJIM_PLUGIN_PATH.patch | 11 +++++++++++
3 files changed, 14 insertions(+), 11 deletions(-)
create mode 100644 gnu/packages/patches/gajim-honour-GAJIM_PLUGIN_PATH.patch

Toggle diff (62 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index a1da838aee..e728ed28d1 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -990,6 +990,7 @@ dist_patch_DATA = \
%D%/packages/patches/freedink-engine-fix-sdl-hints.patch \
%D%/packages/patches/freeimage-unbundle.patch \
%D%/packages/patches/fuse-overlapping-headers.patch \
+ %D%/packages/patches/gajim-honour-GAJIM_PLUGIN_PATH.patch \
%D%/packages/patches/ganeti-deterministic-manual.patch \
%D%/packages/patches/ganeti-disable-version-symlinks.patch \
%D%/packages/patches/ganeti-drbd-compat.patch \
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 624ad72c23..99131dcf05 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -743,7 +743,8 @@ of xmpppy.")
(version-major+minor version)
"/gajim-" version ".tar.gz"))
(sha256
- (base32 "1gfcp3b5nq43xxz5my8vfhfxnnli726j3hzcgwh9fzrzzd9ic3gx"))))
+ (base32 "1gfcp3b5nq43xxz5my8vfhfxnnli726j3hzcgwh9fzrzzd9ic3gx"))
+ (patches (search-patches "gajim-honour-GAJIM_PLUGIN_PATH.patch"))))
(build-system python-build-system)
(arguments
`(#:imported-modules
@@ -756,16 +757,6 @@ of xmpppy.")
(guix build utils))
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'add-plugin-dirs
- (lambda _
- (substitute* "gajim/common/configpaths.py"
- (("_paths\\['PLUGINS_USER'\\]\\]")
- "_paths['PLUGINS_USER']] + \
-([os.getenv('GAJIM_PLUGIN_PATH')] \
-if os.getenv('GAJIM_PLUGIN_PATH') \
-and Path(os.getenv('GAJIM_PLUGIN_PATH')).is_dir() \
-else [])"))
- #t))
(replace 'check
(lambda _
;; Tests require a running X server.
diff --git a/gnu/packages/patches/gajim-honour-GAJIM_PLUGIN_PATH.patch b/gnu/packages/patches/gajim-honour-GAJIM_PLUGIN_PATH.patch
new file mode 100644
index 0000000000..cb3313197c
--- /dev/null
+++ b/gnu/packages/patches/gajim-honour-GAJIM_PLUGIN_PATH.patch
@@ -0,0 +1,11 @@
+--- a/gajim/common/configpaths.py 2020-11-19 12:12:02.004414323 +0100
++++ a/gajim/common/configpaths.py 2020-11-19 15:34:52.211476895 +0100
+@@ -47,7 +47,7 @@
+ return [Path(_paths['PLUGINS_BASE']),
+ Path('/app/plugins')]
+ return [Path(_paths['PLUGINS_BASE']),
+- Path(_paths['PLUGINS_USER'])]
++ Path(_paths['PLUGINS_USER'])] + ([Path(os.getenv('GAJIM_PLUGIN_PATH'))] if os.getenv('GAJIM_PLUGIN_PATH') and Path(os.getenv('GAJIM_PLUGIN_PATH')).is_dir() else [])
+
+
+ def get_paths(type_: PathType) -> Generator[str, None, None]:
--
2.29.2
The plug-ins are found, but won't load with my version of Gajim.

Toggle snippet (7 lines)
11/19/20 15:10:01 (W) gajim.plugin_system Plugin omemo not
loaded, newer version of gajim required: 1.2.91 <= 1.2.2 <= 1.3.90
11/19/20 15:10:01 (W) gajim.plugin_system Plugin openpgp
not loaded, newer version of gajim required: 1.2.91 <= 1.2.2 <=
1.3.90

This is on current master. How are these plug-ins expected to be
used?

Toggle quote (3 lines)
> - (variable "GAJIM_PLUGIN_PATH")
> + (variable "PLUGINS_OS")

This doesn't look related to the fix at hand.

Why remove GAJIM_?
Why rename _PATH?
TBH, both strike me as unnecessary regressions.

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCX7aEzw0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW15hB8BAM726V8hc632zdEaX4KZWUya5B+VL0JK/oL9Kr42
9n83AQCLu7+Ezt4wozc7oJqgieulQtXufpeSj/Cwf2IC6Yx8BA==
=q9bR
-----END PGP SIGNATURE-----

R
R
Raghav Gururajan wrote on 19 Nov 2020 21:50
(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)
dba8fa42-86b1-a28b-2dc0-dc02ed6cacfd@raghavgururajan.name
Hello Tobias!

Toggle quote (2 lines)
> Thanks for taking care of Gajim.

Anytime! :-)

Toggle quote (11 lines)
> Raghav Gururajan ???
>> fix plugins issue in Gajim.
>
> Please provide more information: what was wrong with the original code,
> and why and how will your patch fix it?  It's better to put this in the
> commit message itself (above the change log), not just the cover letter
> (your mail).  No more than a few lines.
>
> The more clear your explanation, the faster the fix can be reviewed and
> merged.

I keep doing this, my apologies. I have included comment in commit
message of revised patch.

Toggle quote (7 lines)
> I assume that the problem is the empty ‘Plugins’ list when I run:
>
>  $ guix environment guix \
>    -- ./pre-inst-env guix environment \
>    --pure --ad-hoc gajim{,-openpgp,-omemo} \
>    -- gajim

Yes!

Toggle quote (26 lines)
> However, the fix doesn't look right to me.
>
> After applying your patch, Gajim is broken.  Menus don't work.
>
> --8<---------------cut here---------------start------------->8---
> Traceback (most recent call last):
>  File
>  "/gnu/store/zd02xplbafrmzs2swrj3r3zx1hrsvg4y-gajim-1.2.2/lib/python3.8/site-packages/gajim/application.py",  line 222, in _activate
>    self.interface.run(self)
>  File
>  "/gnu/store/zd02xplbafrmzs2swrj3r3zx1hrsvg4y-gajim-1.2.2/lib/python3.8/site-packages/gajim/gui_interface.py",  line 1965, in run
>    app.plugin_manager = plugins.PluginManager()
>  File
>  "/gnu/store/zd02xplbafrmzs2swrj3r3zx1hrsvg4y-gajim-1.2.2/lib/python3.8/site-packages/gajim/common/helpers.py",  line 1002, in __call__
>    cls._instances[cls] = super(Singleton, cls).__call__(
>  File
>  "/gnu/store/zd02xplbafrmzs2swrj3r3zx1hrsvg4y-gajim-1.2.2/lib/python3.8/site-packages/gajim/plugins/pluginmanager.py",  line 224, in __init__
>    self._load_plugins()
>  File
>  "/gnu/store/zd02xplbafrmzs2swrj3r3zx1hrsvg4y-gajim-1.2.2/lib/python3.8/site-packages/gajim/plugins/pluginmanager.py",  line 668, in _load_plugins
>    for plugin_dir in configpaths.get_plugin_dirs():
>  File
>  "/gnu/store/zd02xplbafrmzs2swrj3r3zx1hrsvg4y-gajim-1.2.2/lib/python3.8/site-packages/gajim/common/configpaths.py",  line 50, in get_plugin_dirs
>    Path(os.getenv['PLUGINS_OS']),
> --8<---------------cut here---------------end--------------->8---

Sorry, I was misled by a dev. I tries your patch instead now.

Toggle quote (3 lines)
> I wrote my own patch (attached; no, I don't speak much Python).  I think
> it fixes the problem but I can't test it.

Thanks! I just tested it. It works. :-)

Toggle quote (11 lines)
> The plug-ins are found, but won't load with my version of Gajim.
>
> --8<---------------cut here---------------start------------->8---
> 11/19/20 15:10:01 (W) gajim.plugin_system        Plugin omemo not
> loaded, newer version of gajim required: 1.2.91 <= 1.2.2 <= 1.3.90
> 11/19/20 15:10:01 (W) gajim.plugin_system        Plugin openpgp not
> loaded, newer version of gajim required: 1.2.91 <= 1.2.2 <= 1.3.90
> --8<---------------cut here---------------end--------------->8---
>
> This is on current master.  How are these plug-ins expected to be used?

I think you installed plugins, both via guix and via gajim's plugin
installer. You should remove one of them.

Toggle quote (8 lines)
>> -       (variable "GAJIM_PLUGIN_PATH")
>> +       (variable "PLUGINS_OS")
>
> This doesn't look related to the fix at hand.
>
> Why remove GAJIM_?
> Why rename _PATH?
> TBH, both strike me as unnecessary regressions.
I was discussing with a Gajim Dev. They agreed to merge our patch in
Gajim's upstream. So it can be useful for other non-conventional distros
as well.

Regards,
RG.
From e102e488114673069f879afb3796a8e6fb69aaf4 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Thu, 19 Nov 2020 15:36:48 -0500
Subject: [PATCH] gnu: gajim: Fix loading of os-installed plugins.

* gnu/packages/messaging.scm (gajim) [patches]: Add gajim-plugins-os.patch.
[arguments]<#:phases>['add-plugins-dir]: Remove phase.
[native-search-paths]: Modify.
* gnu/packages/patches/gajim-plugins-os.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.

[1] The 'add-plugins-dir phase does not work for version 1.2.2,
so this patch is a work-around.
[2] The variable name is changed from GAJIM_PLUGINS_PATH to PLUGINS_OS,
to resonate close with variable names PLUGINS_BASE and PLUGINS_USER,
as this patch is planned to be merged in gajim's upstream.
---
gnu/local.mk | 1 +
gnu/packages/messaging.scm | 16 ++++---------
gnu/packages/patches/gajim-plugins-os.patch | 25 +++++++++++++++++++++
3 files changed, 30 insertions(+), 12 deletions(-)
create mode 100644 gnu/packages/patches/gajim-plugins-os.patch

Toggle diff (86 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 217c05eab6..7fd98876d7 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -991,6 +991,7 @@ dist_patch_DATA = \
%D%/packages/patches/freedink-engine-fix-sdl-hints.patch \
%D%/packages/patches/freeimage-unbundle.patch \
%D%/packages/patches/fuse-overlapping-headers.patch \
+ %D%/packages/patches/gajim-plugins-os.patch \
%D%/packages/patches/ganeti-deterministic-manual.patch \
%D%/packages/patches/ganeti-disable-version-symlinks.patch \
%D%/packages/patches/ganeti-drbd-compat.patch \
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 624ad72c23..09834bfe63 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -743,7 +743,9 @@ of xmpppy.")
(version-major+minor version)
"/gajim-" version ".tar.gz"))
(sha256
- (base32 "1gfcp3b5nq43xxz5my8vfhfxnnli726j3hzcgwh9fzrzzd9ic3gx"))))
+ (base32 "1gfcp3b5nq43xxz5my8vfhfxnnli726j3hzcgwh9fzrzzd9ic3gx"))
+ (patches
+ (search-patches "gajim-plugins-os.patch"))))
(build-system python-build-system)
(arguments
`(#:imported-modules
@@ -756,16 +758,6 @@ of xmpppy.")
(guix build utils))
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'add-plugin-dirs
- (lambda _
- (substitute* "gajim/common/configpaths.py"
- (("_paths\\['PLUGINS_USER'\\]\\]")
- "_paths['PLUGINS_USER']] + \
-([os.getenv('GAJIM_PLUGIN_PATH')] \
-if os.getenv('GAJIM_PLUGIN_PATH') \
-and Path(os.getenv('GAJIM_PLUGIN_PATH')).is_dir() \
-else [])"))
- #t))
(replace 'check
(lambda _
;; Tests require a running X server.
@@ -795,7 +787,7 @@ else [])"))
(native-search-paths
(list
(search-path-specification
- (variable "GAJIM_PLUGIN_PATH")
+ (variable "PLUGINS_OS")
(separator #f) ;single entry
(files
(list
diff --git a/gnu/packages/patches/gajim-plugins-os.patch b/gnu/packages/patches/gajim-plugins-os.patch
new file mode 100644
index 0000000000..80a0dfacaf
--- /dev/null
+++ b/gnu/packages/patches/gajim-plugins-os.patch
@@ -0,0 +1,25 @@
+From c8e8d29243222e52bb30e123f2c7321a9f418995 Mon Sep 17 00:00:00 2001
+From: Raghav Gururajan <raghavgururajan@disroot.org>
+Date: Thu, 19 Nov 2020 15:20:38 -0500
+Subject: [PATCH 3/3] [PATCH]: Fix loading of OS-installed plugins.
+
+---
+ gajim/common/configpaths.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/gajim/common/configpaths.py b/gajim/common/configpaths.py
+index 0ac879314..f4418b020 100644
+--- a/gajim/common/configpaths.py
++++ b/gajim/common/configpaths.py
+@@ -47,7 +47,7 @@ def get_plugin_dirs() -> List[Path]:
+ return [Path(_paths['PLUGINS_BASE']),
+ Path('/app/plugins')]
+ return [Path(_paths['PLUGINS_BASE']),
+- Path(_paths['PLUGINS_USER'])]
++ Path(_paths['PLUGINS_USER'])] + ([Path(os.getenv('PLUGINS_OS'))] if os.getenv('PLUGINS_OS') and Path(os.getenv('PLUGINS_OS')).is_dir() else [])
+
+
+ def get_paths(type_: PathType) -> Generator[Path, None, None]:
+--
+2.29.2
+
--
2.29.2
Attachment: OpenPGP_signature
R
R
Raghav Gururajan wrote on 19 Nov 2020 22:44
(name . Tobias Geerinckx-Rice)(address . me@tobias.gr)
413febc7-09cc-fd0b-18ee-eef5bd0b0305@raghavgururajan.name
Hello Tobias!

As we discussed in IRC, here are the patches to downgrade gajim-plugins.

Regards,
RG.
From 9fa851423882d67ade3d3a30aa84e294c8fdedc2 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Thu, 19 Nov 2020 16:35:08 -0500
Subject: [PATCH 1/2] gnu: gajim-omemo: Downgrade to 2.6.80.

* gnu/packages/messaging.scm (gajim-omemo) [version]: Downgrade to 2.6.80.

This gajim-plugin is downgraded to a version that is compatible with
stable version of gajim (1.2.2).
---
gnu/packages/messaging.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 624ad72c23..e970c3f000 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -859,7 +859,7 @@ and OpenPGP) and available in 29 languages.")
(define-public gajim-omemo
(package
(name "gajim-omemo")
- (version "2.7.9")
+ (version "2.6.80")
(source
(origin
(method url-fetch/zipbomb)
@@ -868,7 +868,7 @@ and OpenPGP) and available in 29 languages.")
"https://ftp.gajim.org/plugins_releases/omemo_"
version ".zip"))
(sha256
- (base32 "19si2v5yrxpn2m0f684npsg0iiyl2h3r5hbxyrxv4k3acmfmhb3z"))))
+ (base32 "179hgx091c12258335znn1540jhp4z3n3wv5ksrgqq7l3jgc93d7"))))
(build-system trivial-build-system)
(arguments
`(#:modules ((guix build utils))
--
2.29.2
From e97939170362cbcac58537f72d929c14a675d095 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Thu, 19 Nov 2020 16:40:17 -0500
Subject: [PATCH 2/2] gnu: gajim-openpgp: Downgrade to 1.2.14.

* gnu/packages/messaging.scm (gajim-openpgp) [version]: Downgrade to 1.2.14.

This gajim-plugin is downgraded to a version that is compatible with
the stable version of gajim (1.2.2).
---
gnu/packages/messaging.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index e970c3f000..9a2034f253 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -897,7 +897,7 @@ multi-client end-to-end encryption.")
(define-public gajim-openpgp
(package
(name "gajim-openpgp")
- (version "1.3.5")
+ (version "1.2.14")
(source
(origin
(method url-fetch/zipbomb)
@@ -906,7 +906,7 @@ multi-client end-to-end encryption.")
"https://ftp.gajim.org/plugins_releases/openpgp_"
version ".zip"))
(sha256
- (base32 "1jvpl2gjl5xxvsgxpmvh3mn2mm142dg2hknakkc32swb7l1fqx5m"))))
+ (base32 "0wdjpf1i4pvl4ha4plfpywwi9aw5n2mhrpv8mmbidpawxqfbd94b"))))
(build-system trivial-build-system)
(arguments
`(#:modules ((guix build utils))
--
2.29.2
Attachment: OpenPGP_signature
?