[PATCH] gnu: fonts.scm: Add nerd-fonts

  • Open
  • quality assurance status badge
Details
3 participants
  • Barnabas Beres
  • John Kehayias
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Barnabas Beres
Severity
normal
Merged with
B
B
Barnabas Beres wrote on 6 Nov 2020 09:09
(address . guix-patches@gnu.org)(name . Barnabas Beres)(address . beresbarnus03@gmail.com)
20201106080938.821-2-beresbarnus03@gmail.com
* gnu/packages/fonts.scm (nerd-fonts): New variable
---
gnu/packages/fonts.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 360a3ece76..3969d5eb97 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -38,6 +38,7 @@
;;; Copyright © 2020 Simen Endsjø <simendsjo@gmail.com>
;;; Copyright © 2020 Tim Van den Langenbergh <tmt_vdl@gmx.com>
;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
+;;; Copyright © 2020 Barnabas Beres <beresbarnus03@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1979,3 +1980,36 @@ operators and special symbols.")
is a stylish type with a polished yet relaxed feel. Its versatility makes it
suitable for a wide range of uses.")
(license license:silofl1.1))))
+
+(define-public font-nerd-fonts
+ (package
+ (name "font-nerd-fonts")
+ (version "2.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ryanoasis/nerd-fonts")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1la79y16k9rwcl2zsxk73c0kgdms2ma43kpjfqnq5jlbfdj0niwg"))))
+ (build-system font-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'make-files-writable
+ (lambda _
+ (for-each
+ make-file-writable
+ (find-files "." ".*\\.(otf|otc|ttf|ttc)$"))
+ #t)))))
+ (home-page "https://www.nerdfonts.com/")
+ (synopsis "Iconic font aggregator, collection, and patcher")
+ (description
+ "Nerd Fonts patches developer targeted fonts with a high number
+of glyphs (icons). Specifically to add a high number of extra glyphs
+from popular ‘iconic fonts’ such as Font Awesome, Devicons, Octicons,
+and others.")
+ (license license:expat)))
--
2.26.0
T
T
Tobias Geerinckx-Rice wrote on 6 Nov 2020 12:30
(no subject)
(address . control@debbugs.gnu.org)
87361md8ni.fsf@nckx
merge 44476 44477 44478
thanks
ur the best
B
B
Barnabás Béres wrote on 6 Nov 2020 13:30
[PATCH] gnu: fonts.scm: Add nerd-fonts
(address . 44478@debbugs.gnu.org)
CAOcmTtd+FUOXtrZ_tkNfu4O=ZkM6hq9b41W1fhkQnzxaQ5DVEw@mail.gmail.com
Thanks! I will close this issue
Attachment: file
B
B
Barnabás Béres wrote on 6 Nov 2020 10:27
(address . 44478-done@debbugs.gnu.org)
CAOcmTtfH90kyU1_7Si60qDd40USgW0deYs9APnYNcRtcrpWjWw@mail.gmail.com
close 44478
Attachment: file
Closed
B
B
Barnabás Béres wrote on 6 Nov 2020 16:30
(address . 44478@debbugs.gnu.org)
CAOcmTtfeUbSU7MimT-JTZPb=-dFOHNTXJ1R2ZZOGAJzpLti0SA@mail.gmail.com
reopen 44478
Attachment: file
J
J
John Kehayias wrote on 18 Aug 2021 22:23
bug#44476 ([PATCH] gnu: fonts.scm: Add nerd-fonts)
(name . control@debbugs.gnu.org)(address . control@debbugs.gnu.org)
9hfMGTmQi7lAIwLMpO3bG-nVQCm2Pogo7gZi2JIstUqUoNr2k7CLVxhJvFuJHNEZX8QuOs6aqns1s7G0DenBPyxuqQyyN3GBBaiEESqvLjE=@protonmail.com
unarchive 44476
reopen 44476
J
J
John Kehayias wrote on 18 Aug 2021 22:29
(address . control@debbugs.gnu.org)
YvrkkHBrI1lwrqHuQRfvjVNDrsSmHHpf4M8z7GYI2GvnhcWnkWQGP-T0QGdu9XPiJkUMhKDyAqNzMPGc3NXHUtWSD-sgf1SBkU1yRU8vpGY=@protonmail.com
merge 44575 44476
?