[PATCH] gnu: fonts.scm: Add nerd-fonts

  • Open
  • quality assurance status badge
Details
3 participants
  • Barnabas Beres
  • John Kehayias
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Barnabas Beres
Severity
normal
Merged with
B
B
Barnabas Beres wrote on 6 Nov 2020 08:36
(address . guix-patches@gnu.org)(name . Barnabas Beres)(address . beresbarnus03@gmail.com)
20201106073600.1640-1-beresbarnus03@gmail.com
* gnu/packages/fonts.scm (nerd-fonts): New variable
---
gnu/packages/fonts.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 360a3ece76..3969d5eb97 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -38,6 +38,7 @@
;;; Copyright © 2020 Simen Endsjø <simendsjo@gmail.com>
;;; Copyright © 2020 Tim Van den Langenbergh <tmt_vdl@gmx.com>
;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
+;;; Copyright © 2020 Barnabas Beres <beresbarnus03@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1979,3 +1980,36 @@ operators and special symbols.")
is a stylish type with a polished yet relaxed feel. Its versatility makes it
suitable for a wide range of uses.")
(license license:silofl1.1))))
+
+(define-public font-nerd-fonts
+ (package
+ (name "font-nerd-fonts")
+ (version "2.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ryanoasis/nerd-fonts")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1la79y16k9rwcl2zsxk73c0kgdms2ma43kpjfqnq5jlbfdj0niwg"))))
+ (build-system font-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'make-files-writable
+ (lambda _
+ (for-each
+ make-file-writable
+ (find-files "." ".*\\.(otf|otc|ttf|ttc)$"))
+ #t)))))
+ (home-page "https://www.nerdfonts.com/")
+ (synopsis "Iconic font aggregator, collection, and patcher")
+ (description
+ "Nerd Fonts patches developer targeted fonts with a high number
+of glyphs (icons). Specifically to add a high number of extra glyphs
+from popular ‘iconic fonts’ such as Font Awesome, Devicons, Octicons,
+and others.")
+ (license license:expat)))
--
2.26.0
T
T
Tobias Geerinckx-Rice wrote on 6 Nov 2020 12:30
(no subject)
(address . control@debbugs.gnu.org)
87361md8ni.fsf@nckx
merge 44476 44477 44478
thanks
ur the best
T
T
Tobias Geerinckx-Rice wrote on 6 Nov 2020 12:48
Re: [PATCH] gnu: fonts.scm: Add nerd-fonts
(address . 44476@debbugs.gnu.org)
87zh3ubt9d.fsf@nckx
Barnabas,

Thank you for your contribution!

Sending multiple mails to bug-guix@ requires a ritual dance[0]
with our bug tracker.

Every time you send mail to bug-guix@gnu.org without CC'ing a bug
number, the Debbugs software will create a new bug number for you.
Unconditionally. In this case, http://issues.guix.gnu.org/44476,
/44477, and /44478. I've merged them.

Kind regards,

T G-R

[0]:
-----BEGIN PGP SIGNATURE-----

iIMEARYKACsWIQT12iAyS4c9C3o4dnINsP+IT1VteQUCX6U4Hg0cbWVAdG9iaWFz
LmdyAAoJEA2w/4hPVW15QkoA/09z7QebirNvoMZqM5j5izHNkPRHPa6zrHtb2QR4
zUGlAP9VBubkLFZl1M4ef6Sjw4OPQTVHzmf3FO9XeJeR+a3aDg==
=Z/es
-----END PGP SIGNATURE-----

J
J
John Kehayias wrote on 18 Aug 2021 22:23
bug#44476 ([PATCH] gnu: fonts.scm: Add nerd-fonts)
(name . control@debbugs.gnu.org)(address . control@debbugs.gnu.org)
9hfMGTmQi7lAIwLMpO3bG-nVQCm2Pogo7gZi2JIstUqUoNr2k7CLVxhJvFuJHNEZX8QuOs6aqns1s7G0DenBPyxuqQyyN3GBBaiEESqvLjE=@protonmail.com
unarchive 44476
reopen 44476
J
J
John Kehayias wrote on 18 Aug 2021 22:29
(address . control@debbugs.gnu.org)
YvrkkHBrI1lwrqHuQRfvjVNDrsSmHHpf4M8z7GYI2GvnhcWnkWQGP-T0QGdu9XPiJkUMhKDyAqNzMPGc3NXHUtWSD-sgf1SBkU1yRU8vpGY=@protonmail.com
merge 44575 44476
?