[PATCH 0/1] gnu: emacs-tuareg: Update to 2.2.0-0.ccde45b.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • zimoun
Owner
unassigned
Submitted by
zimoun
Severity
normal
Z
Z
zimoun wrote on 5 Oct 2020 09:23
(address . guix-patches@gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20201005072342.17369-1-zimon.toutoune@gmail.com
Dear,

This patch updates to the last revision. The main argument is to fix the
annoying warning message about "Package cl deprecated". It has been fixed
upstream by the commit f1fb36d2dbc34c989300662a4d94d7cdd8234f9e [1].
Moreover, this commit also fixes 'lexical-binding'.

Last, note that even nothing had been released, the last upstream commit is
from Sep. 16, 2018.



All the best,
simon

zimoun (1):
gnu: emacs-tuareg: Update to 2.2.0-0.ccde45b.

gnu/packages/ocaml.scm | 84 +++++++++++++++++++++---------------------
1 file changed, 43 insertions(+), 41 deletions(-)


base-commit: 435e5e27742eb71796be8a73be7a6549fd5e9582
--
2.28.0
Z
Z
zimoun wrote on 5 Oct 2020 09:25
[PATCH 1/1] gnu: emacs-tuareg: Update to 2.2.0-0.ccde45b.
(address . 43809@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20201005072501.17848-1-zimon.toutoune@gmail.com
* gnu/packages/ocaml.scm (emacs-tuareg): Update to 2.2.0-0.ccde45b.
---
gnu/packages/ocaml.scm | 84 +++++++++++++++++++++---------------------
1 file changed, 43 insertions(+), 41 deletions(-)

Toggle diff (106 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index d61948afc3..c16fcc5bd1 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2020 Simon Tournier <zimon.toutoune@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -672,49 +673,50 @@ the OCaml core distribution.")
(license license:lgpl2.1+))); with linking exception
(define-public emacs-tuareg
- (package
- (name "emacs-tuareg")
- (version "2.2.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/ocaml/tuareg")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "06zxnn85fk5087iq0zxc5l5n9fz8r0367wylmynbfhc9711vccy6"))))
- (build-system gnu-build-system)
- (native-inputs `(("emacs" ,emacs-minimal)
- ("opam" ,opam)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'make-git-checkout-writable
- (lambda _
- (for-each make-file-writable (find-files "."))
- #t))
- (delete 'configure)
- (add-before 'install 'fix-install-path
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "Makefile"
- (("/emacs/site-lisp")
- (string-append (assoc-ref %outputs "out")
- "/share/emacs/site-lisp/")))
- #t))
- (add-after 'install 'post-install
- (lambda* (#:key outputs #:allow-other-keys)
- (symlink "tuareg.el"
- (string-append (assoc-ref outputs "out")
- "/share/emacs/site-lisp/"
- "tuareg-autoloads.el"))
- #t)))))
- (home-page "https://github.com/ocaml/tuareg")
- (synopsis "OCaml programming mode, REPL, debugger for Emacs")
- (description "Tuareg helps editing OCaml code, to highlight important
+ (let ((commit "ccde45bbc292123ec20617f1af7f7e19f7481545"))
+ (package
+ (name "emacs-tuareg")
+ (version (git-version "2.2.0" "0" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ocaml/tuareg")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1yxv4bnqarilnpg5j7wywall8170hwvm0q4xx06yqjgcn8pq1lac"))))
+ (build-system gnu-build-system)
+ (native-inputs `(("emacs" ,emacs-minimal)
+ ("opam" ,opam)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'make-git-checkout-writable
+ (lambda _
+ (for-each make-file-writable (find-files "."))
+ #t))
+ (delete 'configure)
+ (add-before 'install 'fix-install-path
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "Makefile"
+ (("/emacs/site-lisp")
+ (string-append (assoc-ref %outputs "out")
+ "/share/emacs/site-lisp/")))
+ #t))
+ (add-after 'install 'post-install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (symlink "tuareg.el"
+ (string-append (assoc-ref outputs "out")
+ "/share/emacs/site-lisp/"
+ "tuareg-autoloads.el"))
+ #t)))))
+ (home-page "https://github.com/ocaml/tuareg")
+ (synopsis "OCaml programming mode, REPL, debugger for Emacs")
+ (description "Tuareg helps editing OCaml code, to highlight important
parts of the code, to run an OCaml REPL, and to run the OCaml debugger within
Emacs.")
- (license license:gpl2+)))
+ (license license:gpl2+))))
(define-public ocaml-menhir
(package
--
2.28.0
N
N
Nicolas Goaziou wrote on 7 Oct 2020 21:43
Re: [bug#43809] [PATCH 1/1] gnu: emacs-tuareg: Update to 2.2.0-0.ccde45b.
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 43809@debbugs.gnu.org)
871ri9bz55.fsf@nicolasgoaziou.fr
Hello,

zimoun <zimon.toutoune@gmail.com> writes:

Toggle quote (2 lines)
> * gnu/packages/ocaml.scm (emacs-tuareg): Update to 2.2.0-0.ccde45b.

Thank you. Some minor comments follow.

Toggle quote (2 lines)
> + (let ((commit "ccde45bbc292123ec20617f1af7f7e19f7481545"))

I suggest to add a comment explaining why we do not use regular release.

Toggle quote (16 lines)
> + (package
> + (name "emacs-tuareg")
> + (version (git-version "2.2.0" "0" commit))
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/ocaml/tuareg")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "1yxv4bnqarilnpg5j7wywall8170hwvm0q4xx06yqjgcn8pq1lac"))))
> + (build-system gnu-build-system)
> + (native-inputs `(("emacs" ,emacs-minimal)
> + ("opam" ,opam)))

Nitpick: Please move these inputs below `native-inputs'.

Otherwise, LGTM.

Regards,
--
Nicolas Goaziou
Z
Z
zimoun wrote on 9 Oct 2020 00:25
[PATCH v2] gnu: emacs-tuareg: Update to 2.2.0-0.ccde45b.
(address . 43809@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20201008222532.19034-1-zimon.toutoune@gmail.com
* gnu/packages/ocaml.scm (emacs-tuareg): Update to 2.2.0-0.ccde45b.
---
gnu/packages/ocaml.scm | 87 ++++++++++++++++++++++--------------------
1 file changed, 46 insertions(+), 41 deletions(-)

Toggle diff (111 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index d61948afc3..9ad17ec49c 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2020 Simon Tournier <zimon.toutoune@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -672,49 +673,53 @@ the OCaml core distribution.")
(license license:lgpl2.1+))); with linking exception
(define-public emacs-tuareg
- (package
- (name "emacs-tuareg")
- (version "2.2.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/ocaml/tuareg")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "06zxnn85fk5087iq0zxc5l5n9fz8r0367wylmynbfhc9711vccy6"))))
- (build-system gnu-build-system)
- (native-inputs `(("emacs" ,emacs-minimal)
- ("opam" ,opam)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'make-git-checkout-writable
- (lambda _
- (for-each make-file-writable (find-files "."))
- #t))
- (delete 'configure)
- (add-before 'install 'fix-install-path
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "Makefile"
- (("/emacs/site-lisp")
- (string-append (assoc-ref %outputs "out")
- "/share/emacs/site-lisp/")))
- #t))
- (add-after 'install 'post-install
- (lambda* (#:key outputs #:allow-other-keys)
- (symlink "tuareg.el"
- (string-append (assoc-ref outputs "out")
- "/share/emacs/site-lisp/"
- "tuareg-autoloads.el"))
- #t)))))
- (home-page "https://github.com/ocaml/tuareg")
- (synopsis "OCaml programming mode, REPL, debugger for Emacs")
- (description "Tuareg helps editing OCaml code, to highlight important
+ ;; Last upstream release on Sept., 14th, 2018, since then "Package cl
+ ;; deprecated" or 'lexical-binding' and others had been fixed.
+ (let ((commit "ccde45bbc292123ec20617f1af7f7e19f7481545"))
+ (package
+ (name "emacs-tuareg")
+ (version (git-version "2.2.0" "0" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ocaml/tuareg")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1yxv4bnqarilnpg5j7wywall8170hwvm0q4xx06yqjgcn8pq1lac"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("emacs" ,emacs-minimal)
+ ("opam" ,opam)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'make-git-checkout-writable
+ (lambda _
+ (for-each make-file-writable (find-files "."))
+ #t))
+ (delete 'configure)
+ (add-before 'install 'fix-install-path
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "Makefile"
+ (("/emacs/site-lisp")
+ (string-append (assoc-ref %outputs "out")
+ "/share/emacs/site-lisp/")))
+ #t))
+ (add-after 'install 'post-install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (symlink "tuareg.el"
+ (string-append (assoc-ref outputs "out")
+ "/share/emacs/site-lisp/"
+ "tuareg-autoloads.el"))
+ #t)))))
+ (home-page "https://github.com/ocaml/tuareg")
+ (synopsis "OCaml programming mode, REPL, debugger for Emacs")
+ (description "Tuareg helps editing OCaml code, to highlight important
parts of the code, to run an OCaml REPL, and to run the OCaml debugger within
Emacs.")
- (license license:gpl2+)))
+ (license license:gpl2+))))
(define-public ocaml-menhir
(package

base-commit: 7e917283d71fee1a29363e113f29c8c21f7c4739
--
2.28.0
Z
Z
zimoun wrote on 9 Oct 2020 00:28
Re: [bug#43809] [PATCH 1/1] gnu: emacs-tuareg: Update to 2.2.0-0.ccde45b.
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 43809@debbugs.gnu.org)
CAJ3okZ1FNYSKF0+f4mES3aREQ85gPSoqUraVLVVbOgKNvtLQ9w@mail.gmail.com
Hi Nicolas,

Thank you for the review. The v2 is sent.


On Wed, 7 Oct 2020 at 21:43, Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:

Toggle quote (4 lines)
> > + (let ((commit "ccde45bbc292123ec20617f1af7f7e19f7481545"))
>
> I suggest to add a comment explaining why we do not use regular release.

Done but I was not very inspired. :-)


Toggle quote (5 lines)
> > + (native-inputs `(("emacs" ,emacs-minimal)
> > + ("opam" ,opam)))
>
> Nitpick: Please move these inputs below `native-inputs'.

Thank you for the nitpick. Done. To be honest, I am not tweaked this line. :-)

Cheers,
simon
N
N
Nicolas Goaziou wrote on 13 Oct 2020 09:30
Re: [bug#43809] [PATCH v2] gnu: emacs-tuareg: Update to 2.2.0-0.ccde45b.
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 43809@debbugs.gnu.org)
87a6wq60rw.fsf@nicolasgoaziou.fr
Hello,

zimoun <zimon.toutoune@gmail.com> writes:

Toggle quote (2 lines)
> * gnu/packages/ocaml.scm (emacs-tuareg): Update to 2.2.0-0.ccde45b.

Thank you.

Toggle quote (7 lines)
> + ;; Last upstream release on Sept., 14th, 2018, since then "Package cl
> + ;; deprecated" or 'lexical-binding' and others had been fixed.
> + (let ((commit "ccde45bbc292123ec20617f1af7f7e19f7481545"))
> + (package
> + (name "emacs-tuareg")
> + (version (git-version "2.2.0" "0" commit))

I suggest to bind "0" to `revision' instead of hard-coding it here.
Otherwise, LGTM.

Toggle quote (11 lines)
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/ocaml/tuareg")
> + (commit commit)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "1yxv4bnqarilnpg5j7wywall8170hwvm0q4xx06yqjgcn8pq1lac"))))
> + (build-system gnu-build-system)

I assume emacs-build-system is not an option, right?

Regards,
--
Nicolas Goaziou
Z
Z
zimoun wrote on 13 Oct 2020 10:34
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 43809@debbugs.gnu.org)
CAJ3okZ2iMqKZfzUGLsNvtNfpzThGvm77z5b=z654xbHBnGU7Cw@mail.gmail.com
Hi,

On Tue, 13 Oct 2020 at 09:30, Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:

Toggle quote (13 lines)
> > + (source
> > + (origin
> > + (method git-fetch)
> > + (uri (git-reference
> > + (url "https://github.com/ocaml/tuareg")
> > + (commit commit)))
> > + (file-name (git-file-name name version))
> > + (sha256
> > + (base32 "1yxv4bnqarilnpg5j7wywall8170hwvm0q4xx06yqjgcn8pq1lac"))))
> > + (build-system gnu-build-system)
>
> I assume emacs-build-system is not an option, right?

I do not know. I have just tried to fix an annoying message with my
Emacs config, not really tried to check the Tuareg package itsefl. :-)
What do you mean? Use the OCaml build system instead?

Thanks for the review.

All the best,
simon
N
N
Nicolas Goaziou wrote on 13 Oct 2020 11:36
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 43809@debbugs.gnu.org)
871ri25uyg.fsf@nicolasgoaziou.fr
zimoun <zimon.toutoune@gmail.com> writes:

Toggle quote (21 lines)
> Hi,
>
> On Tue, 13 Oct 2020 at 09:30, Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:
>
>> > + (source
>> > + (origin
>> > + (method git-fetch)
>> > + (uri (git-reference
>> > + (url "https://github.com/ocaml/tuareg")
>> > + (commit commit)))
>> > + (file-name (git-file-name name version))
>> > + (sha256
>> > + (base32 "1yxv4bnqarilnpg5j7wywall8170hwvm0q4xx06yqjgcn8pq1lac"))))
>> > + (build-system gnu-build-system)
>>
>> I assume emacs-build-system is not an option, right?
>
> I do not know. I have just tried to fix an annoying message with my
> Emacs config, not really tried to check the Tuareg package itsefl. :-)
> What do you mean? Use the OCaml build system instead?

AFAICT, I see mostly elisp files in the repository, and all the
additional phases in the package are already handled by Emacs build
system. So, I thought using emacs-build-system would be enough. I didn't
try it, tho.

But this is indeed orthogonal to your patch, so I think you can push it
as-is.

Regards,
Z
Z
zimoun wrote on 13 Oct 2020 12:53
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 43809@debbugs.gnu.org)
86pn5mmm7f.fsf@gmail.com
Hi Nicolas,

Please find attached the v3 tweaking the ’revision’ “0”.


On Tue, 13 Oct 2020 at 11:36, Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:

Toggle quote (2 lines)
>>> I assume emacs-build-system is not an option, right?

[...]

Toggle quote (5 lines)
> AFAICT, I see mostly elisp files in the repository, and all the
> additional phases in the package are already handled by Emacs build
> system. So, I thought using emacs-build-system would be enough. I didn't
> try it, tho.

I tried and I do not know… It seems building successfully. Even if I
have not checked if the result is functional. However, the ’check’
phase needs revamp, I guess.

Well, the replacement needs more care than a simple drop-in. :-)


All the best,
simon

-- >8 --
From 8c7d3838648e5f5b1d6dc6292550e35cf9413f82 Mon Sep 17 00:00:00 2001
From: zimoun <zimon.toutoune@gmail.com>
Date: Mon, 5 Oct 2020 09:14:54 +0200
Subject: [PATCH v3] gnu: emacs-tuareg: Update to 2.2.0-0.ccde45b.

* gnu/packages/ocaml.scm (emacs-tuareg): Update to 2.2.0-0.ccde45b.
---
gnu/packages/ocaml.scm | 88 ++++++++++++++++++++++--------------------
1 file changed, 47 insertions(+), 41 deletions(-)

Toggle diff (110 lines)
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index d61948afc3..2abe63238e 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2020 Simon Tournier <zimon.toutoune@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -672,49 +673,54 @@ the OCaml core distribution.")
(license license:lgpl2.1+))); with linking exception
(define-public emacs-tuareg
- (package
- (name "emacs-tuareg")
- (version "2.2.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/ocaml/tuareg")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "06zxnn85fk5087iq0zxc5l5n9fz8r0367wylmynbfhc9711vccy6"))))
- (build-system gnu-build-system)
- (native-inputs `(("emacs" ,emacs-minimal)
- ("opam" ,opam)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'make-git-checkout-writable
- (lambda _
- (for-each make-file-writable (find-files "."))
- #t))
- (delete 'configure)
- (add-before 'install 'fix-install-path
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "Makefile"
- (("/emacs/site-lisp")
- (string-append (assoc-ref %outputs "out")
- "/share/emacs/site-lisp/")))
- #t))
- (add-after 'install 'post-install
- (lambda* (#:key outputs #:allow-other-keys)
- (symlink "tuareg.el"
- (string-append (assoc-ref outputs "out")
- "/share/emacs/site-lisp/"
- "tuareg-autoloads.el"))
- #t)))))
- (home-page "https://github.com/ocaml/tuareg")
- (synopsis "OCaml programming mode, REPL, debugger for Emacs")
- (description "Tuareg helps editing OCaml code, to highlight important
+ ;; Last upstream release on Sept., 14th, 2018, since then "Package cl
+ ;; deprecated" or 'lexical-binding' and others had been fixed.
+ (let ((commit "ccde45bbc292123ec20617f1af7f7e19f7481545")
+ (revision "0"))
+ (package
+ (name "emacs-tuareg")
+ (version (git-version "2.2.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ocaml/tuareg")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1yxv4bnqarilnpg5j7wywall8170hwvm0q4xx06yqjgcn8pq1lac"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("emacs" ,emacs-minimal)
+ ("opam" ,opam)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'make-git-checkout-writable
+ (lambda _
+ (for-each make-file-writable (find-files "."))
+ #t))
+ (delete 'configure)
+ (add-before 'install 'fix-install-path
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "Makefile"
+ (("/emacs/site-lisp")
+ (string-append (assoc-ref %outputs "out")
+ "/share/emacs/site-lisp/")))
+ #t))
+ (add-after 'install 'post-install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (symlink "tuareg.el"
+ (string-append (assoc-ref outputs "out")
+ "/share/emacs/site-lisp/"
+ "tuareg-autoloads.el"))
+ #t)))))
+ (home-page "https://github.com/ocaml/tuareg")
+ (synopsis "OCaml programming mode, REPL, debugger for Emacs")
+ (description "Tuareg helps editing OCaml code, to highlight important
parts of the code, to run an OCaml REPL, and to run the OCaml debugger within
Emacs.")
- (license license:gpl2+)))
+ (license license:gpl2+))))
(define-public ocaml-menhir
(package
--
2.28.0
Z
Z
zimoun wrote on 19 Oct 2020 09:58
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 43809@debbugs.gnu.org)
CAJ3okZ3xw4_j1bKjxEsBBW7ai-d2Boe_V+hqjiuJM6wbjgCecw@mail.gmail.com
Hi Nicolas,

Friendly ping. The patch is attached to:


Tell me if something does not like correct.


All the best,
simon
N
N
Nicolas Goaziou wrote on 19 Oct 2020 17:20
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 43809@debbugs.gnu.org)
BD67B983-19CF-473B-BFE4-4F96B9D1F798@nicolasgoaziou.fr
Hello,

LGTM, as I wrote already :)

Le 19 octobre 2020 09:58:58 GMT+02:00, zimoun <zimon.toutoune@gmail.com> a écrit :
Toggle quote (12 lines)
>Hi Nicolas,
>
>Friendly ping. The patch is attached to:
>
> <http://issues.guix.gnu.org/43809#8>
>
>Tell me if something does not like correct.
>
>
>All the best,
>simon

--
Nicolas Goaziou
Z
Z
zimoun wrote on 19 Oct 2020 20:34
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)(address . 43809@debbugs.gnu.org)
CAJ3okZ3vLYv7WDkfkSM-dWs=MS4UCxUdqL4G=tfmDqEXMoovyA@mail.gmail.com
Hi Nicolas,

On Mon, 19 Oct 2020 at 19:20, Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:

Toggle quote (2 lines)
> LGTM, as I wrote already :)

Ah sorry to bother you again, that's just because I do not have the
super power; not granted to commit access :-).

Cheers,
simon
N
N
Nicolas Goaziou wrote on 19 Oct 2020 22:48
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 43809-done@debbugs.gnu.org)
87h7qq7xhy.fsf@nicolasgoaziou.fr
Hello,

zimoun <zimon.toutoune@gmail.com> writes:

Toggle quote (3 lines)
> Ah sorry to bother you again, that's just because I do not have the
> super power; not granted to commit access :-).

Oh, sorry! I could have sworn you had commit access.

Patch applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?