Add emacs-boon

  • Done
  • quality assurance status badge
Details
3 participants
  • Elais Player
  • Ludovic Courtès
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Elais Player
Severity
normal
Merged with
E
E
Elais Player wrote on 28 Apr 2020 21:57
(address . guix-patches@gnu.org)
CSKI9Q.P7JNA1CYLV2D3@fastmail.com
Hi,

This patch adds the boon modal editing package
Attachment: file
From 809ed7f518f2cc6b8774ab54c4e0ec35285ed21c Mon Sep 17 00:00:00 2001
From: Elais Player <elais@samus.hsd1.nm.comcast.net>
Date: Tue, 28 Apr 2020 13:44:00 -0600
Subject: [PATCH 1/1] Add emacs-boon package

This patch adds boon modal editing packages.
---
gnu/packages/emacs-xyz.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2c61c4189d..13d539e607 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -68,6 +68,7 @@
;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
;;; Copyright © 2020 Jérémy Korwin-Zmijowski <jeremy@korwin-zmijowski.fr>
;;; Copyright © 2020 Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>
+;;; Copyright © 2020 Elais Player <elais@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -22662,3 +22663,34 @@ deleting them with @code{(setq delete-by-moving-to-trash t)}. This package
provides a simple but convenient user interface to manage those trashed
files.")
(license license:gpl3+)))
+
+(define-public emacs-boon
+ (package
+ (name "emacs-boon")
+ (version "1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jyp/boon/")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ss9bjs34q41pa0g0nbdzd8fwpjcbd2239rdlx5aykfv9v0b8j77"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-expand-region" ,emacs-expand-region)
+ ("spaceline" ,emacs-spaceline)
+ ("powerline" ,emacs-powerline)
+ ("emacs-dash" ,emacs-dash)
+ ("emacs-multiple-cursors" ,emacs-multiple-cursors)))
+ (home-page "https://github.com/jyp/boon")
+ (synopsis "Ergonomic Command Mode for Emacs.")
+ (description
+ "Boon brings modal editing capabilities to Emacs and...
+
+- It tries to be as ergonomic as possible.
+- It remains lightweight (~300 loc for its core.)
+- It attempts to integrate with Emacs as smoothly as possible")
+ (license license:gpl3)))
--
2.26.2
N
N
Nicolas Goaziou wrote on 29 Apr 2020 16:48
(name . Elais Player)(address . elais@fastmail.com)(address . 40947@debbugs.gnu.org)
87imhie4bh.fsf@nicolasgoaziou.fr
Hello,

Elais Player <elais@fastmail.com> writes:

Toggle quote (2 lines)
> This patch adds the boon modal editing package

Thank you.

Toggle quote (4 lines)
> Subject: [PATCH 1/1] Add emacs-boon package
>
> This patch adds boon modal editing packages.

The expected commit message is slightly different.

gnu: Add emacs-boon.

* gnu/packages/emacs-xyz.scm (emacs-boon): New variable.

If you use Yasnippets, using "add <TAB>" in an empty commit message
generates it for you. See (info "(guix)The Perfect Setup").

Toggle quote (4 lines)
> provides a simple but convenient user interface to manage those trashed
> files.")
> (license license:gpl3+)))

As a rule of thumb, please do not append new packages at the end of the
file. It is more likely to generate merge conflicts.

Toggle quote (4 lines)
> + (sha256
> + (base32
> + "1ss9bjs34q41pa0g0nbdzd8fwpjcbd2239rdlx5aykfv9v0b8j77"))))

Nitpick: could you move the string on the same line as `base32'?

Toggle quote (8 lines)
> + (build-system emacs-build-system)
> + (propagated-inputs
> + `(("emacs-expand-region" ,emacs-expand-region)
> + ("spaceline" ,emacs-spaceline)
> + ("powerline" ,emacs-powerline)
> + ("emacs-dash" ,emacs-dash)
> + ("emacs-multiple-cursors" ,emacs-multiple-cursors)))

Could you re-order inputs alphabetically?

Toggle quote (3 lines)
> + (synopsis "Ergonomic Command Mode for Emacs.")

Synopsis is not expected to end with a full stop. You may want to run
guix lint on the package.

Toggle quote (7 lines)
> + (description
> + "Boon brings modal editing capabilities to Emacs and...
> +
> +- It tries to be as ergonomic as possible.
> +- It remains lightweight (~300 loc for its core.)
> +- It attempts to integrate with Emacs as smoothly as possible")

Here you should write Texinfo markup:

@itemize
@item it tries to...
@item ...
...
@end itemize

However, you way want to extract the description from the project's
GitHub front page instead of the main file.

Could you send an updated patch?

Regards,

--
Nicolas Goaziou
L
L
Ludovic Courtès wrote on 17 Jun 2020 12:04
control message for bug #40970
(address . control@debbugs.gnu.org)
87zh92qa8i.fsf@gnu.org
merge 40970 40947
quit
?