[PATCH] gnu: add emacs-boon

  • Done
  • quality assurance status badge
Details
3 participants
  • Elais Player
  • Ludovic Courtès
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Elais Player
Severity
normal
Merged with
E
E
Elais Player wrote on 29 Apr 2020 20:54
(address . guix-patches@gnu.org)
MJCK9Q.9GY8EBVY4BEJ@fastmail.com
Hi,

This patch adds the emacs-boon package with changes recommended by
Nicolas Goaziou.

Best,

--
Elais Player
From a11d6a58aa6c4ccc403d0bf4955b899b8e482cd3 Mon Sep 17 00:00:00 2001
From: Elais Player <elais@fastmail.com>
Date: Wed, 29 Apr 2020 10:37:24 -0600
Subject: [PATCH] gnu: Add emacs-boon.

* gnu/packages/emacs-xyz.scm (emacs-boon): New variable.
---
gnu/packages/emacs-xyz.scm | 67 +++++++++++++++++++++-----------------
1 file changed, 37 insertions(+), 30 deletions(-)

Toggle diff (84 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 13d539e607..f9438fca10 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -22640,6 +22640,43 @@ ASCII UML sequence diagrams in Emacs, which can be embedded in source code,
comments or emails.")
(license license:gpl3+))))
+(define-public emacs-boon
+ (package
+ (name "emacs-boon")
+ (version "1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jyp/boon/")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ss9bjs34q41pa0g0nbdzd8fwpjcbd2239rdlx5aykfv9v0b8j77"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-expand-region" ,emacs-expand-region)
+ ("emacs-multiple-cursors" ,emacs-multiple-cursors)
+ ("powerline" ,emacs-powerline)
+ ("spaceline" ,emacs-spaceline)))
+ (home-page "https://github.com/jyp/boon")
+ (synopsis "Ergonomic Command Mode for Emacs")
+ (description
+ "Boon is a complete package for modal editing, which is not Evil.
+Strong points:
+
+@itemize
+@item Ergonomic: common commands are easy to type.
+@item Emacs-friendly: Emacs conventions are respected as much as compatible
+with design goals. This means that Boon integrates well with existing Emacs
+infrastructure, and leverages it. Existing user configuration can often be
+re-used.
+@item Modular: No need to buy into the whole system: mix-and-match the parts
+you want.
+@end itemize")
+ (license license:gpl3)))
+
(define-public emacs-trashed
(package
(name "emacs-trashed")
@@ -22664,33 +22701,3 @@ provides a simple but convenient user interface to manage those trashed
files.")
(license license:gpl3+)))
-(define-public emacs-boon
- (package
- (name "emacs-boon")
- (version "1.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/jyp/boon/")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1ss9bjs34q41pa0g0nbdzd8fwpjcbd2239rdlx5aykfv9v0b8j77"))))
- (build-system emacs-build-system)
- (propagated-inputs
- `(("emacs-expand-region" ,emacs-expand-region)
- ("spaceline" ,emacs-spaceline)
- ("powerline" ,emacs-powerline)
- ("emacs-dash" ,emacs-dash)
- ("emacs-multiple-cursors" ,emacs-multiple-cursors)))
- (home-page "https://github.com/jyp/boon")
- (synopsis "Ergonomic Command Mode for Emacs.")
- (description
- "Boon brings modal editing capabilities to Emacs and...
-
-- It tries to be as ergonomic as possible.
-- It remains lightweight (~300 loc for its core.)
-- It attempts to integrate with Emacs as smoothly as possible")
- (license license:gpl3)))
--
2.26.2
N
N
Nicolas Goaziou wrote on 1 May 2020 22:49
(name . Elais Player)(address . elais@fastmail.com)(address . 40970@debbugs.gnu.org)
878sib8jp6.fsf@nicolasgoaziou.fr
Hello,

Elais Player <elais@fastmail.com> writes:

Toggle quote (3 lines)
> This patch adds the emacs-boon package with changes recommended by
> Nicolas Goaziou.

Thank you.

Toggle quote (4 lines)
> + (description
> + "Boon is a complete package for modal editing, which is not Evil.
> +Strong points:

Nitpick: I suggest to use a complete sentence here.

Toggle quote (8 lines)
> +@itemize
> +@item Ergonomic: common commands are easy to type.
> +@item Emacs-friendly: Emacs conventions are respected as much as compatible
> +with design goals. This means that Boon integrates well with existing Emacs
> +infrastructure, and leverages it. Existing user configuration can often be
> +re-used.
> +@item Modular: No need to buy into the whole system: mix-and-match the parts

"No need" -> "no need"

Also, you need to put two spaces at the end of sentences in description.

Otherwise, LGTM.

You generated a new patch on top of the previous one. Could you merge
both, fix the above, and send one last patch?

Regards,

--
Nicolas Goaziou
L
L
Ludovic Courtès wrote on 17 Jun 2020 12:04
control message for bug #40970
(address . control@debbugs.gnu.org)
87zh92qa8i.fsf@gnu.org
merge 40970 40947
quit
N
N
Nicolas Goaziou wrote on 16 Nov 2020 20:22
Re: [bug#40970] [PATCH] gnu: add emacs-boon
(name . Elais Player)(address . elais@fastmail.com)(address . 40970-done@debbugs.gnu.org)
877dqlm7i9.fsf@nicolasgoaziou.fr
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

Toggle quote (30 lines)
> Elais Player <elais@fastmail.com> writes:
>
>> This patch adds the emacs-boon package with changes recommended by
>> Nicolas Goaziou.
>
> Thank you.
>
>> + (description
>> + "Boon is a complete package for modal editing, which is not Evil.
>> +Strong points:
>
> Nitpick: I suggest to use a complete sentence here.
>
>> +@itemize
>> +@item Ergonomic: common commands are easy to type.
>> +@item Emacs-friendly: Emacs conventions are respected as much as compatible
>> +with design goals. This means that Boon integrates well with existing Emacs
>> +infrastructure, and leverages it. Existing user configuration can often be
>> +re-used.
>> +@item Modular: No need to buy into the whole system: mix-and-match the parts
>
> "No need" -> "no need"
>
> Also, you need to put two spaces at the end of sentences in description.
>
> Otherwise, LGTM.
>
> You generated a new patch on top of the previous one. Could you merge
> both, fix the above, and send one last patch?

I pushed a new iteration of this patch. I'm closing this one.
Closed
?