[PATCH] gnu: rust-cbindgen: update to 0.11.0

  • Done
  • quality assurance status badge
Details
2 participants
  • Jakub K?dzio?ka
  • Martin Becze
Owner
unassigned
Submitted by
Martin Becze
Severity
normal
M
M
Martin Becze wrote on 6 Dec 2019 01:20
(address . guix-patches@gnu.org)(name . Martin Becze)(address . mjbecze@riseup.net)
20191206002058.1835-1-mjbecze@riseup.net
* gnu/packages/rust-cbindgen.scm (rust-cbindgen) update to 0.11.0
* gnu/packages/crates-io.scm update all the dependencies for cbindgen
---
gnu/packages/crates-io.scm | 7011 +++++++++++++++++---------------
gnu/packages/rust-cbindgen.scm | 67 +-
2 files changed, 3768 insertions(+), 3310 deletions(-)

Toggle diff (561 lines)
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b4bb599dcc..2e03db9f64 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -29,11 +29,45 @@
;;;
;;; Please: Try to add new module packages in alphabetic order.
;;;
+(define-public rust-addr2line
+ (package
+ (name "rust-addr2line")
+ (version "0.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "addr2line" version))
+ (file-name
+ (string-append name "-" version ".crate"))
+ (sha256
+ (base32
+ "1daaxrzk6fmfzaqi06y704hcw0rjz199l0n9214ybfm3m3jnmc4m"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build?
+ #t
+ #:cargo-inputs
+ (("rust-cpp-demangle" ,rust-cpp-demangle)
+ ("rust-fallible-iterator"
+ ,rust-fallible-iterator)
+ ("rust-gimli" ,rust-gimli)
+ ("rust-intervaltree" ,rust-intervaltree)
+ ("rust-lazycell" ,rust-lazycell)
+ ("rust-object-0.12.0" ,rust-object-0.12.0)
+ ("rust-rustc-demangle" ,rust-rustc-demangle)
+ ("rust-smallvec-0.6.13" ,rust-smallvec-0.6.13))))
+ (home-page
+ "https://github.com/gimli-rs/addr2line")
+ (synopsis
+ "A cross-platform symbolication library written in Rust, using `gimli`")
+ (description
+ "This package provides a cross-platform symbolication library written in Rust, using `gimli`")
+ (license #f)))
-(define-public rust-adler32-1.0
+(define-public rust-adler32
(package
(name "rust-adler32")
- (version "1.0.3")
+ (version "1.0.4")
(source
(origin
(method url-fetch)
@@ -42,18 +76,47 @@
(string-append name "-" version ".crate"))
(sha256
(base32
- "0p7fxlnks9l7p7rwfqi7aqgnk2bps5zc0rjiw00mdw19nnbjjlky"))))
+ "1hnan4fgmnidgn2k84hh2i67c3wp2c5iwd5hs61yi7gwwx1p6bjx"))))
+ (build-system cargo-build-system)
+ (arguments `(#:skip-build? #t))
+ (home-page
+ "https://github.com/remram44/adler32-rs")
+ (synopsis
+ "Minimal Adler32 implementation for Rust.")
+ (description
+ "Minimal Adler32 implementation for Rust.")
+ (license license:zlib)))
+
+(define-public rust-afl
+ (package
+ (name "rust-afl")
+ (version "0.5.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "afl" version))
+ (file-name
+ (string-append name "-" version ".crate"))
+ (sha256
+ (base32
+ "0azpi917l8nhvx25n2v670nvkxkrhcwmddfi85qnr6kchmi6y946"))))
(build-system cargo-build-system)
- (home-page "https://github.com/remram44/adler32-rs")
- (synopsis "Implementation of the Adler32 rolling hash algorithm")
+ (arguments
+ `(#:skip-build?
+ #t
+ #:cargo-inputs
+ (("rust-cc" ,rust-cc)
+ ("rust-clap" ,rust-clap)
+ ("rust-rustc-version" ,rust-rustc-version)
+ ("rust-xdg" ,rust-xdg))))
+ (home-page "https://github.com/rust-fuzz/afl.rs")
+ (synopsis
+ "Fuzzing Rust code with american-fuzzy-lop")
(description
- "This library is an implementation of the Adler32 rolling hash algorithm in
-the Rust programming language.")
- (properties '((hidden? . #t)))
- (license (list license:bsd-3
- license:zlib))))
+ "Fuzzing Rust code with american-fuzzy-lop")
+ (license license:asl2.0)))
-(define-public rust-ansi-term-0.11
+(define-public rust-ansi-term-0.11.0
(package
(name "rust-ansi-term")
(version "0.11.0")
@@ -61,42 +124,128 @@ the Rust programming language.")
(origin
(method url-fetch)
(uri (crate-uri "ansi_term" version))
- (file-name (string-append name "-" version ".crate"))
+ (file-name
+ (string-append name "-" version ".crate"))
(sha256
- (base32
- "16wpvrghvd0353584i1idnsgm0r3vchg8fyrm0x8ayv1rgvbljgf"))))
+ (base32
+ "16wpvrghvd0353584i1idnsgm0r3vchg8fyrm0x8ayv1rgvbljgf"))))
(build-system cargo-build-system)
- (home-page "https://github.com/ogham/rust-ansi-term")
- (synopsis "Library for ANSI terminal colours and styles")
+ (arguments
+ `(#:skip-build?
+ #t
+ #:cargo-inputs
+ (("rust-winapi" ,rust-winapi))))
+ (home-page
+ "https://github.com/ogham/rust-ansi-term")
+ (synopsis
+ "Library for ANSI terminal colours and styles (bold, underline)")
(description
- "This is a library for controlling colours and formatting, such as red bold
-text or blue underlined text, on ANSI terminals.")
- (properties '((hidden? . #t)))
+ "Library for ANSI terminal colours and styles (bold, underline)")
(license license:expat)))
-(define-public rust-antidote-1.0
+(define-public rust-arrayref
(package
- (name "rust-antidote")
- (version "1.0.0")
+ (name "rust-arrayref")
+ (version "0.3.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "arrayref" version))
+ (file-name
+ (string-append name "-" version ".crate"))
+ (sha256
+ (base32
+ "1vphy316jbgmgckk4z7m8csvlyc8hih9w95iyq48h8077xc2wf0d"))))
+ (build-system cargo-build-system)
+ (arguments `(#:skip-build? #t))
+ (home-page "https://github.com/droundy/arrayref")
+ (synopsis
+ "Macros to take array references of slices")
+ (description
+ "Macros to take array references of slices")
+ (license #f)))
+
+(define-public rust-arrayvec
+ (package
+ (name "rust-arrayvec")
+ (version "0.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "arrayvec" version))
+ (file-name
+ (string-append name "-" version ".crate"))
+ (sha256
+ (base32
+ "1f5mca8kiiwhvhxd1mbnq68j6v6rk139sch567zwwzl6hs37vxyg"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build?
+ #t
+ #:cargo-inputs
+ (("rust-serde" ,rust-serde))))
+ (home-page "https://github.com/bluss/arrayvec")
+ (synopsis
+ "A vector with fixed capacity, backed by an array (it can be stored on the stack too). Implements fixed capacity ArrayVec and ArrayString.")
+ (description
+ "This package provides a vector with fixed capacity, backed by an array (it can be stored on the stack too). Implements fixed capacity ArrayVec and ArrayString.")
+ (license #f)))
+
+(define-public rust-arrayvec-0.4.12
+ (package
+ (name "rust-arrayvec")
+ (version "0.4.12")
(source
(origin
(method url-fetch)
- (uri (crate-uri "antidote" version))
- (file-name (string-append name "-" version ".crate"))
+ (uri (crate-uri "arrayvec" version))
+ (file-name
+ (string-append name "-" version ".crate"))
(sha256
- (base32
- "19g2sw2qa2ibnh4x7j1snk46593jgx6y7rnvva496ynq61af5z9l"))))
+ (base32
+ "1fdiv5m627gh6flp4mpmi1mh647imm9x423licsr11psz97d97yd"))))
(build-system cargo-build-system)
- (home-page "https://github.com/sfackler/rust-antidote")
- (synopsis "Poison-free Mutex and RwLock types")
+ (arguments
+ `(#:skip-build?
+ #t
+ #:cargo-inputs
+ (("rust-nodrop" ,rust-nodrop)
+ ("rust-serde" ,rust-serde))))
+ (home-page "https://github.com/bluss/arrayvec")
+ (synopsis
+ "A vector with fixed capacity, backed by an array (it can be stored on the stack too). Implements fixed capacity ArrayVec and ArrayString.")
(description
- "These types expose identical APIs to the standard library @code{Mutex} and
-@code{RwLock} except that they do not return @code{PoisonError}s.")
- (properties '((hidden? . #t)))
- (license (list license:asl2.0
- license:expat))))
+ "This package provides a vector with fixed capacity, backed by an array (it can be stored on the stack too). Implements fixed capacity ArrayVec and ArrayString.")
+ (license #f)))
+
+(define-public rust-atlatl
+ (package
+ (name "rust-atlatl")
+ (version "0.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "atlatl" version))
+ (file-name
+ (string-append name "-" version ".crate"))
+ (sha256
+ (base32
+ "18kyvdm56fdb52b1sryi80xgs3nkjdylynsv324aiqnj85l1bfrj"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build?
+ #t
+ #:cargo-inputs
+ (("rust-fnv" ,rust-fnv)
+ ("rust-num-traits" ,rust-num-traits)
+ ("rust-serde" ,rust-serde))))
+ (home-page
+ "https://github.com/tapeinosyne/atlatl")
+ (synopsis "Double-array tries.")
+ (description "Double-array tries.")
+ (license #f)))
-(define-public rust-atty-0.2
+(define-public rust-atty
(package
(name "rust-atty")
(version "0.2.13")
@@ -104,1571 +253,2008 @@ text or blue underlined text, on ANSI terminals.")
(origin
(method url-fetch)
(uri (crate-uri "atty" version))
- (file-name (string-append name "-" version ".crate"))
+ (file-name
+ (string-append name "-" version ".crate"))
(sha256
- (base32
- "140sswp1bwqwc4zk80bxkbnfb3g936hgrb77g9g0k1zcld3wc0qq"))))
+ (base32
+ "140sswp1bwqwc4zk80bxkbnfb3g936hgrb77g9g0k1zcld3wc0qq"))))
(build-system cargo-build-system)
+ (arguments
+ `(#:skip-build?
+ #t
+ #:cargo-inputs
+ (("rust-libc" ,rust-libc)
+ ("rust-winapi" ,rust-winapi))))
(home-page "https://github.com/softprops/atty")
(synopsis "A simple interface for querying atty")
(description
- "This package provides a simple interface for querying atty.")
- (properties '((hidden? . #t)))
+ "This package provides a simple interface for querying atty")
(license license:expat)))
-(define-public rust-autocfg-0.1
+(define-public rust-backtrace
(package
- (name "rust-autocfg")
- (version "0.1.7")
+ (name "rust-backtrace")
+ (version "0.3.40")
(source
(origin
(method url-fetch)
- (uri (crate-uri "autocfg" version))
- (file-name (string-append name "-" version ".crate"))
+ (uri (crate-uri "backtrace" version))
+ (file-name
+ (string-append name "-" version ".crate"))
(sha256
- (base32
- "1chwgimpx5z7xbag7krr9d8asxfqbh683qhgl9kn3hxk2l0djj8x"))))
+ (base32
+ "1skpshz0gszhpmj51p35ci9nf4nmd79s899cfrfs570dgxcpck4j"))))
(build-system cargo-build-system)
- (home-page "https://github.com/cuviper/autocfg")
- (synopsis "Automatic cfg for Rust compiler features")
- (description "Rust library for build scripts to automatically configure
-code based on compiler support. Code snippets are dynamically tested to see
-if the @code{rustc} will accept them, rather than hard-coding specific version
-support.")
- (properties '((hidden? . #t)))
- (license (list license:asl2.0
- license:expat))))
+ (arguments
+ `(#:skip-build?
+ #t
+ #:cargo-inputs
+ (("rust-addr2line" ,rust-addr2line)
+ ("rust-backtrace-sys" ,rust-backtrace-sys)
+ ("rust-cfg-if" ,rust-cfg-if)
+ ("rust-compiler-builtins"
+ ,rust-compiler-builtins)
+ ("rust-cpp-demangle" ,rust-cpp-demangle)
+ ("rust-findshlibs" ,rust-findshlibs)
+ ("rust-goblin-0.0.24" ,rust-goblin-0.0.24)
+ ("rust-libc" ,rust-libc)
+ ("rust-memmap" ,rust-memmap)
+ ("rust-rustc-demangle" ,rust-rustc-demangle)
+ ("rust-rustc-serialize" ,rust-rustc-serialize)
+ ("rust-rustc-std-workspace-core"
+ ,rust-rustc-std-workspace-core)
+ ("rust-serde" ,rust-serde)
+ ("rust-winapi" ,rust-winapi))))
+ (home-page
+ "https://github.com/rust-lang/backtrace-rs")
+ (synopsis
+ "A library to acquire a stack trace (backtrace) at runtime in a Rust program.
+")
+ (description
+ "This package provides a library to acquire a stack trace (backtrace) at runtime in a Rust program.
+")
+ (license #f)))
-(define-public rust-backtrace-sys-0.1
+(define-public rust-backtrace-sys
(package
(name "rust-backtrace-sys")
- (version "0.1.31")
+ (version "0.1.32")
(source
(origin
(method url-fetch)
(uri (crate-uri "backtrace-sys" version))
- (file-name (string-append name "-" version ".crate"))
+ (file-name
+ (string-append name "-" version ".crate"))
(sha256
- (base32
- "0as2pk77br4br04daywhivpi1ixxb8y2c7f726kj849dxys31a42"))))
+ (base32
+ "14c406z8bdmms8a5l8cv79jfkz1mk10qk5p97izf4vai53qparax"))))
(build-system cargo-build-system)
- (home-page "https://github.com/rust-lang/backtrace-rs")
- (synopsis "Bindings to the libbacktrace gcc library")
+ (arguments
+ `(#:skip-build?
+ #t
+ #:cargo-inputs
+ (("rust-compiler-builtins"
+ ,rust-compiler-builtins)
+ ("rust-libc" ,rust-libc)
+ ("rust-rustc-std-workspace-core"
+ ,rust-rustc-std-workspace-core))))
+ (home-page
+ "https://github.com/alexcrichton/backtrace-rs")
+ (synopsis
+ "Bindings to the libbacktrace gcc library
+")
(description
- "This package provides bindings to the libbacktrace gcc library.")
- (properties '((hidden? . #t)))
- (license (list license:asl2.0
- license:expat))))
+ "Bindings to the libbacktrace gcc library
+")
+ (license #f)))
-(define-public rust-base-x-0.2
+(define-public rust-base-x
(package
(name "rust-base-x")
- (version "0.2.5")
+ (version "0.2.6")
(source
(origin
(method url-fetch)
(uri (crate-uri "base-x" version))
- (file-name (string-append name "-" version ".crate"))
+ (file-name
+ (string-append name "-" version ".crate"))
(sha256
- (base32
- "0hv4y5cdhv6bk0ghk2434clw8v4mmk5cc9lsh6qrpri92zlfmx3n"))))
+ (base32
+ "1hfy0wv7j5ynd73yk1vyr32pqa77rp15lkrc54f8ky9c6hcbc80v"))))
(build-system cargo-build-system)
+ (arguments `(#:skip-build? #t))
(home-page "https://github.com/OrKoN/base-x-rs")
(synopsis "Encode/decode any base")
- (description "This library provides for encoding and decoding any base.")
- (properties '((hidden? . #t)))
+ (description "Encode/decode any base")
(license license:expat)))
-(define-public rust-bencher-0.1
+(define-public rust-base64-0.10.1
(package
- (name "rust-bencher")
- (version "0.1.5")
+ (name "rust-base64")
+ (version "0.10.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "base64" version))
+ (file-name
+ (string-append name "-" version ".crate"))
+ (sha256
+ (base32
+ "13k6bvd3n6dm7jqn9x918w65dd9xhx454bqphbnv0bkd6n9dj98b"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build?
+ #t
+ #:cargo-inputs
+ (("rust-byteorder" ,rust-byteorder))))
+ (home-page
+ "https://github.com/marshallpierce/rust-base64")
+ (synopsis
+ "encodes and decodes base64 as bytes or utf8")
+ (description
+ "encodes and decodes base64 as bytes or utf8")
+ (license #f)))
+
+(define-public rust-bincode
+ (package
+ (name "rust-bincode")
+ (version "1.2.0")
(source
(origin
(method url-fetch)
- (uri (crate-uri "bencher" version))
- (file-name (string-append name "-" version ".crate"))
+ (uri (crate-uri "bincode" version))
+ (file-name
+ (string-append name "-" version ".crate"))
(sha256
- (base32
- "1x8p2xblgqssay8cdykp5pkfc0np0jk5bs5cx4f5av097aav9zbx"))))
+ (base32
+ "14jzj61c145s9jwr1i213b7mdcmv1ny4z1lns9s8gvp34j9n7axq"))))
(build-system cargo-build-system)
- (home-page "https://github.com/bluss/bencher/")
- (synopsis "Port of the libtest benchmark runner to Rust stable")
- (description "This package provides a port of the libtest (unstable Rust)
-benchmark runner to Rust stable releases. Supports running benchmarks and
-filtering based on the name. Benchmark execution works exactly the same way
-and no more (caveat: black_box is still missing!).")
- (properties '((hidden? . #t)))
- (license (list license:asl2.0
- license:expat))))
+ (arguments
+ `(#:skip-build?
+ #t
+ #:cargo-inputs
+ (("rust-byteorder" ,rust-byteorder)
+ ("rust-serde" ,rust-serde))))
+ (home-page "https://github.com/servo/bincode")
+ (synopsis
+ "A binary serialization / deserialization strategy that uses Serde for transforming structs into bytes and vice versa!")
+ (description
+ "This package provides a binary serialization / deserialization strategy that uses Serde for transforming structs into bytes and vice versa!")
+ (license license:expat)))
-(define-public rust-bitflags-1
+(define-public rust-bitflags
(package
(name "rust-bitflags")
- (version "1.1.0")
+ (version "1.2.1")
(source
(origin
(method url-fetch)
(uri (crate-uri "bitflags" version))
- (file-name (string-append name "-" version ".crate"))
+ (file-name
+ (string-append name "-" version ".crate"))
(sha256
- (base32
- "1zc1qb1hwsnl2d8rhzicsv9kqd5b2hwbrscrcfw5as4sfr35659x"))))
+ (base32
+ "14qnd5nq8p2almk79m4m8ydqhd413yaxsyjp5xd19g3mikzf47fg"))))
(build-system cargo-build-system)
- (home-page "https://github.com/bitflags/bitflags")
- (synopsis "Macro to generate structures which behave like bitflags")
- (description "This package provides a macro to generate structures which
-behave like a set of bitflags.")
- (properties '((hidden? . #t)))
- (license (list license:asl2.0
- license:expat))))
+ (arguments `(#:skip-build? #t))
+ (home-page
+ "https://github.com/bitflags/bitflags")
+ (synopsis
+ "A macro to generate structures which behave like bitflags.
+")
+ (description
+ "This package provides a macro to generate structures which behave like bitflags.
+")
+ (license #f)))
-(define-public rust-blas-sys-0.7
+(define-public rust-blake2b-simd
(package
- (name "rust-blas-sys")
- (version "0.7.1")
+ (name "rust-blake2b-simd")
+ (version "0.5.9")
(source
(origin
(method url-fetch)
- (uri (crate-uri "blas-sys" version))
- (file-name (string-append name "-" version ".crate"))
+ (uri (crate-uri "blake2b_simd" version))
+ (file-name
+ (string-append name "-" version ".crate"))
(sha256
- (base32
- "0h14zjycwc76v15h8qll9z1xiryvmpvsb5gam97pqpdjrrwv5c8k"))))
+ (base32
+ "1h6hhzgvvmp9jb4pvb48h5j0w5vb1n02ahi0g26p2wg6n6m7nfxq"))))
(build-system cargo-build-system)
- (home-page "https://github.com/blas-lapack-rs/blas-sys")
- (synopsis "Bindings to BLAS (Fortran)")
+ (arguments
+ `(#:skip-build?
+ #t
+ #:cargo-inputs
+ (("rust-arrayref" ,rust-arrayref)
+ ("rust-arrayvec" ,rust-arrayvec)
+ ("rust-constant-time-eq" ,rust-constant-time-eq))))
+ (home-page
+ "https://github.com/oconnor663/blake2_simd")
+ (synopsis
+ "a pure Rust BLAKE2b implementation with dynamic SIMD")
(des
This message was truncated. Download the full message here.
M
J
J
Jakub K?dzio?ka wrote on 12 Jul 2020 00:02
(address . 38506-done@debbugs.gnu.org)
20200711220220.sbxidmy6foi7ot2i@gravity
The rust-cbindgen package is already past version 0.11, so I assume this
patch is now obsolete. Closing.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEE5Xa/ss9usT31cTO54xWnWEYTFWQFAl8KNuwACgkQ4xWnWEYT
FWRJnRAAn9GXLUDFn3o4zumMAou5Pws3dEAMzo7jl/NOwJCZXbFBJJ5qkOogm3Rp
jTkFY18IkFm8Kou3suhsl/qZ8Of0ySQM00ZiT57KxbkDiv1WUlqmSYvRbdKUhq6L
SyIf1AWZyXjIsSLhccp5fd/KoyYE6ZKgMguePI/a/uB3Dlz7tlIvt0P9VaW6VivQ
inCcmf23gFQe7shtvLpRxh+6Od3yL5RazPUzpQjGGXjTHQoVHEcrLmVcDVIY4x7a
Dz1wj8fCOEEwBvOeuf+rADsJLkS8A9mckDBeyrx/VucYbu3ZhtHJjvU3W2TqKVwr
OG6YWxirNbiZdeRTgij0J4Cjf4PJWfiV7xHUG8UX1QM1D1zshcqyd1fYZnNW4sF3
5fGEqiBZyHV/UzGCX00NloCPCzksfOA1rgcLsfQl8443gVz+IV0+zvZ4WpTI3hLD
NXfSPT9x7npJEZdC3q1dile9hQOqEcKdNZHu3pvYVL4kLi8slxRr6+MT2mwgQssq
hBNvx9mh6CYj10hj9HH1wJdUDeJ0YRqsJVoiGQwNdtarMwgHCOSXg/9QRptxkogv
RAKtYABcg5awcHD8oNpzgGlDUgKAd3FPV3Jr/AAODdmDkcVlFRNH//UTHnSdmPoh
kUbkdDqUIG3PAOCDJAGftVYoNwFPSFeq1vxQf7/wojFZCU6GMyE=
=4AQ+
-----END PGP SIGNATURE-----


Closed
?