Kernel job for Cuirass

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Leo Famulari
Severity
normal
L
L
Leo Famulari wrote on 28 Dec 2022 03:22
(address . guix-patches@gnu.org)
Y6uoeHOZoTGBVjCG@jasmine.lan
Here are some patches to create a 'kernel-updates' Cuirass
specification, so that CI will build kernel-related things based on
changes to a kernel-updates Git branch.

The first patch creates a manifest of packages named "linux-libre-*" for
the Guix source tree, and the second patch creates the Cuirass spec for
maintenance.git.

I can test the manifest with `guix weather`, but I'm not sure how to
test the Cuirass spec.

Advice is welcome!
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAmOrqHQACgkQJkb6MLrK
fwgw4A/9HuQfQhmfvcVkaPfTyicOwyQCSu0h4fbUfejPB+vp5jo/RXIIZjh1fwDL
rZ/QbF7tbCun27NXKnW32y0XW10vLyOYPcBzjtPGxO77b4zdVFjmHu5swJ9LG4ga
F7vmI/gqDRBCkEptGWw2Fh0rjl3BG7t6BppPDrJ75i3xl6yGYwpw4eHpOZmgjy0s
KxQQJLfV2/kHIzjw9sWq5J9a+uzPCGHPgpKePWQUQObpyTNDrbQdJFudZZgY7nW8
i3LH3nBI88jSnioR8OGl9iio2Jk8G0nyefTghNaApt4BYjIDIJIS3PSYOFKISq4+
CXwCSbxds3+i/bTGFNfjlsjxrJkZP7eWo/qadLjtGT89MDFGZwHkQmhb1YM9N315
9KUfyM0tMutudPv/rDCy11Nxj77w7/CqELoyLcJMtjuAbLa207s4BQLgz5HzZ5yW
arndm/KmJ2cg/rHlGvB5i944LXglHCEFEtMF+W/OOe3kaZIDSHVFBgdU/pNQXi90
vF6bFor6F9Oqu2isB8dDh/DKivm1aw8Qj5PBq3WH7oXW4bVrPt4cF1ImwQy3av4+
9Rsdb0v0ieBwWrfEI0v2drW3LndB6J4qDeYh8cbIqy28qWvSkCTMSxeo6B2ueRz/
Ay1yCT3VZXdeDZo3pRAIBarWImHhgHzTLNyRwe49HjhPB7lzK2Y=
=8FgM
-----END PGP SIGNATURE-----


L
L
Leo Famulari wrote on 28 Dec 2022 03:25
[PATCH] maint: Add a manifest for everything related to linux-libre.
(address . 60373@debbugs.gnu.org)
f51f6ab72191f6961dab335e81f8d8fe3de6eb6b.1672194327.git.leo@famulari.name
* etc/kernels-manifest.scm: New file.
* Makefile.am (EXTRA_DIST): Add it.
---
Makefile.am | 1 +
etc/kernels-manifest.scm | 35 +++++++++++++++++++++++++++++++++++
2 files changed, 36 insertions(+)
create mode 100644 etc/kernels-manifest.scm

Toggle diff (55 lines)
diff --git a/Makefile.am b/Makefile.am
index b54288c0fc..8b026b6da6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -689,6 +689,7 @@ EXTRA_DIST += \
etc/guix-install.sh \
etc/historical-authorizations \
etc/news.scm \
+ etc/kernels-manifest.scm \
etc/release-manifest.scm \
etc/source-manifest.scm \
etc/system-tests.scm \
diff --git a/etc/kernels-manifest.scm b/etc/kernels-manifest.scm
new file mode 100644
index 0000000000..6f1b31abb3
--- /dev/null
+++ b/etc/kernels-manifest.scm
@@ -0,0 +1,35 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2022 Leo Famulari <leo@famulari.name>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+;;; This file returns a manifest of packages related to linux-libre.
+;;; Specifically, it selects packages whose names begin with "linux-libre-".
+;;; It is used to assist continuous integration of the kernel packages.
+
+(use-modules (gnu packages)
+ (guix packages)
+ (guix profiles))
+
+(manifest
+ (map package->manifest-entry
+ (fold-packages
+ (lambda (package lst)
+ (if (string-prefix? "linux-libre-"
+ (package-name package))
+ (cons package lst)
+ lst))
+ '())))
--
2.38.1
L
L
Leo Famulari wrote on 28 Dec 2022 03:29
[PATCH] hydra: cuirass: Add 'kernel-updates' jobset.
(address . 60373@debbugs.gnu.org)
f007e96b5ca0f20d8aa1edd2a486227bd6429391.1672194511.git.leo@famulari.name
Can the build field actually contain this kind of list?

Should it contain system-tests? Normally they only run on x86_64, but
this would run them for all systems.

* hydra/modules/sysadmin/services.scm (cuirass-specs): Add
'kernel-updates' jobset.
---
hydra/modules/sysadmin/services.scm | 9 +++++++++
1 file changed, 9 insertions(+)

Toggle diff (29 lines)
diff --git a/hydra/modules/sysadmin/services.scm b/hydra/modules/sysadmin/services.scm
index d0c5b24..8d143ad 100644
--- a/hydra/modules/sysadmin/services.scm
+++ b/hydra/modules/sysadmin/services.scm
@@ -2,6 +2,7 @@
;;;
;;; Copyright © 2016-2022 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017, 2018, 2020, 2022 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2022 Leo Famulari <leo@famulari.name>
;;;
;;; This program is free software: you can redistribute it and/or modify
;;; it under the terms of the GNU General Public License as published by
@@ -347,6 +348,14 @@
(branch "core-updates"))))
(priority 4)
(systems '#$systems)))
+ #~())
+ #$@(if (member "kernel-updates" branches)
+ #~((specification
+ (name "kernel-updates")
+ (build '(images system-tests (manifests "etc/kernels-manifest.scm")))
+ (period 7200)
+ (priority 2)
+ (systems '#$systems)))
#~())))
--
2.38.1
M
M
Mathieu Othacehe wrote on 28 Dec 2022 15:35
Re: bug#60373: Kernel job for Cuirass
(name . Leo Famulari)(address . leo@famulari.name)(address . 60373@debbugs.gnu.org)
87r0wjsijd.fsf_-_@gnu.org
Hey Leo,

Good initiative!

Toggle quote (2 lines)
> Can the build field actually contain this kind of list?

No sadly it cannot right now. That would require to edit a bit the (gnu
ci) module in Guix so that it allows a list of things to be built
instead of individual subsets. Then a thing or two would need to be
adjusted in Cuirass as well.

Toggle quote (3 lines)
> Should it contain system-tests? Normally they only run on x86_64, but
> this would run them for all systems.

What you could do instead is something like:

Toggle snippet (20 lines)
((specification
(name "kernel-updates")
(build '(manifests "etc/kernels-manifest.scm"))
(period 7200)
(priority 2)
(systems '#$systems))
(specification
(name "kernel-updates-images")
(build 'images)
(period 7200)
(priority 2)
(systems '#$systems))
(specification
(name "kernel-updates-tests")
(build 'system-tests)
(period 7200)
(priority 2)
(systems '("x86_64-linux"))))

Then we could think about supporting multiple build subsets.

WDYT?

Thanks,

Mathieu
L
L
Leo Famulari wrote on 28 Dec 2022 23:50
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 60373@debbugs.gnu.org)
Y6zIJb4Pk2mbDQ/6@jasmine.lan
On Wed, Dec 28, 2022 at 03:35:18PM +0100, Mathieu Othacehe wrote:
Toggle quote (23 lines)
> What you could do instead is something like:
>
> --8<---------------cut here---------------start------------->8---
> ((specification
> (name "kernel-updates")
> (build '(manifests "etc/kernels-manifest.scm"))
> (period 7200)
> (priority 2)
> (systems '#$systems))
> (specification
> (name "kernel-updates-images")
> (build 'images)
> (period 7200)
> (priority 2)
> (systems '#$systems))
> (specification
> (name "kernel-updates-tests")
> (build 'system-tests)
> (period 7200)
> (priority 2)
> (systems '("x86_64-linux"))))
> --8<---------------cut here---------------end--------------->8---

That's perfect! I've attached an updated patch.

Toggle quote (2 lines)
> Then we could think about supporting multiple build subsets.

Well, your suggested workaround is great, so it's not necessary to add
the functionality.

What's the procedure for making these changes? I can push to guix.git
and maintenance.git, but I'll need assistance putting the changes into
practice.
From 299039cf429210392b979a57e898c4a00ca4a6c3 Mon Sep 17 00:00:00 2001
From: Leo Famulari <leo@famulari.name>
Date: Tue, 27 Dec 2022 21:26:16 -0500
Subject: [PATCH v2] hydra: cuirass: Add jobsets for testing kernel updates.

* hydra/modules/sysadmin/services.scm (cuirass-specs): Add 'kernel-updates',
'kernel-updates-images', and 'kernel-updates-system-tests' jobsets.
---
hydra/modules/sysadmin/services.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (41 lines)
diff --git a/hydra/modules/sysadmin/services.scm b/hydra/modules/sysadmin/services.scm
index d0c5b24..66bf231 100644
--- a/hydra/modules/sysadmin/services.scm
+++ b/hydra/modules/sysadmin/services.scm
@@ -2,6 +2,7 @@
;;;
;;; Copyright © 2016-2022 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017, 2018, 2020, 2022 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2022 Leo Famulari <leo@famulari.name>
;;;
;;; This program is free software: you can redistribute it and/or modify
;;; it under the terms of the GNU General Public License as published by
@@ -347,6 +348,26 @@
(branch "core-updates"))))
(priority 4)
(systems '#$systems)))
+ #~())
+ #$@(if (member "kernel-updates" branches)
+ #~((specification
+ (name "kernel-updates")
+ (build '(manifests "etc/kernels-manifests.scm"))
+ (period 7200)
+ (priority 2)
+ (systems '#$systems))
+ (specification
+ (name "kernel-updates-images")
+ (build 'images)
+ (period 7200)
+ (priority 2)
+ (systems '#$systems))
+ (specification
+ (name "kernel-updates-system-tests")
+ (build 'system-tests)
+ (period 7200)
+ (priority 2)
+ (systems '("x86_64-linux"))))
#~())))
--
2.38.1
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAmOsyCEACgkQJkb6MLrK
fwhkaBAAgbCoocPjSV5C3dggbUcptflPu9snpLfQc6+f9jVVEvG6e5+kS1AxVRbk
wzgWFuVAH8az/Il5O7v1/rkLMy1R61k4S1P2ckZonVcwVOjM7G8julBIh4Fu74hz
OL/nFsKmKRN/JEsJtFwFuwz7RAl3GE8gQ46v+NdD3Nxh4AiI0VPQTE3UviSOz7XV
PzdN9OoopzqMiZn8tdQxPTPapGGKg2p1nC3AhSewlUsA43JzQJ943AZqS+/ZJXKp
Ntv1JvKBjrqmr+6ImF6XN9FkDBCsEbntXTE3fDlHIX/tspGyRKbB1TLmkY2ERjZP
u6SWujLQU/LxvuhdR+Oof76jMifimqb7FkuRAVodj51by1bCB6w3bpT8ueBHugDD
fo4H0Rw5WDCxRrFqW59S96WGFWtkHDZu2QAWl7yfTYvN53WNwm2zFrqfdr7fbsRY
kXzc25CB/GPDkJmQ+DgJduGo6oWm2c738Iq09c8XYlDE20UcWGw/S4453IJrQjOa
83Ix6qcskf6xNJNasoKsdwCRFE0lNl0szq+IWD4VMH9sLDLmoUQvZKc3J22ya7Gb
fiKpxvpN1nEqYP6N4EpIgtIjRUz69VI9dt+8pJ/vHCzReqm/Rd0MBAtJ5BAWOHwX
LqQTipHe2Jwi2fAJnBGNS1kEASZRp5a8yw2ZJCUk67X0hm00KtM=
=ig20
-----END PGP SIGNATURE-----


L
L
Leo Famulari wrote on 28 Dec 2022 23:54
[PATCH v2] maint: Add a manifest for everything related to linux-libre.
(address . 60373@debbugs.gnu.org)
d94b58a318789d46fa0107f4898ba29fe4df3b4c.1672268060.git.leo@famulari.name
* etc/kernels-manifest.scm: New file.
* Makefile.am (EXTRA_DIST): Add it.
---
Makefile.am | 1 +
etc/kernels-manifest.scm | 35 +++++++++++++++++++++++++++++++++++
2 files changed, 36 insertions(+)
create mode 100644 etc/kernels-manifest.scm

Toggle diff (55 lines)
diff --git a/Makefile.am b/Makefile.am
index b54288c0fc..8b026b6da6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -689,6 +689,7 @@ EXTRA_DIST += \
etc/guix-install.sh \
etc/historical-authorizations \
etc/news.scm \
+ etc/kernels-manifest.scm \
etc/release-manifest.scm \
etc/source-manifest.scm \
etc/system-tests.scm \
diff --git a/etc/kernels-manifest.scm b/etc/kernels-manifest.scm
new file mode 100644
index 0000000000..5fc4f52f2b
--- /dev/null
+++ b/etc/kernels-manifest.scm
@@ -0,0 +1,35 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2022 Leo Famulari <leo@famulari.name>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+;;; This file returns a manifest of packages related to linux-libre.
+;;; Simplistically, it selects packages whose names begin with "linux-libre".
+;;; It is used to assist continuous integration of the kernel packages.
+
+(use-modules (gnu packages)
+ (guix packages)
+ (guix profiles))
+
+(manifest
+ (map package->manifest-entry
+ (fold-packages
+ (lambda (package lst)
+ (if (string-prefix? "linux-libre"
+ (package-name package))
+ (cons package lst)
+ lst))
+ '())))
--
2.38.1
M
M
Mathieu Othacehe wrote on 29 Dec 2022 11:33
Re: bug#60373: Kernel job for Cuirass
(name . Leo Famulari)(address . leo@famulari.name)(address . 60373@debbugs.gnu.org)
874jtezegu.fsf@gnu.org
Hey,

Toggle quote (4 lines)
> What's the procedure for making these changes? I can push to guix.git
> and maintenance.git, but I'll need assistance putting the changes into
> practice.

You can go ahead and I'll take care of reconfiguring Berlin. If you
prefer to do it by yourself, the procedure is the following:

- Log in on Berlin
- Checkout the latest maintenance repository in your home
- Run guix pull
- Run sudo -E guix system reconfigure ~/maintenance/hydra/berlin.scm -L
~/maintenance/hydra/modules/
- Notify sysadmins about the reconfiguration

Thanks,

Mathieu
L
L
Leo Famulari wrote on 29 Dec 2022 19:54
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 60373@debbugs.gnu.org)
Y63iUTh/DFflyIM+@jasmine.lan
On Thu, Dec 29, 2022 at 11:33:37AM +0100, Mathieu Othacehe wrote:
Toggle quote (3 lines)
> You can go ahead and I'll take care of reconfiguring Berlin. If you
> prefer to do it by yourself, the procedure is the following:

Thanks, I pushed to guix.git and maintenance.git. Can you do the rest?
I'm not free to spend much time on it today.
-----BEGIN PGP SIGNATURE-----

iQIzBAABCAAdFiEEsFFZSPHn08G5gDigJkb6MLrKfwgFAmOt4lEACgkQJkb6MLrK
fwiaMQ/9HEK39JiZ7G70EFbhlmBFOzviXaWiT+NVwxmloqZ7HaurgXoRglLZ9ylJ
XkTv3t3x8KqqgjzbvmUX3qOoUuIs/JV0fwk0NlzZlJiMMYmxy4l3S3Cn+sIskHeO
d90Btw48nOckxe/xr5BXsraoxC9Az42LwQdOs3VJwSpDxdFWUbhtztRo0HbRX1j9
6ywNV9ySPMA0JH18EuZ8x5PgGGmZWT1PEuBYTp2FmCXg9qegzJPOYmVZwYXYRHn+
w1PwqZe/enFvJ6QmWdqHpACT2L3WjoO+zSWa2doGAAWzlLaxlgAWbXzTb2yeWMSh
kMn2alLW5NVbSMy52ivXdj2+Tb9FEnqxZX2howviFT5XJljBJEy9E2tLzTA3oTVr
uuBweDrbxcRjWdUnODQtEVVNBmIiB3YhGLLK6QqmPateEYM+PkqbG8tuy/0HKwtj
7B2KL6bI27gcM/PZ6I87sj/ediAKcIQXEVvQUVRJKtGPKAJzDozBUUA+cMVKsPr0
aUjSAV8yi8xk0O9qeh/Ks9J6W6dlPampkZTunDCjGTyOW81O/WJGY/DG+Px4V6Ih
oVBXjE16lshI2tlm/fuRkVbYpwQvaTWgSMnaksQ3FgcQnrx04Yw0FjrPwGGQZsvy
pI4plH9s6qg+Ill+glRT0CqKqm6KiFbRDQQzHQYafTFPG+mogLs=
=IEKb
-----END PGP SIGNATURE-----


L
L
Leo Famulari wrote on 5 Jan 2023 04:48
(name . Mathieu Othacehe)(address . othacehe@gnu.org)
Y7ZIm548Lcy5iwXj@jasmine.lan
On Thu, Dec 29, 2022 at 11:33:37AM +0100, Mathieu Othacehe wrote:
Toggle quote (10 lines)
> You can go ahead and I'll take care of reconfiguring Berlin. If you
> prefer to do it by yourself, the procedure is the following:
>
> - Log in on Berlin
> - Checkout the latest maintenance repository in your home
> - Run guix pull
> - Run sudo -E guix system reconfigure ~/maintenance/hydra/berlin.scm -L
> ~/maintenance/hydra/modules/
> - Notify sysadmins about the reconfiguration

Okay, I've gone ahead and reconfigured berlin based on maintenance.git
commit 97cbea05bfc53e8d3fba1d2e1455dda8237eb3c0.

It's not clear to me if I need to restart any services now in order to
make my new Cuirass jobsets effective. A few services were restarted
automatically:

------
[...]
shepherd: Service host-name has been started.
shepherd: Service user-homes has been started.
shepherd: Service sysctl has been started.
shepherd: Service postgres-roles has been started.
[...]
------
M
M
Mathieu Othacehe wrote on 5 Jan 2023 18:37
(name . Leo Famulari)(address . leo@famulari.name)
87zgawanmj.fsf@gnu.org
Hello Leo,

Toggle quote (3 lines)
> Okay, I've gone ahead and reconfigured berlin based on maintenance.git
> commit 97cbea05bfc53e8d3fba1d2e1455dda8237eb3c0.

Thanks for taking care of it. I added
0fad0d2cc4e7e440e80bcbcc519184a7a9111347 to the maintenance repository
because "kernel-updates" was not part of the default branches and
reconfigured.

I then restarted the "cuirass" service which is required to install the
new specifications. They are now listed in the web interface. Lets see
if they can be evaluated now ;)

Mathieu
L
L
Leo Famulari wrote on 6 Jan 2023 02:19
(name . Mathieu Othacehe)(address . othacehe@gnu.org)
Y7d3LU/xyOHI1jtA@jasmine.lan
On Thu, Jan 05, 2023 at 06:37:40PM +0100, Mathieu Othacehe wrote:
Toggle quote (5 lines)
> Thanks for taking care of it. I added
> 0fad0d2cc4e7e440e80bcbcc519184a7a9111347 to the maintenance repository
> because "kernel-updates" was not part of the default branches and
> reconfigured.

Thanks for your help!

Toggle quote (4 lines)
> I then restarted the "cuirass" service which is required to install the
> new specifications. They are now listed in the web interface. Lets see
> if they can be evaluated now ;)

I just pushed to the kernel-updates branch. Now watching the Cuirass web
interface to see how it goes :)
L
L
Leo Famulari wrote on 6 Jan 2023 04:00
(name . Mathieu Othacehe)(address . othacehe@gnu.org)
Y7eOwraGvdxERL1S@jasmine.lan
On Thu, Jan 05, 2023 at 08:19:41PM -0500, Leo Famulari wrote:
Toggle quote (3 lines)
> I just pushed to the kernel-updates branch. Now watching the Cuirass web
> interface to see how it goes :)

It doesn't look like the kernel-updates job is working right:


I confirmed the substitutes aren't available on the server.

The images seem to be failing often, but not exclusively on the
kernel-updates branch:

L
L
Leo Famulari wrote on 6 Jan 2023 06:33
(name . Mathieu Othacehe)(address . othacehe@gnu.org)
Y7eys65b0tP9yO4b@jasmine.lan
On Thu, Jan 05, 2023 at 10:00:18PM -0500, Leo Famulari wrote:
Toggle quote (4 lines)
> It doesn't look like the kernel-updates job is working right:
>
> https://ci.guix.gnu.org/jobset/kernel-updates

I think some modules were missing from kernels-manifest.scm. I added
them in commit 8be0a97a8139fdd4d196092008b98668f1a8b2bb, reconfigured,
and restarted Cuirass.
L
L
Leo Famulari wrote on 6 Jan 2023 07:27
(name . Mathieu Othacehe)(address . othacehe@gnu.org)
Y7e/bx3A3FBN9ENh@jasmine.lan
On Fri, Jan 06, 2023 at 12:33:39AM -0500, Leo Famulari wrote:
Toggle quote (4 lines)
> I think some modules were missing from kernels-manifest.scm. I added
> them in commit 8be0a97a8139fdd4d196092008b98668f1a8b2bb, reconfigured,
> and restarted Cuirass.

It didn't help, unfortunately.
M
M
Mathieu Othacehe wrote on 7 Jan 2023 15:47
(name . Leo Famulari)(address . leo@famulari.name)
87tu12mmfn.fsf@gnu.org
Hello,

Toggle quote (4 lines)
> It doesn't look like the kernel-updates job is working right:
>
> https://ci.guix.gnu.org/jobset/kernel-updates

That's because of a typo fixed on the maintenance repository with:
fa9b904b7b7cc9ccacb4ff1bfcfe92d6266b5f05.

Is it not advertised anywhere but there is a way to test that. You can
modify the following file:

Toggle snippet (12 lines)
--- a/build-aux/cuirass/evaluate.scm
+++ b/build-aux/cuirass/evaluate.scm
@@ -96,7 +96,9 @@ (define derivation
inferior store
`(lambda (store)
(cuirass-jobs store
- '((subset . all)
+ '((subset
+ . (manifests
+ "etc/kernels-manifest.scm"))

then run `make cuirass-jobs` and the computed derivations will be
printed in the cuirass-jobs/jobs-<system>.scm files.

Toggle quote (6 lines)
> The images seem to be failing often, but not exclusively on the
> kernel-updates branch:
>
> https://ci.guix.gnu.org/jobset/kernel-updates-images
> https://ci.guix.gnu.org/jobset/images

Yes, same for the tests, it is very likely of this issue:
https://issues.guix.gnu.org/48468,which is under investigation.

Thanks,

Mathieu
M
M
Mathieu Othacehe wrote on 7 Jan 2023 15:50
(name . Leo Famulari)(address . leo@famulari.name)
87pmbqmmah.fsf@gnu.org
Hey Leo,

Toggle quote (4 lines)
> I think some modules were missing from kernels-manifest.scm. I added
> them in commit 8be0a97a8139fdd4d196092008b98668f1a8b2bb, reconfigured,
> and restarted Cuirass.

Note that in that specific case, i.e modifying a manifest that is part
of Guix, it is not necessary to reconfigure Berlin.

The reason is that Cuirass role is to checkout the latest Guix then
evaluate the etc/kernel-manifest.scm file in an inferior, and build the
resulting derivations.

In that case, pushing the edited manifest to Guix's git then waiting for
the next evaluation of the specification is enough :)

Thanks,

Mathieu
L
L
Leo Famulari wrote on 7 Jan 2023 19:38
(name . Mathieu Othacehe)(address . othacehe@gnu.org)
Y7m8PJEqOOr4FN7l@jasmine.lan
On Sat, Jan 07, 2023 at 03:47:08PM +0100, Mathieu Othacehe wrote:
Toggle quote (3 lines)
> That's because of a typo fixed on the maintenance repository with:
> fa9b904b7b7cc9ccacb4ff1bfcfe92d6266b5f05.

? Thank you Mathieu!

Toggle quote (20 lines)
>
> Is it not advertised anywhere but there is a way to test that. You can
> modify the following file:
>
> --8<---------------cut here---------------start------------->8---
> --- a/build-aux/cuirass/evaluate.scm
> +++ b/build-aux/cuirass/evaluate.scm
> @@ -96,7 +96,9 @@ (define derivation
> inferior store
> `(lambda (store)
> (cuirass-jobs store
> - '((subset . all)
> + '((subset
> + . (manifests
> + "etc/kernels-manifest.scm"))
> --8<---------------cut here---------------end--------------->8---
>
> then run `make cuirass-jobs` and the computed derivations will be
> printed in the cuirass-jobs/jobs-<system>.scm files.

Awesome, I will try it out.

Toggle quote (9 lines)
> > The images seem to be failing often, but not exclusively on the
> > kernel-updates branch:
> >
> > https://ci.guix.gnu.org/jobset/kernel-updates-images
> > https://ci.guix.gnu.org/jobset/images
>
> Yes, same for the tests, it is very likely of this issue:
> https://issues.guix.gnu.org/48468, which is under investigation.

Yes, I found these issues later. I hope we can solve them soon!
L
L
Leo Famulari wrote on 7 Jan 2023 19:40
(no subject)
(address . control@debbugs.gnu.org)
Y7m8lcrU00heXa6M@jasmine.lan
close 60373
?