Hi,

This is not a bug. The gcc package exists, but is hidden from CLI on purpose because you shouldn't install it and use it directly. You should use gcc-toolchain instead.

Le 15 novembre 2022 00:53:32 GMT+01:00, bbb ee <blasforr@gmail.com> a écrit :
in version c81457a5883ea43950eb2ecdcbb58a5b144bcd11 of guix, gcc-toolchain depends gcc:
```
$ DEFAULT_CHANNELS=/tmp/default_channels.scm
$ echo "%default-channels" > $DEFAULT_CHANNELS
# I force guix to use only %default-channels here
$ guix time-machine --commit=c81457a5883ea43950eb2ecdcbb58a5b144bcd11  -C $DEFAULT_CHANNELS -- search gcc-toolchain
guile: warning: failed to install locale
name: gcc-toolchain
version: 9.3.0
outputs: out debug static
systems: x86_64-linux i686-linux
dependencies: binutils@2.32 gcc@9.3.0 glibc@2.29 ld-wrapper@0
```


However, I can't find gcc package in this version of guix
```
$ guix time-machine --commit=c81457a5883ea43950eb2ecdcbb58a5b144bcd11  -C $DEFAULT_CHANNELS -- search gcc
# no found gcc

# guix install failure message confirm that gcc doesn't exist in commit c81457
$ guix time-machine --commit=c81457a5883ea43950eb2ecdcbb58a5b144bcd11 -C $DEFAULT_CHANNELS -- install gcc -p ~/opt/python-dev_3_7
guile: warning: failed to install locale
guix install: error: gcc: unknown package
```

in commit c81457, how gcc-toolchain can depends a package who doesn't exists?